Ubuntu

ask me later fails

Reported by Michael Vogt on 2011-10-13
744
This bug affects 98 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Medium
Brian Murray
Natty
Medium
Unassigned
Oneiric
Medium
Brian Murray
Precise
Medium
Brian Murray

Bug Description

Clicking on "ask me laster" in the release upgraer window fails with:

Traceback (most recent call last):
  File "/usr/lib/update-manager/check-new-release-gtk", line 126, in on_button_ask_me_later_clicked
    client.set_int("/apps/update-notifier/release_check_time", next_check)
TypeError: integer argument expected, got float
Traceback (most recent call last):
  File "/usr/lib/update-manager/check-new-release-gtk", line 126, in on_button_ask_me_later_clicked
    client.set_int("/apps/update-notifier/release_check_time", next_check)
TypeError: integer argument expected, got float
Traceback (most recent call last):
  File "/usr/lib/update-manager/check-new-release-gtk", line 126, in on_button_ask_me_later_clicked
    client.set_int("/apps/update-notifier/release_check_time", next_check)
TypeError: integer argument expected, got float
Traceback (most recent call last):
  File "/usr/lib/update-manager/check-new-release-gtk", line 126, in on_button_ask_me_later_clicked
    client.set_int("/apps/update-notifier/release_check_time", next_check)
TypeError: integer argument expected, got float

Test Case:
This can be tested by running '/usr/lib/update-manager/check-new-release-gtk -d (-d so you see that precise is avaiable)
Then click ask me later and watch it crash

Michael Vogt (mvo) on 2011-10-13
Changed in update-manager (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
status: Confirmed → In Progress
Changed in update-manager (Ubuntu Oneiric):
status: New → In Progress
Changed in update-manager (Ubuntu Natty):
status: New → In Progress
Changed in update-manager (Ubuntu Oneiric):
importance: Undecided → Medium
Changed in update-manager (Ubuntu Natty):
importance: Undecided → Medium

Hello Michael, or anyone else affected,

Accepted update-manager into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in update-manager (Ubuntu Natty):
status: In Progress → Fix Committed
tags: added: verification-needed

Hi,

Martin Pitt a tapoté, le 14/10/2011 10:11:
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
> enable and use -proposed. Thank you in advance!
>
> ** Changed in: update-manager (Ubuntu Natty)
> Status: In Progress => Fix Committed

It doesn't work!

sudo apt-get update && sudo aptitude install update-manager/natty-proposed

2 000 o réceptionnés en 1min 8s (29 o/s)
Lecture des listes de paquets... Fait
Unable to find an archive "natty-proposed" for the package "update-manager"
Unable to find an archive "natty-proposed" for the package "update-manager"
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

Is there an alternative with apt-get?

--
Stéphane

<http://pasdenom.info/fortune/>

Et si on ôtait l'oisiveté du monde,
bientôt périraient les arts de Cupidon.
 -+- François Rabelais (1494?-1553), Tiers livre (chap. 31) -+-

yamo (stephane-gregoire) wrote :

Sorry I didn't seen "few hours", I can't cancel my post...

Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Natty:
I have reproduced the problem with update-manager 1:0.150.3 in natty-updates and have verified that the version of update-manager 1:0.150.4 in -proposed fixes the issue.

Marking as verification-done

tags: added: verification-done
removed: verification-needed
Daniel Kelly (dkellyhome) wrote :

      *
      *
      *
      * On Mon, 2011-10-17 at 13:04 +0000, Jean-Baptiste Lallement
        wrote:
> SRU verification for Natty:
> I have reproduced the problem with update-manager 1:0.150.3 in natty-updates and have verified that the version of update-manager 1:0.150.4 in -proposed fixes the issue.
>
> Marking as verification-done
>
>
> ** Tags removed: verification-needed
> ** Tags added: verification-done
>
How do I get the Natty upgrade?

When I used the update manager, it crashes.

Julian Taylor (jtaylor) wrote :

@Daniel Kelly: See this page for information on how to enable the -proposed repository:
https://wiki.ubuntu.com/Testing/EnableProposed
make sure you have version 1:0.150.4 installed (e.g. with apt-cache policy update-manager), if it still fails please report back.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.150.4

---------------
update-manager (1:0.150.4) natty-proposed; urgency=low

  * check-new-release-gtk:
    - ensure to write a integer when calculating the next time that
      the release available window will be presented (LP: #873424)
    - hide redundant release-notes button (LP: #873432)
 -- Michael Vogt <email address hidden> Thu, 13 Oct 2011 17:35:24 +0200

Changed in update-manager (Ubuntu Natty):
status: Fix Committed → Fix Released
mmohan (emmohankkalathi) wrote :

sir i have updated the update manager as you have told. i am aleaner. i
followed the instructions when i pressed the ask me later button. i tried
that from a live usb stick. i will try once and if it fails i will report
thank u for ur kind support

On Wed, Oct 19, 2011 at 7:27 PM, Launchpad Bug Tracker <
<email address hidden>> wrote:

> This bug was fixed in the package update-manager - 1:0.150.4
>
> ---------------
> update-manager (1:0.150.4) natty-proposed; urgency=low
>
> * check-new-release-gtk:
> - ensure to write a integer when calculating the next time that
> the release available window will be presented (LP: #873424)
> - hide redundant release-notes button (LP: #873432)
> -- Michael Vogt <email address hidden> Thu, 13 Oct 2011 17:35:24
> +0200
>
> ** Changed in: update-manager (Ubuntu Natty)
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (877544).
> https://bugs.launchpad.net/bugs/873424
>
> Title:
> ask me later fails
>
> Status in “update-manager” package in Ubuntu:
> In Progress
> Status in “update-manager” source package in Natty:
> Fix Released
> Status in “update-manager” source package in Oneiric:
> In Progress
> Status in “update-manager” source package in Precise:
> In Progress
>
> Bug description:
> Clicking on "ask me laster" in the release upgraer window fails with:
>
> Traceback (most recent call last):
> File "/usr/lib/update-manager/check-new-release-gtk", line 126, in
> on_button_ask_me_later_clicked
> client.set_int("/apps/update-notifier/release_check_time", next_check)
> TypeError: integer argument expected, got float
> Traceback (most recent call last):
> File "/usr/lib/update-manager/check-new-release-gtk", line 126, in
> on_button_ask_me_later_clicked
> client.set_int("/apps/update-notifier/release_check_time", next_check)
> TypeError: integer argument expected, got float
> Traceback (most recent call last):
> File "/usr/lib/update-manager/check-new-release-gtk", line 126, in
> on_button_ask_me_later_clicked
> client.set_int("/apps/update-notifier/release_check_time", next_check)
> TypeError: integer argument expected, got float
> Traceback (most recent call last):
> File "/usr/lib/update-manager/check-new-release-gtk", line 126, in
> on_button_ask_me_later_clicked
> client.set_int("/apps/update-notifier/release_check_time", next_check)
> TypeError: integer argument expected, got float
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/873424/+subscriptions
>

--
EMMOHANKKALATHI

Changed in update-manager (Ubuntu Precise):
assignee: nobody → Brian Murray (brian-murray)
Changed in update-manager (Ubuntu Oneiric):
assignee: nobody → Brian Murray (brian-murray)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.156

---------------
update-manager (1:0.156) precise; urgency=low

  [ Michael Vogt ]
  * pyflake fixes, remove some dead code
  * update unity dependency

  [ Brian Murray ]
  * DistUpgrade/DistUpgradeController.py
    - call apport-cli directly for bug reporting of errors
  * check-new-release-gtk
    - ensure to write a integer when calculating the next time that
      the release available window will be presented (LP: #873424)
    - hide redundant release-notes button (LP: #873432)
 -- Michael Vogt <email address hidden> Fri, 13 Jan 2012 11:08:32 +0100

Changed in update-manager (Ubuntu Precise):
status: In Progress → Fix Released

Hello Michael, or anyone else affected,

Accepted update-manager into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in update-manager (Ubuntu Oneiric):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
tags: added: bugpattern-written
description: updated
Brian Murray (brian-murray) wrote :

The debdiff that I uploaded to Oneiric was insufficient as it was looking in the update-manager schema for the particular setting rather than the update-notifier schema. I've uploaded a fix for that to oneiric-proposed and its in the queue awaiting approval.

Martin Pitt (pitti) wrote :

Hello Michael, or anyone else affected,

Accepted update-manager into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Moritz Naumann (mnaumann) wrote :

Thanks Brian and pitti, update-manager 1:0.152.25.7 from oneiric-proposed now passes the test case for me. No more crash on 'remind me later'.

A "Gtk-WARNING" and a "GLib-GIO-CRITICAL" remain, but this is probably a different issue and does not seem to impact overall functionality:

(check-new-release-gtk:4476): Gtk-WARNING **: Unknown property: GtkMessageDialog.has-separator

(check-new-release-gtk:4476): GLib-GIO-CRITICAL **: g_settings_set_value: key 'release-check-time' in 'com.ubuntu.update-notifier' expects type 'u', but a GVariant of type 'i' was given

Martin Pitt (pitti) on 2012-02-10
tags: added: verification-done
removed: verification-needed
Brian Murray (brian-murray) wrote :

Looking at update-manager in oneiric-updates this fix is included in the package.

Changed in update-manager (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Brian Murray (brian-murray) wrote :

Actually it isn't fixed in oneiric-updates as the security upload did not include the unverified changes.

Changed in update-manager (Ubuntu Oneiric):
status: Fix Released → In Progress

Ok!

Thanks for that! I'll try make this.

Cheers,

On Wed, Apr 4, 2012 at 6:02 PM, Brian Murray <email address hidden> wrote:

> Actually it isn't fixed in oneiric-updates as the security upload did
> not include the unverified changes.
>
> ** Changed in: update-manager (Ubuntu Oneiric)
> Status: Fix Released => In Progress
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (889657).
> https://bugs.launchpad.net/bugs/873424
>
> Title:
> ask me later fails
>
> Status in “update-manager” package in Ubuntu:
> Fix Released
> Status in “update-manager” source package in Natty:
> Fix Released
> Status in “update-manager” source package in Oneiric:
> In Progress
> Status in “update-manager” source package in Precise:
> Fix Released
>
> Bug description:
> Clicking on "ask me laster" in the release upgraer window fails with:
>
> Traceback (most recent call last):
> File "/usr/lib/update-manager/check-new-release-gtk", line 126, in
> on_button_ask_me_later_clicked
> client.set_int("/apps/update-notifier/release_check_time", next_check)
> TypeError: integer argument expected, got float
> Traceback (most recent call last):
> File "/usr/lib/update-manager/check-new-release-gtk", line 126, in
> on_button_ask_me_later_clicked
> client.set_int("/apps/update-notifier/release_check_time", next_check)
> TypeError: integer argument expected, got float
> Traceback (most recent call last):
> File "/usr/lib/update-manager/check-new-release-gtk", line 126, in
> on_button_ask_me_later_clicked
> client.set_int("/apps/update-notifier/release_check_time", next_check)
> TypeError: integer argument expected, got float
> Traceback (most recent call last):
> File "/usr/lib/update-manager/check-new-release-gtk", line 126, in
> on_button_ask_me_later_clicked
> client.set_int("/apps/update-notifier/release_check_time", next_check)
> TypeError: integer argument expected, got float
>
> Test Case:
> This can be tested by running
> '/usr/lib/update-manager/check-new-release-gtk -d (-d so you see that
> precise is avaiable)
> Then click ask me later and watch it crash
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/873424/+subscriptions
>

--
*Caio Branco
(21) 8870-8004*

Hello Michael, or anyone else affected,

Accepted into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in update-manager (Ubuntu Oneiric):
status: In Progress → Fix Committed
C de-Avillez (hggdh2) wrote :

confirmed working with the -proposed version.

tags: added: oneiric-verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.152.25.9

---------------
update-manager (1:0.152.25.9) oneiric-proposed; urgency=low

  * In the apport package hook continue if unable to import gconf data
    (LP: #880704)
  * In the apport package hook do not gzip the apt-clone attachment two times
    (LP: #973747)
  * check-new-release-gtk:
    - ensure to write a integer when calculating the next time that
      the release available window will be presented (LP: #873424)
    - hide redundant release-notes button (LP: #873432)
  * check-new-release-gtk:
    - write the time to check the new release to the update-notifier schema
      not the update-manager one (LP: #873424)
 -- Brian Murray <email address hidden> Wed, 04 Apr 2012 13:04:28 -0700

Changed in update-manager (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.