Ubuntu

Cycle of pinning/unpinning application leads to icon not appearing in launcher

Reported by Erlan Sergaziev on 2011-07-02
38
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Unity
Undecided
Unassigned
unity (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Unassigned

Bug Description

TEST CASE:
1.) Run gedit with Alt+F2 'gksu gedit'
2.) Pin gedit to the launcher with 'Right Click > Keep in Launcher'
3.) Open gedit with the pinned launcher icon and then close it as fast as possible then unpin it
4.) Keep repeating 1-3 until you open gedit and no launcher icon appears.

At that point dragging the icon from the Dash when gedit is closed will not do anything (the icon won't appear)

= Original Description =
Gedit doesn't properly integrate with the launcher, namely:

1) If I drag it's icon from dash to the launcher, I don't see the icon, but instead an empty space. Hovering over this space produces a tooltip "Empty Label"
2) When launched from dash (or command line) and then choosing "Keep in Launcher" the icon doesn't indicate a running app (i.e. when gedit gets launched from this, there's no triangle to indicate that it's running)
3) On certain occasions, nothing appears at all on the launcher when gedit gets launched.

Happens from time to time on Natty, always on Oneiric.
---
Architecture: i386
DistroRelease: Ubuntu 11.10
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110702)
Package: gedit 3.1.1-0ubuntu4
PackageArchitecture: i386
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.0-2.3-generic 3.0.0-rc4
Tags: unity-2d oneiric running-unity
Uname: Linux 3.0-2-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

description: updated

Not confirmable fgr me on either Natty or Oneiric. Can you run 'apport-collect 804878' in a terminal so we can see which package versions are involved?

apport information

tags: added: apport-collected oneiric running-unity unity-2d
description: updated

It appears intermittent in Oneiric as well, I'll try to come up with steps to reproduce soon.

Erlan Sergaziev (sergeant) wrote :

OK, after a dozen of tries I still can't come up with an exact sequence of actions to reproduce this bug.
However, it's quite frequent and surprises me why nobody's experiencing it.
Here are a few things that greatly increase the chances of hitting this bug:

1) Alt+F2, type "gksudo gedit", pin the app and close it.
2) Click on gedit launcher and while it's still running unpin it or just close it quickly.
3) Do it several times.

If I do above in series of 5-6 I hit the bug almost all the times.

Wow - indeed, this does in fact happen after 5-6 tries. Seems like a race condition. Have you been able to make it happen with any other applications?

To clarify steps to reproduce:

1.) Run gedit with Alt+F2 'gksu gedit'
2.) Pin gedit to the launcher with 'Right Click > Keep in Launcher'
3.) Open gedit with the pinned launcher icon and then close it as fast as possible then unpin it
4.) Keep repeating 1-3 until you open gedit and no launcher icon appears.

At that point dragging the icon from the Dash when gedit is closed will not do anything (the icon won't appear)

Good spot! Thanks for raising this bug and helping to make Ubuntu better.

Changed in gedit (Ubuntu):
status: New → Confirmed
affects: gedit (Ubuntu) → unity (Ubuntu)
summary: - weird gedit + launcher behavior
+ Cycle of pinning/unpinning application leads to icon not appearing in
+ launcher

I've moved this bug to Unity and changed the title because I would expect the problem is likely to be there (there may be some aspect of gedit's .desktop file which trigger this bug but it's unlikely to be the problem itself). I also clarified the title as it didn't really explain what's happening.

Andreas Moog (amoog) on 2011-07-03
Changed in unity (Ubuntu):
importance: Undecided → Medium
Erlan Sergaziev (sergeant) wrote :

Thanks!
I am not quite sure but Nautilus also exhibited same behavior in Natty. In Oneiric it doesn't start at all with gksudo.
I don't have Natty anymore, but I am using Oneiric extensively so if I come accross anything I'll let know.

Hi,

Actually I have confirmed this in Oneiric as well. Interesting to know it can happen with Nautilus too.

description: updated
Changed in unity (Ubuntu Oneiric):
status: Confirmed → Triaged
Didier Roche (didrocks) on 2011-07-05
Changed in unity:
status: New → Triaged
Alex Peters (alex-peters) wrote :

At the expense of cross-polluting bugs, I have added commentary to Bug #748190 for this exact issue with Shotwell.

I have successfully replicated the behaviour three times by following these (possibly less than optimal) steps:

1. Ensure that a Shotwell icon is set to "keep in launcher."
2. Log out, then back in.
3. Start Shotwell via the launcher icon.
4. Quit Shotwell via the launcher icon.
5. Start Shotwell via the launcher icon.
6. Right-click the Shotwell launcher icon and untick "keep in launcher."
7. Quit Shotwell via the launcher icon.
8. Start Shotwell via the Ubuntu logo > View Photos.
9. Quit Shotwell via the launcher icon.
10. Start Shotwell via the Ubuntu logo > View Photos.
11. Right-click the Shotwell launcher icon and tick "keep in launcher."
12. Quit Shotwell via the launcher icon.
13. Start Shotwell via the launcher icon. Observe that Shotwell successfully starts, but the launcher icon continues to pulsate and fails to show a triangle on the side indicating running.

Bug #688777, while marked as having a "fix released," appears to be very much related.

tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers