Ubuntu

Wrong keyboard selection with starting directly ubiquity

Reported by Didier Roche on 2010-10-08
52
This bug affects 9 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Evan Dandrea
Natty
High
Evan Dandrea
Oneiric
High
Evan Dandrea

Bug Description

Binary package hint: ubiquity

From a box connected or disconnected from the Internet:

1. start the live without using the syslinux menu (so, wait for booting in the ubiquity installer)
2. Select French
3. get to next steps…
4. if you try to either define manually partition or set the town/country your are in, you will see that your keyboard is in qwerty (most of people speaking French have an azerty keyboard, especially as the default town when choosing French with no network is "Paris".
5. then, the good keyboard is proposed as a default on the next step and all is well configured.

-> having a qwerty keyboard can be confusing when making a custom partition, or trying to set a town/country in the map.
-> Not that, if you choose "try ubuntu" from ubiquity after selecting French, you are leaded to a live session with an azerty keyboard, at least, this only affects the "partition manually" and "choose you city" in ubiquity.

This doesn't happen if you use the syslinux menu. (which means, pressing a key at the very start, then choosing French) -> the right keyboard is selected.

Related branches

lp:ubiquity
Adolfo Jayme (community): Disapprove on 2014-04-02
Ondrej Pačay: Pending requested 2013-12-11
tags: added: iso-testing
Didier Roche (didrocks) on 2010-10-08
description: updated
Didier Roche (didrocks) on 2010-10-08
description: updated
Evan Dandrea (ev) wrote :

This is a consequence of us moving partitioning before keyboard selection. The timezone page already appeared before the keyboard page in previous releases, but typing to find a city was not the secondary means of interaction then, as it is now.

This use case was meant to be handled by a keyboard layout indicator, but that work was deferred to Natty.

Unfortunately, we cannot move keyboard selection any further forward as it depends on the timezone being set so that it may guess the correct layout based on location and language.

Changed in ubiquity (Ubuntu):
importance: Undecided → High
milestone: none → later
status: New → Confirmed
Didier Roche (didrocks) wrote :

Why not taking the choice than if you select "French" -> azerty (well, French oss) as keyboard detection is proposing in the following screen after by default? (also, syslinux is making the same assumption).

It seems like you have the same map between language -> common keyboard layout used.

innaheight (innaheight) wrote :

For the French or any others not using a QWERTY keyboard

Same bug in the German version. Usually German users use QWERTZ keyboards. Not easy for newcomers to type in their home town which might be written with an umlaut.

starslights (starslights) wrote :

Same bug with Swiss-French on ubuntu-desktop natty iso-testing 64 bits, build 20110329.1

All swiss-French choose give same as Swiss-German: é = ö and à = ä

starslights (starslights) wrote :

Update for #5:

In system setting --> keyboard, if i choose "French and layout Swiss-French" , i get the right task .

So only in ubiquity it do wrong

Best Regards

Colin Watson (cjwatson) wrote :

Didier, in the wider context it's not always just the language that informs the keyboard choice: it's often the combination of language and country, or even just the country. Selecting by language only may be an improvement over the US keymap in your case, but definitely not always. For example, the French Canadian keymap is very much closer to the US keymap than to the French keymap, and I'm willing to bet that French Canadians would be quite upset if we assumed that they'd prefer the French keymap just because they speak French.

While you're right that gfxboot makes the same assumption, at the time I made that assumption in gfxboot there was very little typing required before you had the opportunity to modify the default keyboard layout; and gfxboot also offers a keyboard menu, so it's possible to change it immediately if it's wrong (at least after the first time you notice the problem). That wouldn't be the case here - there's no way to change the keyboard layout until after the timezone page.

As Evan says, there isn't a simple quick fix here, certainly not as simple as moving things around or assuming that language is sufficient to infer keyboard layout. A keyboard indicator would allow the user to change the keyboard layout before or after the timezone page as necessary, and is probably the proper solution.

Didier Roche (didrocks) wrote :

Oh sure Colin, we discussed that around maverick release cycle and I agree with you. :)

What do you think about adding the keyboard indicator (it's there for natty IIRC) by default in the ubiquity session with a default selection based on language, as for gfxboot does? Not sure the timeframe will enable that though, but maybe for Oneiric?

Colin Watson (cjwatson) wrote :

That seems reasonable for Oneiric. (I didn't know the indicator existed; Evan may have been aware of it though ...)

Changed in ubiquity (Ubuntu):
milestone: later → ubuntu-11.04-beta-2
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Colin Watson (cjwatson) wrote :

Kate, we can't do this for beta-2 - it would be too disruptive. Moving back to later, as we should revisit it for Oneiric per the previous comments.

Changed in ubiquity (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Evan Dandrea (ev)
milestone: ubuntu-11.04-beta-2 → later
Changed in ubiquity (Ubuntu Oneiric):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Evan Dandrea (ev)
Pete Graner (pgraner) on 2011-04-25
Changed in ubiquity (Ubuntu Natty):
status: Confirmed → Won't Fix
milestone: later → none

Similar problem in the Japanese version--but at this point I'm expecting Ubuntu to become more useless with each so-called upgrade. I'm just trying to do the upgrade, and the first question it asks is for a keyboard, but it does NOT offer ANY option that is recognizably similar to the keyboard they I am using. I wouldn't mind so much if it was some kind of exotic computer, but it is NOT. Just a plain Jane Lenovo X61 ThinkPad. Ever heard of it? Evidently not.

Look, I really want you to succeed, but you are failing more and more. I have already decided NOT to install Ubuntu on any more machines, because it gets worse and worse each time. At this point I'm still attempting to update some of my VMware installations... Or at least I tried it once. The so far evidence is that I should just give up now and save myself the additional grief.

Waste of time, but I'm going to repeat myself: I don't blame you for failing. I think the problem is your economic model, which is basically the big donor model for charity. That can work if the donor is rich enough, but he isn't, or if he always makes perfect decisions, but he doesn't. I'm going to try to end on a constructive note that addresses the REAL problem here by suggesting that you need to adjust your economic model to get MUCH more testing into the process. My main conclusion at this point is that you need to insure there is enough testing BEFORE you release an upgrade, even if it delays the upgrades. Here's a suggested funding mechanism that would get committed funds from small donors BEFORE you program:

http://eco-epistemology.blogspot.com/2009/11/economics-of-small-donors-reverse.html

Bernard Decock (decockbernard) wrote :

I have a suggestion. When the installer menu (install ubuntu/try ubuntu) pops up, you can set up your network through the network-tab (top-right) just before installing ubuntu (this allows the downloading of patches during install). Why don't you add a tab next to the network-tab in order to allow one to set the proper keyboard-layout?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.7.0

---------------
ubiquity (2.7.0) oneiric; urgency=low

  [ Evan Dandrea ]
  * Prevent the OOM killer from selecting ubiquity. See LP #770865.
  * Ensure that the partition ComboBoxEntry can be focused
    (LP: #769043).
  * Hide the other pages when starting the slideshow so that verbose
    languages that cause the window to grow do not leave lots of
    whitespace on the slideshow (LP: #770253).
  * Don't offer the download updates option when there is no Internet
    connection. See LP: 651932.
  * Provide access to the keymaps most-relevant for the currently
    selected language in the keyboard indicator (LP: #656777).
  * gnome-settings-daemon no longer daemonizes (LP: #788859).
  * Automatic update of included source packages: partman-auto
    93ubuntu16.

  [ Colin Watson ]
  * Re-enable alpha warning for oneiric.
  * Make ubiquity/nonfree_package preseedable, and allow it to contain
    multiple whitespace-separated package names.

  [ Mario Limonciello ]
  * In automatic ubiquity mode, don't clobber grub-installer/bootdev
    because of the U/I widget not being populated. Fixes preseeded
    grub-installer/bootdev.
 -- Evan Dandrea <email address hidden> Tue, 31 May 2011 14:56:14 +0100

Changed in ubiquity (Ubuntu Oneiric):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints