libxml2:i386 and ubuntu-desktop are not coinstallable on 64bit oneiric due to broken multiarch dependencies

Bug #1082170 reported by Daniel Gimpelevich on 2012-11-22
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
iso-codes (Ubuntu)
Undecided
Unassigned
Oneiric
High
Colin Watson
libxml2 (Ubuntu)
Undecided
Unassigned
Oneiric
High
Unassigned
skype (Ubuntu)
Oneiric
Critical
Adam Conrad

Bug Description

libxml2 needs to be backported from precise to oneiric

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in skype (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) wrote :

Marking iso-codes as "Multi-Arch: foreign" in oneiric would help. This was done in 3.30-1, but oneiric has 3.27-1.

Changed in iso-codes (Ubuntu):
status: New → Fix Released
Colin Watson (cjwatson) wrote :

As for libxml2, this needs to be converted for multiarch, specifically Multi-Arch: same. This was done in 2.7.8.dfsg-5ubuntu1 in precise and 2.7.8.dfsg-9 in Debian unstable. Perhaps a backport would be a bit more minimal though.

Changed in libxml2 (Ubuntu):
status: New → Fix Released
Colin Watson (cjwatson) wrote :

My feeling is that we're going to need to revert skype, get these updates in place, and then restore the new skype.

Changed in iso-codes (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → High
Changed in libxml2 (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → High
Changed in skype (Ubuntu):
status: Confirmed → Invalid
Changed in skype (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → Critical
Colin Watson (cjwatson) on 2012-11-22
Changed in iso-codes (Ubuntu Oneiric):
status: Triaged → In Progress
assignee: nobody → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

I've uploaded iso-codes (awaiting review). However, I'm decreasingly convinced that we can convert libxml2 to multiarch in oneiric at all. Lots of .la files referred to the non-multiarch location (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=643026), and at least parser, pyabiword, and gnustep-base had to be fixed due to broken build system assumptions. This is a lot to try to do in a stable release, and we'd probably need a full test rebuild.

I wonder if it's possible to get a version of the new skype without the libqtwebkit4 dependency, which is the relevant difference here?

If it offers any clue, the Skype website offers a binary in a tarball dynamically linked to all the same libraries, which runs just fine from its self-contained directory on oneiric.

Hello Daniel, or anyone else affected,

Accepted iso-codes into oneiric-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/iso-codes/3.27-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in iso-codes (Ubuntu Oneiric):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in skype (Ubuntu Oneiric):
status: Triaged → Fix Committed
Adam Conrad (adconrad) wrote :

Hello Daniel, or anyone else affected,

Accepted skype into oneiric-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/skype/4.1.0.20+4.0.0.8-0ubuntu0.11.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in skype (Ubuntu Oneiric):
assignee: nobody → Adam Conrad (adconrad)

Skype has been reverted in oneiric to the old version for now.

Changed in skype (Ubuntu Oneiric):
status: Fix Committed → Fix Released

Sorry, I don't see any tag section to change the verification status.

Changed in iso-codes (Ubuntu Oneiric):
status: Fix Committed → Fix Released

On Fri, 2012-11-23 at 00:15 +0000, Colin Watson wrote:
> I've uploaded iso-codes (awaiting review). However, I'm decreasingly
> convinced that we can convert libxml2 to multiarch in oneiric at all.
> Lots of .la files referred to the non-multiarch location
> (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=643026), and at least
> parser, pyabiword, and gnustep-base had to be fixed due to broken build
> system assumptions. This is a lot to try to do in a stable release, and
> we'd probably need a full test rebuild.

I've reviewed iso-codes, and it appears to be fine. You already said
that libxml2 is fully converted in precise, which has the exact same
upstream version. Given that, I see no reason at all not to backport it
from precise.

tags: added: verification-done
removed: verification-needed
description: updated
summary: - skype-bin is not installable on 64bit oneiric due to broken multiarch
+ libxml2 is not installable on 64bit oneiric due to broken multiarch
dependencies
Colin Watson (cjwatson) wrote :

The "verification-done" tag is sufficient; iso-codes shouldn't go to Fix Released until the package is actually copied to -updates.

I explained in comment #5 why it is not a straightforward matter to convert libxml2 to multiarch in oneiric. Sure, the package itself is fairly easy to convert, but there are a lot of knock-on effects; it wouldn't be acceptable, for instance, to cause any future security updates of an unknown but definitely non-zero number of packages to fail to build. We would have to do a full test rebuild of all reverse dependencies of libxml2 and backport all the build system fixes that we and/or Debian applied to those in precise. Given that oneiric has only five months of support left, and that we do not appear to have a clear requirement to update skype in oneiric, it's not obvious that this effort is worth it by comparison with the other things we could be fixing in oneiric or other releases.

Changed in iso-codes (Ubuntu Oneiric):
status: Fix Released → Fix Committed
summary: - libxml2 is not installable on 64bit oneiric due to broken multiarch
- dependencies
+ libxml2:i386 and ubuntu-desktop are not coinstallable on 64bit oneiric
+ due to broken multiarch dependencies
Colin Watson (cjwatson) wrote :

And this is not a theoretical concern, by the way. We *know* that when we converted libxml2 to multiarch in precise, several other things broke as a result. The fact that it was the same upstream version didn't matter.

Won't Fix status, then?

Colin Watson (cjwatson) wrote :

That's my current feeling, but I like to get general agreement before whacking things with the Won't Fix stick, in general :-)

no longer affects: skype (Ubuntu)

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package iso-codes - 3.27-1ubuntu1

---------------
iso-codes (3.27-1ubuntu1) oneiric-proposed; urgency=low

  * Mark package as "Multi-Arch: foreign" (LP: #1082170).
 -- Colin Watson <email address hidden> Thu, 22 Nov 2012 23:46:41 +0000

Changed in iso-codes (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in libxml2 (Ubuntu Oneiric):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.