Oneiric update to 3.0.25 stable release

Bug #959470 reported by Tim Gardner on 2012-03-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from Linus' tree or in a minimally
       backported form of that patch. The 3.0.25 upstream stable
       patch set is now available. It should be included in the Ubuntu
       kernel as well.

       git://git.kernel.org/

    TEST CASE: TBD

       The following patches are in the 3.0.25 stable release:

ASoC: neo1973: fix neo1973 wm8753 initialization
aio: fix io_setup/io_destroy race
aio: fix the "too late munmap()" race
x86: Derandom delay_tsc for 64 bit
PCI: ignore pre-1.1 ASPM quirking when ASPM is disabled
firewire: cdev: fix 32 bit userland on 64 bit kernel compat corner cases
firewire: core: handle ack_busy when fetching the Config ROM
PM / Driver core: leave runtime PM enabled during system shutdown
rt2x00: fix random stalls
vfs: fix return value from do_last()
vfs: fix double put after complete_walk()
acer-wmi: support Lenovo ideapad S205 wifi switch
acer-wmi: check wireless capability flag before register rfkill
acer-wmi: No wifi rfkill on Lenovo machines
neighbour: Fixed race condition at tbl->nht
ipsec: be careful of non existing mac headers
ppp: fix 'ppp_mp_reconstruct bad seq' errors
tcp: fix false reordering signal in tcp_shifted_skb
vmxnet3: Fix transport header size
tcp: don't fragment SACKed skbs in tcp_mark_head_lost()
bridge: check return value of ipv6_dev_get_saddr()
tcp: fix tcp_shift_skb_data() to not shift SACKed data below snd_una
IPv6: Fix not join all-router mcast group when forwarding set.
atl1c: dont use highprio tx queue
usb: asix: Patch for Sitecom LN-031
compat: Re-add missing asm/compat.h include to fix compile breakage on s390
regulator: Fix setting selector in tps6524x set_voltage function
block: Fix NULL pointer dereference in sd_revalidate_disk
block, sx8: fix pointer math issue getting fw version
block: fix __blkdev_get and add_disk race condition
Block: use a freezable workqueue for disk-event polling
sfc: Fix assignment of ip_summed for pre-allocated skbs
sparc32: Add -Av8 to assembler command line.
compat: Re-add missing asm/compat.h include to fix compile breakage on s390
hwmon: (w83627ehf) Fix writing into fan_stop_time for NCT6775F/NCT6776F
hwmon: (w83627ehf) Fix memory leak in probe function
i2c-algo-bit: Fix spurious SCL timeouts under heavy load
Linux 3.0.25

Tim Gardner (timg-tpi) on 2012-03-19
tags: added: kernel-stable-tracking-bug
description: updated
Changed in linux (Ubuntu Oneiric):
status: New → Fix Committed
Changed in linux (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (24.1 KiB)

This bug was fixed in the package linux - 3.0.0-19.33

---------------
linux (3.0.0-19.33) oneiric-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #985736

  [ Luis Henriques ]

  * SAUCE: ite-cir: postpone ISR registration
    - LP: #984387

linux (3.0.0-19.32) oneiric-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #974368

  [ Brad Figg ]

  * SAUCE (no-up) Provide a param for allowing the BIOS to handle changing
    the brightness on AC/battery status changes.
    - LP: #949311
  * SAUCE (no-up) Quirk for enabling backlight hotkeys on Samsung N150P
    - LP: #875893

  [ Daniel Vetter ]

  * SAUCE: (drop after 3.5) drm/i915: reinstate GM45 TV detection fix
    - LP: #638939

  [ Herton Ronaldo Krzesinski ]

  * SAUCE: (no-up) Reinstate missing hunk from nx emulation
    - LP: #972821

  [ Tim Gardner ]

  * SAUCE: ubuntu drivers: use UMH_WAIT_PROC consistently
    - LP: #963685
  * SAUCE: disable_nx should not be in __cpuinitdata section for X86_32
    - LP: #968233
  * SAUCE: (no-up) remove __initdata from vesafb_fix
    - LP: #969309

  [ Upstream Kernel Changes ]

  * usermodehelper: use UMH_WAIT_PROC consistently
    - LP: #963685
  * usermodehelper: introduce umh_complete(sub_info)
    - LP: #963685
  * usermodehelper: implement UMH_KILLABLE
    - LP: #963685
  * usermodehelper: kill umh_wait, renumber UMH_* constants
    - LP: #963685
  * usermodehelper: ____call_usermodehelper() doesn't need do_exit()
    - LP: #963685
  * kmod: introduce call_modprobe() helper
    - LP: #963685
  * kmod: make __request_module() killable
    - LP: #963685
  * x86, tsc: Fix SMI induced variation in quick_pit_calibrate()
    - LP: #965586
  * ata_piix: Add Toshiba Satellite Pro A120 to the quirks list due to
    broken suspend functionality.
    - LP: #886850
  * ACPICA: Fix regression in FADT revision checks
    - LP: #883441
  * ASPM: Fix pcie devices with non-pcie children
    - LP: #961482
  * USB: option: Add MediaTek MT6276M modem&app interfaces
    - LP: #971808
  * USB: option driver: adding support for Telit CC864-SINGLE, CC864-DUAL
    and DE910-DUAL modems
    - LP: #971808
  * USB: option: make interface blacklist work again
    - LP: #971808
  * USB: option: add ZTE MF820D
    - LP: #971808
  * USB: ftdi_sio: fix problem when the manufacture is a NULL string
    - LP: #971808
  * USB: ftdi_sio: add support for BeagleBone rev A5+
    - LP: #971808
  * USB: Microchip VID mislabeled as Hornby VID in ftdi_sio.
    - LP: #971808
  * USB: ftdi_sio: new PID: Distortec JTAG-lock-pick
    - LP: #971808
  * USB: ftdi_sio: add support for FT-X series devices
    - LP: #971808
  * USB: ftdi_sio: new PID: LUMEL PD12
    - LP: #971808
  * powerpc/usb: fix bug of kernel hang when initializing usb
    - LP: #971808
  * usb: musb: Reselect index reg in interrupt context
    - LP: #971808
  * usb: gadgetfs: return number of bytes on ep0 read request
    - LP: #971808
  * USB: gadget: Make g_hid device class conform to spec.
    - LP: #971808
  * futex: Cover all PI opcodes with cmpxchg enabled check
    - LP: #971808
  * sysfs: Fix memory leak in sysfs_sd_setsecdata().
    - LP: #971808
  * tty: ...

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers