Activity log for bug #911507

Date Who What changed Old value New value Message
2012-01-03 23:05:51 Tyler Hicks bug added bug
2012-01-03 23:37:00 Fabian Köster bug added subscriber Fabian Köster
2012-01-04 07:58:34 Mihai Capotă bug added subscriber Mihai Capotă
2012-01-04 15:35:30 toobuntu bug added subscriber toobuntu
2012-01-05 18:25:03 bojo42 bug added subscriber bojo42
2012-01-11 01:16:02 Bohdan Kmit' bug added subscriber Bohdan Kmit'
2012-01-11 07:26:42 Adam Porter bug added subscriber Adam Porter
2012-02-03 15:21:01 Torsten Krah bug added subscriber Torsten Krah
2012-02-08 06:49:57 Tyler Hicks ecryptfs: importance High Medium
2012-02-26 09:17:07 Alexis de Lattre bug added subscriber Alexis de Lattre
2012-03-13 07:58:33 Søren Holm bug added subscriber Søren Holm
2012-04-05 03:35:51 Rocko bug added subscriber Rocko
2012-04-07 07:03:53 vkapas bug added subscriber vkapas
2012-04-13 19:25:56 David Moreno Fernández bug added subscriber David Moreno Fernández
2012-04-14 01:13:24 Jakub Kałuża bug added subscriber Jakub Kałuża
2012-05-11 12:23:25 DanielW bug added subscriber DanielW
2012-05-26 16:39:16 Nicolas Diogo attachment added ecryptfs_installed https://bugs.launchpad.net/ecryptfs/+bug/911507/+attachment/3164342/+files/ecryptfs_installed
2012-05-31 07:43:42 klerfayt bug added subscriber klerfayt
2012-06-04 20:17:27 Mauro Amico bug added subscriber Mauro Amico
2012-06-13 16:57:59 Tyler Hicks ecryptfs: status Triaged In Progress
2012-06-27 15:19:41 aslam karachiwala bug added subscriber aslam karachiwala
2012-06-28 16:17:45 Félim Whiteley bug added subscriber Félim Whiteley
2012-06-29 23:29:51 Florian Rathgeber bug added subscriber Florian Rathgeber
2012-07-01 23:14:35 Kamyar bug added subscriber Kamyar
2012-07-02 11:10:40 Mario Vukelic bug added subscriber Mario Vukelic
2012-07-03 13:34:41 Marius Kruger bug added subscriber Marius Kruger
2012-07-07 10:08:59 sas bug added subscriber sas
2012-07-09 10:15:50 peddy bug added subscriber peddy
2012-07-31 15:02:40 Marius B. Kotsbak bug task added linux (Ubuntu)
2012-07-31 15:03:23 Marius B. Kotsbak tags precise
2012-07-31 15:03:40 Marius B. Kotsbak linux (Ubuntu): status New Confirmed
2012-07-31 15:05:59 Marius B. Kotsbak bug added subscriber Marius Kotsbak
2012-07-31 15:10:49 Marius B. Kotsbak description Empty files left in the lower filesystem cause eCryptfs to return error codes and log error messages when eCryptfs tries to read the metadata. This has been the mode of operation since the beginning of eCryptfs. There is no eCryptfs metadata available, so it seemed appropriate to refuse to open the file. However, more and more users are having trouble with this poor design. It would not be too difficult to convert the empty file into a proper eCryptfs file in the open() path, just as is done in the create() path. Currently, users see these messages logged to their syslog: Valid eCryptfs headers not found in file header region or xattr region Either the lower file is not in a valid eCryptfs format, or the key could not be retrieved. Plaintext passthrough mode is not enabled; returning -EIO Transparently converting the empty file to an eCryptfs file and successfully completing the open() request will greatly improve usability. Empty files left in the lower filesystem cause eCryptfs to return error codes and log error messages when eCryptfs tries to read the metadata. This has been the mode of operation since the beginning of eCryptfs. There is no eCryptfs metadata available, so it seemed appropriate to refuse to open the file. However, more and more users are having trouble with this poor design. It would not be too difficult to convert the empty file into a proper eCryptfs file in the open() path, just as is done in the create() path. Currently, users see these messages logged to their syslog: Valid eCryptfs headers not found in file header region or xattr region Either the lower file is not in a valid eCryptfs format, or the key could not be retrieved. Plaintext passthrough mode is not enabled; returning -EIO Transparently converting the empty file to an eCryptfs file and successfully completing the open() request will greatly improve usability. WORKAROUND: see comment #19 https://bugs.launchpad.net/ecryptfs/+bug/911507/comments/19
2012-08-02 19:54:00 Christian Mertes bug added subscriber Christian Mertes
2012-08-02 20:03:32 Tyler Hicks ecryptfs: status In Progress Fix Committed
2012-08-03 15:31:37 FuzzyQ bug added subscriber FuzzyQ
2012-08-04 02:45:21 Tyler Hicks ecryptfs: status Fix Committed Fix Released
2012-08-07 14:55:19 Tim Gardner linux (Ubuntu): status Confirmed In Progress
2012-08-07 14:55:19 Tim Gardner linux (Ubuntu): assignee Colin King (colin-king)
2012-08-07 14:55:36 Tim Gardner nominated for series Ubuntu Precise
2012-08-07 14:55:36 Tim Gardner bug task added linux (Ubuntu Precise)
2012-08-07 14:55:36 Tim Gardner nominated for series Ubuntu Quantal
2012-08-07 14:55:36 Tim Gardner bug task added linux (Ubuntu Quantal)
2012-08-07 14:56:01 Tim Gardner linux (Ubuntu Precise): status New In Progress
2012-08-07 14:56:01 Tim Gardner linux (Ubuntu Precise): assignee Colin King (colin-king)
2012-08-07 14:56:19 Tim Gardner linux (Ubuntu Quantal): status In Progress Fix Committed
2012-08-07 14:58:08 Tim Gardner nominated for series Ubuntu Oneiric
2012-08-07 14:58:08 Tim Gardner bug task added linux (Ubuntu Oneiric)
2012-08-07 14:58:32 Tim Gardner linux (Ubuntu Oneiric): status New In Progress
2012-08-07 14:58:32 Tim Gardner linux (Ubuntu Oneiric): assignee Colin King (colin-king)
2012-08-08 12:20:45 Tim Gardner linux (Ubuntu Oneiric): status In Progress Fix Committed
2012-08-08 12:20:50 Tim Gardner linux (Ubuntu Precise): status In Progress Fix Committed
2012-08-08 12:20:55 Tim Gardner linux (Ubuntu Quantal): status Fix Committed Fix Released
2012-08-08 12:21:39 Tim Gardner linux (Ubuntu Quantal): status Fix Released Fix Committed
2012-08-10 00:06:09 Launchpad Janitor linux (Ubuntu Quantal): status Fix Committed Fix Released
2012-08-10 05:28:03 Launchpad Janitor branch linked lp:ubuntu/linux-lowlatency
2012-08-10 07:16:03 Fabian Köster removed subscriber Fabian Köster
2012-08-20 22:54:25 Brad Figg tags precise precise verification-needed-oneiric
2012-08-21 09:24:51 Luis Henriques tags precise verification-needed-oneiric precise verification-needed-oneiric verification-needed-precise
2012-08-21 09:53:06 Colin Ian King tags precise verification-needed-oneiric verification-needed-precise precise verification-done-oneiric
2012-08-21 10:01:14 Colin Ian King tags precise verification-done-oneiric precise verification-done-oneiric verification-done-precise
2012-08-21 12:27:39 Launchpad Janitor branch linked lp:ubuntu/oneiric-proposed/linux-ti-omap4
2012-08-21 12:27:49 Launchpad Janitor branch linked lp:ubuntu/precise-proposed/linux-ti-omap4
2012-08-21 12:34:29 Launchpad Janitor branch linked lp:ubuntu/precise-proposed/linux-armadaxp
2012-08-22 12:42:20 Tim Gardner nominated for series Ubuntu Lucid
2012-08-22 12:42:20 Tim Gardner bug task added linux (Ubuntu Lucid)
2012-08-22 12:42:20 Tim Gardner nominated for series Ubuntu Natty
2012-08-22 12:42:20 Tim Gardner bug task added linux (Ubuntu Natty)
2012-08-22 12:42:55 Tim Gardner linux (Ubuntu Lucid): status New Fix Committed
2012-08-22 12:42:55 Tim Gardner linux (Ubuntu Lucid): assignee Colin King (colin-king)
2012-08-22 12:43:18 Tim Gardner linux (Ubuntu Natty): status New Fix Committed
2012-08-22 12:43:18 Tim Gardner linux (Ubuntu Natty): assignee Colin King (colin-king)
2012-08-31 20:46:02 grosso bug added subscriber grosso
2012-09-04 23:46:10 Launchpad Janitor linux (Ubuntu Precise): status Fix Committed Fix Released
2012-09-05 00:10:15 Launchpad Janitor linux (Ubuntu Oneiric): status Fix Committed Fix Released
2012-09-05 00:10:15 Launchpad Janitor cve linked 2012-2372
2012-09-07 14:47:07 Colin Ian King tags precise verification-done-oneiric verification-done-precise precise verification-done-lucid verification-done-oneiric verification-done-precise
2012-09-07 22:59:42 Launchpad Janitor branch linked lp:ubuntu/lucid-proposed/linux-ec2
2012-09-10 10:52:57 Luis Henriques tags precise verification-done-lucid verification-done-oneiric verification-done-precise precise verification-done-lucid verification-done-oneiric verification-done-precise verification-needed-natty
2012-09-10 11:18:45 Colin Ian King tags precise verification-done-lucid verification-done-oneiric verification-done-precise verification-needed-natty precise verification-done-lucid verification-done-natty verification-done-oneiric verification-done-precise
2012-09-10 17:13:28 Launchpad Janitor branch linked lp:ubuntu/lucid-proposed/linux-lts-backport-natty
2012-09-13 23:14:09 Launchpad Janitor linux (Ubuntu Natty): status Fix Committed Fix Released
2012-09-13 23:14:09 Launchpad Janitor cve linked 2012-2745
2012-09-13 23:14:09 Launchpad Janitor cve linked 2012-3412
2012-09-13 23:14:09 Launchpad Janitor cve linked 2012-3430
2012-09-13 23:14:09 Launchpad Janitor cve linked 2012-3511
2012-09-18 01:35:12 Launchpad Janitor linux (Ubuntu Lucid): status Fix Committed Fix Released
2012-11-14 21:30:44 Launchpad Janitor branch linked lp:ubuntu/precise-proposed/linux-lowlatency
2013-05-07 17:21:21 Launchpad Janitor branch linked lp:ubuntu/lucid-security/linux-lts-backport-oneiric
2014-01-15 21:39:30 Launchpad Janitor branch linked lp:ubuntu/lucid-updates/linux-lts-backport-oneiric