Ubuntu

Second monitor doesn't work on MacBookAir3,1 with noveau driver (Experimental 3D support for NVIDIA cards)

Reported by Sean Sosik-Hamor on 2011-09-08
38
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Mactel Support
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Unassigned

Bug Description

When plugging-in an external monitor on my MacBookAir3,1 using a Mini DisplayPort to DVI adapter my system freezes for a few seconds (screen doesn't update, can't type or move mouse, etc.) and the following errors are generated:

Sep 8 16:41:55 Rico kernel: [22723.143036] [drm] nouveau 0000:02:00.0: plugged DP-1
Sep 8 16:41:55 Rico kernel: [22723.169853] [drm] nouveau 0000:02:00.0: unplugged DP-1
Sep 8 16:41:56 Rico kernel: [22723.589260] [drm] nouveau 0000:02:00.0: plugged DP-1
Sep 8 16:41:58 Rico kernel: [22725.770323] [drm] nouveau 0000:02:00.0: expected bit 16 == 0, got 0x01114000
Sep 8 16:42:06 Rico kernel: [22733.254017] [drm] nouveau 0000:02:00.0: unplugged DP-1
Sep 8 16:42:06 Rico kernel: [22733.565425] [drm] nouveau 0000:02:00.0: unplugged DP-1
Sep 8 16:42:06 Rico kernel: [22733.986777] [drm] nouveau 0000:02:00.0: plugged DP-1
Sep 8 16:42:08 Rico kernel: [22736.168598] [drm] nouveau 0000:02:00.0: expected bit 16 == 0, got 0x01114000
Sep 8 16:42:18 Rico kernel: [22745.373358] [drm] nouveau 0000:02:00.0: unplugged DP-1
Sep 8 16:42:18 Rico kernel: [22745.688777] [drm] nouveau 0000:02:00.0: unplugged DP-1
Sep 8 16:42:18 Rico kernel: [22746.107852] [drm] nouveau 0000:02:00.0: plugged DP-1
Sep 8 16:42:21 Rico kernel: [22748.289316] [drm] nouveau 0000:02:00.0: expected bit 16 == 0, got 0x01114000
Sep 8 16:42:26 Rico kernel: [22753.406729] [drm] nouveau 0000:02:00.0: unplugged DP-1

For as long as I keep the external monitor plugged-in the intermittent freezes and errors continue. In System Settings -> Displays clicking Detect Displays doesn't detect the external monitor.

System recovers and acts normally when I unplug the external monitor. I had been using this monitor just fine daily for months with Natty and the nvidia proprietary drivers.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: libgl1-mesa-dri-experimental 7.11-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
NonfreeKernelModules: wl
.tmp.unity.support.test.0:

Architecture: amd64
CheckboxSubmission: 15c9c9b122c9273f52b28c9a5df794ac
CheckboxSystem: 7e42599bda39ea7ff8b528272b6ef52b
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Thu Sep 8 16:38:44 2011
DistUpgraded: Log time: 2011-09-07 17:56:12.528248
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus: bcmwl, 5.100.82.38+bdcom, 3.0.0-10-generic, x86_64: installed
EcryptfsInUse: Yes
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 nVidia Corporation Device [10de:08a2] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Apple Computer Inc. Device [106b:00d4]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64+mac (20110901)
MachineType: Apple Inc. MacBookAir3,1
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-10-generic root=UUID=f1ecb7d8-5574-470d-b78e-030315e3a87a ro quiet splash reboot=pci acpi_backlight=vendor vt.handoff=7
SourcePackage: mesa
UnitySupportTest: Error: command ['/usr/lib/nux/unity_support_test', '-p', '-f'] failed with exit code -11:
UpgradeStatus: Upgraded to oneiric on 2011-09-08 (0 days ago)
dmi.bios.date: 11/18/10
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBA31.88Z.0061.B01.1011181342
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-942452F5819B1C1B
dmi.board.vendor: Apple Inc.
dmi.board.version: 1.0
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-942452F5819B1C1B
dmi.modalias: dmi:bvnAppleInc.:bvrMBA31.88Z.0061.B01.1011181342:bd11/18/10:svnAppleInc.:pnMacBookAir3,1:pvr1.0:rvnAppleInc.:rnMac-942452F5819B1C1B:rvr1.0:cvnAppleInc.:ct10:cvrMac-942452F5819B1C1B:
dmi.product.name: MacBookAir3,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
version.compiz: compiz 1:0.9.5.92+bzr2791-0ubuntu2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental 7.11-0ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Sean Sosik-Hamor (sciri) wrote :
summary: Second monitor doesn't work on MacBookAir3,1 with noveau driver
- Experimental 3D support for NVIDIA cards)(
+ (Experimental 3D support for NVIDIA cards)
Chris Halse Rogers (raof) wrote :

Moving to Linux; this is a drm problem.

This is fixed upstream, and should be in linux 3.2; Ben Skeggs has given me a list of the list of 13(!) (invasive!) commits that should fix this, but given kernel freeze is two days away this might not be appropriate for Oneiric.

Once git.kernel.org is back up I'll ask the kernel team to update the drm-next kernel build so you can check that it's actually fixed there.

affects: mesa (Ubuntu) → linux (Ubuntu)
Brad Figg (brad-figg) on 2011-09-13
Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
tags: added: kernel-handoff-graphics
jackbravo (jackbravo) wrote :

drm-next doesn't seem to have been updated. (is this the correct address? http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-next/)

I guess once this is done then you need to do something like this right?

http://www.khattam.info/howto-install-latest-intel-drm-kernel-to-avoid-crashes-on-boards-with-intel-hd-graphics-2010-08-14.html

jackbravo (jackbravo) wrote :

Ok, I see new drivers on http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-next/, should I install them to see if it fixes the problem? Or I'm looking on the wrong spot for this drm-next packages?

jackbravo (jackbravo) wrote :

By the way, I'm using a MacBook Pro 7,1

I installed the kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-next/2011-10-28-oneiric/ on my MacBook Air 3,2 but it would not boot. Probably due to other drivers not being updated/compatible.

Is there anything else we can start testing?

Joseph Salisbury (jsalisbury) wrote :

Would it be possible for someone seeing this issue to test the latest 3.2 release candidate, which is available at:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.2-rc1-oneiric/

I was able to install and boot the 3.2 rc1 kernel. It did not improve things. Nouveau graphics was heavily distorted with flicker and a missing color channel. Adding xorg-edgers on top did not improve things. Still a long way to go...

With the first alpha of Precise the external monitor actually works well. The problem now is that there is a regression for the internal monitor which although you can see the desktop displays vertical color bands and black and white noise (https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/898784).

Andy Whitcroft (apw) wrote :

Based on the expected inclusion date for these patches and the testing results in comment #9 I am assuming this is a Fix Released for Precise.

Changed in linux (Ubuntu Oneiric):
status: New → Triaged
importance: Undecided → Medium
Changed in linux (Ubuntu):
status: Triaged → Fix Released
dino99 (9d9) wrote :
Changed in linux (Ubuntu Oneiric):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers