Dialog command buttons can't be focused

Bug #853774 reported by Smylers on 2011-09-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Weather Indicator
Status tracked in 2.0
2.0
Low
Joshua Tasker
indicator-weather (Ubuntu)
Low
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

In the preferences window it isn't possible to Tab to the Cancel or OK buttons, so as to then activate them by pressing Enter; Tab cycles through all the form controls on the current tab, skipping the buttons at the bottom.

Similarly in the Forecast window the Close button can't be focused with Tab. In that case it should probably be focused by default, since it's the only interactive control in the entire window.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: indicator-weather 11.05.31-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
ApportVersion: 1.23-0ubuntu1
Architecture: i386
Date: Mon Sep 19 11:48:42 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110803.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 LC_COLLATE=C
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: indicator-weather
UpgradeStatus: Upgraded to oneiric on 2011-09-15 (4 days ago)

Smylers (smylers) wrote :
Robert Roth (evfool) on 2011-09-19
Changed in indicator-weather (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Changed in weather-indicator:
importance: Undecided → Medium
milestone: none → cloudy-9
status: New → Triaged
Vadim Rutkovsky (roignac) wrote :

Commited the fix in rev 299

Changed in indicator-weather (Ubuntu):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-weather - 11.11.28-0ubuntu1

---------------
indicator-weather (11.11.28-0ubuntu1) precise; urgency=low

  * New upstream release.
   - Preferences buttons OK and Cancel and Forecast's Close
     are not focusable (LP: #853774)
   - Don't crash if Google doesn't return icons (LP: #809187)
   - Display degrees in wind info item if Yahoo is selected (LP: #838369)
   - Fixed Assistant behavior for Forward/Back movements (LP: #804659)
   - Fixed a crash when Unknown wind condition was returned, thanks
     Tomasz Maciejewski! (LP: #886028)
   - Don't write too much debug info in the log (LP: #917253)
  * Drop debian/patches/autostart.patch, applied upstream.
  * Drop debian/README.source, no longer needed.
 -- Andrew Starr-Bochicchio <email address hidden> Fri, 20 Jan 2012 15:25:46 -0500

Changed in indicator-weather (Ubuntu):
status: Triaged → Fix Released
Changed in indicator-weather (Ubuntu Oneiric):
status: New → Confirmed
Joshua Tasker (jtasker) on 2013-06-06
Changed in indicator-weather (Ubuntu Oneiric):
status: Confirmed → Fix Released
Joshua Tasker (jtasker) wrote :

Turns out this wasn't actually fixed...

Joshua Tasker (jtasker) on 2013-10-01
no longer affects: weather-indicator/3.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers