Mist is not displayed in Forecast

Bug #804659 reported by Song on 2011-07-02
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Weather Indicator
Medium
Vadim Rutkovsky
indicator-weather (Ubuntu)
Low
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

The program can detect the weather is Light Rain, but the icon shows a question mark.

Screenshot: https://bugs.launchpad.net/weather-indicator/+bug/804659/+attachment/2188093/+files/light_rain_weather.png

Song (sonoud) wrote :
Felix Lawrence (felix-lawrence) wrote :

Hi Song, the version in the Ubuntu repositories is a bit old - this problem has probably been fixed already in a newer version. Could you try installing the version from our PPA and see if that solves your problem? The PPA is ppa:weather-indicator-team/ppa . Don't forget to quit and reopen indicator-weather after you've installed the new version. Let us know whether this fixes your problem, or if it still exists in the current version.

Song (sonoud) wrote :

Hi Felix, thanks a lot for the suggestions. the new version in ppa works. I can add my city successfully. thanks a lot. Btw, I am not sure if I should ask this here. The program can detect the weather is Light Rain, but the icon shows a question mark. I am not sure if this is expected or not. thanks.

Song (sonoud) wrote :

Attaching the screenshot.
The icon of indicator-weather just shows a question mark when it shows Light Rain.

Song (sonoud) wrote :

Attaching the log file.

Song (sonoud) wrote :

Dear Felix, I am not sure if it's OK to talk about this Light Rain Icon issue in this bug. My city is supported in the latest ppa version.

Some more information regarding the icon issue:
    [Clear], [Partly Cloudy] states show the correct icon. This is fine. I just found this today.
    So far, only [Light Rain] icon shows a question mark icon.

Thanks.

Changed in weather-indicator:
assignee: nobody → Vadim Rutkovsky (roignac)
importance: Undecided → Medium
milestone: none → 11.05.31
status: New → Fix Committed
milestone: 11.05.31 → cloudy-9
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
summary: - My City can not be added, but it can be found with the search button
+ Mist is not displayed in Forecast
Changed in weather-indicator:
status: Fix Committed → Fix Released
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: ubuntu → indicator-weather (Ubuntu)
Changed in indicator-weather (Ubuntu):
status: New → Confirmed
Changed in indicator-weather (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-weather - 11.11.28-0ubuntu1

---------------
indicator-weather (11.11.28-0ubuntu1) precise; urgency=low

  * New upstream release.
   - Preferences buttons OK and Cancel and Forecast's Close
     are not focusable (LP: #853774)
   - Don't crash if Google doesn't return icons (LP: #809187)
   - Display degrees in wind info item if Yahoo is selected (LP: #838369)
   - Fixed Assistant behavior for Forward/Back movements (LP: #804659)
   - Fixed a crash when Unknown wind condition was returned, thanks
     Tomasz Maciejewski! (LP: #886028)
   - Don't write too much debug info in the log (LP: #917253)
  * Drop debian/patches/autostart.patch, applied upstream.
  * Drop debian/README.source, no longer needed.
 -- Andrew Starr-Bochicchio <email address hidden> Fri, 20 Jan 2012 15:25:46 -0500

Changed in indicator-weather (Ubuntu):
status: Triaged → Fix Released
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in indicator-weather (Ubuntu Oneiric):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers