Ubuntu

Timezone is not set correctly for some locations

Reported by Ferran Pegueroles on 2011-04-30
106
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Medium
Ted Gould
Ubuntu Geonames
Undecided
Unassigned
indicator-datetime (Ubuntu)
Medium
Ted Gould
Oneiric
Medium
Unassigned
Precise
Medium
Ted Gould

Bug Description

Binary package hint: indicator-datetime

If I set the location in the indicator-datetime-preferences to Barcelona it changes the timezone to Africa/Abidjan when is should be Europe/Madrid.

The same occurs with the "Other locations" option. It seems that it has Barcelona as Latitude/longitude at 0.0 , 0.0
The same occurs for Sabadell (Catalonia Spanin)

Sebastien Bacher (seb128) wrote :

Bug #774370 indicates that's also an issue for New York

Changed in indicator-datetime (Ubuntu):
importance: Undecided → Low
Changed in indicator-datetime:
importance: Undecided → High
Changed in indicator-datetime (Ubuntu):
importance: Low → High
Changed in indicator-datetime:
status: New → Confirmed
Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
Karl Lattimer (karl-qdh) wrote :

Must be as a result of missing or corrupted data in ubuntu geonames if it's only a problem for some locations.

Sam_ (and-sam) wrote :

Examples, Houston (Florida), Cape Canaveral are supposed to be 6 and 7 hours behind Berlin, but they both show up as 2 hours behind. They're a must, because I don't want to miss STS-134 launch. :-)
http://www.timeanddate.com/worldclock/

Sam_ (and-sam) wrote :

First off, sorry, correct my error in #3 Houston (Texas), Cape Canaveral (Florida).
According to dconf-editor, Cape Canaveral and Houston are assigned to Africa instead of US.?field.comment=First off, sorry, correct my error in #3 Houston (Texas), Cape Canaveral (Florida).
According to dconf-editor, Cape Canaveral and Houston are assigned to Africa instead of US.

Matthieu Patou (mat-matws) wrote :

I face this problem when adding additional locations.
I'm in Moscow and my timezone is ok, so it is for most location but datetime-indicator insists to put New-York in GMT when obviously it's not.

Sam_ (and-sam) wrote :

Still the case in Oneiric.

tags: added: natty oneiric
Teg (teg-xd) wrote :

Singapore is also affected when added in indicator-datetime.
In dconf-editor com.canonical.indicator.datetime, it is displayed as 'Asia/Jakarta Singapore' or Jakarta is UTC+7 and Singapore is UTC+8.
(in Natty)

Teg (teg-xd) wrote :

'Asia/Singapore Singapore' instead of 'Asia/Jakarta Singapore' is correct.

Javier Jardón (jjardon) wrote :

Ferran: I cant reproduce this in current Oneiric package. Could you verify that you still have the problem?

Changed in indicator-datetime:
status: Confirmed → Incomplete
Changed in indicator-datetime (Ubuntu):
status: Confirmed → Incomplete
Sam_ (and-sam) wrote :

As in comment #4,6 time zone is still wrong in Natty and Oneiric.
Oneiric (screenshots).
indicator-datetime:
  Installed: 0.2.93-0ubuntu2
  Candidate: 0.2.93-0ubuntu2
  Version table:
 *** 0.2.93-0ubuntu2 0

Natty.
indicator-datetime:
  Installed: 0.2.3-0ubuntu3
  Candidate: 0.2.3-0ubuntu3
  Version table:
 *** 0.2.3-0ubuntu3 0

Sam_ (and-sam) wrote :
Changed in indicator-datetime (Ubuntu):
status: Incomplete → Confirmed
Ferran Pegueroles (ferranpeg) wrote :

I've tested with Oneric Beta 1 and it worked OK.

Javier Jardón (jjardon) wrote :

Tested here with indicator-datetime 0.2.93-0ubuntu2

@Matthieu: Added New York and Its correctly assigned to 'America/New_York New York'

@Sam_ (and-sam): Added Cape Canaveral and Its correctly assigned to 'America/New_York Cape Canaveral'

Could you remove your saved locations and try again?

Moritz Naumann (mnaumann) wrote :

@Javier: Based on his other bug reports, I assume that Matthieu is, like me, using Natty, and thus has a version installed which is still affected by this: I was able to reproduce this on my Natty system which has 0.2.3-0ubuntu3 and still displays the UTC time for New York. That's unless it crashes while you are trying to add the new location (but that's a different bug, #851085, a SIGSEGV in malloc_consolidate()).

Sam_ (and-sam) wrote :

Javier, saved and removed locations, no change on both. Writing now from Natty and attach screenshots, package is the same as in #10.

Sam_ (and-sam) wrote :
Sam_ (and-sam) wrote :
Sam_ (and-sam) wrote :

Now Oneiric. Same procedure remove and add back locations.
indicator-datetime:
  Installed: 0.2.95-0ubuntu1
  Candidate: 0.2.95-0ubuntu1
  Version table:
 *** 0.2.95-0ubuntu1 0

Sam_ (and-sam) wrote :

Where Cape Canaveral should be UTC -4 hours.

Sam_ (and-sam) wrote :

Still assigned to Africa in dconf. Houston btw. is ok now in both Natty and Oneiric.

Javier Jardón (jjardon) wrote :

@Sam_ : I've tested today with the latest Oneiric package and also with today oneiric liveCD and dconf shows the correct value here:

'America/New_York Cape Canaveral'

Could you test with the latest Oneiric package?

Sam_ (and-sam) wrote :

Javier, still assigned to Africa. Removed and added back Cape Canaveral. I didn't logout yet (but restarted after update) and test again because on second and third remove-add attempt g-c-c crashed.
Bug 863489 just uploaded and currently private because of core dump, but here is the link of the video.
https://bugs.launchpad.net/ubuntu/+source/indicator-datetime/+bug/863489/+attachment/2488084/+files/datetime.ogv

indicator-datetime:
  Installed: 0.3.0-0ubuntu1
  Candidate: 0.3.0-0ubuntu1
  Version table:
 *** 0.3.0-0ubuntu1 0

Sam_ (and-sam) wrote :

Still assigned to Africa after remove-add and logout-in.
Workaround: changed the value in dconf manually according to #21, which sets correct timezone instantly and remains after logout-in.

Sam_ (and-sam) wrote :

Tested again remove-add, still assigned to Africa, needs to be edited manually.
(g-c-c doesn't crash anymore on more attempts.)
indicator-datetime:
  Installed: 0.3.0-0ubuntu3
  Candidate: 0.3.0-0ubuntu3
  Version table:
 *** 0.3.0-0ubuntu3 0

Olivier Tilloy (osomon) wrote :

I can confirm the original issue as reported by Ferran is still there in Oneiric up-to-date: both Barcelona and Sabadell are detected as being in Africa/Abidjan whereas they really are in Europe/Madrid.

Manually editing the values in com.canonical.indicator.datetime using dconf-editor works around the issue.

If someone can point me to the relevant source package I’m happy to fix it and submit a patch, this is a very annoying issue.

Sebastien Bacher (seb128) wrote :

The Barcelona issue is still there

Changed in indicator-datetime:
status: Incomplete → Confirmed
Changed in indicator-datetime (Ubuntu Precise):
assignee: nobody → Ted Gould (ted)
Sam_ (and-sam) wrote :

Still wrong time zones on Precise.
indicator-datetime:
  Installed: 0.3.1-0ubuntu2
  Candidate: 0.3.1-0ubuntu2
  Version table:
 *** 0.3.1-0ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

tags: added: precise
filsd (filsdd) wrote :

I don't know if this is the same bug, but both on Gnome 3 and on Unity (I'm on Oneiric AMD64) the month March don't appear (on unity it says "label empty" instead of the name of the month).

I'm on Brazil and saw this on two totally different computers already.

tags: added: rls-mgr-p-tracking
Olli Ries (ories) on 2012-03-01
tags: added: udp
Olli Ries (ories) wrote :

I cannot reproduce comment #27:

indicator-datetime:
  Installed: 0.3.90-0ubuntu1
  Candidate: 0.3.90-0ubuntu1
  Version table:
 *** 0.3.90-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

please reopen if you still see the issue

Changed in indicator-datetime:
status: Confirmed → Incomplete
Changed in indicator-datetime (Ubuntu Precise):
status: Confirmed → Incomplete
Raphaël Badin (rvb) wrote :

I'm still seeing that issue on precise: this is what I get when I add "New York (United States)": http://people.canonical.com/~rvb/indicator_time.png

atarixle (atarixle) wrote :

I'm living in germany, so I use to pick CET time when installing Ubuntu (this may be helpful to reproduce that bug).

When I want to pick the New York Time Zone in the Clock Indicator, I always get the UTC time, either I pick New York City from the list.

Even switching to florida time doesn't work, I still get UTC instead of West Coast Time.

This bug has been in Ubuntu 11.10 too, now in 12.04 LTS "PRECISE" it is still there!

Charles Kerr (charlesk) wrote :

Could someone who's still seeing this issue report what version of indicator-datetime they have installed, as comment #27 and comment #29 do?

Raphaël Badin (rvb) wrote :

Still seeing this issue today:
dpkg -s indicator-datetime | grep Version → Version: 0.3.90-0ubuntu1

Sam_ (and-sam) wrote :

Cape Caneveral is ok since adjusted manually.
Others are still wrong.
e.g.
New York City shouldn't be UTC, it should be -5 from UTC or -6 from Berlin.
The other options of New York aren't any better.
Barcelona should be the same time as Madrid.
dconf shows NYC and Barcelona assigned to Africa.

indicator-datetime:
  Installed: 0.3.90-0ubuntu1
  Candidate: 0.3.90-0ubuntu1
  Version table:
 *** 0.3.90-0ubuntu1 0

Sam_ (and-sam) wrote :
Sam_ (and-sam) wrote :

Source of time zones during the test.
http://www.timeanddate.com/worldclock/

Changed in indicator-datetime (Ubuntu Precise):
status: Incomplete → Confirmed
Changed in indicator-datetime:
status: Incomplete → Confirmed
atarixle (atarixle) wrote :

That's what aptitude says:

i indicator-datetime 0.3.90-0ub 0.3.90-0ub

So, Version 0.3.90-0ub

Charles Kerr (charlesk) on 2012-03-06
Changed in indicator-datetime (Ubuntu Precise):
importance: High → Medium
Changed in indicator-datetime:
importance: High → Medium
tags: added: rls-p-tracking
Olli Ries (ories) on 2012-03-27
tags: removed: udp
tags: removed: rls-p-tracking
atarixle (atarixle) wrote :

o.k. ... still no fix in Ubuntu 12.04 LTS Beta 2 ...

Why the hell nothing is happening here?

Ken VanDine (ken-vandine) wrote :

I've tried every example given in the comments with indicator-datetime=0.3.94-0ubuntu1 and can't reproduce this bug.

atarixle (atarixle) wrote :

Well, it's not really hard to reproduce:

http://www.youtube.com/watch?v=L3ohTiG32ac

Ken VanDine (ken-vandine) wrote :

I wish it was that easy, we really want to get this fixed. I can follow the exact same steps as your video and not get the same results. None of our developers have been able to reproduce it.

@ted had a hunch that perhaps there was a timeout on a server query and it defaulted to an offset of 0, but from your video it looks like the lookup for the location is quite fast.

atarixle (atarixle) wrote :

You could try to install a german system (either time-zone, or language, or both).

Ken VanDine (ken-vandine) wrote :

@atarixle could you please try the same thing with the network disabled?

Arek Olek (arekolek) wrote :

Any way we can help? Because devs not being able to reproduce it does not imply anything. At least 18 people can, so I'm sure there's a way to handle this.

Ken VanDine (ken-vandine) wrote :

@atarixle disregard that request, i found someone else that could reproduce it test that. It does indeed return the correct results when offline, so it does have something to do with the server lookup for names. This should help us figure out the problem.

Arek Olek (arekolek) wrote :

#43 That's a workaround, disabling network results in correct hour. But number of cities is very limited without a network.

atarixle (atarixle) wrote :

I tested it, got the same result as Arek Olek got (correct time zone, lower choice of cities).

Ken VanDine (ken-vandine) wrote :

OK, we've figured this out. When it is mapping the returned coordinates to a timezone it is failing because it doesn't handle the locale well. It is treating 40.714270 as 40,714270 so this actually affects all locales that use the comma for a decimal separator.

Ted Gould (ted) on 2012-04-18
Changed in ubuntu-geonames:
status: New → Invalid
Changed in indicator-datetime:
status: Confirmed → In Progress
assignee: nobody → Ted Gould (ted)
Changed in indicator-datetime (Ubuntu Oneiric):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Ken VanDine (ken-vandine)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-datetime - 0.3.94-0ubuntu2

---------------
indicator-datetime (0.3.94-0ubuntu2) precise; urgency=low

  * src/datetime-prefs-locations.c, src/datetime-prefs.c
    - Switch the parsing of the lat and long to be non-locale based as it's
      returned from the webservice in C, we want to parse it using the decimal
      instead of a comma. This fixes incorrect timezone selection for users
      with a locale that uses a comma as a decimal separator (LP: #773987)
 -- Ken VanDine <email address hidden> Wed, 18 Apr 2012 23:20:30 -0400

Changed in indicator-datetime (Ubuntu Precise):
status: Confirmed → Fix Released

I received an update for this (this morning). You guys are awesome. Maybe you have the power to fix this too:
https://bugs.launchpad.net/bugs/465689

I can't seem to rally enough support :(

Charles Kerr (charlesk) wrote :

Lonnie, the ticket you linked to is marked as a Wishlist item. It's not something that the coders would just decide to "fix" -- as I told you in that ticket, the next step is for Design to weigh in on the suggestion.

Also, please don't spam launchpad... if you want to continue this discussion, please do it in the appropriate ticket. Thanks!

Ted Gould (ted) on 2012-09-12
Changed in indicator-datetime:
status: In Progress → Fix Released
Charles Kerr (charlesk) on 2012-09-20
Changed in indicator-datetime:
milestone: none → 12.10.0
Changed in indicator-datetime (Ubuntu Oneiric):
assignee: Ken VanDine (ken-vandine) → nobody
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions