Ubuntu

"num lock is on" warning remains even after num lock is turned off (thinkpad, numlock status for laptop and external keyboard different)

Reported by Paul Collins on 2011-09-05
178
This bug affects 35 people
Affects Status Importance Assigned to Milestone
gnome-screensaver (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Unassigned
Precise
Medium
Unassigned
gtk+3.0 (Ubuntu)
Medium
Canonical Desktop Team
Oneiric
Medium
Unassigned
Precise
Medium
Canonical Desktop Team

Bug Description

Version: 3.1.5-0ubuntu6
Release: 11.10

After fiddling with Num Lock, I noticed that the lock window claimed it was still enabled, and yet it is not.

Comments info:
"it might be connected with the fact that on (new) Thinkpads there are something like TWO num locks, one is for an external keyboard and the other - for the internal one."

Sequence of events:
* Turn on Num Lock.
* Lock the screen. (On a ThinkPad, I do this by pressing Fn+F2. Whatever option it is that means "lock the screen immediately", I have it turned on.)
* Tap a key to bring up the screen-locked/enter-password dialog.
* Observe the warning.
* Turn off Num Lock.
* Observe the warning is still there.
* Successfully unlock the screen.
* Lock the screen again.
* Observe the warning is still there.
* [Optional] Unlock the screen. File a bug against gnome-screensaver.

Not related to bug #835649, which concerns showing the warning when Num Lock is enabled but not otherwise problematic, e.g. when using a "full-size" (i.e. "has lots of extra keys") keyboard.

Paul Collins (pjdc) on 2011-09-05
description: updated
Changed in gnome-screensaver (Ubuntu):
status: New → Confirmed
rduplain (ron.duplain) wrote :

Sorry for the status change, but I'm unable to reproduce this (not on a ThinkPad, though). Janitor changed to Confirmed on "affects me too", but I meant to +1 on bug #835649.

Changed in gnome-screensaver (Ubuntu):
status: Confirmed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-screensaver (Ubuntu):
status: New → Confirmed
gavintlgold (puttabutta) wrote :

I have this issue with my Lenovo Thinkpad W500. The numlock light is not on and they keys do not register as numbers, but the warning remains.

If I put numlock on (and the light goes on) it works as it should. However it warns me when numlock is not on, that it is on.

gavintlgold (puttabutta) wrote :

I would like to clarify that the numlock warning has been on on this computer for at least a week, and there's no way to disable it. Restarting the computer does not remove the warning even though numlock is never turned on on my laptop.

Changed in gnome-screensaver (Ubuntu):
importance: Undecided → Medium
Changed in gnome-screensaver (Ubuntu Oneiric):
milestone: none → oneiric-updates
status: Confirmed → Triaged
Changed in gnome-screensaver (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Medium
tags: added: iso-testing
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, I can't confirm that here though...

Grigory Rechistov (atakua) wrote :

I can confirm this bug in gnome-screensaver. I use Thinkpad X220i. I think it might be connected with the fact that on (new) Thinkpads there are something like TWO num locks, one is for an external keyboard and the other - for the internal one. I came to this thought because there is an option in BIOS settings to decide whether they should be manipulated separately or not.

I haven't tried to change BIOS settings though, left them at defaults. The last note: this warning is not present in KDE default unlock dialog.

George Pollard (porges) wrote :

I reported this as: https://bugs.launchpad.net/ubuntu/+source/gnome-screensaver/+bug/865778

My keyboard doesn't even have a num-lock key (no numpad) and it says this on the lock screen. It is connected via a KVM switch so not sure if that is affecting anything. I can test this later.

Aren Cambre (aren-arencambre) wrote :

The whole num lock warning should be junked. That would solve this. See #877456.

Regarding Comment #6: I can confirm that changing the BIOS setting on numlock behavior from "independent" to "synchronized" does indeed solve the problem here.

Have the same problem here, Lenovo Thinkpad T400, Ubuntu 11.10 64 bits.

Did the trick of BIOS setting and is now working fine.

Lachezar Dobrev (lachezar) wrote :

I am having this issue on a Lenovo T500.
The lock screen, the PGP key unlocking, and SSH Agent key unlocking all warn me of NumLock on.
Even restarting does not help. Once NumLock has been turned on I always get this warning no matter what the actual status is.

The NumLock warning has a point:
On Laptop computers NumLock changes letters into digits!
It is just as bad, as having CapsLock turned on.

Same issue here. Thinkpad X200s with Ubuntu 11.10 (64bit).

agnul (sucrabu) wrote :

Same here on oneiric/t420. The warning shows in evolution password fields too.

Sebastien Bacher (seb128) wrote :

is that specific to gnome-screensaver? you can try with gtk3-demo, entry > entry buffer and select the second entry

summary: "num lock is on" warning remains even after num lock is turned off
+ (thinkpad, numlock status for laptop and external keyboard different)
description: updated
agnul (sucrabu) wrote :

Just a minor update: I've connected an external keyboard, turned off num-lock on that keyboard and the warning disappeared from both evolution and gnome-screensaver dialogs. After a reboot (with no external keyboard connected) the warning sign was there again, both evolution and gnome-screensaver. The BIOS is still set to "independent" num-lock, I've tried setting it to "synchronized" but I haven't been able to figure out how that works before giving up and going back to default ;-)

eitch (eitch) wrote :

This is a weird message, as I am on a desktop computer and I have this message in all password fields. My Numlock key must be on.

tags: added: rls-mgr-p-tracking
Changed in gnome-screensaver (Ubuntu Precise):
assignee: nobody → Ubuntu Desktop (ubuntu-desktop)
Changed in gnome-screensaver (Ubuntu Precise):
assignee: Ubuntu Desktop (ubuntu-desktop) → Canonical Desktop Team (canonical-desktop-team)
Marc Deslauriers (mdeslaur) wrote :

I can reproduce this on my Thinkpad when the BIOS is set to "Thinkpad NumLock - Independent" (which is the default setting).

I can reproduce this with gtk3-demo and policykit authentication dialogs. It needs to be fixed in gtk+3.0.

I suggest we turn off the numlock warning altogether in gtk+3.0.

affects: gnome-screensaver (Ubuntu Oneiric) → gtk+3.0 (Ubuntu Oneiric)
tags: added: rls-p-tracking
Changed in gtk+3.0 (Ubuntu Precise):
milestone: none → ubuntu-12.04-beta-1
Marc Deslauriers (mdeslaur) wrote :

Adding gnome-screensaver back, as there is code in there too to print the capslock/numlock status underneath the password entry box.

Changed in gnome-screensaver (Ubuntu Oneiric):
status: New → Triaged
Changed in gnome-screensaver (Ubuntu Precise):
status: New → Triaged
Changed in gnome-screensaver (Ubuntu Oneiric):
importance: Undecided → Medium
Changed in gnome-screensaver (Ubuntu Precise):
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

Note sure that should be a blocker bug, it's a pretty specific configuration (specific laptop with external keyboard use and bios option dependent), the issue is also cosmetic

I've no real objection to just drop the numlock warning in gtk, you would assume that numlock on is the default for most users and not something to warn about, ideally that would be discussed upstream first though

Sebastien Bacher (seb128) wrote :

Upstream similar bugs:

https://bugzilla.gnome.org/show_bug.cgi?id=662093 "should warns about no numlock when entering password"
https://bugzilla.gnome.org/show_bug.cgi?id=658875 "Should limit Num Lock warning to notebooks"

the first one being bug #835649 on launchpad

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-screensaver - 3.2.0-1ubuntu8

---------------
gnome-screensaver (3.2.0-1ubuntu8) precise; urgency=low

  * debian/patches/22_dont_show_numlock_warning.patch: Don't show a warning
    for the numlock key, as some hardware tracks numlock status
    differently. (LP: #841541, LP: #877456, LP: #835649)
  * debian/patches/21_properly_lock_when_activated.patch: Updated with
    final upstream commit.
 -- Marc Deslauriers <email address hidden> Sun, 05 Feb 2012 17:15:02 -0500

Changed in gnome-screensaver (Ubuntu Precise):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.3.14-0ubuntu1

---------------
gtk+3.0 (3.3.14-0ubuntu1) precise; urgency=low

  * New upstream version
  * debian/control.in: updated gdk-pixbuf requirement
  * debian/patches/git_appchooser_ref_hold.patch:
    - dropped the fix is in the new version

  [ Marc Deslauriers ]
  * debian/patches/dont_show_numlock_warning.patch: Don't show a warning
    for the numlock key in gtkentry boxes, as some hardware tracks numlock
    status differently. (LP: #841541, LP: #877456, LP: #835649)
 -- Sebastien Bacher <email address hidden> Tue, 07 Feb 2012 16:18:49 +0100

Changed in gtk+3.0 (Ubuntu Precise):
status: Triaged → Fix Released
Dominik Menke (dmke) wrote :

Will this patch be backported to Oneiric, too? It's kind of annoying since I use the num lock function quite often...

—Dominik

h-bomb (henrymccown) wrote :

I can confirm that this bug is real. I have a Lenovo T61. Rebooting and setting from "independent" to "synchronized" in the BIOS under keyboard/mouse settings does remove the message. Would be nice if this was backported to Oneiric...

FWIW I got this not on a desktop machine, not a thinkpad, but I was
connected via a KVM switch which might have something to do with it.

George Pollard (porges) wrote :

Sorry, should be "on a desktop" not "not on a desktop".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.