Lost Search engines on upgrade

Bug #858683 reported by Micah Gersten on 2011-09-25
142
This bug affects 37 people
Affects Status Importance Assigned to Milestone
Ubuntu Mozilla PPA Bugs
Undecided
Unassigned
firefox (Ubuntu)
Critical
Unassigned
Oneiric
Critical
Unassigned

Bug Description

WORKAROUND (if you have 7.0+build2+nobinonly-0ubuntu3):
1. sudo apt-get remove firefox
2. sudo apt-get install firefox

I lost my search engines on the latest upgrade to 9.0 20110924r77404
Actually, not lost entirely, just have only ask.com and Mozilla's Bugzilla.

Micah Gersten (micahg) on 2011-09-25
description: updated
Chris Coulson (chrisccoulson) wrote :

This is in oneiric as well now

Changed in firefox (Ubuntu Oneiric):
importance: Undecided → Critical
status: New → Triaged
Changed in firefox (Ubuntu Oneiric):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 7.0+build2+nobinonly-0ubuntu2

---------------
firefox (7.0+build2+nobinonly-0ubuntu2) oneiric; urgency=low

  * Fix LP: #858683 - All search engines disappear. Revert the change to move
    distribution.ini, it seems to need some extra postinst magic to make it
    upgrade correctly and not break everything. Not for a Sunday morning though
    - update debian/rules
 -- Chris Coulson <email address hidden> Sun, 25 Sep 2011 08:21:19 +0100

Changed in firefox (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Glauco (glauco-hass) wrote :

Seems like the bug is back in 7.0+build2+nobinonly-0ubuntu3.

Scott Abbey (malakhi) wrote :

Yep. 7.0+build2+nobinonly-0ubuntu3 reintroduces the bug.

Ricardo Hernández (richerve) wrote :

Confirmed is reintroduced in 7.0+build2+nobinonly-0ubuntu3 oneiric amd64 up-to-date

Nate Wiebe (natew) wrote :

Needs to be reopened, since the bug is present again.

Micah Gersten (micahg) wrote :

So, this won't affect people upgrade from 7.0 beta 6, but anyone who upgraded to the 7.0 final release before the ubuntu3 revision is affected.

Changed in firefox (Ubuntu Oneiric):
status: Fix Released → Triaged
Micah Gersten (micahg) wrote :

After further investigation, this only affects users who upgraded to 7.0+build2+nobinonly-0ubuntu2 previously.

Micah Gersten (micahg) on 2011-09-26
description: updated
Micah Gersten (micahg) wrote :

The postinst should just clean up everyone upgrading from everything up to the ubuntu3 revision. I'll upload a fix in a couple hours.

Changed in firefox (Ubuntu Oneiric):
assignee: nobody → Micah Gersten (micahg)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 7.0+build2+nobinonly-0ubuntu4

---------------
firefox (7.0+build2+nobinonly-0ubuntu4) oneiric; urgency=low

  * Really fix LP: #858683 - Clean up the symlinks for users who upgraded to
    7.0+build2+nobinonly-0ubuntu2; This means checking for everything before the
    -0ubuntu3 revision since the -0ubuntu2 users already upgraded
    - update debian/firefox.postinst.in
 -- Micah Gersten <email address hidden> Mon, 26 Sep 2011 01:30:33 -0500

Changed in firefox (Ubuntu Oneiric):
status: In Progress → Fix Released
Changed in firefox (Ubuntu Oneiric):
assignee: Micah Gersten (micahg) → javiertorrealba (javier-torrealba)
Micah Gersten (micahg) wrote :

Fixed in the PPAs as well now.

Changed in firefox (Ubuntu Oneiric):
assignee: javiertorrealba (javier-torrealba) → Micah Gersten (micahg)
assignee: Micah Gersten (micahg) → nobody
Changed in ubuntu-mozilla-ppa-bugs:
status: New → Fix Released
Stefano Mtangoo (mtangoo) wrote :

While waiting for a fix to be released you can restore it using this page. I have tested it and it works
http://mycroft.mozdev.org/
or directly adding google.com as search engine
http://mycroft.mozdev.org/jsreq.html

Paul Gevers (paul-climbing) wrote :

I upgraded yesterday from Ubuntu 11.04 to 11.10 and now have firefox 7.0.1+build1+nobinonly-0ubuntu1. I have the same experience as described in this bug, so I think it should be reopened?

Micah Gersten (micahg) wrote :

The natty -> oneiric upgrade issue is being tracked in bug 869311.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers