Ubuntu

"Cannot open book: Could not create DesktopcouchSession object"

Reported by Alex Peters on 2011-10-12
288
This bug affects 57 people
Affects Status Importance Assigned to Milestone
Thunderbird EDS Contacts Integration
High
Mike Conley
desktopcouch
Undecided
Unassigned
desktopcouch (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Unassigned
thunderbird (Ubuntu)
Medium
Unassigned
Oneiric
High
Unassigned

Bug Description

Frequently on Thunderbird startup, I see this error dialogue:

[Could not open address book]
There was a problem opening the address book "Ubuntu One" - the message returned was:
Cannot open book: Could not create DesktopcouchSession object

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: thunderbird 7.0.1+build1+nobinonly-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: lx 1889 F.... pulseaudio
BuildID: 20110929183320
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf8700000 irq 47'
   Mixer name : 'Realtek ALC268'
   Components : 'HDA:10ec0268,103c30cc,00100003 HDA:10573055,10573055,00100700'
   Controls : 21
   Simple ctrls : 13
Channel: release
Date: Wed Oct 12 13:42:56 2011
ExecutablePath: /usr/lib/thunderbird-7.0.1/thunderbird-bin
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
IpRoute:
 default via 192.168.0.1 dev wlan0 proto static
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.0.0/24 dev wlan0 proto kernel scope link src 192.168.0.3 metric 2
Prefs:
 places.database.lastMaintenance - 1318297850
 extensions.lastAppVersion - 7.0.1
 network.cookie.prefsMigrated - true
 places.history.expiration.transient_current_max_pages - 62892
Profiles: Profile0 (Default) - LastVersion=7.0.1/20110929183320 (Running)
RunningIncompatibleAddons: False
SourcePackage: thunderbird
UpgradeStatus: Upgraded to oneiric on 2011-09-12 (29 days ago)
dmi.bios.date: 04/04/2007
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.05
dmi.board.name: 30CC
dmi.board.vendor: Quanta
dmi.board.version: 79.10
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.05:bd04/04/2007:svnHewlett-Packard:pnHPPaviliondv6500NotebookPC:pvrRev1:rvnQuanta:rn30CC:rvr79.10:cvnQuanta:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv6500 Notebook PC
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard

Alex Peters (alex-peters) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed
Mike Conley (mconley) wrote :

This is the EDS Contacts Add-on, having difficulty communicating with the DesktopCouch service. You can disable that add-on in Thunderbird for now to avoid these warnings while we work on resolving them.

Mike Conley (mconley) on 2011-10-14
affects: thunderbird (Ubuntu) → thunderbird-eds-extension
Changed in thunderbird-eds-extension:
assignee: nobody → Mike Conley (mconley)
importance: Undecided → High
Chris Coulson (chrisccoulson) wrote :

I thought we'd fixed this already. What version of libcouchdb-glib-1.0-2 is on your system?

I have 0.7.4-0ubuntu2 of libcouchdb-glib-1.0-2 and the same problem.

The message shows up every time I click an email.... even with contacts sync being turned off in the Ubuntu One control panel. Disabling the EDS Contacts addon indeed gets rid of the problem.

Chris Coulson (chrisccoulson) wrote :

Rodrigo - any ideas?

Rodrigo Moya (rodrigo-moya) wrote :

This message means couchdb-glib couldn't find the token for Desktopcouch in the keyring. So I guess this is a desktopcouch problem we've seen a few times, that either it doesn't start (could you test this by trying to run /usr/lib/desktopcouch/desktopcouch-service on a terminal and see if it shows up any error?) or even though it does start, it doesn't sync the tokens in the keyring, so couchdb-glib doesn't know how to authenticate at all.

So, follow the instructions at the 'killing and restarting dc' section at http://www.freedesktop.org/wiki/Specifications/desktopcouch/Documentation/Troubleshooting and let's see if it's that, but it really looks like it indeed is, since that message comes from here:

http://git.gnome.org/browse/evolution-couchdb/tree/addressbook/e-book-backend-couchdb.c#n1099

and the only way desktopcouch_session_new can fail is because of it not being able to contact desktopcouch or finding the tokens in the keyring:

http://git.gnome.org/browse/couchdb-glib/tree/desktopcouch-glib/desktopcouch-session.c#n57

So either desktopcouch is not installed or not being started correctly, or it's not writing the tokens to the keyring.

Mike Conley (mconley) wrote :

At the very least, we shouldn't be firing an alert each time this problem crops up. I'll have a patch to silence those alerts ready in an hour or two.

Changed in thunderbird (Ubuntu Oneiric):
importance: Undecided → High
status: New → Triaged
Changed in thunderbird (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Samizdata (samizdata) wrote :

I have tried shutting it down, killing the config, then starting it back up, both before and after reinstall couchdb. I do see the process running, but the dbus command gives me

Error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

and I am unable to access the http interface. This is under Oneiric. Please see bug 874297 for Apport information.

Mike Conley (mconley) wrote :

The alert suppression was released as part of EDS Contacts Integration 0.3.8. I believe this should be available shortly via the update-manager.

This will not solve the DesktopCouch problem, but it'll certainly ease the pain of it.

Rodrigo wrote:
> So, follow the instructions at the 'killing and restarting dc' section at
> http://www.freedesktop.org/wiki/Specifications/desktopcouch/Documentation/Troubleshooting and let's see if it's that

For me this works.

Oops, I was wrong. Those errors are still shown.

Launchpad Janitor (janitor) wrote :
Download full text (7.3 KiB)

This bug was fixed in the package thunderbird - 8.0~b2+build1-0ubuntu1

---------------
thunderbird (8.0~b2+build1-0ubuntu1) precise; urgency=low

  * New upstream release from the beta channel (THUNDERBIRD_8_0b2_BUILD1)

  * Update messagingmenu-extension to 0.8.1
  * Update eds extension to 0.3.8 (r96)
    - Fix LP: #872639 - Cannot open book: Could not create DesktopcouchSession
      object. Don't display errors from evolution-data-server for now, as
      they make Thunderbird unusable. Note, this doesn't fix the actual bug
      with desktopcouch
    - Fix LP: #863150 - Endless loop with password prompt
  * Provide a useful error message when trying to build the source package
    with an out of date control file
    - update debian/rules
  * Provide a way to prevent the source package from being built if the list
    of shipped locales changed upstream. Note that this is disabled on
    nightly and aurora
    - update debian/rules
    - add debian/extract-file.py
  * Move custom scripts to debian/scripts
    - move debian/get-xpi-id.py to debian/scripts/get-xpi-id.py
    - move debian/refresh-supported-locales.pl to
       debian/scripts/refresh-supported-locales.pl
    - move debian/extract-file.py to debian/scripts/extract-file.py
    - update debian/rules
  * Shrink the default mozconfig right down so that we use mostly upstream
    defaults, rather than overriding them with our own options. It is still
    possible to override them though. We also drop the pkg-config checks in
    debian/rules which allowed a fallback build configuration when dependencies
    aren't satisfied. Really, the build should just fail here rather than
    continuing in some undesirable fallback mode
    - update debian/thunderbird-dev.links.in
    - update debian/mozconfig.in
    - update debian/control.in
    - update debian/rules
  * Refresh build-depends, as this hasn't been done for a while:
    - Drop patchutils, libxft-dev, libxinerama-dev, libgnome2-dev, sharutils
      and bzip2. These don't appear to be needed
    - Drop liborbit2-dev - only appears to be required if there is no libidl
    - Add libglib2.0-dev, libext-dev, libfontconfig1-dev and libpango1.0-dev,
      as the configure script checks for these directly
    - Add minimum versions to libgconf2-dev, libgnomevfs2-dev, yasm and
      libgnomeui-dev
    - Specify minimum versions for libnspr4-dev, libcairo2-dev, libsqlite3-dev
      and libnss3-dev when using system versions of those libs
  * Disable gconf support on >= 12.04
    - update debian//rules
    - update debian/mozconfig.in
  * Refresh binary dependencies:
    - Drop psmisc and fontconfig depends. We don't use any binaries
      from either of these packages
    - Drop debianutils dependency. This is an essential package
  * Introduce a branch config file (debian/config/branch.mk) which holds
    settings which shouldn't be merged between branches (eg, whether
    the crash reporter should be enabled)
    - add debian/config/branch.mk
    - update debian/rules
  * Move debian/locales.* to debian/config
    - move debian/locales.shipped => debian/config/locales.shipped
    - move debian/locales.unavail => debian/config/locales....

Read more...

Changed in thunderbird (Ubuntu):
status: Triaged → Fix Released
Chris Coulson (chrisccoulson) wrote :

I've uploaded the fix which hides the alert dialog to oneiric-proposed now

Does this mean that the integration is still broken but you have just hidden the alert dialog? Is a real fix going to be done later?

Mike Conley (mconley) wrote :

Craig:

That's correct - we still need to figure out what has gone wrong with your DesktopCouch.

Does any of this help?: http://www.freedesktop.org/wiki/Specifications/desktopcouch/Documentation/Troubleshooting

-Mike

Changed in thunderbird-eds-extension:
status: Confirmed → Fix Released

I will try those things but really this problem started after I installed the update to Ubuntu 11.10. I did nothing to the system to cause this problem. Anyway thanks for the effort on this.

I just installed todays proposed updates, but Thunderbird still complains about the DesktopcouchSession object.

Chris Coulson (chrisccoulson) wrote :

It hasn't been approved yet, so you haven't downloaded any Thunderbird updates

Forage (forage) wrote :

I've got the same issue. For what it's worth: I'm not using Ubuntu One at all, nor have I configured it and I have disabled it in the start-up application list. I would like to keep it that way, without Thunderbird giving me these errors.

Changed in desktopcouch:
status: New → Confirmed
Changed in desktopcouch (Ubuntu Oneiric):
status: New → Triaged
Changed in desktopcouch (Ubuntu):
status: New → Triaged
Changed in desktopcouch (Ubuntu Oneiric):
importance: Undecided → Medium
Changed in desktopcouch (Ubuntu):
importance: Undecided → Medium
Pw1 (pw1) wrote :

I had the exact same problem. As suggested by Mike I looked at the page http://www.freedesktop.org/wiki/Specifications/desktopcouch/Documentation/Troubleshooting

This page has a section called "Killing and restarting desktopcouch". I decided to follow these instructions. In step 1 and 2 the desktopcouch process is killed and desktop-couchdb.ini is removed. In step 3 the desktopcouch should be restarted. In my case, however, this process could not be started. At that point I decided to restart the machine. (I'm not sure I this is a required step) After restarting the machine and starting Thunderbird the error did not return. This seems to have fixed the problem.

Chris Coulson (chrisccoulson) wrote :

Note, we just removed thunderbird from the queue, as we want to get a fix in for bug 856642 as well

Chris Coulson (chrisccoulson) wrote :

Sorry, I meant bug 850229

Pat Egan (pategan) wrote :

0 down vote

I have this problem too, and it is making my machine unusable with the message popping up sometimes every 10 seconds. Any chance of a fix, or at least a workaround? Otherwise I'm going to have to go back to Windows. Arrrggghhh!!

Pat Egan (pategan) wrote :

Re PW1's entry
... As suggested by Mike I looked at the page http://www.freedesktop.org/wiki/Specifications/desktopcouch/Documentation/Troubleshooting ... This page has a section called "Killing and restarting desktopcouch". I decided to follow these instructions.

I tried this, but it didn't work.

The problem is certainly not DesktopCouch. I'm using it for many other things without any problems, but Thunderbird keeps complaining.

Pat Egan (pategan) wrote :

Thanks Jo, but whatever is doing the complaining, is there anything I can do to stop the message popping up?

Yes, you can install Evolution and delete the u1 contact list from there. Afterwards, Thunderbird will no longer attempt to use that addressbook, and will therefore not complain about it either. When you're done with it, you can savely remove Evolution again if you don't want it.

Pat Egan (pategan) wrote :

Thanks Jo, but how to delete the U1 contact lists?

I cannot find any option to delete in evolution. BTW "lists" is plural, because I thought renaming it might get me out of trouble, but a new one was automatically created, so now I have two couchDB lists, and double the number of errors!

Right click the contact list and delete.

By the way, this bug belongs to Evolution, not to Thunderbird and certainly not to DesktopCouch. It is Evolution that is unable to open CouchDB contact lists and doesn't even provide fields for address, username and password. All other contact lists from Evolution works well in Thunderbird, which tells me that Thunderbird EDS is not to blame for this. Google contacts configured in Evolution appears without a hitch in Thunderbird, for instance.

Rodney Dawes (dobey) wrote :

Installing the proposed version of thunderbird should get rid of the extraneous popups in Thunderbird.

This bug does not belong to Evolution, as it is not an evolution issue. The bug however, probably does belong in couchdb-glib. And possibly in evolution-data-server. It is hard to say for sure which one is causing this though.

Another possibility is that there is a problem with gnome-keyring.

Pat Egan (pategan) wrote :

Thank you both for your comments. Unfortunately, right clicking on the contact list and selecting delete returns the message "Could not remove address book". I restored to an old evolution backup which did get me back to only one couchDB address book, but the error message persists.

Rodney, which is the "proposed version" of Thunderbird?
I am using 7.0.1.

I'm unsure I understand your references to different components, but are you saying that I am reporting these problems in the wrong place? If so, would you be good enough to include a link to where I should report this?

Thanks
Pat

Rodney Dawes (dobey) wrote :

Paul, see comment #14 for the version and change information in the proposed Thunderbird update. It is proposed and not yet accepted to -updates, but you can test it by enabling the oneiric-proposed archive, and upgrading thunderbird from there. Enabling the proposed archive will get you many updates though, some of which you may not want or need, or which may break something else on your system; as it is the testing grounds for updates to the stable release.

As for the components, we can change which packages and projects are affected, without reporting a new bug. However, it is unclear where the problem actually lies at this point. Once it is more clear, the affected package/project can be updated, or added, as necessary.

Hello Alex, or anyone else affected,

Accepted thunderbird into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in thunderbird (Ubuntu Oneiric):
status: Triaged → Fix Committed
tags: added: verification-needed

Hello,

I am also effected.

Regards
Thomas Könning

peter swain (swine) wrote :

yes, I confirm fix -- I don't see the problem anymore.

If the underlying cause is not completely understood, yet so few people saw problem, I have a guess why:
I'm using multiple mailservers (gmail + another IMAP server).
Perhaps bug only appears when multiple servers are configured?

If anyone who was affected is did *not* have multiple mail servers configured, please respond to shoot down this hypothesis!

I've been annoyed that two competing "Enter master password to unlock mailserver passwords" dialogs appear on startup,
and this suggests there might be an architectural problem in common: some other instance of two competing threads trying to process what should be a common object (the couchdb session), and one failing.

I'm just reporting user experience & guessing structure, I have no knowledge of the codebase here

I don't understand how this issue can be related to Thunderbird when the problem exists when Thunderbird isn't even installed. Evolution presents the same errors. It is most likely an issue with EDS itself. From the GUI in Evolution, it seems to confuse CouchDB with DesktopCouch, and those are different things.

magelan (magelan) wrote :

Hello,

the fix works.

I had the same error message and deactivated this EDS add-on first.

I now tried your proposed-version and the error message are still gone after activating the add-on and the settings "local adressbooks" and "LDAP directory server" in the settings on the tab "writing", "addressing" (all translated). So no more error messages and the proposal of email-addresses and lists works. Thank you.

I installed only thunderbird and two dependencies, thunderbird-gnome-support and thunderbird-globalmenu from the proposed archives.

Alex Peters (alex-peters) wrote :

peter swain (swine) wrote on 2011-11-11 (comment #37):
> I'm using multiple mailservers (gmail + another IMAP server).
> Perhaps bug only appears when multiple servers are configured?

I have been experiencing this issue with only one server configured.

However, in your comment you also report seeing multiple concurrent master password entry prompts. This was also a problem for me in the past when I did in fact have multiple servers configured.

Martin Pitt (pitti) on 2011-11-14
tags: added: verification-done
removed: verification-needed
Lucas Madar (lucas-madar) wrote :

I am receiving this same issue with thunderbird, but I get an error when I try to start the desktopcouch-service:

$ /usr/lib/desktopcouch/desktopcouch-service
Traceback (most recent call last):
  File "/usr/lib/desktopcouch/desktopcouch-service", line 41, in <module>
    from desktopcouch.service import DesktopcouchService
  File "/usr/lib/pymodules/python2.7/desktopcouch/service.py", line 9, in <module>
    from desktopcouch.application.service import *
  File "/usr/lib/pymodules/python2.7/desktopcouch/application/service.py", line 45, in <module>
    from desktopcouch.application import replication
  File "/usr/lib/pymodules/python2.7/desktopcouch/application/replication.py", line 26, in <module>
    from desktopcouch.application.pair.couchdb_pairing import couchdb_io
  File "/usr/lib/pymodules/python2.7/desktopcouch/application/pair/couchdb_pairing/couchdb_io.py", line 34, in <module>
    from desktopcouch.application import server
  File "/usr/lib/pymodules/python2.7/desktopcouch/application/server.py", line 27, in <module>
    from couchdb import Server
  File "/usr/lib/pymodules/python2.7/couchdb/__init__.py", line 9, in <module>
    from couchdb.client import Database, Document, Server
  File "/usr/lib/pymodules/python2.7/couchdb/client.py", line 30, in <module>
    from textwrap import dedent
ImportError: cannot import name dedent

Hi to all,
I have experimented the same issue. In my case, the problem start when I have deleted the folder [home]/.gnome2/keyring following the solution to solve another problem. Then I have started to experiment the problem show in this topic.

I have disabled the extension CouchDB addressbook integration without success.

But, I have also disabled the Ubuntu One contacts sync. option, and now, everything works well (except the shared contacts, of course).

I hope it helps!

Hi everyone,

Fix works for me too. I experienced the same problem:

There was a problem opening the address book "Ubuntu One" - the message returned was: Cannot open book: Could not create DesktopcouchSession object

I updated everything to the Proposed repository, and haven't seen this error anymore.

Thanks devs and testers!

knatschfisch (maxstauch) wrote :

Hello together,

The fix helped me. I got the message, even if I wanted to open an e-mail folder. Now it is disappeared. But now the message emerges only if I open Thunderbird.

Launchpad Janitor (janitor) wrote :
Download full text (5.0 KiB)

This bug was fixed in the package thunderbird - 8.0+build1-0ubuntu0.11.10.1

---------------
thunderbird (8.0+build1-0ubuntu0.11.10.1) oneiric-security; urgency=low

  * New upstream stable release v8.0 (THUNDERBIRD_8_0_BUILD1)

  * Update messagingmenu-extension to 0.8.3
    - This version backs out the change made in 7.0.1+build1+nobinonly-0ubuntu2
      that didn't fix LP#850229
  * Don't disable our bundled addons on upgrade
    - update debian/vendor.js
  * Move custom scripts to debian/build
    - move debian/get-xpi-id.py to debian/build/get-xpi-id.py
    - move debian/refresh-supported-locales.pl to
       debian/build/refresh-supported-locales.pl
    - move debian/extract-file.py to debian/build/extract-file.py
    - move debian/testsuite.mk to debian/build
    - update debian/rules
  * Shrink the default mozconfig right down so that we use mostly upstream
    defaults, rather than overriding them with our own options. It is still
    possible to override them though. We also drop the pkg-config checks in
    debian/rules which allowed a fallback build configuration when dependencies
    aren't satisfied. Really, the build should just fail here rather than
    continuing in some undesirable fallback mode
    - update debian/thunderbird-dev.links.in
    - update debian/mozconfig.in
    - update debian/control.in
    - update debian/rules
  * Refresh build-depends, as this hasn't been done for a while:
    - Drop patchutils, libxft-dev, libxinerama-dev, libgnome2-dev, sharutils
      and bzip2. These don't appear to be needed
    - Drop liborbit2-dev - only appears to be required if there is no libidl
    - Add libglib2.0-dev, libext-dev, libfontconfig1-dev and libpango1.0-dev,
      as the configure script checks for these directly
    - Add minimum versions to libgconf2-dev, libgnomevfs2-dev, yasm and
      libgnomeui-dev
    - Specify minimum versions for libnspr4-dev, libcairo2-dev, libsqlite3-dev
      and libnss3-dev when using system versions of those libs
  * Introduce a branch config file (debian/config/branch.mk) which holds
    settings which shouldn't be merged between branches (eg, whether
    the crash reporter should be enabled)
    - add debian/config/branch.mk
    - update debian/rules
  * Move debian/locales.* to debian/config
    - move debian/locales.shipped => debian/config/locales.shipped
    - move debian/locales.unavail => debian/config/locales.unavail
    - update debian/rules
    - update debian/build/refresh-supported-locales.pl
  * Move debian/mozconfig.in to debian/config
  * Touch debian/control.in during clean to force a refresh of debian/control,
    so we can check if it is out-of-date and fail if it is
    - update debian/rules
  * Refresh patches:
    - update debian/patches/ctypes-callback-reentry-fix.patch
    - update debian/patches/theme-refresh-compose-toolbar-icons.patch
    - update debian/patches/theme-refresh-message-header-buttons.patch
  * Drop the mozilla-devscripts dependency. We were only using this for creating
    tarballs anyway. Instead, implement our own get-orig-source target, which
    also fixes some problems we were having
    - update debian/control.in
    - remove debian/moz-r...

Read more...

Changed in thunderbird (Ubuntu Oneiric):
status: Fix Committed → Fix Released
effell (effell) wrote :

I'm sure this is not the best place for this comment, but it may be useful:
Having a lot of trouble starting desktop couch, was getting a lot of

"WARNING:root:Pid file does not contain int: \n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n"

turned out that the permissions were readonly on

~/.cache/desktop-couch/desktop-couchdb.stdout
~/.cache/desktop-couch/desktop-couchdb.stderr

Deleted them both.

Przemyslaw Majewski (przemmaj) wrote :

I experience the same problem on the up to date system.

Xwarman (xwarman) wrote :

me too...

Xwarman (xwarman) wrote :

Description: Ubuntu 12.04.2 LTS
Release: 12.04
3.2.0-40-generic #63-Ubuntu SMP Wed Mar 20 17:18:21 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
latest official patches

To post a comment you must log in.