Ubuntu

Failed to activate external monitor (dual monitor mode)

Reported by Jean-Baptiste Lallement on 2011-07-11
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Unity
High
Unassigned
compiz (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

TEST CASE:
1. Plug an external monitor before logging in (otherwise you'll face bug 733346)
2. Login
3. Open the display configuration applet
  $ gnome-control-center display
4. Activate the second monitor

Result:
Everything becomes black, unity reappears but not the main viewport.
Windows (terminal, gnome-control-center, ...) are invisible
CPU goes to 100%
Then after a while the session quits.

Similar issue bug 769650

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: compiz 1:0.9.4+bzr20110606-0ubuntu6
ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
Uname: Linux 3.0-3-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
Date: Mon Jul 11 10:55:58 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110209)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Changed in compiz (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
importance: Undecided → High
summary: - Failed to activate external monitor
+ Failed to activate external monitor (dual monitor mode)
tags: added: compiz-0.9
David Barth (dbarth) wrote :

@jibel:
If it's related to the i915 issue, could you verify what's at 100%: is it the xserver or compiz?
Could you attach to the process eating the cpu and see if it loops inside the driver for example?

Alternatively, is this bug reproducible on a different HW configuration?

f1anker (ianspigeon) wrote :

Similar issue occurs for me on an up to date Oneiric x86_64 install on a Dell Latitude E6400 but after connecting an external monitor the laptop screen goes completely back and the external monitor goes into standby after reporting no signal. Trying to switch to a virtual terminal does not reactivate the laptop screen, all I can do is hit the power button to reboot.

Attaching lspci output, let me know what else I can provide to help track down the cause.

Changed in compiz (Ubuntu):
status: New → Confirmed
ngsupb (ngsupb) wrote :

the same issue with nouveau driver and 8400gs card and external monitor. Badly need it working to migrate from 11.04

tags: added: rls-mgr-o-tracking
David Barth (dbarth) on 2011-09-16
Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
milestone: none → 4.18.0
importance: Undecided → High
status: New → Triaged
tags: added: testcase
Jay Taoko (jaytaoko) wrote :

What was the resolution of the both the internal and external monitors? Does the situation improve if the external monitor resolution is lowered?

Jean-Baptiste Lallement (jibel) wrote :

external: 1600x1200
internal: 1280x1024

ngsupb (ngsupb) wrote :

in my case it was:
external: 1920x1080
internal: 1280x800
Exactly the same issue as f1anker described.

Unfortunately won't be able to test a lower resolution until October. I am attaching lspci output, hope this helps.

Jay Taoko (jaytaoko) wrote :

I have tested with a fresh install of Oneiric on a intel core i3 system. I cannot reproduce the issue mentioned.

My internal display is resolution is 1280x800 while my external monitor is 1280x1024. The gnome control panel offers the following resolutions for the external monitor:
 - 1024x768
 - 800x600

I can run in dual monitor config with my internal resolution maxed at 1280x800 and any of the resolutions above for the external monitor.

The control panel used to propose the option to choose the maximum resolution of my external monitor (1280x1024) but it doesn't do that anymore. It has been like that for a month or so. Previously, if I had tried to use the max resolution of the external monitor, things would become very slow as if running in software. So I suppose the control panel is more clever now and only offers resolution that can be supported.

Please, test with a fresh install and a recent version of Oneiric.

Changed in unity:
status: Triaged → Incomplete
ngsupb (ngsupb) wrote :

HI Jay,

thanks for working on it. Just a quick question. Did you use the Mirror displays option? In mirroring it works fine for me too, but the external display can't have resolution larger internal's display. That is why you weren't able to set '1280x1024'.

I can run my external display at the same resolution as internal (1280x800) in mirroring. But things look too big for '1920x1080' display:)

Please try to disable the mirroring option to set the external display separately.

Jay Taoko (jaytaoko) wrote :

Hello ngsupb

I wasn't running in mirror mode. I was running the monitors as 2 independent surfaces; and moving application windows from one monitor to the other. This worked well on my system. No glitch or artifacts.

I also want to add that my system has a VGA external output and I used a VGA cable to connect to the VGA input of the external monitor.

David Barth (dbarth) on 2011-09-23
Changed in compiz (Ubuntu Oneiric):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Jay Taoko (jaytaoko)
status: Confirmed → Incomplete
Didier Roche (didrocks) on 2011-09-26
Changed in unity:
milestone: 4.18.0 → 4.20.0
Didier Roche (didrocks) on 2011-09-29
Changed in unity:
milestone: 4.20.0 → 4.22.0
Didier Roche (didrocks) on 2011-10-04
Changed in unity:
milestone: 4.22.0 → 4.24.0

The same happens also using VirtualBox. This could help testing and fixing I guess.

ngsupb (ngsupb) wrote :

I have tried with some other monitor. I was able to attach it and set separate resolution for the external monitor(not mirroring) . I had both notebook and external monitor(1280 x 1024 ) running. After that I selected "off" option in the display manager for the notebook's display to turn off it in order to use the external monitor as primary monitor with the unity panel. Both displays went black. The only way was to shut down and reboot.

I can't test it with the previous display (1920x1080). With that one everything hanged and went to black right after I plug in the external display and set it as separate screen.

With the current one the issue appears after I disable internal notebook's display to use the external display only.

ngsupb (ngsupb) wrote :

I have tested with the same monitor I have the issue with. It works almost fine now except of the following two issues:

1) slow. It seems worked faster on 11.04
2) when I reboot with the plugged in external monitor it doesn't work. But works when I unplug it, reboot. and plug in after boot again.

ngsupb (ngsupb) wrote :

I have tested a bit more:

1) external display works fine as it is supposed when I plug in it first time. After reboot doesn't work even when I boot without it and plug in it back. I have to delete the file .config/monitors.xml after booting and plug in the display to start it working.

Anyway it is better than it was before. At least it works somehow.

2) everything works noticeably slower when both displays are enabled. After I disabled notebook's display it works at acceptable level.

Omer Akram (om26er) wrote :

Is that still an issue in Ubuntu 11.10 with all the update applied.

Omer Akram (om26er) on 2012-06-25
Changed in unity:
assignee: Jay Taoko (jaytaoko) → nobody
Changed in compiz (Ubuntu):
assignee: Jay Taoko (jaytaoko) → nobody
Changed in compiz (Ubuntu Oneiric):
assignee: Jay Taoko (jaytaoko) → nobody
Changed in unity:
milestone: 4.24.0 → none
Launchpad Janitor (janitor) wrote :

[Expired for compiz (Ubuntu Oneiric) because there has been no activity for 60 days.]

Changed in compiz (Ubuntu Oneiric):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for compiz (Ubuntu) because there has been no activity for 60 days.]

Changed in compiz (Ubuntu):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for Unity because there has been no activity for 60 days.]

Changed in unity:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers