[sandybridge-gt2+] Intel sandy-bridge dual-head GPU hang

Bug #732304 reported by yope on 2011-03-09
82
This bug affects 15 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Medium
Robert Hooker
Natty
Medium
Robert Hooker

Bug Description

Binary package hint: xserver-xorg-video-intel

Just upgraded my PC to natty as of today (alpha-3) and moved the HDD to a new PC barebone based on Intel Sandy-bridge (Core-i7 2600K) with two monitors connected.
After configureing xorg.conf and booting, kdm came up fine, but the session-type menu top-half is unreadable (garbled).
After logging in (Desktop effects disabled), everything seems to work for a few seconds with only minor display glitches, but after a random time, or at certain actions (like entering a URL in chrome), the X server freezes. Sometimes it freezes forever, and sometimes it comes back after a few seconds (display goes black for a while).
The system keeps running fine, and dmesg shows this:

...
[ 44.619127] EXT4-fs (sda2): re-mounted. Opts: errors=remount-ro,commit=0
[ 111.166652] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[ 111.166659] [drm:kick_ring] *ERROR* Kicking stuck semaphore on render ring
[ 117.179392] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[ 117.179399] [drm:kick_ring] *ERROR* Kicking stuck semaphore on render ring
[ 143.863963] exe (2839): /proc/2839/oom_adj is deprecated, please use /proc/2839/oom_score_adj instead.
[ 713.763627] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[ 713.768747] [drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -11 (awaiting 189057 at 189056, next 189058)
[ 713.769135] [drm:init_ring_common] *ERROR* render ring initialization failed ctl 0001f003 head 00000000 tail 00000000 start 00000000
[ 720.080216] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[ 720.080228] [drm:kick_ring] *ERROR* Kicking stuck semaphore on blt ring
[ 721.583394] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[ 721.583407] [drm:kick_ring] *ERROR* Kicking stuck semaphore on blt ring
[ 723.086571] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[ 723.086582] [drm:kick_ring] *ERROR* Kicking stuck semaphore on blt ring
[ 724.589766] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[ 724.589799] [drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -11 (awaiting 189083 at 188507, next 189084)

In the situation shown above the X server had recovered from the freeze.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-intel 2:2.14.0-4ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic-pae 2.6.38-rc7
Uname: Linux 2.6.38-6-generic-pae i686
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: kwin
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DP.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x1024 1280x1024 1152x864 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 640x480 640x480 640x480 720x400
 edid-base64: AP///////wAi8OomAQEBAS8RAQOAIhuM7txVo1lIniQRUFSt74CBgAEBAQEBAQEBAQEBAQEBMCoAmFEAKkAwcBMAVA4RAAAeAAAA/QAyTRhTDgAKICAgICAgAAAA/ABIUCBMMTc1MAogICAgAAAA/wBDTkQ3NDcyTUtKCiAgAHM=
DRM.card0.HDMI.A.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x1024 1280x1024 1152x864 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 640x480 640x480 640x480 720x400
 edid-base64: AP///////wAi8OkmAQEBASoRAQNoIhuM7q/Ap1NFnSQXUFSt74CBgAEBAQEBAQEBAQEBAQEBMCoAmFEAKkAwcBMAVA4RAAAeAAAA/QAyTRhTDgAKICAgICAgAAAA/ABIUCBMMTc1MAogICAgAAAA/wBDTkM3NDJRR1BKCiAgADs=
Date: Wed Mar 9 23:32:14 2011
DistUpgraded: Log time: 2011-03-09 22:13:09.851169
DistroCodename: natty
DistroVariant: kubuntu
DkmsStatus:
 nvidia-current, 270.29, 2.6.38-6-generic-pae, i686: installed
 nvidia-current, 270.29, 2.6.35-27-generic, i686: installed
 nvidia-current, 270.29, 2.6.38-6-generic, i686: installed
 vboxhost, 4.0.4, 2.6.38-6-generic-pae, i686: installed
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0122] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:844d]
MachineType: ASUSTeK Computer INC. V-P8H67E
ProcEnviron:
 LANGUAGE=
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-6-generic-pae root=UUID=217ebb2e-1497-4da5-9aba-7e59c4f101b3 ro crashkernel=384M-2G:64M,2G-:128M quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xserver-xorg-video-intel
UnitySupportTest: Error: command ['/usr/lib/nux/unity_support_test', '-p'] failed with exit code -11: Xlib: extension "GLX" missing on display ":0".
UpgradeStatus: Upgraded to natty on 2011-03-09 (0 days ago)
dmi.bios.date: 11/02/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0212
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: V-P8H67E
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0212:bd11/02/2010:svnASUSTeKComputerINC.:pnV-P8H67E:pvrSystemVersion:rvnASUSTeKComputerINC.:rnV-P8H67E:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: V-P8H67E
dmi.product.version: System Version
dmi.sys.vendor: ASUSTeK Computer INC.
version.compiz: compiz 1:0.9.4-0ubuntu4
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu5

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 2nd Generation Core Processor Family DRAM Controller [8086:0100] (rev 09)
     Subsystem: ASUSTeK Computer Inc. Device [1043:844d]
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0122] (rev 09) (prog-if 00 [VGA controller])
     Subsystem: ASUSTeK Computer Inc. Device [1043:844d]

yope (djander) wrote :
yope (djander) wrote :

Extra information. Since today I have added

     Option "Shadow" "true"

to the device section in xorg.conf and since that, the artifacts and visual glitches seem to be gone, and I have yet to see the X server freeze.
Of course this is not a solution, but merely a workaround. I have virtually no form of acceleration now.

Bryce Harrington (bryce) wrote :

@Robert, mind looking at this one? I recall you mentioned today seeing something that sounded similar to this bug, perhaps you already know of a patch to test?

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Robert Hooker (sarvatt)
Bryce Harrington (bryce) wrote :

@yope, I see you're running a somewhat older kernel. Can you please update to current natty and check if you can reproduce the issue there?

I ask because we've fixed several quite commonly encountered gpu lockups between the kernel this is reported against and current, so want to make sure what you saw is not just an already solved issue.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
yope (djander) wrote :

@Bryce, I was running up-to-date versions of everything when I initially posted.
I just updated and commented-out the "shadow" option in my xorg.conf file as you suggest, restarted the X server and until now, no lockups.
But.... the display glitches are back. See the attached screenshot.
Should I file a new bug-report for the glitches?

Robert Hooker (sarvatt) wrote :

Yeah semaphores were disabled in the final 2.6.38 release so that hang will be gone. Can you please try this kernel to see if the corruption is still present?

http://kernel.ubuntu.com/~sarvatt/2011Q1/

tags: added: hwe-blocker
Atanas (atanasd) wrote :

Just tried the above linked kernel, but it doesn't seem to make any difference.
This is on a Core-i5 2500K running Maverick/amd64 with xorg-edgers-ppa packages.

yope (djander) wrote :

@Robert, I tried with your kernel, and it doesn't make any difference. There are no hangups (at least for the few hours I tested), but corruption is still present and has not changed a bit.

Atanas (atanasd) wrote :

Today I tried the new Natty beta1 (Kubuntu) and the garbled menus are still there.

Changed in xserver-xorg-video-intel (Ubuntu Natty):
importance: Undecided → Medium
CaCO3 (caco3) wrote :

The option with the
Option "Shadow" "true"
in the xorg.conf works for me on Kubuntu 10.10 as well as in 11.04 beta 1.

The attached xorg.conf has a lot of data which is not really needed. If you want to use another screen configuration, remove everything form the file except the code below:

Section "Device"
        Identifier "Sandybridge"
        Driver "intel"
        Option "DRI" "false"
        Option "Shadow" "true"
EndSection

Atanas (atanasd) wrote :

With the latest kernel and intel driver updates as of yesterday (12.04.2011) the garbled menus problem appears fixed.
This is Kubuntu 11.04 beta1 with empty xorg.conf running on a Core-i5-2500K based system.

CaCO3 (caco3) wrote :

I can confirm that it now is working without the xorg.conf.
I also got dual screen working, how ever Kubuntu seems to forget this settings after every X server restart.
I am fixing this with the following lines in /etc/kde4/kdm/Xsetup:
xrandr --output HDMI1 --primary
xrandr --output HDMI1 --mode 1920x1080
xrandr --output HDMI3 --mode 1280x1024
xrandr --output HDMI3 --left-of HDMI1

I am sure there would be a better solution but that’s how it works for me.

My system:
Core i5 2500K, 3.3GHz with HD 3000 GPU
Kernel: Linux PC2 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Just wanted to confirm the problem. I have the same hardware and had the problem before updating to a 2.6.39 kernel.

bugbot (bugbot) on 2011-04-27
description: updated
bugbot (bugbot) on 2011-04-28
summary: - Intel sandy-bridge dual-head GPU hang
+ [sandybridge-gt2+] Intel sandy-bridge dual-head GPU hang
Bryce Harrington (bryce) wrote :

Comments #11 and #12 suggest this is now fixed, is that correct?

Changed in xserver-xorg-video-intel (Ubuntu Natty):
status: Incomplete → Confirmed

I am seeing something similar with the released 11.04 distribution. The symptom is that I'll leave the computer running and when I come back it is hung, either with a black screen or a frozen screensaver. The only way I have found to recover is a power cycle. Browsing the logs, I see the following two lines repeated every 1-2 seconds:

May 3 12:48:24 david-laptop kernel: [54980.004156] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
May 3 12:48:24 david-laptop kernel: [54980.004165] [drm:kick_ring] *ERROR* Kicking stuck wait on render ring

Does this sound like the same bug or something new?

Jonathan Goya (jkgoya) wrote :

Daedalus - maybe you're seeing something related to:
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/661450

I was having similar problems getting external monitors to work on a laptop, switching to ubuntu classic fixed it for now.

Jonathan - I don't think mine (https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/778283) is quite the same, but I think they could be related. Bug https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/711378 also seems related to what I'm seeing, but again not quite the same...

Pieter L. (pieterlangendonck) wrote :

Hello Daedalus Prime,
I think I have the same problem you are have. Have you taken any action yet? And any results.

Here my problem:
Since my upgrade to Ubuntu 11.04 with Unity, I sometimes have a GPU hung error in which case it seems the screen is 'dead' and does not show anything anymore.

Here the error:

May 26 13:02:42 ubuntu-server kernel: [22293.856048] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
May 26 13:02:42 ubuntu-server kernel: [22293.856069] [drm:kick_ring] *ERROR* Kicking stuck wait on render ring

The system remains trying for every while to get control over the GPU, but without any effect. The lines above are repeated every couple of seconds in the logfile.

If I do a Remote shell to my ubuntu machine it seems that the machine works without problems except for the videocard.
If I do a reboot, everything works fine immediately again (including the videocard).
In Windows7 (my system is dualboot) I have never experienced any problem with my videocard.

I have a Intel® Desktop Board D945GSEJT motherboard with an ATOM 1.6 GHz processor on it and with an onboard i915 GPU chip.

In an earlier version of Ubuntu I have had a problem with the videocard as well, after an upgrade to that version a strange problem occurred which caused my Xwindows to freeze completely.
This was eventually fixed with upgrading to a higher version of the Linux kernel, but it seems related to not be able to get control over the GPU (that is at least what I remember).

Info of my motherboard:
http://www.intel.com/products/desktop/motherboards/D945GSEJT/D945GSEJT-overview.htm
It has the latest available version of the BIOS inside.

I have no clue how to continue and to get this issue solved.
If I would have known on forehand I would not have upgraded to 11.04, because I want a stable system.

Does anyone have any suggestions?

Pieter L. (pieterlangendonck) wrote :

Do I need to submit a new bug for this, or is it the same?

On 06/03/2011 05:56 AM, Pieter L. wrote:
> Do I need to submit a new bug for this, or is it the same?
>
Looks the same to me. I've seen comments that upgrading to the next
kernel might fix the problem...

Linus van Geuns (nirkus) wrote :

Hey,

I have a similar problem, see Bug #827531

I get this i915 hangcheck messages all the time:
[..][drm:i915_hangcheck_ring_idle] *ERROR* Hangcheck timer elapsed... blt ring idle [waiting on 2310953, at 2310953], missed IRQ?
[..]

My GPU is a Intel HD3000 (sany birdge, Core i7-2620M). Computer is a Dell E6520 (Laptop).

$ dmesg
[..]
[ 5.828173] i915 0000:00:02.0: irq 45 for MSI/MSI-X
[ 5.828180] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
[ 5.828182] [drm] Driver supports precise vblank timestamp query.
[..]
[ 5.984485] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem
[ 6.076969] fbcon: inteldrmfb (fb0) is primary device
[ 6.139589] Console: switching to colour frame buffer device 240x67
[ 6.146270] fb0: inteldrmfb frame buffer device
[ 6.146272] drm: registered panic notifier
[..]

Ayan George (ayan) on 2011-08-31
tags: added: blocks-hwcert-enablement
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original bug reporter. However, if the issue still exists in the latest development version of Ubuntu and you are the original reporter please feel free to reopen with the requested information. If you are not the original reporter, please don't reopen this one but instead file a new bug and reference this one.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Invalid
Robert Hooker (sarvatt) on 2012-02-13
Changed in xserver-xorg-video-intel (Ubuntu Natty):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers