Ubuntu

Menu pops up repeatedly during game (w/savegame)

Reported by Hans Joachim Desserud on 2010-05-06
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
singularity (Debian)
Fix Released
Unknown
singularity (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Binary package hint: singularity

the packaged singularity is not compatible with python 2.7, it ises locale.format in a wrong way.
This issue was fixed in 0.30c, that version only fixes this issue and commends some unused translations, so one can use that complete new release for an SRU instead of backporting the fix.

TESTCASE:
start game from the console, start new game in any difficulty.
click on finance in the lower left

one gets this traceback on the console:
  File "/usr/share/games/singularity/code/g.py", line 268, in to_percent
    return locale.format("%.2f%%", raw_percent / 100.).decode(encoding)
  File "/usr/lib/python2.7/locale.py", line 189, in format
    "format specifier, %s not valid") % repr(percent))
ValueError: format() must be given exactly one %char format specifier, '%.2f%%' not valid

the fix is extremely simple, so regressions should be impossible.

original report:
In one game I played, the menu suddenly popped up all by itself. I selected back to continue the game, but the menu popped up again. And it continued to pop up each time I pressed back, making the game unplayable.

This is the only game where I have experienced this bug, so I do not know how rare this bug is.
Other games I have played have worked normally.

Steps to reproduce:
1. Download the attached savegame and store it in ~/.endgame/saves/
2. Start singularity.
3. Choose "Load game" and select the savegame named "Bug: menu pops up".

ProblemType: Bug
Architecture: i386
CheckboxSubmission: 3d4e70beb3eff6f543ce51ffa626d20a
CheckboxSystem: e704f33cc0866ff0f0256a33de39ea1c
Date: Thu May 6 18:39:38 2010
DistroRelease: Ubuntu 9.10
Package: singularity 0.30-2
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=nb_NO.UTF-8
 LANG=nb_NO.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-21.59-generic
SourcePackage: singularity
Uname: Linux 2.6.31-21-generic i686

Hans Joachim Desserud (hjd) wrote :
Francesco Muriana (f-muriana) wrote :

This bug also affects me on Natty.

ProblemType: Bug
Architecture: i386
Date: Sat Jun 18 00:47:56 2011
DistroRelease: Ubuntu 11.04
InstallationMedia: Natty (i386)
Package: singularity 0.30b-1
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=it_IT:en
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
SourcePackage: singularity
Tags: natty running-unity
Uname: Linux 2.6.38-8-generic-pae i686
UpgradeStatus: No upgrade log present (probably fresh install)

Tuomas Heino (iheino+ub) wrote :

This seems to be a regression from python 2.7 update.
http://bugs.python.org/issue10379 implies that correct fix for this is changing locale.format to locale.format_string.

Easier test case for this is starting game and clicking on the "Finance" button, which always shows percents.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in singularity (Ubuntu):
status: New → Confirmed
Tuomas Heino (iheino+ub) on 2011-09-24
tags: added: amd64 natty regression-update

The attachment "sing_p_not_vs_src.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in singularity (Debian):
status: Unknown → Confirmed
Julian Taylor (jtaylor) wrote :

the latest upstream version fixes this issue:
Version 0.30c (2 mb) 06-11-2011. Linux only, as this fixes a Linux-only bug.
 Changes:
- Fixed crash in Python 2.7 due to different handling of locale strings. (Phil Bordelon, Roger Pixley/Daskreech for bug report)

Changed in singularity (Ubuntu):
status: Confirmed → Triaged
Julian Taylor (jtaylor) on 2011-09-27
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package singularity - 0.30c-0ubuntu1

---------------
singularity (0.30c-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - fixes python 2.7 incompatibility (LP: #576504)
 -- Julian Taylor <email address hidden> Tue, 27 Sep 2011 18:24:44 +0200

Changed in singularity (Ubuntu):
status: Triaged → Fix Released
Daniel Holbach (dholbach) wrote :

Uploaded. Sitting in the queue now.

Changed in singularity (Ubuntu Natty):
status: New → Fix Committed

Hello Hans, or anyone else affected,

Accepted singularity into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Sebastian Bator (eremit7) wrote :

I will test it within the next two weeks.

Sebastian Bator (eremit7) wrote :

According to a short test the bug is fixed in the proposed package: The game displays the menus like it should and there are no errors in the terminal.

Thanks to everyone involved in the fix.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package singularity - 0.30c-0ubuntu0.1

---------------
singularity (0.30c-0ubuntu0.1) natty-proposed; urgency=low

  * New upstream bugfix release.
    - fixes incompatibility with python 2.7 (LP: #576504)
 -- Julian Taylor <email address hidden> Wed, 05 Oct 2011 18:50:48 +0200

Changed in singularity (Ubuntu Natty):
status: Fix Committed → Fix Released
Changed in singularity (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.