Ubuntu

Pandora does not support your client version. (Need v33 keys)

Reported by Mike Gibson on 2011-11-09
122
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Pithos
Fix Released
Critical
Unassigned
pianobar
Fix Released
Undecided
Unassigned
pianobar (Debian)
Fix Released
Unknown
pianobar (Ubuntu)
High
Unassigned
Natty
High
Unassigned
Oneiric
High
Unassigned
pithos (Debian)
Fix Released
Unknown
pithos (Ubuntu)
Undecided
Unassigned
Natty
High
Unassigned
Oneiric
High
Unassigned

Bug Description

== SRU INFORMATION ==

Pandora changed their API, so here we provide an update to support API v33. As usual, the change was without warning, and rendered pianobar and pithos unusable.

This is low-impact to other apps, because pithos and pianobar have no rev-depends.

=== pithos (gtk) ===
The API was fixed, and we included a pointer to the upstream maintainer's site for the error dialogue in future instances of breakage.

What happens:
On login, "Pandora does not support your client version"

What should happen:
You are logged in and a station loaded.

Ideally, test with your Pandora.com account.

=== pianobar (cli) ===

What happens:
    # pianobar
    Welcome to pianobar (2010.10.07)! Press ? for a list of commands.
    [?] Username: <email address hidden>
    [?] Password:
    (i) Login... Error: Protocol incompatible. Please upgrade libpiano.

What should happen:
    # pianobar
    Welcome to pianobar (2010.10.07)! Press ? for a list of commands.
    [?] Username: <email address hidden>
    [?] Password:
    (i) Login... Ok.

Etc.

Ideally, test with your Pandora.com account.

Minimal diff attached.

== END SRU INFORMATION ==

I'm running 0.3.11. Looks like it's been updated in the past hour.

bkberger (bkberger) wrote :

Running 0.3.11 here also -

ERROR:root:fault: org.apache.xmlrpc.XmlRpcException: 000.000.000.000|0|INCOMPATIBLE_VERSION|Pandora does not support your client version.

Francis McGrew (sanfranciscotx) wrote :

Looks like they changed the decryption keys as well.

Pithos 0.3.9
LinuxMint 11 Kayta
Kernel Linux 2.6.38-8-generic
GNOME 2.32.1

ERROR:root:fault: org.apache.xmlrpc.XmlRpcException: 000.000.000.000|0|INCOMPATIBLE_VERSION|Pandora does not support your client version

-- Sounds like Pandora made a few chances?

Reed Loden (reed) wrote :

Being worked on by the pianobar folks...

https://github.com/PromyLOPh/pianobar/issues/171

Joan Gushin (mymorninglite-h) wrote :

Pithos was working ok this afternoon and this evening has a message

 " Does not support client agent."

 I went to pithos.com and was able to login, so my account is still active.

Joan Gushin (mymorninglite-h) wrote :

I forgot to add, I am using Bodhi Linux 1.2.1 Stable.

Changed in pithos:
status: New → Confirmed
importance: Undecided → Critical
summary: - Pandora does not support your client version.
+ Pandora does not support your client version. (Need v33 keys)
Changed in pithos:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pianobar (Ubuntu):
status: New → Confirmed
Changed in pithos (Ubuntu):
status: New → Confirmed
Changed in pithos:
status: Fix Committed → Fix Released
Luke Faraone (lfaraone) on 2011-11-09
Changed in pianobar:
status: New → Fix Released
Tchalvak (tchalvak) wrote :

Hmmm, how can we tell when to check the ppa for pithos again? I see status is "Fix Released", but nothing new to download from the launchpad ppa at the moment. *shrugs*

Kevin Mehall (kevin-mehall) wrote :

I started to deploy 0.3.12 through the PPA, but then Pandora updated again. Need to do some more reverse engineering - looks like they've changed the login API in the last few minutes,

Changed in pithos:
status: Fix Released → In Progress
James Lynch (2-wizard) wrote :

Thanks Kevin, much appreciated. For the curious, current daily (pithos_0.3.12~bzr174_all.deb) gives me the following on Lucid:
blank error dialog in GUI and on the CLI:
  ERROR:root:fault: com.savagebeast.radio.api.protocol.xmlrpc.RadioXmlRpcException: 192.168.160.46|1320858658929|AUTH_WEB_LOGIN_NOT_ALLOWED|

Adam Porter (alphapapa) wrote :

Thanks for your work on this, Kevin.

Zach Tibbitts (zachtib) wrote :

 > I started to deploy 0.3.12 through the PPA, but then Pandora updated again. Need to do some more reverse engineering - looks like they've changed the login API in the last few minutes,

Pretty sure this is the case. I had it working for a couple hours earlier by rebuilding from source, but when I got back from lunch, I'm seeing the same error James Lynch posted.

D. Wiley (dnwiley) wrote :

Thanks for the status update.

While I'm sure this is assumed,0 .3.10 is also showing the same error message. I've looked around but I've found no obvious updates to the login api (but then again I am a bit of a novice at this)

Kevin Mehall (kevin-mehall) wrote :

Pithos 0.3.13 is now in the PPA and fixes both this bug and the subsequent login issue.

Changed in pithos:
status: In Progress → Fix Released
Reed Loden (reed) wrote :

Looks like this is due to auth now requiring SSL.

https://github.com/PromyLOPh/pianobar/issues/174

Awesome! Thanks!

Mike Gibson (megibson) wrote :

Fixed in thirteen hours. AWESOME. Thanks.

bkberger (bkberger) wrote :

Upgrade for Debian

bzr branch https://code.launchpad.net/~kevin-mehall/pithos/trunk pithos
cd pithos
sudo python setup.py install --prefix=/usr/local

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pithos - 0.3.13-1

---------------
pithos (0.3.13-1) unstable; urgency=high

  * New upstream bugfix release, fixing among other bugs:
    - Support protocol 33. (closes: #648210, LP: #887886)

 -- Luke Faraone <email address hidden> Wed, 09 Nov 2011 14:39:02 -0500

Changed in pithos (Ubuntu):
status: Confirmed → Fix Released
Luke Faraone (lfaraone) on 2011-11-10
description: updated
Changed in pithos (Ubuntu Oneiric):
importance: Undecided → High
status: New → Confirmed
Changed in pithos (Ubuntu Natty):
importance: Undecided → High
status: New → Confirmed
Changed in pianobar (Ubuntu Oneiric):
importance: Undecided → High
status: New → Confirmed
Changed in pianobar (Ubuntu Natty):
importance: Undecided → High
status: New → Confirmed
Changed in pianobar (Ubuntu):
importance: Undecided → High
Reed Loden (reed) on 2011-11-11
description: updated

Hello Mike, or anyone else affected,

Accepted pithos into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in pithos (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
Chris Halse Rogers (raof) wrote :

Hello Mike, or anyone else affected,

Accepted pithos into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in pithos (Ubuntu Natty):
status: Confirmed → Fix Committed
Michael C (michaelcchastain) wrote :

Is there any plan to update 10.04?

Ken VanDine (ken-vandine) wrote :

I confirmed the fix for pithos works on oneiric.

Martin Pitt (pitti) on 2011-11-15
tags: added: verification-done-oneiric
Luke Faraone (lfaraone) wrote :

> Is there any plan to update 10.04?

pianobar has only been shipped since Maverick:

$ rmadison pianobar
  pianobar | 2010.10.07-1 | maverick/universe | source, amd64, armel, i386, powerpc
  pianobar | 2010.10.07-1ubuntu0.3 | maverick-updates/universe | source, amd64, armel, i386, powerpc
  pianobar | 2011.01.24-1 | natty/universe | source, amd64, armel, i386, powerpc
  pianobar | 2011.01.24-1ubuntu0.2 | natty-updates/universe | source, amd64, armel, i386, powerpc
  pianobar | 2011.09.22-1 | oneiric/universe | source, amd64, armel, i386, powerpc
  pianobar | 2011.09.22-1 | precise/universe | source, amd64, armel, i386, powerpc

pithos was new in natty:

$ rmadison pithos
    pithos | 0.3.8-1 | natty/universe | source, all
    pithos | 0.3.9-1~ubuntu3 | natty-updates/universe | source, all
    pithos | 0.3.9-1~ubuntu4 | natty-proposed/universe | source, all
    pithos | 0.3.10-1ubuntu1 | oneiric/universe | source, all
    pithos | 0.3.10-1ubuntu2 | oneiric-proposed/universe | source, all
    pithos | 0.3.13-1 | precise/universe | source, all

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pianobar - 2011.11.11-1

---------------
pianobar (2011.11.11-1) unstable; urgency=high

  * New upstream version
    - SSL support and XMLRPC api version compatibility (v33)
      (closes: #648209, LP: #887886)

 -- Luke Faraone <email address hidden> Wed, 16 Nov 2011 14:26:36 -0500

Changed in pianobar (Ubuntu):
status: Confirmed → Fix Released
Changed in pianobar (Debian):
status: Unknown → Fix Released
Changed in pithos (Debian):
status: Unknown → Fix Released
Brian Murray (brian-murray) wrote :

I also confirm that the fix for pithos works in Oneiric.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pithos - 0.3.10-1ubuntu2

---------------
pithos (0.3.10-1ubuntu2) oneiric-proposed; urgency=low

  * Support protocol 33. (LP: #887886)
  * Modify dialogue which appears on future protocol breakages.
 -- Luke Faraone <email address hidden> Thu, 10 Nov 2011 18:07:46 -0500

Changed in pithos (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Luke Faraone (lfaraone) on 2012-01-11
description: updated
Chris Halse Rogers (raof) wrote :

Hello Mike, or anyone else affected,

Accepted pianobar into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in pianobar (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Bartosz Kosiorek (gang65) wrote :

After install pianobar packages from proposed, it works perfectly.
Verification-done

Here is the results of login:

~$ pianobar
Welcome to pianobar (2011.12.11)! Press ? for a list of commands.
[?] Email: <email address hidden>
[?] Password:
(i) Login... Ok.
(i) Get stations... Ok.
  0) q Adele Radio
  1) Q b4605331's QuickMix
  2) q Bjork Radio
  3) q Chris Brown Radio
  4) q Drake Radio
  5) Farruko Radio
  6) q Kanye West Radio
  7) q Lana Del Rey Radio
  8) q Maroon 5 Radio
  9) Rick Ross Radio
 10) Rihanna Radio
 11) q The Cranberries Radio
 12) q Timbaland Radio
 13) q Today's Hip Hop and Pop Hits Radio
[?] Select station:

Bartosz Kosiorek (gang65) wrote :

PS. I checked it for Oneiric :-)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pianobar - 2011.12.11-1~ubuntu11.10.1

---------------
pianobar (2011.12.11-1~ubuntu11.10.1) oneiric-proposed; urgency=low

  * Upload fixed version to Ubuntu (LP: #887886)
 -- Luke Faraone <email address hidden> Wed, 11 Jan 2012 16:18:09 -0500

Changed in pianobar (Ubuntu Oneiric):
status: Fix Committed → Fix Released
dino99 (9d9) wrote :
Changed in pithos (Ubuntu Natty):
status: Fix Committed → Invalid
Changed in pianobar (Ubuntu Natty):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.