Ubuntu

Problem when copying folders with Nautilus using WebDAV

Reported by Martin Wendt on 2009-12-27
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gvfs
Fix Released
Medium
gvfs (Ubuntu)
Low
Unassigned
Natty
Low
Unassigned

Bug Description

Binary package hint: nautilus

I am writing a WebDAV server ('wsgidav') and noticed that I cannot copy folders with Nautilus.

1. connect to the WebDAV share, open it in Nautilus
2. drag a folder to the Ubuntu Desktop
3. A HTML file is created, where the copied folder should be

Happens on Ubuntu 8.04 and 9

In the WebDAV log I can see, that Nautilus sends a GET request for the collection. My server generates an HTML response in this case, so that the share can be viewed with a browser.
I am pretty sure, that this is OK, according to the spec:
http://www.webdav.org/specs/rfc4918.html#rfc.section.9.4

I think, Nautilus should rather send recursive GETs for the single files (or send a COPY or MOVE request, if the target is inside the same WebDAV share)

Log snippet:
...
<3612> 192.168.178.28 - tester - [2009-12-27 20:32:21] "PROPFIND /xeri2" length=235, depth=0, elap=0.003sec -> 207 Multistatus
<4868> 192.168.178.28 - tester - [2009-12-27 20:32:21] "GET /xeri2" elap=0.002sec -> 200 OK
<880> 192.168.178.28 - tester - [2009-12-27 20:32:21] "PROPFIND /xeri2" length=235, depth=0, elap=0.004sec -> 207 Multistatus
...

ProblemType: Bug
Architecture: i386
Date: Sun Dec 27 21:32:34 2009
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/nautilus
Package: nautilus 1:2.22.5.1-0ubuntu3
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
Uname: Linux 2.6.24-24-generic i686

A. Walton (awalton) wrote :

Thanks for your concern. It would be helpful if you opened a bug on bugzilla.gnome.org on the gvfs product with the webdav component and give as explicit instructions as possible on how to reproduce this bug so that we can see what code is wrong and if we can fix it. Thanks in advance.

affects: nautilus (Ubuntu) → gvfs (Ubuntu)
Changed in gvfs (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Changed in gvfs (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in gvfs:
status: Unknown → New
Changed in gvfs:
importance: Unknown → Medium
Changed in gvfs:
status: New → Unknown
Changed in gvfs:
status: Unknown → Invalid
Colin Leroy (colin-colino) wrote :

Gnome bug #605619 has been resolved Duplicate of Gnome bug #551339, updating remote watch.

Changed in gvfs:
importance: Medium → Unknown
status: Invalid → Unknown
Colin Leroy (colin-colino) wrote :

Gnome bug #551339 has been marked RESOLVED FIXED in may, there is a patch available which has been commited as d3fcf41ef3676139b5a035757c6d67c6fef073c9 on git.gnome.org.

http://git.gnome.org/browse/gvfs/patch/?id=d3fcf41ef3676139b5a035757c6d67c6fef073c9

Attached is a debdiff that adds this patch. I've been successful copying folders recursively using WebDAV with this patch.

It would be nice for the rest of the world if a maintainer could update the gvfs package in Ubuntu Natty with this fix.

Changed in gvfs:
importance: Unknown → Medium
status: Unknown → Fix Released
Sebastien Bacher (seb128) wrote :

the issue is fixed in Oneiric

Changed in gvfs (Ubuntu):
status: Triaged → Fix Released
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Changed in gvfs (Ubuntu Natty):
status: New → Confirmed
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

Thanks for your work, setting the bug as affecting natty and subscribing the sponsors team so it's listed in the review queue

Colin Leroy (colin-colino) wrote :

Thanks Sebastien :)

Martin Pitt (pitti) wrote :

Uploaded natty SRU, thanks!

Changed in gvfs (Ubuntu Natty):
status: Confirmed → Fix Committed
Colin Leroy (colin-colino) wrote :

Thanks Martin !

Hello Martin, or anyone else affected,

Accepted gvfs into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.