Ubuntu

[nautilus] ubuntu-one ribbon in folders is too obtrusive

Reported by Martin Pitt on 2010-08-03
118
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Undecided
John Lenton
ubuntuone-client (Ubuntu)
Medium
John Lenton
Maverick
Medium
John Lenton

Bug Description

Binary package hint: ubuntuone-client

In current maverick alpha-3 I now see a "Ubuntu One - folder not synchronized" in each and every folder. This is way too presumptuous. Most folders aren't meant to be synced through ubuntu one. People keep all kinds of data on their machines, e. g. huge videos (which will get them a saturated/stuck internet link for the next three years) or company confidential data (which should not be encouraged to leave your machine). Right now it is way too easy to click that button in any folder.

As a minor thing, this takes away quite a lot of vertical screen space and is an useless UI element in all but 0.001% of daily use cases.

Please revert it back to the state where it only syncs the "Ubuntu One" folder by default.

Martin Pitt (pitti) on 2010-08-03
Changed in ubuntuone-client (Ubuntu Maverick):
assignee: nobody → John Lea (johnlea)
milestone: none → ubuntu-10.10-beta
Sebastien Bacher (seb128) wrote :

Confirmed, those are displayed as well for users who don't use any syncing or work offline, it's just cluttering the interface for the users who don't use the option

Ken VanDine (ken-vandine) wrote :

I partially agree, mostly for space reasons. That banner takes up quite a bit of real estate, and in a time when we are trying to save vertical pixels we should do our best to save. Perhaps a Ubuntu One icon in the toolbar, which opens some menu with Ubuntu One actions you can do with that folder?

I also think the "Sync now" button is way too inviting. I know we want to make it easy for users to discover the conveniences of Ubuntu One, but it is too easy to click on that in a folder that might be way to big to sync. If we make it that easy to enable it, we should make disabling it work much better. If they click to disable syncing of a folder, it should immediately stop trying to sync files from that folder. Having to way for it to upload 20G of files before disabling it leaves a bad taste for users.

Changed in ubuntuone-client:
assignee: nobody → John Lea (johnlea)

Ken VanDine [2010-08-03 13:46 -0000]:
> Perhaps a Ubuntu One icon in the toolbar, which opens some menu with
> Ubuntu One actions you can do with that folder?

That sounds like a good compromise to me, too.

I could agree why a netbook user would have a problem with this ribbon part but other desktop users should not be having a problem as the vertical screen estate is quick big enough to have it.

Maybe for netbook interfaces there could be a toolbar button that does this

Changed in ubuntuone-client:
status: New → Opinion
status: Opinion → New
Matej Svetlík (matej-svetlik) wrote :

@"other desktop users should not be having a problem" ... the problem is not in vertical screen estate but that there is a feature I have no intention to use ... you could write anything there ... e.g. "do you want to become cricket player?" with only "yes" option ... NO! I don't want! I have no intention to do it in the future so why are you asking me that every time I open my music folder?

On my aspire one netbook running beta3 ubuntu-one packages make nautilus practically unusable, uninstalling them restores nautilus to its normal snappy performance.

Rodrigo Moya (rodrigo-moya) wrote :

We have now a 'Show/Hide location bar' menu item in the right-click menu for Nautilus, so if you don't want to see it, just select Hide from that menu and it won't be shown anymore

Changed in ubuntuone-client:
status: New → Fix Released
Changed in ubuntuone-client (Ubuntu Maverick):
status: New → Fix Released
Martin Pitt (pitti) wrote :

Seriously, that's not a solution at all. First, the location bar is useful for other things than just ignoring Ubuntu one, and second, it's still shown by default.

Changed in ubuntuone-client (Ubuntu Maverick):
status: Fix Released → Confirmed
Martin Pitt (pitti) wrote :

Why can't we add it to the toolbar instead? That would be much less intrusive and prone for accidental clicking, and not take away screen space. We can still keep the ribbon in the ~/Ubuntu One/ folder, of course, since there it actually is an error if the folder isn't synchronized.

Changed in ubuntuone-client:
status: Fix Released → Confirmed

This is simply not working well. If users click that checkbox, and then there is no way to reverse or stop the process, that is not acceptable. The ability to recover from errors is a very basic usability principle. The ribbon is too visible, and the consequences too severe to ship like this.

I'm ok with keeping the option on the right click menu, but we should remove the banner until the function is reversible.

John Lenton (chipaca) wrote :

Ok, several issues I need to expand a little on, here.
The current nautilus extension has no way of adding things to the nautilus toolbar, nor to the view menu; we're limited to emblems, property pages, context menu entries and sub-entries, and the ribbon.
The current ribbon uses up a lot less vertical space than when this bug was opened. It can be further collapsed, and the collapsed state is preserved. It can be disabled completely via the context menu (we need to find a way to have nautilus redisplay the window so the ribbon goes away instantly, but that's another issue).
The current ribbon only shows up in some folders: in folders that are already synchronizing, and in the toplevel "special" directories (Music, Videos, Documents, etc).
The current ribbon, and the extension as a whole, does not even start up if the user has disabled file syncing.
There is a bug, bug #613219, that the nautilus extension will start syncdaemon even if it is has been removed from the startup applications. We'll be fixing that one.
When the user clicks the checkbox with syncdaemon connected (the usual case), there is a short delay (less than a second as measured from this hotel's slow network in argentina) and then they can click the checkbox again and the sync is aborted. syncdaemon works for a little longer to cancel all the jobs it fired off, but the system remains responsive. There are corner cases such as folders with a huge (50k+) amount of files where the delay is longer; if syncdaemon is disconnected, the delay is longer while it connects and etc, but it definitely becomes responsive again as soon as it's connected and before the upload starts.

Martin Pitt (pitti) wrote :

Ah, thanks Jon for the update. I think that's already much better. I filed bug 623482 about some fine tuning (not show it in the video dir, and perhaps not in the music dir either, for the same reason).

So I'll lower the severity a bit.

Changed in ubuntuone-client (Ubuntu Maverick):
milestone: ubuntu-10.10-beta → none
summary: - [nautilus] shows ubuntu-one ribbon in each folder
+ [nautilus] ubuntu-one ribbon in folders is too obtrusive
Changed in ubuntuone-client (Ubuntu Maverick):
importance: Undecided → Medium
John Lenton (chipaca) wrote :

Martin, I'm not sure what this bug is about any longer.

John Lenton (chipaca) on 2010-08-26
Changed in ubuntuone-client:
assignee: John Lea (johnlea) → John Lenton (chipaca)
Changed in ubuntuone-client (Ubuntu Maverick):
assignee: John Lea (johnlea) → John Lenton (chipaca)
Martin Pitt (pitti) wrote :

> Martin, I'm not sure what this bug is about any longer.

The remaining gripe is that it shouldn't be such a big banner, but rather a button in the toolbar, something that doesn't sacrifice a lot of vertical screen space and is also easily revertable (the banner goes away once you enable syncing).

I understand that we might not get that for Maverick, so I un-target it for Maverick and just keep the floating task open.

Thanks!

Changed in ubuntuone-client (Ubuntu Maverick):
status: Confirmed → Won't Fix
John Lenton (chipaca) wrote :

OK, thank you for the clarification.

Rodrigo Moya (rodrigo-moya) wrote :

nautilus extensions cannot add stuff to the toolbar, so yes, maybe that's something to add to Nautilus (as well as adding stuff to the window menu) and then have our extension use that. But yes, maverick+1 work

Sebastien Bacher (seb128) wrote :

is there a bug tracking the change for this cycle to not use the banner? the beta image still has it

Changed in ubuntuone-client (Ubuntu Maverick):
status: Won't Fix → Triaged
John Lenton (chipaca) wrote :

Seb, there is no such change planned for this cycle.

Dave Ahlswede (mightyquinn) wrote :

The context menu item is really hard to discover (I had no idea this was possible until i checked this bug). Can there be a hide button in the ribbon itself?

tsg1zzn (tsg1zzn) wrote :

The context menu is hard to discover, but worse: it doesn't stick. In both Natty and Oneiric, the ubuntu one ribbon kept reappearing until I uninstalled Ubuntu One from the software center.

hollerith (hollerith) wrote :

I do not have UbuntuOne in my context menu yet I still have the annoying ribbon. I expect you will say 'install UbuntuOne, use context menu, then remove UbuntuOne', but I am afraid to. I have Maverick 10.10. because I don't want Unity &c. It really ought to be directly configurable via the View menu, like the "Tick" location bar. "Tick" Annoying Ribbon. Backports pretty pleases.

Oliver Joos (oliver-joos) wrote :

Well, I use Natty without UbuntuOne and Unity simply by removing their packages:

sudo apt-get remove ubuntuone-*
sudo apt-get remove unity-common liboverlay-scrollbar-* appmenu-gtk
sudo apt-get remove indicator-applet-appmenu indicator-appmenu

This won't work for Oneiric, but I expect it to work in Maverick. Please try it and leave a comment about your results!

I also deactivate the resize-gripper-hack (so that apps like StickyNotes work correctly again) by copying these 8 lines into a Terminal:

cat <<EOF >>~/.gtkrc-2.0
style "default-style"
{
  GtkWindow::resize-grip-height = 0
  GtkWindow::resize-grip-width = 0
}
class "GtkWidget" style "default-style"
EOF

You have to logout and login to see the difference!
To revert the changes just reinstall the packages and remove the 8 lines from ~/.gtkrc-2.0

Adolfo Jayme (fitoschido) wrote :

This is already fixed, isn't it?

Rodney Dawes (dobey) on 2012-06-11
Changed in ubuntuone-client (Ubuntu Maverick):
status: Triaged → Won't Fix
Changed in ubuntuone-client:
status: Confirmed → Fix Released
Changed in ubuntuone-client (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers