MPD lacks Mp3/LAME support in Ubuntu 10.10

Bug #701282 reported by C.Kontros on 2011-01-10
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mpd (Ubuntu)
Undecided
Unassigned
Maverick
Medium
Unassigned

Bug Description

Binary package hint: mpd

As MPD currently stands it lacks Mp3/LAME streaming output support. This was because LAME was not in Universe at one point. LAME support has been enabled for 11.04 so I'd like a SRU for any previous version of Ubuntu where this can be enabled.

Cheers.

Benjamin Drung (bdrung) on 2011-01-10
Changed in mpd (Ubuntu):
status: New → Fix Released
Benjamin Drung (bdrung) wrote :

Attached the debdiff for the uploaded mpd 0.15.10-1ubuntu3.1.

Changed in mpd (Ubuntu Maverick):
status: New → Triaged
importance: Undecided → Medium
Martin Pitt (pitti) wrote :

This looks like a new feature, not a regression. As such it is not covered by the SRU policy.

Benjamin Drung (bdrung) wrote :

There were other SRUs that added build dependencies to enable different modules, for example vlc 1.0.2-1ubuntu2.1 [1].

[1] https://launchpad.net/ubuntu/+source/vlc/1.0.2-1ubuntu2.1

Martin Pitt (pitti) wrote :

Discussed further on IRC, let's go ahead with this.

Accepted mpd into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in mpd (Ubuntu Maverick):
status: Triaged → Fix Committed
tags: added: verification-needed
C.Kontros (coryisatm) wrote :

I've been using the package since it hit -proposed without issue. Thank you.

Martin Pitt (pitti) on 2011-03-18
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mpd - 0.15.10-1ubuntu3.1

---------------
mpd (0.15.10-1ubuntu3.1) maverick-proposed; urgency=low

  * Enable Mp3/LAME support (LP: #701282).
 -- Benjamin Drung <email address hidden> Tue, 11 Jan 2011 00:15:22 +0100

Changed in mpd (Ubuntu Maverick):
status: Fix Committed → Fix Released
pataquets (pataquets) wrote :

I can't reopen nor add Lucid as 'also affected' distro.
Creating new lp bug #906004

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers