Ubuntu

Comment 17 for bug 668043

Bill Burman (bill-heliax) wrote :

I installed this patch late last night, and got the error

error: internal error '/sbin/iptables --table mangle --delete POSTROUTING --out-interface virbr0 --protocol udp --destination-port 68 --jump CHECKSUM --checksum-fill' exited with non-zero status 2 and signal 0: iptables v1.4.4: unknown option `--checksum-fill'

I also confirmed that the interface was not started. I tried more than once, just to be sure.

However, I tried again this morning, and it worked, the interface was created, and no errors were reported.

The host has been running without reboot since last night, and before the patch was applied, no other updates have been applied.

I can see that apparmor did a "profile_replace" on libvirt some time after it was started, I don't know much about apparmor, but is it possible this should have been reloaded or something? This is the only thing I can see in my logs that might have changed between it not working and now, when it does.

-----------------------------
$ uname -a
Linux kea 2.6.35-25-generic #44-Ubuntu SMP Fri Jan 21 17:40:44 UTC 2011 x86_64 GNU/Linux