Ubuntu

[08ff:2810] AuthenTec, Inc. AES2810 fingerprint reader not recognized (worked in 10.04)

Reported by Jonathan Davies on 2010-10-08
106
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
libfprint (Ubuntu)
Medium
Unassigned
Maverick
Medium
Unassigned

Bug Description

The fingerprint reader on my Lenovo Thinkpad R400 did work in Ubuntu 10.04.1 LTS, which I have just tested, it also does not work in 10.10.

sudo fprint_demo now reports "no devices found".

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: libfprint0 20081125git-4build1
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
Architecture: amd64
Date: Fri Oct 8 20:15:22 2010
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/usr/bin/zsh
SourcePackage: libfprint

Jonathan Davies (jpds) wrote :
Fabián Rodríguez (magicfab) wrote :

Jonathan, can you try the latest packages from the PPA and report back ?:
https://bugs.edge.launchpad.net/ubuntu/+source/libfprint/+bug/657017/comments/2

Changed in libfprint (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Jonathan Davies (jpds) wrote :

lsusb ID:

Bus 004 Device 002: ID 08ff:2810 AuthenTec, Inc. AES2810

Changed in ubuntu-release-notes:
status: New → Fix Released
Dorian Scholz (dorianscholz) wrote :

Is this really fixed?
I installed the latest packages available from the PPA as mentioned.
And I see the device on the lsusb list:
Bus 004 Device 002: ID 08ff:2810 AuthenTec, Inc. AES2810

But fprint_demo still reports "Status: No devices found."

Atanas Popov (popov-atanas) wrote :

Jonathan,
Are you sure your device worked in Ubuntu 10.04?
As far as i know libfprint does not support AES2810 at the moment -
http://www.reactivated.net/fprint/wiki/Unsupported_devices#AuthenTec_AES2550_.26_AES2810

Fabián Rodríguez (magicfab) wrote :

@Dorian the "Fix Released" is only for the release notes, meaning it's now indicated this doesn't work. :(

Dorian Scholz (dorianscholz) wrote :

@Fabian: Thanks for the explanation.
@Jonathan: Same question as Atanas: Did this model ever work?
I never got it to work on any Ubuntu version and the fprint wiki always stated that it is not supported...

Pavol Klačanský (pavolzetor) wrote :

This model didn't work ever (so, I have this device one year, and it didn't work and doesn't)

I have investigated driver, but this device communicate over encrypted transfer, I have written to authentec and they won't provide driver nor documentation

Russel Winder (russel) wrote :

Presumably Canonical can ask for the information under NDA and write a non-free binary blob driver and provide it via that route?

Pavol Klačanský (pavolzetor) wrote :

I really don't know, BUT I can be possible, I think it has similar interface and communication like 2510. And authentec may not have SDK for linux

I think it's very unlikely any third party will write non-free binary only
drivers unless funded to do so.

That is my point, Canonical should fund this so that the hardware works out of the box under Ubuntu Natty.

Scott,

I don't think I was missing your point. Lenovo only sell T500 with Windows so they only care about Windows drivers. AuthenTec will only do something if it makes a profit and the only operating system that people can get on their T500 machines in the shops is Windows, so only Windows matters to them. Thus no-one with any financial clout is going to care, except Canonical, who I thought had a policy of all hardware working under Ubuntu out of the box. Clearly this is not the case for the T500. So unless a big corporate suddenly decides it has to fund Canonical to have the driver, Canonical will have to fund the project internally or it will never happen. I am guessing from the apparent lack of official Canonical corporate interest in this bug, the answer is this bit of hardware will not now ever work in Ubuntu and definitely never in Debian. Sad, but I have learnt to live with this.

Fabián Rodríguez (magicfab) wrote :

The AES2810 fingerprint reader is also shipped on the x200 series laptops. I've recently tested this with Ubuntu 11.04 with the same results. Multiple reports online seem to confirm it's unlikely any new (free or not) support for this will be provided to GNU/Linux users.

Greg (greg-net-launchpad) wrote :

To clarify: The AES2810 has an "less secure" mode as well as the "super secure" mode.

We do provide documentation to those that ask for it - to the best of our ability (i.e. does not expose information that would compromise the security of the part at our OEMs). Feel free to contact our developer support desk (see http://developers.authentec.com/ ) and they will provide whatever is needed to support the open source community.

Greg Kerr
VP Software Engineering
AuthenTec, Inc.

Zeth (adair-boder) wrote :

I too have the 08ff:2810 AuthenTec, Inc. AES2810 device in my Thinkpad T400 ... running 12.04 and no luck getting the reader to work! :(

Zeth (adair-boder) wrote :

I just sent an Email to <email address hidden> requesting assistance ... worst they can do is say "No!" - :P

Scott Wang (scott-wang) wrote :

I've also sent an Email to ask for documentation to <email address hidden> one week ago.

No reply at all -- no surprise to me at all :-(

Zeth (adair-boder) wrote :

Just got a reply from Authentec:

"Hello,

in fact we have just disclosed the USB spec to the developers interested in integrating the support for this device to the fprint project.
If you're a developer and want to participate in the effort I would suggest to get involved via the fprint community.
We can also share the USB spec with you directly, if you register to our Developer Program and let me know your user id.

Best Regards
Martin Konecny
Software Integration Manager
AuthenTec"

I've put the full specifications documents up on http://shkspr.mobi/blog/index.php/2012/07/athentec-fingerprint-scanners-full-specifications-aes2810-aes2550/
Direct link to PDF http://www.scribd.com/doc/98988635/AES2810-Design-Specification-V1-20

Hopefully that will be of some help to people trying to get this working.

Fabián Rodríguez (magicfab) wrote :

THe fprint PPA has seen quite a few updates lately:
https://launchpad.net/~fingerprint/+archive/fprint

For my Authentec 1600 this means full integration and configuration via system settings (even in 12.04 LTS, contrary to what the documentation indicates) at login and CLI sudo prompts. Keep in mind Ubuntu 10.10 is now out of support, the PPA has packages for supported Ubuntu versions (including 10.04 LTS).

To test such packages:

1. Add this PPA to your sources:
      sudo add-apt-repository ppa:fingerprint/fprint

2. Update your packages database, upgrade packages:
      sudo apt-get update
      sudo apt-get upgrade

3. Install the software:
     sudo apt-get install libfprint0 fprint-demo libpam-fprint gksu-polkit

The above indicated using the libpam-fprint package, although the docs indicate libpam-fprintd (which wasn't found in my test).

Also keep in mind many fingerprint readers are in fact optical scanners so the accuracy will vary when registering/using fingerprints.

Zeth (adair-boder) wrote :

@Fabian Rodriguez

We are discussing the AES2810 device not the "1600" ... ;-)

Fabián Rodríguez (magicfab) wrote :

@Zeth, so don't try what I suggested, please completely ignore the above and keep hoping for the best :)

Confirming that the libfprint does support this device so if it is not working then there is a bug somewhere.

summary: [08ff:2810] AuthenTec, Inc. AES2810 fingerprint reader not recognized
- after upgrading to Ubuntu 10.10
Changed in libfprint (Ubuntu):
status: Confirmed → Triaged
Changed in libfprint (Ubuntu Maverick):
status: Confirmed → Won't Fix
summary: [08ff:2810] AuthenTec, Inc. AES2810 fingerprint reader not recognized
+ (worked in 10.04)
Sorbing (svbutsenko) wrote :

I have not recognized fprint.

#uname -a
Linux e5530 3.2.0-29-generic #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
#lsusb
ID 08ff:2810 AuthenTec, Inc. AES2810

Todd Stiers (tas-x) wrote :

No recognition on my T500 either

# more /etc/issue
Ubuntu 12.04.1 LTS

# uname -a
Linux vader 3.2.0-29-generic-pae #46-Ubuntu SMP Fri Jul 27 17:25:43 UTC 2012 i686 i686 i386 GNU/Linux

# lsusb
Bus 004 Device 002: ID 08ff:2810 AuthenTec, Inc. AES2810

let me know how/if I can help!

-T

anarsoul (anarsoul) wrote :

I've implemented AES2550/AES2810 driver for libfprint, my libfprint repo is here: https://github.com/anarsoul/libfprint branch aes2550-v2. I need some testers with AES2550 and AES2810 devices. Any volunteers?

Zeth (adair-boder) wrote :

@ anarsoul: I would love to test this on my T400 ... though not sure how to ...

anarsoul (anarsoul) wrote :

@Zeth:

You can compile it manually (but don't install it into the system, wait for someone who can make ppa with this lib)

sudo apt-get install build-essential libusb-1.0-0-dev
cd ~
git clone git://github.com/anarsoul/libfprint.git
cd libfprint
./configure --enable-debug-log
make all
cd examples
./enroll # Check if enroll works, may need sudo
./verify # Check if verify works, may need sudo

It would be nice if someone can make ppa with this lib...

anarsoul (anarsoul) wrote :

Uh, also do "git checkout origin/aes2550-v2 -b aes2550-v2 --track" right after "git clone"

Pavol Klačanský (pavolzetor) wrote :

not working for aes 2810 here

anarsoul (anarsoul) wrote :

Please provide log produced by ./enroll or ./verify

Schmankerl (schmankerl) wrote :

Do I have to use autoconf or something on ubuntu 12.04 before using configure?

anarsoul (anarsoul) wrote :

Just invoke ./autogen.sh

Pavol Klačanský (pavolzetor) wrote :

I am sorry, it works, I misread info text. But it makes some weird sound, like high frequency beeping. Man, you are great, thanks, hopefully will be merged in master soon

Pavol Klačanský (pavolzetor) wrote :

How can I use it for login and sudo?

anarsoul (anarsoul) wrote :

You should build updated libfprint package and install it into system. GDM (and Gnome3) use fprintd, so you'll be able to scan finger instead of entering password, not sure about unity/kde4. Btw I've asked fprint ppa team (https://launchpad.net/~fingerprint/+archive/fprint) to build updated libfprint

anarsoul (anarsoul) wrote :

High freq sound is weird anyway, no such issue here... Maybe it's not fingerprint issue, I hear high pitch sound when ac adapter is unplugged (Lenovo 3000 N100 laptop), even with fingerprint scanner disconnected

Schmankerl (schmankerl) wrote :

Great work! Verify and Enroll works!
It is very sensitive but I think thats normal...
I have two questions regarding the power management in combination with fprintd. Are there any powersaving features and will that device wake up ad hoc? Or will it be always on and power draining like some other usb devices?
Lenovo T500 AES2810

anarsoul (anarsoul) wrote :

Well, it depends completely on device. Driver sends "set idle mode" command to it right after imaging session

sandrefuego (sandre-fuego) wrote :

Hey guys, I apologise, is there something for 08ff:168f AuthenTec ? does not want to work on Ubuntu 12.04 ...

anarsoul (anarsoul) wrote :

@sandrefuego: not yet, at least in libfprint, probably you should ask AuthenTec for specs... Anyway, I have only AES2501 and AES2550 scanners...

anarsoul (anarsoul) wrote :

fprint ppa was updated recently and now supports AES2550 and AES2810, see https://launchpad.net/~fingerprint/+archive/fprint

Pavol Klačanský (pavolzetor) wrote :

thanks, works nicely, good

Schmankerl (schmankerl) on 2013-05-21
no longer affects: libfprint
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.