Ubuntu

Bootstrapping needed for fpc for armel

Reported by pirast on 2006-10-22
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
fpc (Debian)
Fix Released
Unknown
fpc (Ubuntu)
High
Unassigned
Lucid
High
LaMont Jones
Maverick
High
LaMont Jones
Natty
High
LaMont Jones
Oneiric
High
przemek hrynkiewicz

Bug Description

Bootstrapping needed for fpc for armel and powerpc

Related branches

Changed in fpc:
status: Unknown → Unconfirmed
Luke Yelavich (themuso) wrote :

Looks like it depends on itself for some reason.

Changed in fpc:
status: Unconfirmed → Confirmed
Changed in fpc:
status: Unconfirmed → Fix Released
Koen Beek (koen-beek) wrote :

Seems this might be fixed by the latest release

2.2.0-2
Published in hardy-release on 2007-12-09

fpc (2.2.0-2) unstable; urgency=low

  [ Mazen Neifer ]
  * Added dbase to fcl-db packaged units for arch other than i386.
  * Fixed build issue for sparc and powerpc arch.

can someone verify this ?

Paul Gevers (paul-climbing) wrote :

I don't know anything about bootstrapping, but AFAICT this needs some attention regarding to get the proper bootstrap binary in place.

Paul Gevers (paul-climbing) wrote :

See also bug 2253, could one of the buildd-admins please bootstrap fpc on ppc?

Emmet Hikory (persia) wrote :

Installing fp-compiler, fp-units-base, fp-utils, and fp-units-rtl from Debian sid on a lucid machine permitted this build to complete successfully (all other build-dependencies, and all dependencies of the packages from sid were installed from lucid). Rebuilding fpc with the four named packages resulting from that build with otherwise entirely lucid sources was also successful. I presume the final binary packages produced after this procedure would be appropriate for inclusion in lucid.

Changed in fpc (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
LaMont Jones (lamont) on 2010-01-26
Changed in fpc (Ubuntu):
assignee: nobody → LaMont Jones (lamont)
Chris Jones (cmsj) wrote :

Building in a chroot bootstrapped with the fp debs from sid produced the attached build failure.

Emmet Hikory (persia) on 2010-03-07
tags: added: powerpc
Emmet Hikory (persia) wrote :

It seems that the requirements for bootstrapping have changed since I last bootstrapped this. The following sequence of commands (output mostly elided) worked for me:

mkdir fpc
cd fpc
schroot -c lucid -u root
apt-get source fpc
echo "deb http://ftp.debian.org/debian sid main" >> /etc/apt/sources.list
apt-get update
apt-get --download-only install fp-compiler fp-units-base fp-utils fp-units-rtl fp-units-fcl
Get:1 http://ftp.debian.org sid/main fp-units-rtl 2.4.0-2 [2239kB]
Get:2 http://ftp.debian.org sid/main fp-compiler 2.4.0-2 [1804kB]
Get:3 http://ftp.debian.org sid/main fp-units-base 2.4.0-2 [1350kB]
Get:4 http://ftp.debian.org sid/main fp-units-fcl 2.4.0-2 [5165kB]
Get:5 http://ftp.debian.org sid/main fp-utils 2.4.0-2 [3604kB]
sed -i /debian/d /etc/apt/sources.list
apt-get update
for i in /var/cache/apt/archives/fp*deb; do dpkg -i $i; done
apt-get build-dep fpc
cd fpc-2.4.0/
debuild -b

    Note that some of these commands produce warnings or errors. Most notable are that one must accept unauthenticated packages from sid (or install debian-keyring, etc.), and that the dpkg install loop complains a lot (although everything ends up resolved after apt-get build-dep).

    Obviously, it's a good idea to rebuild again using the output of this as input against a clean lucid chroot for uploading, just to make sure that any artifacts caused by using Debian binaries have been addressed. Easiest way is probably to install all the output .debs into an otherwise clean lucid chroot, and rebuild there. I've attached the first-stage build-log for reference.

Emmet Hikory (persia) on 2010-04-05
description: updated
tags: added: armel
summary: - PPC build of fpc fails
+ Bootstrapping needed for fpc for armel and powerpc
Matthias Klose (doko) on 2010-04-05
Changed in fpc (Ubuntu):
milestone: none → ubuntu-10.04-beta-2

This didn't get done for beta-2. LaMont, is this on track to be done in time for final release?

Changed in fpc (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-2 → ubuntu-10.04
Matthias Klose (doko) on 2010-04-14
summary: - Bootstrapping needed for fpc for armel and powerpc
+ Bootstrapping needed for fpc for armel
Matthias Klose (doko) wrote :

done for powerpc, the armel build fails according to lamont:

make[6]: Leaving directory `/build/buildd/fpc-2.4.0/fpcsrc/compiler'
./msg2inc msg/errore.msg msg msg
Loading messagefile msg/errore.msg
Writing enumfile msgidx.inc
Writing stringfile msgtxt.inc
/usr/bin/ppcarm -Ur -Xs -O2 -n -Fuarm -Fusystems -Fu/build/buildd/fpc-2.4.0/fpcsrc/rtl/units/arm-linux -Fiarm -FE. -FUarm/units/arm-linux -dRELEASE -darm -dGDB -dBROWSERLOG pp.pas
Fatal: Compilation aborted
An unhandled exception occurred at $00033B60 :
EInOutError : File not found
  $00033B60
  $000F6A30
  $00106AF0
  $0010A620
  $0010A63C
  $0010A63C
  $0010A63C
  $0010AD64
  $0010F0C4
  $000FAAD0
  $000FAFE4
  $00140A14
  $0011FF78
  $0013648C
  $0013FDA0
  $00140950
  $0011FF78

make[5]: *** [ppcarm] Error 217
make[5]: Leaving directory `/build/buildd/fpc-2.4.0/fpcsrc/compiler'
make[4]: *** [next] Error 2
make[4]: Leaving directory `/build/buildd/fpc-2.4.0/fpcsrc/compiler'
make[3]: *** [ppc1] Error 2
make[3]: Leaving directory `/build/buildd/fpc-2.4.0/fpcsrc/compiler'
make[2]: *** [cycle] Error 2
make[2]: Leaving directory `/build/buildd/fpc-2.4.0/fpcsrc/compiler'
make[1]: *** [compiler_cycle] Error 2
make[1]: Leaving directory `/build/buildd/fpc-2.4.0/fpcsrc'
make: *** [build-arch-stamp] Error 2

couldn't reproduce this; I put my binaries at:
deb http://people.canonical.com/~doko/tmp/fpc-armel ./

Lamont, could you give it another try with these binaries?

Alexander Sack (asac) on 2010-04-23
Changed in fpc (Ubuntu Lucid):
milestone: ubuntu-10.04 → lucid-updates
Matthias Klumpp (ximion) wrote :

Any news?

Matthias Klose (doko) wrote :

missed that already for lucid, that should definitely done for maverick

Changed in fpc (Ubuntu Maverick):
importance: Medium → High
milestone: lucid-updates → ubuntu-10.10
Changed in fpc (Ubuntu Lucid):
importance: Medium → High
LaMont Jones (lamont) wrote :

Still fails (in a maverick chroot on a lucid bbg3 board). http://paste.ubuntu.com/490040/ has the tail end of the error message.

lamont

LaMont Jones (lamont) wrote :

that is, a maverick chroot with the debs from deb http://people.canonical.com/~doko/tmp/fpc-armel ./ used to satisfy build-dependencies, in an interactive dpkg-buildpackage -B run.

Matthias Klose (doko) wrote :

didn't check the chroot yet.

I rebuilt on current maverick:

http://people.canonical.com/~doko/tmp/fpc-armel-mav-stage1/
http://people.canonical.com/~doko/tmp/fpc-armel-mav-stage2/

stage1 was built with the binaries from unstable, stage2 built with the binaries from stage1.

Matthias Klose (doko) wrote :

the rebuilt packages still fail on the buildd. hardware/kernel issue? let's delay that

Changed in fpc (Ubuntu Maverick):
milestone: ubuntu-10.10 → maverick-updates
Matthias Klumpp (ximion) wrote :

Strange... Why does it work for Debian, but not for Ubuntu? Should someone file an upstream bug to make them look at this?

On 15.09.2010 22:54, Matthias Klumpp wrote:
> Strange... Why does it work for Debian, but not for Ubuntu?

it even does work on a babbage board running maverick

> Should someone file an upstream bug to make them look at this?

what to look for?

Matthias Klumpp (ximion) wrote :

> what to look for?
If there's a compiler bug, I thought. But if it works on all other devices but not on the buildd, the problem might not be related to FPC itself. (I can't think of any reason for this failure related to buildd, but there has to be one.)
Anyway, thanks for working on this!

One of the reasons fpc may work/build well on Debian (per #16/17) or staged with Debian unstable binaries for fpc (#14), and not Ubuntu/Ubuntu built binaries is that Debian still uses armv4 while we are using thumb2. But I am stuck also trying to bootstrap this for Maverick/armel/thumb2 at the moment and it's lovely self-circular dependency :).

Changed in ubuntu-release-notes:
status: New → Won't Fix
Changed in fpc (Ubuntu Natty):
milestone: maverick-updates → natty-alpha-1
LaMont Jones (lamont) wrote :

On 2010-09-15 Matthias Klose wrote:
> On 15.09.2010 22:54, Matthias Klumpp wrote:
> > Strange... Why does it work for Debian, but not for Ubuntu?
>
> it even does work on a babbage board running maverick

1. start with a bbg3 board running lucid and a 2.6.31-608-imx51 kernel.
2. bzr branch lp:~lamont/launchpad-buildd/chroot-scripts
3. sudo chroot-scripts/make-chroot.sh --lp -d natty --startdist maverick
4. cd chroot-autobuild/tmp; for p in fp-compiler fp-ide fp-units-base fp-units-db fp-units-fcl fp-units-fv fp-units-gfx fp-units-gnome1 fp-units-gtk2 fp-units-gtk fp-units-math fp-units-misc fp-units-multimedia fp-units-net fp-units-rtl fp-utils; do wget http://ftp.de.debian.org/debian/pool/main/f/fpc/${p}_2.4.0-2_armel.deb; done
5. echo deb http://ftpmaster.internal/ubuntu natty main universe > chroot-autobuild/etc/apt/sources.list
6. echo deb-src http://ftpmaster.internal/ubuntu natty main universe >> chroot-autobuild/etc/apt/sources.list
7. mount -t proc proc $(pwd)/chroot-autobuild/proc
8. mount -t devpts devpts $(pwd)/chroot-autobuild/dev/pts
9. chroot chroot-autobuild apt-get remove --purge pkgbinarymangler
10. sudo chroot chroot-autobuild <-- and inside there:
 a. apt-get update
 b. apt-get remove --purge pkgbinarymangler
 c. cd /tmp; dpkg -i fp-{units-base,units-fcl,utils,units-rtl,compiler}_2.4.0-2_armel.deb; apt-get -f install
 d. apt-get build-dep fpc
 e. su - buildd
   1. cd /build/buildd
   2. apt-get source fpc
   3. cd fpc-2.4.0 && dpkg-buildpackage -B

Build fails.
lamont

Changed in fpc (Ubuntu Natty):
milestone: natty-alpha-1 → natty-alpha-2
Martin Pitt (pitti) on 2011-01-25
Changed in fpc (Ubuntu Natty):
milestone: natty-alpha-2 → ubuntu-11.04-beta
Tobin Davis (gruemaster) wrote :

Could this be rechecked on one of the beagleXM buildds and/or against the recent fix for gcc-4.5 patch in bug 705689? Or is this bug deeper?

Changed in fpc (Ubuntu Natty):
milestone: ubuntu-11.04-beta-1 → ubuntu-11.04-beta-2
LaMont Jones (lamont) wrote :

Still fails to build as above in a current natty chroot (with underlying lucid and maverick kernels), on bbg3, beaglexm, and panda.

lamont

Changed in fpc (Ubuntu Natty):
status: Triaged → Incomplete
Colin Watson (cjwatson) on 2011-04-15
Changed in fpc (Ubuntu Natty):
milestone: ubuntu-11.04-beta-2 → ubuntu-11.04
Changed in fpc (Ubuntu Natty):
milestone: ubuntu-11.04 → natty-updates
Changed in fpc (Ubuntu Oneiric):
status: New → Incomplete
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fpc - 2.4.0-2ubuntu4

---------------
fpc (2.4.0-2ubuntu4) oneiric; urgency=low

  * Backported patch from fpc trunk to fix handling of EABI syscalls
    when there are more than five parameters. (Unblocks LP: #67544)
    - http://lists.freepascal.org/lists/fpc-devel/2010-October/022228.html
 -- Michael Casadevall <email address hidden> Tue, 10 May 2011 04:09:51 -0700

Changed in fpc (Ubuntu Oneiric):
status: Incomplete → Fix Released
Changed in fpc (Ubuntu Oneiric):
status: Fix Released → Confirmed

Successfully bootstrapped fpc building against itself in my PPA: https://launchpad.net/~mcasadevall/+archive/ppa/+packages

2.4.0-2ubuntu4 has a patch required to prevent fpc crashing while building itself, the Debian version lacks this patch hence why it crashes on the iMX51 machines in the datacenter. The 2.4.0-2ubuntu4~bootstrap5 package has this patch, and was built by a version of fpc with this patch, so its suitable for the bootstrapping the inarchive version of fpc; it should be a matter of adding my PPA, building fpc, and uploading.

LaMont Jones (lamont) wrote :

And with the working compiler, this bug is finally put to rest. Thanks Michael.

Changed in fpc (Ubuntu Oneiric):
status: Confirmed → Fix Released
Tobin Davis (gruemaster) wrote :

Closed out the Lucid bug (Won't fix) as Lucid is past 18 month support for arm. Will this patch be backported to Maverick & Natty? if not, let's close them also.

Changed in fpc (Ubuntu Lucid):
status: Triaged → Won't Fix
Changed in fpc (Ubuntu Natty):
status: Incomplete → Triaged
Tobin Davis (gruemaster) on 2012-02-09
Changed in fpc (Ubuntu Lucid):
milestone: lucid-updates → none
Changed in fpc (Ubuntu):
assignee: LaMont Jones (lamont) → nobody
milestone: natty-updates → none
JC Hulce (soaringsky) wrote :

This bug affects Ubuntu 10.10, Maverick Meerkat. Maverick has reached end-of-life and is no longer supported, so I am closing the bug task for Maverick. Please upgrade to a newer version of Ubuntu.
More information here: https://lists.ubuntu.com/archives/ubuntu-announce/2012-April/000158.html

Changed in fpc (Ubuntu Maverick):
status: Triaged → Invalid
Changed in fpc (Ubuntu Oneiric):
assignee: nobody → przemek hrynkiewicz (satans1978)
dino99 (9d9) wrote :

natty is no more supported https://wiki.ubuntu.com/Releases

Changed in fpc (Ubuntu Natty):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.