enigmail-locales is no longer needed in Lucid+

Bug #572018 reported by Simone F.
98
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
enigmail (Ubuntu)
Medium
Unassigned
Lucid
High
Chris Coulson
Maverick
Medium
Unassigned
enigmail-locales (Ubuntu)
Medium
Unassigned
Lucid
High
Chris Coulson
Maverick
Medium
Unassigned

Bug Description

SRU Reason: enigmail 1.0.1 provides locales, so we don't need to break them out into enigmail-locale-XX anymore; Also, this prevents upgrades to Thunderbird 3 without removing the enigmail-locale-XX packages or enigmail
TEST CASE:
install Thunderbird 2.0 from karmic (don't bother starting)
install one of the enigmail-locale-XX packages
try upgrading to thunderbird 3 w/out -proposed enabled, should fail
enable -proposed
upgrade should work and you should end up with TB3 and enigmail 1.0.1

---------------------------------------------------------------------

enigmail-locale-it: Dipende: enigmail (< 2:0.96) ma 2:1.0.1-0ubuntu1 è installato.

Package: enigmail-locale-it
Priority: optional
Section: universe/mail
Installed-Size: 164
Maintainer: Ubuntu MOTU Developers <email address hidden>
Original-Maintainer: Hans Ofverbeck <email address hidden>
Architecture: all
Source: enigmail-locales
Version: 0.9x-20070913-0ubuntu2
Depends: enigmail (>= 2:0.95), enigmail (<< 2:0.96), thunderbird-locale-it
Filename: pool/universe/e/enigmail-locales/enigmail-locale-it_0.9x-20070913-0ubuntu2_all.deb

Package: enigmail
Priority: optional
Section: universe/mail
Installed-Size: 3852
Maintainer: Ubuntu Mozilla Team <email address hidden>
Original-Maintainer: Alexander Sack <email address hidden>
Architecture: i386
Version: 2:1.0.1-0ubuntu1
Provides: seamonkey-enigmail, thunderbird-enigmail, xul-ext-enigmail
Depends: libasound2 (>> 1.0.22), libc6 (>= 2.4), libgcc1 (>= 1:4.1.1), libnspr4-0d (>= 4.7.3-0ubuntu1~), libstdc++6 (>= 4.1.1), gnupg
Recommends: thunderbird | seamonkey
Filename: pool/universe/e/enigmail/enigmail_1.0.1-0ubuntu1_i386.deb

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: enigmail-locale-it (not installed)
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
Date: Fri Apr 30 05:53:11 2010
InstallationMedia: Kubuntu 9.10 "Karmic Koala" - Beta i386 (20090929.2)
ProcEnviron:
 PATH=(custom, user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: enigmail-locales

Revision history for this message
Micah Gersten (micahg) wrote :

Thank you for reporting this to Ubuntu. It seems we forgot this for release, but it would qualify for a Stable Update for Lucid. Please report any other issues you may find.

Changed in enigmail-locales (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
importance: Undecided → Medium
milestone: none → lucid-updates
status: New → Triaged
summary: - enigmail-locale-it depends on obsolete enigmail
+ enigmail-locales weren't updated for 1.0.1 enigmail release
Revision history for this message
Michał Gołębiowski-Owczarek (mgol) wrote : Re: enigmail-locales weren't updated for 1.0.1 enigmail release

Another package - enigmail-locale-pl

Revision history for this message
Michał Gołębiowski-Owczarek (mgol) wrote :

$ sudo apt-get install enigmail-locale-pl
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  enigmail-locale-pl: Depends: enigmail (< 2:0.96) but 2:1.0.1-0ubuntu1 is to be installed
E: Broken packages

Micah Gersten (micahg)
Changed in enigmail-locales (Ubuntu):
milestone: lucid-updates → maverick-alpha-2
Revision history for this message
Michał Gołębiowski-Owczarek (mgol) wrote :

Does the change milestone mean we will not see this in Lucid? If this is the case, will it at least be backported?

Revision history for this message
Micah Gersten (micahg) wrote : Re: [Bug 572018] Re: enigmail-locales weren't updated for 1.0.1 enigmail release

No, it means it needs to get into Maverick first, then I will do an
SRU for Lucid. Alpha 2 is the target for Maverick. So, hopefully we
can get this into Lucid before the 10.04.1 release.

On 05/24/2010 09:31 AM, Michał Gołębiowski wrote:
> Does the change milestone mean we will not see this in Lucid? If
> this is the case, will it at least be backported?
>

Changed in enigmail-locales (Ubuntu Lucid):
assignee: nobody → Micah Gersten (micahg)
importance: Undecided → High
status: New → Triaged
Micah Gersten (micahg)
Changed in enigmail-locales (Ubuntu Lucid):
milestone: none → ubuntu-10.04.1
Revision history for this message
Matthias G. (matgnt) wrote : Re: enigmail-locales weren't updated for 1.0.1 enigmail release

Same probleme here.
See bug #588254.

The following packages have unmet dependencies:
  enigmail-locale-de: Depends: enigmail (< 2:0.96) but 2:1.0.1-0ubuntu1 is to be installed
E: Broken packages

Revision history for this message
Philipp Kaluza (pixelpapst) wrote :

(This bug is a bit annoying, as it is preventing gnome-language-selector from doing it's automatic install thing.)

According to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=448878 :
" since a few versions already, enigmail does include the localization
  files itself, making thus enigmail-locales not needed anymore,
  therefore, please remove enigmail-locales from the archive. "

And a quick inspection of the Ubuntu enigmail source package indeed reveals a number of (I guess) pretty complete translations. All languages that had separate XPIs shipped in enigmail-locales before have been included. Two quick tests show these localizations in action with just the enigmail package.

Considering that the current enigmail-locale-XX packages just cannot work in lucid (not only the binary package dependencies are too strict, the dependencies of the included XPIs are also), were not translated via launchpad anyhow, and the existing translations have moved already, I propose the following way forward:
 1. Use this bug to track the removal of enigmail-locale-XX (and src: enigmail-locales) from lucid and maverick. Not sure what the Ubuntu process is for this.
 2. De-dup bug #588254 and update language-selector in lucid to no longer try installing enigmail-locale-XX.
 3. If new user contributed translations ever appear, just update the enigmail package.

Thoughts ?

summary: - enigmail-locales weren't updated for 1.0.1 enigmail release
+ enigmail-locales not useful anymore; please remove
Changed in debian:
status: Unknown → Fix Released
Revision history for this message
Micah Gersten (micahg) wrote :

We cannot remove the source from the stable release. We need to update the locales. In Ubuntu, I don't see the locales in the Enigmail package although it might be in the source. Since Enigmail is in Universe, we cannot use launchpad translations at present. This should be sorted out within the next few weeks as I wanted to get it done before the first Lucid point release.

summary: - enigmail-locales not useful anymore; please remove
+ enigmail-locales weren't updated for 1.0.1 enigmail release
Revision history for this message
Philipp Kaluza (pixelpapst) wrote :

> In Ubuntu, I don't see the locales in the Enigmail package although it might be in the source.
Of course they are in the package - as i said, the localization works fine.
To be exact, they are within
  /usr/lib/xul-ext/enigmail/chrome/enigmail.jar
in the /locale/ folder.

If you want to go through the work of re-adding the ability to have "translation extensions" to enigmail, and somehow marry that to launchpad's TBD universe translation facilities, that is of course your choice. And at that point, we still don't have a single additional translated string yet.

I however think it should be way easier to do an automatic VCS import of enigmail, and set up LP to translate an enigmail branch automatically. Plus, this gives us a chance to cooperate with upstream, instead of rolling another ubuntu-only solution.

Oh, and if we cannot remove a source package from lucid, we can always upload a followup version that only builds one or a few empty transitional packages.

Martin Pitt (pitti)
Changed in enigmail-locales (Ubuntu Maverick):
milestone: maverick-alpha-2 → maverick-alpha-3
Revision history for this message
Monika Eggers (monikakrug) wrote :

I am on Lucid, have installed thunderbird, enigmail, cannot install enigmail-locale-de due to unmet dependencies:

sudo apt-get install enigmail-locale-de
...
Die folgenden Pakete haben nicht-erfüllte Abhängigkeiten:
  enigmail-locale-de: Hängt ab: enigmail (< 2:0.96) aber 2:1.0.1-0ubuntu1 soll installiert werden
E: Kaputte Pakete

Revision history for this message
Micah Gersten (micahg) wrote :

Language selector should no longer install the enigmail-locale-XX-XX packages when the various language packages are installed.

summary: - enigmail-locales weren't updated for 1.0.1 enigmail release
+ enigmail-locales is no longer needed in Lucid+
Changed in language-selector (Ubuntu Lucid):
importance: Undecided → High
milestone: none → ubuntu-10.04.1
status: New → Triaged
Changed in language-selector (Ubuntu Maverick):
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Micah Gersten (micahg) wrote :

@Philipp Kaluza
My apologies, after a more in depth review, we decided to drop the package as you suggested.

Revision history for this message
Micah Gersten (micahg) wrote :

The language selector task should be taken care of in Bug #588254 where the bug was fixed in Maverick.

Changed in language-selector (Ubuntu Lucid):
status: Triaged → Invalid
milestone: ubuntu-10.04.1 → none
Revision history for this message
Micah Gersten (micahg) wrote :

Already fixed in maverick

Changed in language-selector (Ubuntu Maverick):
status: Triaged → Fix Released
Revision history for this message
Micah Gersten (micahg) wrote :

@Archive Admins
Please drop enigmail-locales source from Maverick.

Changed in enigmail-locales (Ubuntu Maverick):
assignee: Micah Gersten (micahg) → nobody
status: Triaged → Confirmed
milestone: maverick-alpha-3 → none
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

This has been removed from maverick now

Changed in enigmail-locales (Ubuntu Maverick):
status: Confirmed → Fix Released
Revision history for this message
Michał Gołębiowski-Owczarek (mgol) wrote :

What about Lucid?

Revision history for this message
Micah Gersten (micahg) wrote :

It seems like the best course of action is to SRU enigmail with Conflicts/Provides/Replaces on the enigmail-locale-XX-XX packages.

affects: language-selector (Ubuntu Lucid) → enigmail (Ubuntu Lucid)
Changed in enigmail (Ubuntu Lucid):
assignee: nobody → Micah Gersten (micahg)
milestone: none → ubuntu-10.04.1
status: Invalid → Triaged
Revision history for this message
Micah Gersten (micahg) wrote :

Marking Maverick invalid for Enigmail since enigmail-locales is already removed from the archive.

Changed in enigmail (Ubuntu Maverick):
status: Fix Released → Invalid
Revision history for this message
Micah Gersten (micahg) wrote :

This debdiff adds Replaces/Conflicts/Provides for all the enigmail-locale-XX packages in Lucid.

Micah Gersten (micahg)
description: updated
Changed in enigmail (Ubuntu Lucid):
assignee: Micah Gersten (micahg) → Chris Coulson (chrisccoulson)
tags: added: patch
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Thanks for looking at this. I'm not sure that the Provides are doing what we want though. If the enigmail-locales-xx packages were being pulled in as a dependency of another package, then they should work. However, language-selector is installing the packages directly, so we'd still end up with a similar problem for people installing locales.

Also, update-manager doesn't seem to resolve upgrades too well where package removals are involved. I just tried this and update-manager offered a partial upgrade, which we want to avoid for a SRU really.

Perhaps having empty transitional packages for enigmail-locales-xx might be the better option :/

Revision history for this message
Micah Gersten (micahg) wrote :

I'll try to get a new debdiff up this weekend.

Revision history for this message
Micah Gersten (micahg) wrote :

Confirmed in pbuilder that this generates empty packages

Revision history for this message
Micah Gersten (micahg) wrote :

Chris, can you see if this engimal-locales debdiff does the trick?

Changed in enigmail-locales (Ubuntu Lucid):
assignee: Micah Gersten (micahg) → Chris Coulson (chrisccoulson)
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Awesome, thanks. I'll review this this afternoon

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Uploaded to lucid-proposed now

Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted enigmail-locales into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in enigmail-locales (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed
Revision history for this message
Martin Pitt (pitti) wrote :

Looks like there's nothing to be done for the enigmail source package itself here? Closing the task. If that was wrong, I'm sorry; please reopen and point out what's left to be done there. Thank you!

Changed in enigmail (Ubuntu Lucid):
milestone: ubuntu-10.04.1 → none
status: Triaged → Invalid
Changed in enigmail-locales (Ubuntu Lucid):
milestone: ubuntu-10.04.1 → ubuntu-10.04.2
Revision history for this message
Aron Xu (happyaron) wrote :

I confirm enigmail-locale-zh-cn 0.9x-20070913-0ubuntu2.1 in lucid-proposed works fine for me.

Revision history for this message
Martin Pitt (pitti) wrote :

Argh indeed, I've been meaning to move this to -updates for .1, for clean upgrades. Doing now.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package enigmail-locales - 0.9x-20070913-0ubuntu2.1

---------------
enigmail-locales (0.9x-20070913-0ubuntu2.1) lucid-proposed; urgency=low

  * debian/control: Make all packages pull in enigmail >= 1.0.1-0ubuntu1;
    enigmail now contains all locales in a .jar file
  * debian/rules: remove build-stamp from build target; this makes empty
    transitional packages for users upgrading from older releases
  * Fixes LP: #572018
 -- Micah Gersten <email address hidden> Sun, 01 Aug 2010 04:03:21 -0500

Changed in enigmail-locales (Ubuntu Lucid):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.