Ubuntu

Not able to dist-upgrade, "calculating changes" can't solve dependencies and fail

Reported by Ursula Junque on 2010-03-30
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Michael Vogt
Lucid
Undecided
Michael Vogt

Bug Description

Binary package hint: update-manager

I'm using Ubuntu Karmic, 9.10, and trying to upgrade to Lucid using update-manager or do-release-upgrade fails with the following message:

{{{
Checking for a new ubuntu release
Done Upgrade tool signature
Done Upgrade tool
Done downloading
extracting 'lucid.tar.gz'
authenticate 'lucid.tar.gz' against 'lucid.tar.gz.gpg'

Reading cache

Checking package manager
Reading package lists: Done
Reading state information: Done
Reading state information: Done
Reading state information: Done
Done downloading
Reading package lists: Donem lucid-backports/universe Packages: 92
Reading state information: Done
Reading state information: Done
Reading state information: Done

Updating repository information
WARNING: Failed to read mirror file
Done downloading

Checking package manager
Reading package lists: Done
Reading state information: Done
Reading state information: Done
Reading state information: Done

Calculating the changes

Calculating the changes

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade:
E:Error, pkgProblemResolver::Resolve generated breaks, this may be
caused by held packages.

This can be caused by:
* Upgrading to a pre-release version of Ubuntu
* Running the current pre-release version of Ubuntu
* Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug against the
'update-manager' package and include the files in
/var/log/dist-upgrade/ in the bug report.

Restoring original system state

Aborting
Reading package lists: Done
Reading state information: Done
Reading state information: Done
Reading state information: Done
}}}

update-manager version is 1:0.126.9

Despite the fact it says the system was restored to the original state, my sources.list has the lucid entries, instead of the karmic ones I had before the upgrade attempt.

Ursula Junque (ursinha) wrote :
Ursula Junque (ursinha) wrote :

Architecture: i386
DistroRelease: Ubuntu 9.10
Package: update-manager 1:0.126.9
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 LANGUAGE=
ProcVersionSignature: Ubuntu 2.6.31-20.58-generic
Uname: Linux 2.6.31-20-generic i686
UserGroups: adm admin audio cdrom dialout lpadmin plugdev pulse pulse-access sambashare smmsp video

tags: added: apport-collected
Ursula Junque (ursinha) wrote :

/usr/bin/do-release-upgrade shows modified in the Dependencies.txt list because I've tried to debug that after it failed twice. But I've removed all debugging, maybe forgot a blankline. :)

davidyu (yuyich) wrote :

Yes, I have the same problem when try to upgrade Ubuntu 09.10 Karmic to 10.04 Lucid.
I can reproduced this problems on my both Thinkpad T40 and T60.
Bump. so, can't upgrade to 10.04 now.
Wait for a fix.

Jeff Lane (bladernr) wrote :

This happened to me on a UNR system. I attempted do-release-upgrade on a Lenovo S-10 that had Ubuntu 9.10 Netbook Remix installed. it failed three times at the same place as the OP (though I did not instrument mine to spit out any useful messages, should have thought of that last night). After the three failures, I thought that maybe I was just not updated enough (the Karmic install was a test install, so had not been updated in quite some time).

So I ran apt-get dist-upgrade and it told me that there were 1100+ packages to update. It never mentioned (that I saw, at least) that those 1100+ packages were Lucid packages. So I ran the upgrade and at the end, I had a Lucid package.

So at least the failure point was after everything was updated enough that I could still install Lucid.

I'm attempting a desktop Karmic - Lucid upgrade now on that system with a different HDD to see if I can re-create it.

davidyu (yuyich) wrote :

I reference bug: 549469 https://bugs.launchpad.net/ubuntu/lucid/+source/update-manager/+bug/549469
And remove empathy, then the problem disappeared now.
I'll check my another T60 tomorrow.

Ursula Junque (ursinha) wrote :

@davidyu my problem seems to be in several packages, according to the apt log. I've removed empathy and no effect.

@jeff maybe your apt.log in /var/log/dist-upgrade/ has info about what happened when the upgrade failed.

description: updated
davidyu (yuyich) wrote :

I tried my another T60 and remove empathy.
After removing empathy, I can upgrade to Ubuntu 10.04 now.
Yes, Everybody's machine may have different environment.
However, both my two thinkpap can upgrade without problem.

Michael Vogt (mvo) wrote :

Could you please try this again? The empathy problem (that is the root for many of the messages like this) is in the archive now and I can no longer reproduce this particular failure (with the /var/lib/dpkg/status file provided). If it stills fails for you (and you are using a up-to-date mirror that has the latest empathy-common) then please attach /var/lib/dpkg/status and I will try to rerproduce.

Changed in update-manager (Ubuntu):
status: New → Fix Released
Dmitriy Geels (dmig) wrote :
Download full text (4.6 KiB)

Michale:
   I'm working now.
   I'll try again after I back home
   Will update my latest result later

David YC Yu
IBM Systems and Technology Group Lab Service & Training
mail : <email address hidden>, Tie-line : 849-6560
Phone : 886-2-8170-6560 / Mobile : 886-932-901-978
8F, Building E, Nan-Kang Software Park, 19-11 San-Chong Road, Taipei, 11501
Taiwan

             Michael Vogt
             <michael.vogt@ubu
             ntu.com> To
             Sent by: David YC Yu/Taiwan/IBM@IBMTW
             bounces@canonical cc
             .com
                                                                   Subject
                                       [Bug 551782] Re: Not able to
             03/31/2010 03:31 dist-upgrade, "calculating
             PM changes" can't solve dependencies
                                       and fail

             Please respond to
                Bug 551782
             <<email address hidden>
                chpad.net>

Could you please try this again? The empathy problem (that is the root
for many of the messages like this) is in the archive now and I can no
longer reproduce this particular failure (with the /var/lib/dpkg/status
file provided). If it stills fails for you (and you are using a up-to-
date mirror that has the latest empathy-common) then please attach
/var/lib/dpkg/status and I will try to rerproduce.

** Changed in: update-manager (Ubuntu)
       Status: New => Fix Released

--
Not able to dist-upgrade, "calculating changes" can't solve dependencies
and fail
https://bugs.launchpad.net/bugs/551782
You received this bug notification because you are a direct subscriber
of the bug.

Status in “update-manager” package in Ubuntu: Fix Released

Bug description:
Binary package hint: update-manager

I'm using Ubuntu Karmic, 9.10, and trying to upgrade to Lucid using
update-manager or do-release-upgrade fails with the following message:

{{{
Checking for a new ubuntu release
Done Upgrade tool signature
Done Upgrade tool
Done downloading
extracting 'lucid.tar.gz'
authenticate 'lucid.tar.gz' against 'lucid.tar.gz.gpg'

Reading cache

Checking package manager
Reading package lists: Done
Reading state information: Done
Reading state information: Done
Reading state information: Done
Done downloading

Reading pa...

Read more...

Roshan Karki (roxan) wrote :

I also faced the similar problem in one of the computer here. I was able to update after removing empathy as suggested.

davidyu (yuyich) wrote :
Download full text (4.7 KiB)

Mike:
    Just back home and retry the problem.
What I do:
1. reinstall empathy back first
2. run update-manager -d
3. No PKGproblemresloveler problem prompts again.
Seems problem is gone.
Have a nice day.

David YC Yu
IBM Systems and Technology Group Lab Service & Training
mail : <email address hidden>, Tie-line : 849-6560
Phone : 886-2-8170-6560 / Mobile : 886-932-901-978
8F, Building E, Nan-Kang Software Park, 19-11 San-Chong Road, Taipei, 11501
Taiwan

             Michael Vogt
             <michael.vogt@ubu
             ntu.com> To
             Sent by: David YC Yu/Taiwan/IBM@IBMTW
             bounces@canonical cc
             .com
                                                                   Subject
                                       [Bug 551782] Re: Not able to
             03/31/2010 03:31 dist-upgrade, "calculating
             PM changes" can't solve dependencies
                                       and fail

             Please respond to
                Bug 551782
             <<email address hidden>
                chpad.net>

Could you please try this again? The empathy problem (that is the root
for many of the messages like this) is in the archive now and I can no
longer reproduce this particular failure (with the /var/lib/dpkg/status
file provided). If it stills fails for you (and you are using a up-to-
date mirror that has the latest empathy-common) then please attach
/var/lib/dpkg/status and I will try to rerproduce.

** Changed in: update-manager (Ubuntu)
       Status: New => Fix Released

--
Not able to dist-upgrade, "calculating changes" can't solve dependencies
and fail
https://bugs.launchpad.net/bugs/551782
You received this bug notification because you are a direct subscriber
of the bug.

Status in “update-manager” package in Ubuntu: Fix Released

Bug description:
Binary package hint: update-manager

I'm using Ubuntu Karmic, 9.10, and trying to upgrade to Lucid using
update-manager or do-release-upgrade fails with the following message:

{{{
Checking for a new ubuntu release
Done Upgrade tool signature
Done Upgrade tool
Done downloading
extracting 'lucid.tar.gz'
authenticate 'lucid.tar.gz' against 'lucid.tar.gz.gpg'

Reading cache

Checking package manager
Reading package lists: Done
Reading state informatio...

Read more...

Rajesh Shanker (rajesh-bms) wrote :

Yes, I have the same problem when try to upgrade Ubuntu 09.10 Karmic to 10.04 Lucid...Initially i get
extracting 'lucid.tar.gz'
authenticate 'lucid.tar.gz' against 'lucid.tar.gz.gpg'
WARNING: Failed to read mirror file

2100 out of 2108 packages were installed and then boom...
Then after a few minutes i get..
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/libg/libgnome-keyring/libgnome-keyring0_2.30.0-0ubuntu1_i386.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/x/xserver-xorg-input-synaptics/xserver-xorg-input-synaptics_1.2.2-1ubuntu1_i386.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/x/xterm/xterm_256-1ubuntu1_i386.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/l/language-pack-gnome-en/language-pack-gnome-en_10.04+20100327.1_all.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/l/language-pack-gnome-en-base/language-pack-gnome-en-base_10.04+20100327.1_all.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/l/language-pack-kde-en/language-pack-kde-en_10.04+20100327.1_all.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/l/language-pack-kde-en-base/language-pack-kde-en-base_10.04+20100327.1_all.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/t/tomcat6/libservlet2.5-java_6.0.24-2ubuntu1_all.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/universe/k/kdeartwork/kdeartwork-theme-icon_4.4.2-0ubuntu1_all.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/universe/k/kdeartwork/nuvola-icon-theme_4.4.2-0ubuntu1_all.deb 404 Not Found
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/universe/k/kdeartwork/kde-icons-nuvola_4.4.2-0ubuntu1_all.deb 404 Not Found

Ursula Junque (ursinha) wrote :

Still happens to me, reopening the bug after talking with Michael.

Changed in update-manager (Ubuntu):
status: Fix Released → New
Ursula Junque (ursinha) wrote :

@Michael my /etc/apt/preferences file, for appreciation (or not :P)

Ursula Junque (ursinha) wrote :
Changed in update-manager (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
status: New → In Progress
Michael Vogt (mvo) wrote :

Thanks for the preferences file. I will add code to update-manager that ensures it detects that condition. In the meantime you can just remove it and continue with the upgrade.

Ursula Junque (ursinha) wrote :

Related conversation with Michael:

<mvo> I did a bit of investigation and was wondering if you have anything in /etc/apt/preferences or /var/lib/synaptic/preferences ?
<mvo> or /etc/apt/preferences.d
<mvo> with that I can exactly reproduce the failure, but only with a preferences file
<Ursinha> yes, I have one preferences file
<mvo> cool
<mvo> bug found
<mvo> I will add code in u-m to deal with it
<mvo> it needs to log that properly and/or move away those preferences

MacRules (macrules) wrote :

in my case it seems to be the kernel:
  Installing linux-image-generic as Depends of linux-generic
  Setting NOT as auto-installed (direct Depends of pkg in APT::Never-MarkAuto-Sections)
Starting
Starting 2
Investigating linux-image-generic
Package linux-image-generic has broken Depends on linux-image-2.6.32-20-generic
Investigating linux-image
Package linux-image has broken Depends on linux-image-generic
  Considering linux-image-generic 4 as a solution to linux-image 2
  Holding Back linux-image rather than change linux-image-generic
Investigating linux
Package linux has broken Depends on linux-image
  Considering linux-image 2 as a solution to linux 0
  Holding Back linux rather than change linux-image
Investigating linux-generic
Package linux-generic has broken Depends on linux-image-generic
  Considering linux-image-generic 4 as a solution to linux-generic 10000
    Reinst Failed early because of linux-image-2.6.32-20-generic

MacRules (macrules) wrote :

well, it seems the karmic-updates contains kernel 2.6.32-20.33 and lucid want .21 or something.
there is also a .58 version for linux-image-2.6.32.20.58 so something goes wrong there.

If I check synaptic while lycid update is busy/gives error, i see that .21 version.
When I check to update I get a dependency error for linux-generic.

I will try to disable karmic-updates en downgrade.

MacRules (macrules) wrote :

i ended up with this:
linux-image-generic:
 Depends: linux-image-2.6.32-20-generic but it is not installable

does anyone know how to fix this?

MacRules (macrules) wrote :

some more info from the terminal:
extracting 'lucid.tar.gz'
authenticate 'lucid.tar.gz' against 'lucid.tar.gz.gpg'
tar: Removing leading `/' from member names
tar: /etc/apt/preferences: Cannot stat: No such file or directory
tar: Exiting with failure status due to previous errors
WARNING: Failed to read mirror file

MacRules (macrules) wrote :

well after some updating, refreshing and fiddling i got it working.
i got a distupgrade package update, could then update the kernel.
then had to reconfigure x because of no keyboard.

except touchscreen all seems to work on my m910 netbook

Michael Vogt (mvo) wrote :

@MacRules: thanks, this error you see is unreleated and a transient error when a new kernel was added.

Changed in update-manager (Ubuntu Lucid):
status: In Progress → Confirmed
tags: added: karmic2lucid
Artin (artin) wrote :

I have the same problem:

sudo do-release-upgrade -d
Checking for a new ubuntu release
Done Upgrade tool signature
Done Upgrade tool 4s
Done downloading
extracting 'lucid.tar.gz'
authenticate 'lucid.tar.gz' against 'lucid.tar.gz.gpg'
tar: Removing leading `/' from member names

Reading cache

Checking package manager
Reading package lists: Done
Reading state information: Done
Reading state information: Done
Reading state information: Done
Done downloading
Reading package lists: Done
Reading state information: Done
Reading state information: Done
Reading state information: Done

Updating repository information
WARNING: Failed to read mirror file

Third party sources disabled

Some third party entries in your sources.list were disabled. You can
re-enable them after the upgrade with the 'software-properties' tool
or your package manager.

Done downloading

Checking package manager
Reading package lists: Donem lucid/partner Packages: 94 ges: 94
Reading state information: Done
Reading state information: Done
Reading state information: Done

Calculating the changes

Calculating the changes

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade:
E:Unable to correct problems, you have held broken packages.

This can be caused by:
* Upgrading to a pre-release version of Ubuntu
* Running the current pre-release version of Ubuntu
* Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug against the
'update-manager' package and include the files in
/var/log/dist-upgrade/ in the bug report.

Restoring original system state

Aborting
Reading package lists: Donermic/main Packages: 94 94 93 es: 92
Reading state information: Done
Reading state information: Done
Reading state information: Done

haneya (a-haneya) wrote :

I Have the same problem but I cant trace the package the held back the upgrade

haneya (a-haneya) wrote :

I Have the same problem but I cant trace the package the held back the upgrade

Dave S (dsokolowsky) wrote :

I am not sure what package(s) I removed which allowed me to upgrade, but after I uninstalled extra desktops (xubuntu and lubuntu) I was able to get past this issue.

kusi (q-launchpad-titlis-org) wrote :

same here: during sudo do-release-upgrade -d, I get
E:Unable to correct problems, you have held broken packages.

kusi (q-launchpad-titlis-org) wrote :
David Tombs (dgtombs) wrote :

I am also experiencing this issue. Attaching main.log and apt.log, I don't have any preferences files for apt.

David Tombs (dgtombs) wrote :
David Tombs (dgtombs) wrote :

Since my error message was slightly different from this one, I opened a new report, at Bug #577544.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers