Bug if ipv6 and ipv4 applied together

Bug #691863 reported by Mahyuddin Susanto on 2010-12-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nginx (Debian)
Fix Released
Unknown
nginx (Ubuntu)
Undecided
Mahyuddin Susanto
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: nginx

As describe at http://nginx.org/pipermail/nginx/2010-December/024152.html

nginx having trouble if ipv4 and ipv6 allied together (regex?), example configurations

  server {
  listen [::]:80 default ipv6only=off;
    server_name ~^(?<domain>.+)\.internal\.mydomain\.tld$;
  ...
  }

Log:
2010/12/12 20:10:37 [debug] 32080#0: *1 http header: "Host: www.internal.mydomain.tld"
2010/12/12 20:10:37 [debug] 32080#0: *1 http header done

Mahyuddin Susanto (udienz) wrote :
tags: added: patch
Changed in nginx (Ubuntu):
assignee: nobody → Mahyuddin Susanto (udienz)

Could you please explain what issue you are having? What do you expect to happen, and what is happening are needed.

Also... we need to know what version of Nginx you're using and how you installed it.

Karl Blessing (kbeezie-com) wrote :

This bug has been fixed by it's creator for version 0.9.3, 0.8.54 and the legacy 0.7.68
Note : http://nginx.org/en/CHANGES-0.7
and
http://nginx.org/en/CHANGES

"Bugfix: if there was a single server for given IPv6 address:port
       pair, then captures in regular expressions in a "server_name"
       directive did not work."

Mahyuddin Susanto (udienz) wrote :

Sorry i'm forget to inform nginx version

$ apt-cache policy nginx
nginx:
  Installed: 0.7.65-1ubuntu2
  Candidate: 0.7.65-1ubuntu2
  Version table:
 *** 0.7.65-1ubuntu2 0
        500 http://mirrors.kernel.org/ubuntu/ lucid/universe Packages
        100 /var/lib/dpkg/status

$ nginx -V
nginx version: nginx/0.7.65
TLS SNI support enabled
configure arguments: --conf-path=/etc/nginx/nginx.conf --error-log-path=/var/log/nginx/error.log --pid-path=/var/run/nginx.pid --lock-path=/var/lock/nginx.lock --http-log-path=/var/log/nginx/access.log --http-client-body-temp-path=/var/lib/nginx/body --http-proxy-temp-path=/var/lib/nginx/proxy --http-fastcgi-temp-path=/var/lib/nginx/fastcgi --with-debug --with-http_stub_status_module --with-http_flv_module --with-http_ssl_module --with-http_dav_module --with-http_gzip_static_module --with-http_realip_module --with-mail --with-mail_ssl_module --with-ipv6 --add-module=/build/buildd/nginx-0.7.65/modules/nginx-upstream-fair

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04.1 LTS
Release: 10.04
Codename: lucid

Changed in nginx (Ubuntu):
status: New → In Progress
assignee: Mahyuddin Susanto (udienz) → Michael Lustfield (mtecknology)
Daniel Hahler (blueyed) wrote :

Just for reference, here is the upstream patch: http://nginx.org/pipermail/nginx/2010-December/024161.html

Mahyuddin Susanto (udienz) wrote :

@Daniel
yes already writing at patch file

summary: - Bug with regrex ipv6
+ Bug if ipv6 and ipv4 applied together
Changed in nginx (Ubuntu):
assignee: Michael Lustfield (mtecknology) → Mahyuddin Susanto (udienz)
assignee: Mahyuddin Susanto (udienz) → nobody
status: In Progress → Confirmed

This is being dealt with upstream. It will be taken care of before Natty release. Please see bug 692087 and note the comment requesting a wait on the sync until 0.8.54-1 where the source is already patched.

Changed in nginx (Ubuntu):
assignee: nobody → Michael Lustfield (mtecknology)
status: Confirmed → In Progress
Mahyuddin Susanto (udienz) wrote :

Well it is SRU for lucid

tags: added: regression-proposed
Changed in nginx (Ubuntu):
assignee: Michael Lustfield (mtecknology) → Mahyuddin Susanto (udienz)
Micah Gersten (micahg) wrote :

Any SRU for Lucid needs to land in Natty first.

tags: removed: regression-proposed

This has been fixed in Debian. I don't see where this bug should be SRU'ed. However, the new version of Nginx could be proposed for backports.

Changed in nginx (Ubuntu):
status: In Progress → Fix Committed
Changed in nginx (Debian):
status: Unknown → Fix Released

Marking as Fix Released as this has been resolved in Debian and the package has since been sync'ed to Ubuntu.

Changed in nginx (Ubuntu):
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in nginx (Ubuntu Lucid):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.