Thinkpad T410, T410s no response when pressing power button

Bug #564051 reported by Martijn de Nerd on 2010-04-15
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Manoj Iyer
Manoj Iyer

Bug Description

Binary package hint: acpi-support


I get no response when pressing the powerbutton. Already tried to change the desired response in the Gnome Power Management preference window, but it seems to be at a lower level.

Let me know if you need more information.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: acpi-support 0.134
ProcVersionSignature: Ubuntu 2.6.32-21.31-generic
Uname: Linux 2.6.32-21-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Apr 15 19:30:44 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100406.1)
SourcePackage: acpi-support

BTW, probably unrelated, but my microphone-mute-button is also not responding. Dedicated volume control and mute buttons are fine.

Steve Langasek (vorlon) wrote :

Thank you for taking the time to report this bug and help to improve Ubuntu.

Please run acpi_listen, and post the output when pressing the power button.

Changed in acpi-support (Ubuntu):
status: New → Incomplete


thanks for helping. acpi_listen gives no output when I press the power button.

(I ensured that i am using it correctly, pressing something else gives 'ibm/hotkey blabla' )

Steve Langasek (vorlon) wrote :

Oh, well if there's no acpi event on the socket, then it's not an acpi-support bug. Probably a kernel bug - indeed, there have been some late changes related to ThinkPad ACPI support, so this is probably fallout from those changes.

I've just tested here, and also see no event when pressing the power button on my T60 - either via acpi_listen, or via the kernel input device. This is with the 2.6.32-20.30 kernel; I'll re-test with 2.6.32-31, but it seems you're already using the newer kernel.

affects: acpi-support (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → High
status: Incomplete → Triaged
Changed in linux (Ubuntu Lucid):
milestone: none → lucid-updates

Just tested with v2.6.34-rc4 from Didn't change anything.

Also not working for me on a T410s!
No output coming from acpi_listen....

summary: - Thinkpad T410 no response when pressing power button
+ Thinkpad T410, T410s no response when pressing power button
Joel Ebel (jbebel) wrote :

I get output from acpi_listen if I hold it down for about 1 second. Are the rest of you not getting this?

On a T410s, pressing it repeatedly:

button/power PWRF 00000080 00000001
button/power PWRF 00000080 00000002
button/power PWRF 00000080 00000003
button/power PWRF 00000080 00000004

It works as well on my T410 with BIOS version 1.18-1.07 (04/19/2010). I run Lucid with Kernel 2.6.32-22-generic (compiled on 05/09/2010 from the git Lucid kernel tree). acpi_listen shows the same output as in comment #8 when pressing the power button for about 1 second and the shut-down window pops up.

tags: added: kernel-acpi kernel-reviewed

@Marco: Uh yeah i feel stupid now. It's just slow... if I hold it, my computer shuts down (correctly)

Manoj Iyer (manjo) wrote :

Since the originator of the bugs claims that the problem is non-existent I am marking this as invalid, please reopen this bug if it is truly valid bug.

Changed in linux (Ubuntu):
assignee: nobody → Manoj Iyer (manjo)
status: Triaged → Invalid
Changed in linux (Ubuntu Lucid):
assignee: nobody → Manoj Iyer (manjo)
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers