Ubuntu

[i915] blank screen on Latitude E6410 (NOT E6510)

Reported by Mathieu Trudel-Lapierre on 2010-04-12
406
This bug affects 71 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Andy Whitcroft
Lucid
Medium
Chris Halse Rogers
Maverick
Medium
Unassigned

Bug Description

Binary package hint: xorg

NOTE: The E6410 and E6510 have different hardware. There's a bug with similar *symptoms* but a *different cause* on E6510+intel hardware, which is bug #600453.

During installation, bootup (plymouth) and while inside X, screen remains blank. Switching VTs yields no results (screen remains blank).

This was done with today's daily desktop image, amd64: 10.04 (20100412).

I've been able to isolate the issue to possibly somewhere in modesetting with the i915 driver, here are the tested cases:

 - Disabling modesetting with 'nomodeset' as a kernel parameter: boot messages visible in 'verbose', otherwise nothing on screen, X remains blank.
 - Disabling modesetting with 'i915.modeset=0' as a kernel parameter: results in a kernel oops, after briefly showing a simple "text" splash and showing corruption of that splash screen. X clearly never comes up, caps/scroll/num blink.
 - Disabling modesetting with 'nomodeset' and switching X drivers to 'vesa': nothing on screen during boot, up to a working, visible desktop.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xorg 1:7.5+5ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-20.29-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-20-generic x86_64
Architecture: amd64
Date: Mon Apr 12 16:14:04 2010
DkmsStatus: Error: [Errno 2] No such file or directory
GdmLog:
 Error: command ['gksu', '-D', 'Apport', '--', 'cat', '/var/log/gdm/:0.log'] failed with exit code 1:
 (gksu:2847): Gtk-WARNING **: cannot open display: localhost:10.0
GdmLog1:
 Error: command ['gksu', '-D', 'Apport', '--', 'cat', '/var/log/gdm/:0.log.1'] failed with exit code 1:
 (gksu:2851): Gtk-WARNING **: cannot open display: localhost:10.0
GdmLog2:
 Error: command ['gksu', '-D', 'Apport', '--', 'cat', '/var/log/gdm/:0.log.2'] failed with exit code 1:
 (gksu:2855): Gtk-WARNING **: cannot open display: localhost:10.0
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100412)
Lsusb:
 Bus 002 Device 003: ID 0a5c:5800 Broadcom Corp. BCM5880 Secure Applications Processor
 Bus 002 Device 002: ID 8087:0020
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 002: ID 8087:0020
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. Latitude E6410
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-20-generic root=UUID=be2ee00c-b05e-4412-84d5-fc61a62388de ro verbose
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
SourcePackage: xorg
Symptom: display
Xrandr: Error: command ['xrandr', '--verbose'] failed with exit code 1: Can't open display localhost:10.0
dmi.bios.date: 01/30/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: X51
dmi.board.name: RAMDEL
dmi.board.vendor: Dell Inc.
dmi.board.version: 0001
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrX51:bd01/30/2010:svnDellInc.:pnLatitudeE6410:pvr0001:rvnDellInc.:rnRAMDEL:rvr0001:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6410
dmi.product.version: 0001
dmi.sys.vendor: Dell Inc.
glxinfo: Error: [Errno 2] No such file or directory
setxkbmap: Error: command ['setxkbmap', '-print'] failed with exit code 255: Cannot open display "localhost:10.0"
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-20-generic
xdpyinfo: Error: command ['xdpyinfo'] failed with exit code 1: xdpyinfo: unable to open display "localhost:10.0".

Attached tar contains the logs with 'nomodeset', up to a blank screen with X running (though not visible).

Ameet Paranjape (ameetp) on 2010-04-12
Changed in xorg (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Goalie Fight (goaliefight) wrote :

Same problem with the BETA2 Live CD.

Shomeir (shomeir) wrote :

I have a black screen on my Latitude D400 laptop when I update from Beta2 or do a clean install of 10.04 RC. I have had to reinstall Beta2 several times in the last few days as I have updated periodically to see if this bug has been fixed.

lostthetrail (lostthetrail) wrote :

I am getting a blank screen on live cd (10.04 LTS 32 bit) on a Dell Latitude E6410 (w/ Nvidia NVS 3100m). I am unsure if my issue is related, but it does seem to have the same system and end problem. Please let me know if I can check into anything that will help diagnose this issue.

Tim (tim-titley) wrote :

Seem to have a similar problem (same symptoms) with my Dell Latitude 510M. If there is any debugging info that may be helpful - let me know what and I'll post it here!

dbarnett (dhbarnett) wrote :

I'm having the same problem with an E6510 with the NVIDIA NVS 3100M. I'm glad to provide any uselful diagnostics. I tried installing a clean 10.04 as well as an upgrade from 9.10 (9.10 displayed fine), but after upgrade no display.

Tim (tim-titley) wrote :

I've installed again using the alternative cd (no graphics mode) and the install went okay. I then booted it using the recovery option (from grub) and chose the "resume" option which gave me a login prompt. I then used aptitude to remove gdm.

My laptop boots successfully to a login prompt. I can then login and try to run X using startx which causes the machine to lock up completely with a blank screen. (There isn't any response from the network - can't even ping.) I tried setting the various nomodeset and i915.modeset=0 kernel options (in all the combinations) to no avail. I even unloaded the i915 module and blacklisted it which made no difference.

This leads me to believe that it is not a problem with the i915 kernel module......

I then created a default xorg.conf (using Xorg -configure) and tried disabling all the modules, and setting various options again, to no avail. I'll keep you posted if I find anything.

Radek Dostal (radekdostal) wrote :

I have reproduced the bug with both Ubuntu 10.04 32-bit and 64-bit on Dell Latitude E6510 - Intel® HD Graphics + 15.6” FHD Wide View Anti-Glare LED Display (1920 x 1080)

Radek Dostal (radekdostal) wrote :

Possible workaround is to use Vesa drivers - add following into your boot parameters:
i915.blacklist=true xforcevesa

Douglas Berdeaux (berdeauxd) wrote :

@Radek - that works, i can confirm on a DELL e6410 with the NVIDIA 3100m, this works only with 9.10. When added to boot options in 10.04 system stays black/blank. (this was tested with install only environment and live environment). I have tried the last few versions of Ubuntu down to 8.x The system doesn't hang, but you cannot access any of the VT's by doing ALT+CTRL+F(x).

After installation of 9.10 with the boot parameters, GDM and Gnome load fine, but with poor graphics. Click "System" and click "Administration" Then "Drivers" and allow the computer to find the NVIDIA driver: 185.x Install it, by clicking "Activate" then reboot. The screen goes black once again. the NVIDIA drivers' installation will change the /etc/X11/xorg.conf to try to run "nv" drivers.

I ran nvidia-xconfig and the xorg.conf file changed, and rebooted, still black screen, and now no sound.

I noticed that X appears for a split second after i type "reboot" from the cli. I blacklisted i915 in /etc/modprobe.d/i915 and rebooted, which turned up a black/blank screen as well. If i hook up an external display to the VGA port, and hit Fn+F8 the screen shows up on the LCD, but the graphics are distorted like the GPU is bad??? After a few minutes of being plugged into the external display the computer halts completely.

I have tried many OS's, the only one that seemed to work out of the box was PCBSD with the 195.x NVIDIA drivers, so I reinstalled Ubuntu 9.10 with the blacklisted i915 and xforcevesa and did this, from a terminal:

wget ftp://download.nvidia.com/XFree86/Linux-x86/195.22/NVIDIA-Linux-x86-195.22-pkg1.run -O nvidia.sh && chmod +x nvidia.sh && ./nvidia.sh

and finally, it's fixed. This, once again, is for 3100m NVS nvidia E6410 Karmic.

@Tim your're right, it's most likely an out of date NVIDIA driver, not i915, and the xforcevesa simply bypasses the issue.

For Lucid, you can't even see the text at boot, so you may need to install the OS a different way and install the driver above in a chrooted environment from another machine possibly.

Tim (tim-titley) wrote :

If it is a NVIDIA issue, you should be able to force vesa initially, and then tell it to use the proprietary drivers (System->Administration->Hardware Drivers). I think those are pretty up to date........ although don't quote me on that!
I think that is essentially the supported way of doing what you have done.
My GPU is Intel, so unfortunately this won't work for me! If anyone fancies trying this method just to clarify (or has already tried it) that would be great!

lostthetrail (lostthetrail) wrote :

It appears my problem was solved by doing the following:

1) Use nomodeset on installation
2) Use nomodeset on GRUB boot command (removing quiet splash)
3) Upon booting, install the recommended hardware drivers.

Everything seems to work great now. Let me know if there is anything I can do to help get this fixed.

kiran (kiran-scalex86) wrote :

I have a dellE6410 with Nvidia 3100M, I just got it working doing the following :
1) Installed 10.04 with alternate media and no x
2) Use nouveau.modeset=0 on the GRUB boot command (if you have nvidia card graphics)
3) Upon booting into textmode install the working nvidia drivers
4) Modify /boot/grub/grub.conf to include nouveau.modeset=0 in the kernel commandline

I have the laptop working with X and wired network now.

botbanky (botbanky) wrote :

I have the Dell E6510 with Nvidia 3100M, and when using the 10.04 64-bit install CD the display hangs before any install screen appears. It simply sits blank.

Does anyone know of an official solution coming from ubuntu? Will they be updating the 10.04 distro with this issue addressed?

Aaron Hanson (aaronhanson) wrote :

I just got mine up and working basically following kiran's directions.

I used the alternate CD to do a regular install and then to do a rescue install, which I backed out of to get to the shell and change the grub boot options to create a text mode option (with the nouveau.modeset=0 as well). I also changed quiet splash to nosplash.

I booted up using the text mode option I created.

Then I installed this driver:
http://www.nvidia.com/object/linux-display-amd64-195.36.24.html

Updated 64 bit version of what Douglas had mentioned:
wget ftp://download.nvidia.com/XFree86/Linux-x86_64/195.36.24/NVIDIA-Linux-x86_64-195.36.24-pkg2.run -O nvidia.sh

The install gave me a warning that the preinstall script didn't work, but I took a look at it and all it does it fail so you don't overwrite the ubuntu packages, I continued anyways. I also let it reconfigure my settings and then rebooted and now it works.

After running all the updates, I modified the grub option again and after booting up I enabled the restricted driver from Ubuntu (looks like it's a couple sub versions back) and it works too.

My thinking is you might be able to just get away with adding the nouveau.modeset=0 and nosplash.

Now I just need to get my touchpad scrolling figured out. Also, I had to modify the right alt key in the keyboard layout, I switched it to the left win key instead.

Douglas Berdeaux (berdeauxd) wrote :

@Aaron are you using the E6410? I tried for hours to get the Touchpad working correctly, I tried Editing /etc/X11/xorg.config
changed from Mouse0 to Synaptics, added it to ServerLayout, Added 'Load "synaptics"'
created HAL file: /etc/hal/fdi/policy/shmconfig.fdi
enabled shared memory in my fstab
rebooted.. I have tried everything to get SHM to run that I could think of.

Nothing.

I installed gsnyaptics, but it will not run saying that I have to add "SHMConfig" "true" in the /etc/xorg.conf file, which it is and I thought about submitting a bug.

Aaron Hanson (aaronhanson) wrote :

Yes. I just got an E6410 with the nVidia 3100M and an i5. Not that it probably matters, but I chose the non-backlit keyboard.

I'm going to be playing around with it more this weekend. But for now I can get by without scrolling.

jlgoolsbee (jlgoolsbee) wrote :

I can confirm this behavior on an E6510 with Intel HD graphics. I realize this question was asked a couple days ago, but I need to ask it as well: will there be an official fix for this, and if so, when? My IT department is looking to switch my team to Dell hardware, and this is what they purchased for me to evaluate; if there's not going to be an official fix for this then I'd like to just know that now.

coldrol (hidegrol) wrote :

Thanks for the solution, it worked for me on E6410 with nvidia card.
After installed the driver from nvidia website it worked, but then I installed the kernel updates of course it didn't worked. Then I uninstalled the preveious installed nvidia driver and reinstalled it from the ubuntu repo (System/Administration/Hardware Drivers).

I think now I can upgrade the kernel flawlessly.

This bug is about the i915 driver specifically, not the E6410 that has a nvidia card. If you have a nvidia card and *only* if you use the open source default driver "nouveau", please refer to bug 556872.

If the issue you are experiencing is not related to the display being blank on an Intel-chipset based Latitude E6410, please file new bugs rather than adding information here, so that the issues can be resolved as soon as possible.

I figured out a pretty easy way to get the video up and running on a Latitude E6510 with NVIDIA NVS 3100m:

1. Attach an external monitor to the port on the back of the machine.
2. Install Ubuntu using the Alternate Install CD.
3. When you reboot into Ubuntu, your desktop will display on the external monitor (in my case, with the right third of the desktop missing).
4. Activate the Nvidia driver via System>Administration>Hardware Drivers.
5. Reboot (in my case, since I couldn't see the right portion of the desktop I had to open Applications>Accessories>Terminal and enter "sudo shutdown -r now").
6. When the machine reboots, your laptop display should be working properly.
7. (optional) Use System>Administration>NVIDIA X Server Settings to configure your external monitor and save the settings to the new X Configuration file. I had to log out and log back in for the Gnome panels to show up on the laptop display instead of the external monitor.

Oops, sorry, Mathieu, I see that my procedure is not actually for this bug.

Does anyone know of an existing bug for the E6510 with NVIDIA NVS 3100m? I did a quick search and didn't see one. I'd like to post this info to an existing bug if possible before I go ahead and create a new one.

Douglas Berdeaux (berdeauxd) wrote :

@Todd Boss: It's here: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/556872

I tried an external monitor and the graphics completely locked up, so for me that wasn't an option. The CAPs lock key still worked and usually on kernel panic my CAPs NUM lock lights blink in unison; this wasn't the case.

Diego Schulz (dschulzg) wrote :

I'm experiencing exactly the same issue with a Latitude E6510 with Intel integrated graphics.

Does anyone knows if this issue is fixed in 10.10 in development?

Chris -

This issue seems to be rather lingering. Could you please see if there is something we should be doing to fix this for users?

Changed in xorg (Ubuntu Lucid):
assignee: Canonical Desktop Team (canonical-desktop-team) → Chris Halse Rogers (raof)
Diego Schulz (dschulzg) wrote :

After installing I modified /etc/default/grub

from

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="nomodeset quiet xforcevesa"

And now I can at least use my laptop without windows, wich of course was a pleasure to get shredded and wiped from the hard disk.

Marcelo Barros (marcelobarros) wrote :

I had the same problem. I am using a Dell E6410 with Intel integrated graphics (cited as i915 by lspci). No nvidia in this case. ubuntu is 10.04, alternate.

It was possible to boot in console mode (security mode) using "nomodeset". xforcevesa did not work or even blacklist for i915.
If I added "nomodeset" (normal boot), it was possible to see the console messages but when the X started I had a blank screen and caps lock/num lock started to blink.

When I added i915.modeset=0 as kernel option I was able to boot the system (kernel 2.6.32-21). I had some hiccups at X startup and some messages related to misconfiguration but it worked.

I tried the latest kernel/intel driver following tips from user´s forum (http://ubuntuforums.org/showthread.php?t=1475128) but downloading the latest available kernel (2.6.35-rc1):

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update && sudo apt-get install xserver-xorg-video-intel

from http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.35-rc1-lucid/, I downloaded and installed the following packet (using wget or similar tool):

linux-image-2.6.35-020635rc1-generic_2.6.35-020635rc1_i386.deb
linux-headers-2.6.35-020635rc1_2.6.35-020635rc1_all.deb
linux-headers-2.6.35-020635rc1-generic_2.6.35-020635rc1_i386.deb

It was necessary to add "i915.modeset=0" as kernel parameters, as cited before. To make this change permanent, do the following:

echo options i915 modeset=0 | sudo tee /etc/modprobe.d/i915-kms.conf
sudo update-initramfs -u

But, same behavior, so it is not necessary to upgrade.
I think I need to create a proper xorg.conf now to avoid all warning messages that I am receiving at X startup.

Marcelo Barros (marcelobarros) wrote :

Side effect: don´t switch to terminal using ctrl+alt+f1 or you will not be able to switch back using alt+f7

SF Basilix (sf-basilix) wrote :
Download full text (3.5 KiB)

I am having the same issue with my laptop. It is a Dell E6510 with an Intel Core i5 chip and with the Intel graphics (not nvidia). Vanilla install of Ubuntu 10.04 with all patches applied (up to date as of posting) and I cannot use the external video display. Upon plugging in an external monitor using the VGA adapter and then going into System->Preferences->Monitors, I get a black screen and no mouse movements at all. Even CTRL+ALT+BKSP doesn't kick me out of X.

I've tried all of the above options and they did not work.

Here is more info to help diagnose the problem, if anyone needs anything else, please let me know and I will post.

System has latest A03 bios but it did the same thing with A01 and A01.1 bios revisions

$ lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
00:19.0 Ethernet controller: Intel Corporation 82577LM Gigabit Network Connection (rev 05)
00:1a.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 05)
00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 05)
00:1d.0 USB Controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 05)
00:1f.2 RAID bus controller: Intel Corporation Mobile 82801 SATA RAID Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
02:00.0 Network controller: Intel Corporation WiFi Link 6000 Series (rev 35)
03:00.0 CardBus bridge: Ricoh Co Ltd Device e476 (rev 02)
03:00.1 SD Host controller: Ricoh Co Ltd Device e822 (rev 03)
03:00.4 FireWire (IEEE 1394): Ricoh Co Ltd Device e832 (rev 03)
3f:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
3f:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
3f:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
3f:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
3f:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
3f:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)

$ xrandr
Screen 0: minimum 320 x 200, current 1600 x 900, maximum 8192 x 8192
VGA1 disconnected (normal left inverted right x axis y axis)
DP1 connected 1600x900+0+0 (normal left inverted right x axis y axis) 344mm x 1...

Read more...

SF Basilix (sf-basilix) wrote :

forgot to note that the above happened on both 32 bit and 64 bit distros...

SF Basilix (sf-basilix) wrote :

I just realized that the op has a separate issue - similar to the one I have, but not the same. I'm debating opening a separate bug for the issue I have.

SF, please don't hesitate to open a new bug report (and use ubuntu-bug to do
so) and report here with the bug number so that we can look at your issue
and so that it can be fixed as well.

On Jun 18, 2010 10:55 AM, "SF Basilix" <email address hidden> wrote:

I just realized that the op has a separate issue - similar to the one I
have, but not the same. I'm debating opening a separate bug for the
issue I have.

-- [lucid] [i915] blank screen on Latitude E6410
https://bugs.launchpad.net/bugs/561802 You receiv...

Status in “xorg” package in Ubuntu: Triaged Status in “xorg” source package
in Lucid: Triaged

Bug description: Binary package hint: xorg During installation, bootup
(plymouth) and while inside ...

Since others in this bug may not have seen it and it would have saved me some Googling, the commit in http://lists.freedesktop.org/archives/intel-gfx/2010-May/006948.html seems to be the source of the problem. After reverting that commit, an otherwise vanilla 2.6.34 kernel works for me on an E6510 with the i915 driver.

libretto (c-hentschel) wrote :

I can confirm the same problem on my new E6410 w/Intel graphics card. All hints here helped me installing 10.04 (kubuntu) using the alternate amd64-cd und updating the system in a recovery shell. But trying to restart in normal mode always results in a black screen with blinking nun/caps lock leds even nomodeset or whatever was mentioned above doesn't help.

Starting with i915.blacklist=true xforcevesa results in a pink screen and text VT showing alternaty for 10-15 seconds. After that there is a black screen again but w/o blinking leds. Althoung hitting the caps lock key does not change the led state the system make a shutdown when pressing the off button. So vesa does not work, too.

So there is no chance to get it running now? :-(

Yingying Zhao (yingying-zhao) wrote :

@libretto - Would you please try the attached patch? I don't have E6410, but this patch should deliver a fix for this blank screen issue on E6410.

tags: added: patch
Steven Yelton (steveny) wrote :

I have the same issue with my dell E6510. I am in the process of rebuilding the kernel with the patch in #36, but for now I was able to get the 'intel' driver working by using the mainline-kernel http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.32.13-lucid/

Steven Yelton (steveny) wrote :

@Yingying Zhao - my E6510 booted fine using the intel driver with your patch applied

Chris Halse Rogers (raof) wrote :

Moving to the kernel source package, as this will require a kernel patch.

The patch attached to this bug seems to be superseded by this commit on the for-linus branch of drm-intel: http://git.kernel.org/?p=linux/kernel/git/anholt/drm-intel.git;a=commit;h=fe27d53e5c597ee5ba5d72a29d517091f244e974

affects: xorg (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
tags: added: xorg-needs-kernel-fix
tags: added: kernel-graphics

Dave Airlie kept working and produced this improved patch:

http://git.kernel.org/?p=linux/kernel/git/anholt/drm-
intel.git;a=commit;h=fe27d53e5c597ee5ba5d72a29d517091f244e974

This is the only patch that fixes the problem on my Dell Latitude E6510. I applied it to vanilla 2.6.34 from upstream and now I have KMS and compiz working.

tags: added: kernel-needs-review
Steve Conklin (sconklin) on 2010-07-06
tags: added: kernel-reviewed
removed: kernel-needs-review
Steve Conklin (sconklin) on 2010-07-09
Changed in linux (Ubuntu Lucid):
status: Triaged → In Progress
papukaija (papukaija) on 2010-08-15
summary: - [lucid] [i915] blank screen on Latitude E6410
+ [i915] blank screen on Latitude E6410
Martin Pitt (pitti) on 2010-08-17
Changed in linux (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) on 2010-08-24
tags: added: verification-failed
removed: verification-needed
Martin Pitt (pitti) on 2010-08-27
tags: added: verification-done
removed: verification-failed
Changed in linux (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Lucid):
status: Fix Released → In Progress
tags: added: verification-failed
removed: verification-done
Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
summary: - [i915] blank screen on Latitude E6410
+ [i915] blank screen on Latitude E6410 (NOT E6510)
description: updated
142 comments hidden view all 222 comments
Download full text (4.1 KiB)

wow :)

i did this in the backwards manner : installed 10.10, which has the problem,
and since downgraded a kernel to 2.6.32.11 which worked fine, but no wifi...

From what I can tell from the forums, there is a kernel patch that fixed
this and that may have been unpatched since......

hoping someone finds and fixes for good.......
david

2010/11/30 CVTECH <email address hidden>

> I have access to qty3 E6410ATGs with the 1280x800 display (reports
> itself as "seiko-epson corporation 14"), only one is experiencing this
> issue and this is after update manager updating from the base Ubuntu
> 10.04.1 installation with 2.6.32-24 kernel. The machine having troubles
> is a core5-i540 vs core5-i520 on the other two machines not having
> troubles.
>
> The symptoms are very similar to post #168. The machine worked fine
> until updating a couple days ago. Included in the update was update from
> kernel 2.6.32-24 to 2.6.32-26 but I suspect this is not the issue for
> reasons I will explain.
>
> I am experiencing similar issues to post #168. At login screen after
> updates including the 2.6.32-26 kernel the blank screen happens.
> Plugging in any external monitor (on Dsub 15 pin, or DisplayPort)
> instantly the internal monitor will come to life. So the workaround is
> to pick the kernel from Grub, wait for the blank screen which would
> normally be the login/welcome screen on Ubuntu, quickly plug in a cable
> (there is about a 5 second window that this works), then unplug the
> cable and now you can take the laptop and walk around the house like you
> wanted to in the first place when you bought a laptop. This is very
> reliable, with about 96 of 100 reboots (hot or cold) able to start the
> internal display by plugging a monitor cable in (Dsub or Displayport,
> doesn't matter). The other 4 reboots vary from won't work (maybe took
> too long to plug) to about 1 in 100 will randomly just boot without
> needing the cable plug procedure!
>
> I note also that the monitor must be present but not required to be
> powered on, an unterminated cable does not have the same effect. So,
> something in the process sees the presence of a new external monitor
> connection and this then triggers the internal monitor to come on (at
> correct resolution) as DP1 and everything is good after that until the
> next reboot, even after disconnecting the external cable.
>
> I suspect something has changed unrelated to the kernel update. The
> reason is that the two machines I have that are working fine one is
> running 2.6.32-24, the other 2.6.32-25. The machine having problems was
> working fine on 2.6.32-24 and started having issues immediately after
> the update (via update manager) that included 2.6.32-26 amongst many
> other things. I removed (via package manager) the 2.6.32-26 kernel image
> and headers and installed the 2.6.32-25. This did not solve the issue
> and now even if I boot (from grub) the old previously working 2.6.32-24
> or the 2.6.32-25 kernel that works on another machine the same issue
> happens on the problem machine, even in recovery mode!
>
> I am reasonably familiar with Ubuntu as a user, but no idea how to
> gather info to track this down. If...

Read more...

partypooper (patrick-monmien) wrote :

Hi there!

Kernel 2.6.37.5-generic that has been released today on kernel-ppa fixes all my issues.

* I can boot without an external monitor and the laptop lcd screen works. Even after a reboot.
* I can boot with an external monitor (attached either via VGA cable or a docking station) and the laptop detects the external monitor fine (although it does not detect it at the correct resolution (monitor is a DELL 24").
Cherry on the top, I tested suspend and resume and it worked.

I have an e6410/i5/intel video card

Looks like I will be able to finally use my laptop.

Could anyone confirm?

Thanks,

Patrick

Mark Buda (hermit) wrote :

Where exactly is this kernel? Apparently I'm incapable of finding it by myself.
--&nbsp;
Mark Buda &lt;<email address hidden>&gt;
I get my monkeys for nothing and my chimps for free.
On Dec 2, 2010 4:41 PM, partypooper &lt;<email address hidden>&gt; wrote:

Kernel 2.6.37.5-generic that has been released today on kernel-ppa fixes

all my issues.

aftertaf (david-wooffindin) wrote :

Patrick / Partypooper:

Where did you get this kernel from exactly?
I can't find it on http://kernel.ubuntu.com/~kernel-ppa/mainline/ ...

Or did you actually get it via apt ? in which case, what is the deb line in your sources.list that gets you this kernel...
I"m also very interested ;)

david

aftertaf (david-wooffindin) wrote :

found it myself.....

deb http://ppa.launchpad.net/kernel-ppa/ppa/ubuntu lucid main

Bear in mind this has been released under the lucid branch, not the maverick
one . . . .

David
About to test

2010/12/2 partypooper <email address hidden>

> Hi there!
>
> Kernel 2.6.37.5-generic that has been released today on kernel-ppa fixes
> all my issues.
>
> * I can boot without an external monitor and the laptop lcd screen works.
> Even after a reboot.
> * I can boot with an external monitor (attached either via VGA cable or a
> docking station) and the laptop detects the external monitor fine (although
> it does not detect it at the correct resolution (monitor is a DELL 24").
> Cherry on the top, I tested suspend and resume and it worked.
>
> I have an e6410/i5/intel video card
>
> Looks like I will be able to finally use my laptop.
>
> Could anyone confirm?
>
> Thanks,
>
> Patrick
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/561802
>
> Title:
> [i915] blank screen on Latitude E6410 (NOT E6510)
>

CVTECH (cvtech) wrote :

Just an update to post #182, I was able to restore functionality only by reinstalling from the 10.04.1 ISO distribution image that had the 2.6.32-24 kernel.

I used meld to compare my two machines running 2.6.32-25, the one that was broken had been updated to 2.6.32-26 by update manager, then I tried to go back to 2.6.32-25. This left slight differences (0.1 rev) in Xorg and Plymouth that maybe were related to this bug. Anyway, there was no way I could find to get back to the state where the internal monitor would come on without plugging in an external monitor, even under previous kernels linked by grub and the recovery modes.

The version of plymouth on the working machine was 0.8.2-2ubuntu2, the broken was 0.8.2-2ubuntu2.1
the version of Xorg on the working machines was xserver-common 2:1.7.6-2ubuntu7.3 and broken version was 7.4. Similarly grub had slight differences version 1.98-1ubuntu7 to 1.98-1ubuntu8. From what I can tell by reading various wikis, hard to image much else video related other than plymouth and xserver is running at the time the splash screen goes dark after grub menu. Plugging in a monitor during the plymouth splash or the login screen instantly would restore the internal display.

Looking forward to hearing some more test reports of the ppa kernel post and bios fix of previous two posts. I may be able to dedicate one machine to testing later this week.

aftertaf (david-wooffindin) wrote :

i've updated the bios to A06, and am using kernel 2.6.37.x (5/7/8) from
kernel ppa.
From what I can tell, it works fine, but I need to test more...
for now I have working screen when not in docking station, and I have cloned
screen with both displays working when in docking station....
but i need to test more to confirm this isn't just a fluke....
david

2010/12/7 CVTECH <email address hidden>

> Just an update to post #182, I was able to restore functionality only by
> reinstalling from the 10.04.1 ISO distribution image that had the
> 2.6.32-24 kernel.
>
> I used meld to compare my two machines running 2.6.32-25, the one that
> was broken had been updated to 2.6.32-26 by update manager, then I tried
> to go back to 2.6.32-25. This left slight differences (0.1 rev) in Xorg
> and Plymouth that maybe were related to this bug. Anyway, there was no
> way I could find to get back to the state where the internal monitor
> would come on without plugging in an external monitor, even under
> previous kernels linked by grub and the recovery modes.
>
> The version of plymouth on the working machine was 0.8.2-2ubuntu2, the
> broken was 0.8.2-2ubuntu2.1
> the version of Xorg on the working machines was xserver-common
> 2:1.7.6-2ubuntu7.3 and broken version was 7.4. Similarly grub had slight
> differences version 1.98-1ubuntu7 to 1.98-1ubuntu8. From what I can tell by
> reading various wikis, hard to image much else video related other than
> plymouth and xserver is running at the time the splash screen goes dark
> after grub menu. Plugging in a monitor during the plymouth splash or the
> login screen instantly would restore the internal display.
>
> Looking forward to hearing some more test reports of the ppa kernel post
> and bios fix of previous two posts. I may be able to dedicate one
> machine to testing later this week.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/561802
>
> Title:
> [i915] blank screen on Latitude E6410 (NOT E6510)
>

Philip Aston (philipa) wrote :

@aftertaf: please explain which kernel you are using from the ppa. (To what does "5/7/8" refer?)

I tried 2.6.37-020637rc2, but no joy.

The only kernel I've found that does not suffer from the black screen problem is 2.6.32-21 from the Lucid repository. I tried later versions of that kernel (-25, -26), but they failed too. FWIW, I'm separately using 2.6.32-25 on an e6400 to avoid the black screen after resume issue.

(e6410, Intel i915, A06 BIOS, maverick).

aftertaf (david-wooffindin) wrote :

yep :
2.6.37-5
2.6.37-7
2.6.37-8
from the lucid backports ...
however, it still doesn't work every time (4 tries yesterday before it
booted with screen)

2010/12/12 Philip Aston <email address hidden>

> @aftertaf: please explain which kernel you are using from the ppa. (To
> what does "5/7/8" refer?)
>
> I tried 2.6.37-020637rc2, but no joy.
>
> The only kernel I've found that does not suffer from the black screen
> problem is 2.6.32-21 from the Lucid repository. I tried later versions
> of that kernel (-25, -26), but they failed too. FWIW, I'm separately
> using 2.6.32-25 on an e6400 to avoid the black screen after resume
> issue.
>
> (e6410, Intel i915, A06 BIOS, maverick).
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/561802
>
> Title:
> [i915] blank screen on Latitude E6410 (NOT E6510)
>

Changed in linux:
importance: Medium → Unknown
status: Confirmed → Fix Released
Mark Russell (marrusl) wrote :

Confirmed to be working on Natty as of Jan 25.

Also confirmed that Maverick works with this kernel from the drm-intel-next PPA:
http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/current/linux-image-2.6.38-997-generic_2.6.38-997.201101250912_i386.deb

Now that Natty has 2.6.38 and an updated X stack, I will try to get a restest.

Mark Russell (marrusl) wrote :

What does the above result say about the chances of backporting the fix to Lucid and/or Maverick? Does this suggest that an eventual kernel backport will work? Or will having a new kernel but an older X stack be an issue?

Thanks.

Chris Halse Rogers (raof) wrote :

Backporting the fix as an SRU to the Lucid or Maverick kernels is unlikely to fly, as there's simply been too many patches over too many kernel releases for it to be easy to extract a minimal safe fix.

There should be no problems with using the Natty kernel on an otherwise Lucid or Maverick system, though, and for Lucid at least I think this should be possible with the lts-backport kernels.

I have an E6410 ATG with i7-640M running Maveric with kernel and xorg from
xorg-edgers. The 2.6.38-1 kernel seems to solve all the addressed issues.

Oddbjørn Hansen

2011/2/2 Chris Halse Rogers <email address hidden>

> Backporting the fix as an SRU to the Lucid or Maverick kernels is
> unlikely to fly, as there's simply been too many patches over too many
> kernel releases for it to be easy to extract a minimal safe fix.
>
> There should be no problems with using the Natty kernel on an otherwise
> Lucid or Maverick system, though, and for Lucid at least I think this
> should be possible with the lts-backport kernels.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/561802
>
...

aftertaf (david-wooffindin) wrote :

Do you have the apt:add link?
On Feb 3, 2011 9:31 AM, "Oddbjørn Hansen" <email address hidden> wrote:
>
> I have an E6410 ATG with i7-640M running Maveric with kernel and xorg from
> xorg-edgers. The 2.6.38-1 kernel seems to solve all the addressed issues.
>
>
> Oddbjørn Hansen
>
>
>
> 2011/2/2 Chris Halse Rogers <email address hidden>
>
> > Backporting the fix as an SRU to the Lucid or Maverick kernels is
> > unlikely to fly, as there's simply been too many patches over too many
> > kernel releases for it to be easy to extract a minimal safe fix.
> >
> > There should be no problems with using the Natty kernel on an otherwise
> > Lucid or Maverick system, though, and for Lucid at least I think this
> > should be possible with the lts-backport kernels.
> >
> > --
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> > https://bugs.launchpad.net/bugs/561802
> >
> ...
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/561802
>
> Title:
> [i915] blank screen on Latitude E6410 (NOT E6510)

Download full text (5.5 KiB)

Take a look at https://launchpad.net/~xorg-edgers/+archive/ppa

*ppa:xorg-edgers/ppa*

2011/2/3 aftertaf <email address hidden>

> Do you have the apt:add link?
> On Feb 3, 2011 9:31 AM, "Oddbjørn Hansen" <email address hidden>
> wrote:
> >
> > I have an E6410 ATG with i7-640M running Maveric with kernel and xorg
> from
> > xorg-edgers. The 2.6.38-1 kernel seems to solve all the addressed issues.
> >
> >
> > Oddbjørn Hansen
> >
> >
> >
> > 2011/2/2 Chris Halse Rogers <email address hidden>
> >
> > > Backporting the fix as an SRU to the Lucid or Maverick kernels is
> > > unlikely to fly, as there's simply been too many patches over too many
> > > kernel releases for it to be easy to extract a minimal safe fix.
> > >
> > > There should be no problems with using the Natty kernel on an otherwise
> > > Lucid or Maverick system, though, and for Lucid at least I think this
> > > should be possible with the lts-backport kernels.
> > >
> > > --
> > > You received this bug notification because you are a direct subscriber
> > > of the bug.
> > > https://bugs.launchpad.net/bugs/561802
> > >
> > ...
> >
> > --
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> > https://bugs.launchpad.net/bugs/561802
> >
> > Title:
> > [i915] blank screen on Latitude E6410 (NOT E6510)
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/561802
>
> Title:
> [i915] blank screen on Latitude E6410 (NOT E6510)
>
> Status in The Linux Kernel:
> Fix Released
> Status in “linux” package in Ubuntu:
> Triaged
> Status in “linux” source package in Lucid:
> In Progress
> Status in “linux” source package in Maverick:
> New
>
> Bug description:
> Binary package hint: xorg
>
> NOTE: The E6410 and E6510 have different hardware. There's a bug with
> similar *symptoms* but a *different cause* on E6510+intel hardware,
> which is bug #600453.
>
> During installation, bootup (plymouth) and while inside X, screen
> remains blank. Switching VTs yields no results (screen remains blank).
>
> This was done with today's daily desktop image, amd64: 10.04
> (20100412).
>
> I've been able to isolate the issue to possibly somewhere in
> modesetting with the i915 driver, here are the tested cases:
>
> - Disabling modesetting with 'nomodeset' as a kernel parameter: boot
> messages visible in 'verbose', otherwise nothing on screen, X remains blank.
> - Disabling modesetting with 'i915.modeset=0' as a kernel parameter:
> results in a kernel oops, after briefly showing a simple "text" splash and
> showing corruption of that splash screen. X clearly never comes up,
> caps/scroll/num blink.
> - Disabling modesetting with 'nomodeset' and switching X drivers to
> 'vesa': nothing on screen during boot, up to a working, visible desktop.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.04
> Package: xorg 1:7.5+5ubuntu1
> ProcVersionSignature: Ubuntu 2.6.32-20.29-generic 2.6.32.11+drm33.2
> Uname: Linux 2.6.32-20-generic x86_64
> Architecture: amd64
> Date: Mon Apr 12 16:14:04 2010
> DkmsStatus: Error: [Errno 2] No such file or directory
> GdmLog:
> Error: co...

Read more...

Changed in linux:
importance: Unknown → Medium
Andy Whitcroft (apw) wrote :

In the upstream bug Jesse provides a 2.6.38 based backport of an upstream fix. I have pulled this into a Natty kernel. Could those of you affected by the black screen on boot try the kernels below and report back here. The kernels are at the URL below:

    http://people.canonical.com/~apw/lp561802-natty/

Please report back here. Thanks.

Andy Whitcroft (apw) on 2011-02-16
Changed in linux (Ubuntu):
status: Triaged → Incomplete
assignee: nobody → Andy Whitcroft (apw)
Alfe (alfeberlin) wrote :

Andy, I tested the kernel located at http://people.canonical.com/~apw/lp561802-natty/ on my Dell Latitude E6510, 2GB, 64bit, Intel graphics. My distribution is Ubuntu 10.10.

First: Your version seems to be working fine. No issues whatsoever up to now. I'm booting and using it with an external second monitor attached via the display port (resolution: 1600x1200). I will add another report here in some minutes regarding a boot without a second monitor.

I also tested all other kernel versions discussed here which were coming as a .deb package ready for download (i. e. I did not test all patch versions). Before the kernel pointed to by you I was using a .35 kernel. With 2.6.38-997.201102020913 and 2.6.38-997.201102081238 I had stability issues after some minutes (without a second monitor after some hours): X just crashed and I had to relogin. I was under the impression that it had trouble handling X sessions with a lot of stuff going on, maybe memory leaks.

No such issues with the 2.6.38-4-generic_2.6.38-4.31~lp561802v201102162013 now. I tried to crash it by opening about a hundred windows, using fancy Compiz extensively, running flash applications, Youtube videos, 3D applications etc. but to no avail :) Uptime now is 44 minutes and everything seems to be just fine.

Also suspend/resume worked without issues. I did not test hibernate (to disk).

I will check booting without a second monitor now, just to make sure, and report back here.

Alfe

Alfe (alfeberlin) wrote :

Andy,

I rebooted without a second monitor and redid my tests (quickly). No problem found. I attached the second monitor on the fly. Detection worked fine, no issues to report.

What I like most is that I'm now able to suspend/resume the laptop.

Thanks a lot for your effort!

Alfe

Timo Jyrinki (timo-jyrinki) wrote :

The kernel fixes the problem both for one E6410 user and two E6510 users.

Steven Yelton (steveny) wrote :

I can confirm the above kernel fixes my video/suspend issues on my E5610 (I know, NOT E6510). I still have these workarounds in place:

-add acpi_sleep=s3_bios to the Grub commandline
-delete /usr/lib/pm-utils/sleep.d/99video and /usr/lib/pm-utils/sleep.d/98video-quirk-db-handler

I'm not sure if it is needed or recommended, but I'm leaving well enough alone for now.

Andy Whitcroft (apw) on 2011-02-17
Changed in linux (Ubuntu):
status: Incomplete → In Progress

I have been working on a customer case about this exact issue.

I have just asked him to try the natty kernel with 10.10, and will report his findings as soon as possible.

Philip Aston (philipa) wrote :

Kernel at http://people.canonical.com/~apw/lp561802-natty/ works well for me (e6410, Intel i915, A06 BIOS, 64-bit maverick).

One issue: if I suspend and resume with the external display connected, I get intense flickering on both displays. I found I could work around this by turning the laptop display off, switching to a vt and back, then turning the laptop display back on.

Otherwise, I'm very happy. Thanks to all of you who have worked on this.

aftertaf (david-wooffindin) wrote :

I've been using kernel 2.6.38.2 since maybe 3 weeks, and I'm really happy
about the stability with the video.

However, I'm having issues now with the wireless, being really really slow
and dropping out.
Has anyone else had this type of issue ?
david

On 17 February 2011 22:26, Moustafa Chamli <email address hidden>wrote:

> I have been working on a customer case about this exact issue.
>
> I have just asked him to try the natty kernel with 10.10, and will
> report his findings as soon as possible.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/561802
>
> Title:
> [i915] blank screen on Latitude E6410 (NOT E6510)
>

Andy Whitcroft (apw) wrote :

Ok the commit tested here is now scheduled for application to 2.6.38, in the meantime I am pulling it into the Natty kerenel and it should be in the next upload. Fix Committed. Thanks all for your testing.

Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Alfe (alfeberlin) wrote :

After testing now for a second day, no stability issues (X crashes) to report (which is a great relief!).

One issue found: I suspended at work with a second monitor attached, then unplugged the second monitor, went home, tried to resume without a second monitor, got a black screen with backlight. Switching to other consoles worked, but switching back to X just restored the black screen. So I could kill and restart my X from another console, so rebooting wasn't necessary, but of course the session was lost.

I can prevent running into this problem by either unplugging the second monitor (and quickly reconfiguring the X for single-display) before suspending or maybe (didn't test this) by attaching another second monitor before resuming, so there is a workaround.

Cheers, Alfe

Jeremy LaCroix (j-jlacroix) wrote :

Hi David, for the wireless speed issue, I reported the following bug:
https://bugzilla.kernel.org/show_bug.cgi?id=29072

Right now I'm seemingly the only one with the problem, so if what happens to me is the same as what happens to you, please add your comments to that bug report, it would help alot.

aftertaf (david-wooffindin) wrote :

I will. Going skiing this evening so May not test soon... but i will.
Le 18 févr. 2011 14:11, "Jeremy LaCroix" <email address hidden> a
écrit :
> Hi David, for the wireless speed issue, I reported the following bug:
> https://bugzilla.kernel.org/show_bug.cgi?id=29072
>
> Right now I'm seemingly the only one with the problem, so if what
> happens to me is the same as what happens to you, please add your
> comments to that bug report, it would help alot.
>
> ** Bug watch added: Linux Kernel Bug Tracker #29072
> http://bugzilla.kernel.org/show_bug.cgi?id=29072
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/561802
>
> Title:
> [i915] blank screen on Latitude E6410 (NOT E6510)
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/linux/+bug/561802/+subscribe

Chris Van Hoof (vanhoof) on 2011-02-18
tags: added: hwe-blocker
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.38-5.32

---------------
linux (2.6.38-5.32) natty; urgency=low

  [ Andy Whitcroft ]

  * rebase to mainline 6f576d57f1fa0d6026b495d8746d56d949989161
  * [Config] updateconfigs following rebase to v2.6.38-rc6
  * [Config] enable CONFIG_DMAR
    - LP: #552311

  [ Upstream Kernel Changes ]

  * drm/i915: skip FDI & PCH enabling for DP_A
    - LP: #561802, #600453, #681877

  [ Major Kernel Changes ]

  * rebase from v2.6.38-rc5 to v2.6.38-rc6
    - LP: #718402
    - LP: #719524
    - LP: #721126
    - LP: #719691
    - LP: #722689
    - LP: #722310
 -- Andy Whitcroft <email address hidden> Tue, 22 Feb 2011 13:28:39 +0000

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Michael (michaeljt) wrote :

I see something which looks like the issue described here (E6410 with i915, Maverick 64bits, black screen after resume). Unlike other subscribers this affects me with 2.6.35-27-generic, but *did not affect me* with 2.6.25-22-generic. (I only got the laptop a few days ago, so I didn't try anything in-between.) I am currently running 2.6.25-22-generic which has been successfully suspended and resumed twice since I booted it. Have any other subscribers seen anything similar, or is anyone aware of a ticket that matches what I am seeing better? It would be nice to have an idea of which kernel (and changeset) is responsible, but I don't feel like researching it myself if someone else has before me.

Ludovic (ludovic-aelbrecht) wrote :

So according to comment 211, this bug is fixed as of version 2.6.38-5.32 of the package "linux". I looked around a bit, and the latest build I can find of that package (for amd64) is https://launchpad.net/ubuntu/+source/linux/2.6.38-7.39/+buildjob/2344157.

But all of those .deb files are built for Natty, not for e.g. Ubuntu 10.10 (which is what I'm using). So how can I get this fix on my system:
- Just install them anyway and hope they'll work?
- Wait for a backport of this fix to Ubuntu 10.10? If so, how can I see when (approximately) such a backport will be done?

Thanks,
Ludovic

Michael (michaeljt) wrote :

Or use the backported Lucid packages which might (but that is just a guess on my part) be more tested than the Natty ones.

aftertaf (david-wooffindin) wrote :

Google for kernel ppa ubuntu and apt-get the new debs...
 Le 27 mars 2011 08:06, "Ludovic" <email address hidden> a écrit :
> So according to comment 211, this bug is fixed as of version 2.6.38-5.32
> of the package "linux". I looked around a bit, and the latest build I
> can find of that package (for amd64) is
> https://launchpad.net/ubuntu/+source/linux/2.6.38-7.39/+buildjob/2344157.
>
> But all of those .deb files are built for Natty, not for e.g. Ubuntu 10.10
(which is what I'm using). So how can I get this fix on my system:
> - Just install them anyway and hope they'll work?
> - Wait for a backport of this fix to Ubuntu 10.10? If so, how can I see
when (approximately) such a backport will be done?
>
> Thanks,
> Ludovic
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/561802
>
> Title:
> [i915] blank screen on Latitude E6410 (NOT E6510)
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/linux/+bug/561802/+subscribe

Changed in linux (Ubuntu Maverick):
status: New → Triaged
importance: Undecided → Medium
Seth Forshee (sforshee) wrote :

I backported the fix from natty to maverick (along with several other things required by the fix). I've posted kernel builds at

http://people.canonical.com/~sforshee/lp681877/

The backport was a little tricky, so I'm not really sure whether it is completely correct or if there's any chance of getting this into a maverick SRU due to the amount of changes required. Testing is appreciated. Please report results back here.

Konstantyn K. (uncombined) wrote :

Hi everybody,
I got Dell Latitude E6410 with Intel HD and Chi Mei Optoelectronics corp. 14 display, and also got all problems described above. Hasn't any luck with resolution on 11.04.
But upgrade to alpha 11.10 oneric resolved mostly all issues. If work fine without nomodeset.
I think Intel 2011Q1 graphics package update which was added to kernel 2.6.39 is a fix for this problem. Even sleep mode works fine.

Only one issue I found in oneric - system goes to black screen under Unity when second monitor connected to VGA port. But same action works normal under KDE.

Has the fix been included into Oneiric's kernel? Just tried the daily build and it still won't activate my screen.

Ayan George (ayan) on 2011-08-31
tags: added: blocks-hwcert-enablement
James M. Leddy (jm-leddy) wrote :

Has anyone running Maveick tried http://people.canonical.com/~sforshee/lp681877/ ? If that works, then we can include this in the Maverick kernel and close this bug out.

Changed in linux (Ubuntu Maverick):
status: Triaged → Incomplete
Bagshot (bagshot2001-2012) wrote :

This problem is also being exhibited on a Dell Latitude X300 laptop (Intel 855GM chipset), standard 10.04 LTS release crashes in GUI applications after coaxing it to boot with i915.modeset=0 and annoyingly I can't run most 12.04 releases due to no PAE support. Would much rather have Gnome 2 10.04 than Lubuntu :(

ki0s (lockakey) wrote :

I have the same issue as all previous posters.
Attempting to install BackTrack5r3 onto a Dell E6410 with Intel Graphics (Model pp27LA)
When attempting to "startx" on a Live USB BT5r3 the monitor goes completely blank.
Kernel panics indicated by consistent flashing blue battery and wifi icons.

I have researched online for the past 3-4 hours and read through the 220 previous comments.
I am fairly new to troubleshooting linux/ubuntu.

So is there a solution to help me with this installation?
I just figured out that I can go into the YUMI liveUSB bootloader and press tab to edit the boot lines for backtrack

I just need to add, "nomodeset" to the end of the line after init.??

Any help very very appreciated!

ki0s (lockakey) wrote :

Ok... So

After about 12 tries I am able to boot into BT5r3 with my DellE6410 intel video card WITH LIT KEYBOARD

i replaced the yumi boot loader from text splash etc. to show only

"nomodeset quiet xforcevesa"

shows errors on boot but very quickly loads into the x and from what I can see supports good resolution.

I am considering just adding this line to the cfg of my yumi loader

Are there other fixes or sudo apt I should run?

Changed in linux (Ubuntu Maverick):
status: Incomplete → Won't Fix
Changed in linux (Ubuntu Lucid):
status: In Progress → Won't Fix
Displaying first 40 and last 40 comments. View all 222 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.