[iwlagn] Network card keeps dropping the connection

Bug #525902 reported by Jono Bacon on 2010-02-22
114
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Linux
New
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Nominated for Maverick by Marc Reichelt
Lucid
Undecided
Unassigned

Bug Description

In Lucid (all packages up to date as of 21st Feb 2010) my wireless connection keeps dropping and selecting the same network again or disconnect and selecting it again in NetworkManager does not bring it back. I suspect this is kernel based. This worked fine a few weeks in the Lucid cycle and fine in Karmic.

ProblemType: Bug
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.21.
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jono 1785 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfc020000 irq 17'
   Mixer name : 'Conexant CX20561 (Hermosa)'
   Components : 'HDA:14f15051,17aa211c,00100000'
   Controls : 14
   Simple ctrls : 7
Date: Mon Feb 22 09:28:22 2010
DistroRelease: Ubuntu 10.04
Frequency: Once a day.
HibernationDevice: RESUME=UUID=0855cc78-bed8-4eaf-b6a3-0d2a68c3c8d3
MachineType: LENOVO 7417CTO
Package: linux-image-2.6.32-14-generic 2.6.32-14.20
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-14-generic root=UUID=d0c0ae51-5326-4259-8fa7-82f0ddc8e582 ro quiet splash
ProcEnviron:
 LANGUAGE=C
 LANG=C
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
Regression: Yes
RelatedPackageVersions: linux-firmware 1.30
Reproducible: No
SourcePackage: linux
TestedUpstream: No
Uname: Linux 2.6.32-14-generic i686
dmi.bios.date: 01/09/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 7UET56WW (2.02 )
dmi.board.name: 7417CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr7UET56WW(2.02):bd01/09/2009:svnLENOVO:pn7417CTO:pvrThinkPadT400:rvnLENOVO:rn7417CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 7417CTO
dmi.product.version: ThinkPad T400
dmi.sys.vendor: LENOVO

Jono Bacon (jonobacon) wrote :
Jono Bacon (jonobacon) wrote :

I forgot to mention: this issue does not seem to affect Wired or Mobile connections (namely tethering over a N900 and a Verizon 3G dongle).

Chase Douglas (chasedouglas) wrote :

@Jono:

Can you confirm whether the CurrentDMesg.txt attachment shows the disconnecting issue you see? It represents the dmesg when you filed the bug. If not, can you attach a dmesg taken after the disconnecting issue so we can see any info logged in it?

Thanks

Changed in linux (Ubuntu):
status: New → Incomplete
Jono Bacon (jonobacon) wrote :

I just waited for it to drop and immediate dumped dmesg output into a file. This is attached.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Jeremy Foshee (jeremyfoshee) wrote :

Jono,
      I may have found something that could help you. Is there anything like vPRO/AMT in your BIOS? Per Intel: "iwlagn currently doesn't support AMT, which is another user for the same hardware. At this time, the only way we can do is to disable it." So you may want to see if it is there and disable it. If that does fix it, then we may have some regression that I need to dig up.

-JFo

Jono Bacon (jonobacon) wrote :

Thanks, Jeremy. So it turns out that I do have an AMT option in the BIOS that was enabled. I have now disabled it and I will see how I get on.

Jono Bacon (jonobacon) wrote :

Tt turns out that despite switching AMT off, the problem is still present.

Chase Douglas (chasedouglas) wrote :

@Jono:

Please try the upstream mainline kernel to see if it's any better. Packages can be found at: http://kernel.ubuntu.com/~kernel-ppa/mainline/. Please try the latest 2.6.33 kernel.

If that doesn't help, the next thing to try would likely be asking for support from the linux wireless community: http://linuxwireless.org/en/users/Support. We don't really have enough expertise to figure out where an issue may lie without detailed info like a kernel OOPS statement.

Tim Gardner (timg-tpi) on 2010-03-08
Changed in linux (Ubuntu Lucid):
assignee: nobody → Tim Gardner (timg-tpi)
status: Confirmed → In Progress
Jono Bacon (jonobacon) wrote :

Tim recommended on IRC that I install linux-backports-modules-wireless-lucid-generic and see if this resolves it. Just installed, I will see how I get on.

Jono Bacon (jonobacon) wrote :

OK, so I have been running the card all day and while it seems to be better, it has dropped out a few times, requiring me to reboot as usual to get connected again. Sorry, folks!

Tim Gardner (timg-tpi) wrote :

Jono - when it gets in that state, how about trying to toggle your RF kill state:

sudo rfkill block wifi
sudo rfkill unblock wifi

Jono Bacon (jonobacon) wrote :

Thanks, Tim. I tried that when it hung last: it never brought wireless back. Sorry!

Tim Gardner (timg-tpi) wrote :

OK - next thing to try is to remove the driver, then re-install e.g.,

dmesg > dmesg-before.txt
sudo modprobe -r iwlagn
sleep 15 # Give NetworkManager time to notice
sudo modprobe iwlagn
dmesg > dmesg-after.txt

Attach both dmesg files along with your perception of the results, i.e., did it change the behavior or fix the connection?

Beyond (3volution3) wrote :

I have same problem disconnecting after a while with my university internet.
In their config page they say to use PEAP but as I was tired of getting disconnected so I messed up with connection options a bit and found out that if I use Tunneling TLS I don't disconnect anymore.
Give it a try to see if it's because of PEAP bug.

Dominik (dominalien) wrote :

I seem to have the same issue with Lucid. I'm using a Netgear WNDA3100 USB dongle which works using the ar9170usb driver. After some time (from 5 minutes to a couple of hours) the connection will drop and scanning for wireless networks will produce no more results. In my case, rebooting has no effect. The thing that cures the problem is unplugging the USB dongle and replugging it - voila, instant connection.

I believe this is due to Network Manager. Uninstalling network-manager and network-manager-gnome and configuring wpa_supplicant by hand has given me a stable connection since this morning (it's never lasted this long so far).

Jono Bacon (jonobacon) wrote :

Tim, do you still want me to use linux-backports-modules-wireless-lucid-generic?

Chase Douglas (chasedouglas) wrote :

It would be helpful if someone could follow the instructions provided by Tim in comment #13 and attach the appropriate dmesg logs.

Also, there may be fixes in the latest 2.6.34 kernel that is being developed. If someone could test out the Ubuntu mainline package for that kernel it may help us find a fix. The package can be found at http://kernel.ubuntu.com/~kernel-ppa/mainline/.

Thanks

Stefan Bader (smb) wrote :

@Jono, I might misunderstand, but somehow comments #9 and #10 sounded to me like you had l-b-m-w installed. If not, yes, if you could install that and compare the results.

@Dominik, could you file a new bug please. It might turn out its the same bug, but then we could dup them. But for the initial stage its better to keep different hardware/drivers separate. Thanks.

summary: - Network card keeps dropping the connection
+ [iwlagn] Network card keeps dropping the connection
Stefan Bader (smb) wrote :

There seems to be a related bug (https://bugs.edge.launchpad.net/ubuntu/+source/linux/+bug/544254) on the same driver. But there it seems to immediately reconnect.

Jono Bacon (jonobacon) wrote :

OK, so I had uninstalled linux-backports-modules-wireless-lucid-generic and the two dmesg logs are attached.

Jono Bacon (jonobacon) wrote :
Stefan Bader (smb) wrote :

I hope I am not misinterpreting... But the dmesg has also this entries:

[ 5171.417046] pciehp 0000:00:1c.1:pcie04: Card not present on Slot(1)
[ 5171.421651] pciehp 0000:00:1c.1:pcie04: Card present on Slot(1)

00:1c.1 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 [8086:2942] (rev 03
Bus: primary=00, secondary=03

03:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection [8086:4237]

So, could it be that in addition to other problems, the connection of the wireless card is loose? Later messages in the log seem to indicate that the card is deep sleep state. But that might just be a side-effect of the card itself being flaky.

Would there be a chance for you to check on the physical connection of the wireless card? Sometimes it can be reached by some service covers from the bottom.

Jono Bacon (jonobacon) wrote :

Stefan, nothing seems to be loose: and everything was working great in Karmic.

I am now going to have a crack at testing the mainline kernel.

Jono Bacon (jonobacon) wrote :

I tried testing the 2.6.34-020634rc1 package and it would not boot form me. Running the 2.6.33 package now - will see how I get on.

Jono Bacon (jonobacon) wrote :

OK, it just dropped again. dmesg files attached.

Jono Bacon (jonobacon) wrote :
Jono Bacon (jonobacon) wrote :
Jono Bacon (jonobacon) wrote :

I am wondering if these bugs are related:

 * https://bugs.edge.launchpad.net/linux/+bug/388014 is related to this bug?
 * https://bugzilla.redhat.com/show_bug.cgi?id=529153

Hey Jono,

As Stefan pointed out, the following repeated messages seem suspicious:

[ 299.564596] pciehp 0000:00:1c.1:pcie04: Card not present on Slot(1)
[ 299.569738] pciehp 0000:00:1c.1:pcie04: Card present on Slot(1)

How long does it usually take for your network connection to drop after you've booted? Could you try to go back and test with Karmic just so we can eliminate it's not failing hardware etc. You mentioned you didn't think the card was loose. Assuming Karmic doesn't exhibit this issue, can you try the latest 2.6.34-rc3 based kernel I've thrown in my PPA (https://edge.launchpad.net/~leannogasawara/+archive/ppa/+packages linux-2.6.34-1.2~oga1). That way we can either escalate the issue upstream or start a bisect to figure out where the fix lies. Thanks in advance.

Hans (klein-hans) wrote :

Hello you all,
I have the same issue with lucid (same in karmic) and networkmanager dropping the wireless connection (iwl3945 card). Possible cause is networkmanager itself, replacing networkmanager with wicd solved the problem (don't forget to uninstall networkmanager!).

Ed (kokko1) wrote :

I also have had problems with networkmanager dropping my wireless connection. Per recommendation by Hans (comment #32), I installed wicd and uninstalled networkmanager. It has been 2 days and I haven't had any problems with my connection dropping. Thanks for the suggestion.

Sebastian Geiger (lanoxx) wrote :

Hi, I am also experiencing this bug. Sometimes my wireless connection gets dropped and I am unable to reconnect, despite clicking on the accesspoint name in networkmanager. Networkmanager shows the two dots, but only one of the is green, the otherone never gets green and it does not connect. I have tried serval things:
1. switching to suspend and resuming
2. opening the wireless options and edit the connection, change nothing, save, try again
3. toggeling the killswitch

in option two I often notice that the mentioned wireless accesspoint has a status of: 'Never' in the last connected column. Even though it was just connected a few minutes ago.

While writing this the issue occured again, I tried option two without success.
Then after suspend/resume I could connect again.
dmesg attached.

Sebastian Geiger (lanoxx) wrote :

wlan_dmesg is before suspending/resuming (when unable to connect)
wlan_dmesg is afterwards (when connected to the ap)

Toma (tomhaste) wrote :

This also effects me. Online gaming is now impossible. Worked perfect in Karmic.

Toma (tomhaste) wrote :

Ive got back to the karmic kernel that was left over from my upgrade. The problem still persists. Ive run 'ping -i 1 192.168.0.1' and found it drops for ~40 seconds when it does drop. The wifi point hasnt changed in the last 6 hours since upgrading and the laptop is still sitting in the same place. Im also using the karmic version of wicd to connect, as the lucid version does not work. My next point of call is tinkerign with wpa_supplicant as that would be the next link in the chain...

Carl Richell (carlrichell) wrote :

This may be related to a problem with Intel 5100 (5XXX series?) wireless cards connecting to wireless APs via 802.11n. Does changing your router to "BG" or "G" fix the problem?

Sven Rinke (sr12) wrote :

I have an Intel 5000 card and can't get a stable connection when my router is in N-mode. Running in B/G-mode works fine. The problem first appeared after upgrading to 10.04.

Matt Davey (mcdavey) wrote :

I had symptoms similar to this (intel 4965 AGN) and resolved by replacing NetworkManager with wicd. No further problems.

Mehul J. Rajput (mehulrajput) wrote :

Agree with #42. It does not seem to be a kernel related problem. Seems the NetworkManager software is having some issue, I installed wicd and it is working like a charm on the same connection. NetworkManager was reconnecting every 3 minutes.

Adding NetworkManager software to the bug makes sense.

krahim (karim-rahim) wrote :

I use gnome network manager and currently I have brief drops and reconnects with both wired and wireless connections. Does anyone else have similar problems with wired?

I had a simular problem with wired.
It seems that the problem has solved itself in some way.

bpowell (bpowell2008) wrote :

Hello,

Running Ubuntu Lucid fully upgraded, had this same problem; wireless would drop, I'd get the two "balls" only one green, system would search for a network forever...killing wireless would not help...sometimes stopping and starting the network-manager service would fix it, but not always. I've since had to move to a custom kernel for an unrelated standby / recovery issue...so I'm afraid I won't be able to contribute much here (given I'm running a non-standard build now) however, I just removed network-manager and installed wicd...so far, so good! I'll keep you posted. Hope to see this fixed in an upgrade down the road.

Tim Gardner (timg-tpi) on 2010-08-30
Changed in linux (Ubuntu):
assignee: Tim Gardner (timg-tpi) → nobody
status: In Progress → Triaged
Changed in linux (Ubuntu Lucid):
assignee: Tim Gardner (timg-tpi) → nobody
status: In Progress → Triaged
Saint DanBert (saintdanbert) wrote :

See bug #604175 and #545708. They seems to speak to the same issues.

I posted comments and a syslog extract under the #604175 bug.

~~~ 0;-Dan

Marc Reichelt (mreichelt) wrote :

I am experiencing this bug, too. The connection seems to be more unstable in my university network than at home. I guess the reason could be that there are multiple accesspoints with the same ESSID - which seems reasonable because of the multiple mac addresses in my dmesg. So I think this should be a bug in network manager.

dmbfan2007 (dmbfan2007) wrote :

Add me to the list with a ThinkPad L512. Ubuntu 10.10 with 2.6.32-25-generic.
lspci --nn (shortened):
03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8191SEvB Wireless LAN Controller [10ec:8172] (rev 10)

This is definitely an annoying one :-(

Thorsten K (thortekrause) wrote :

Have the same problem.
Looks like a gnome-network-manager bug.
bpowell's tip to use WICD insteda works very good.
no more wifi instability...

Bucky Ball (buckyball) wrote :

Having similar problem with Realtek RTL8191SEvB on 10.10, kernel 2.6.35-24. All runs fine but signal strength randomly drops to 56%, speed not quite 1Mbps ALL the time while the other three machines in the house are getting 10Mbps +. When signal strength drops, network activity seems to stop also. I'm thinking this might be somehow related to this bug.

Toshiba Satellite Pro L510.

Bucky Ball (buckyball) wrote :

PS: Wired flies, 10Mbps +. Only effecting wireless. :)

tags: removed: regression-potential

I just installed 64-bit 10.04 onto an IBM ThinkPad W500, and I was having the same network-manager related problem, which was resolved by switching to wicd as suggested in comment #46.

The important snippet from lspci -v is:

03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection
        Subsystem: Intel Corporation Device 1211
        Flags: bus master, fast devsel, latency 0, IRQ 30
        Memory at f4300000 (64-bit, non-prefetchable) [size=8K]
        Capabilities: [c8] Power Management version 3
        Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable+
        Capabilities: [e0] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting <?>
        Capabilities: [140] Device Serial Number b6-df-4d-ff-ff-5d-21-00
        Kernel driver in use: iwlagn
        Kernel modules: iwlagn

Also, here are the details from iwconfig in case they matter:

wlan0 IEEE 802.11abgn ESSID:<ESSID>
          Mode:Managed Frequency:2.462 GHz Access Point: 00:1A:1E:64:20:62
          Bit Rate=54 Mb/s Tx-Power=15 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=67/70 Signal level=-43 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

I'd like to switch back to network-manager, since it has 802.1X support for wired connections that wicd lacks, so it would be nice to see some activity on this bug. What information is required at this point in order to proceed? I am very willing to try to help outside of work hours.

Brendan_P (brendan-p) wrote :

Hi All,

Also willing to test as this is a daily problem for me having to resort to restarts to get it fixed... each time...

Thanks for the time and effort.

Cheers
Brendan

Jono Bacon, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p linux <replace-with-bug-number>

Also, could you please test the latest upstream kernel available following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Please do not test the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-v3.11

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

tags: added: bios-outdated-3.24-3.25 regression-release
Changed in linux (Ubuntu):
status: Triaged → Incomplete
affects: network-manager → linux
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in linux (Ubuntu Lucid):
status: Triaged → Won't Fix
Po-Hsu Lin (cypressyew) wrote :

Closing this bug with Won't fix as this kernel / release is no longer supported.
Please feel free to open a new bug report if you're still experiencing this on a newer release (Bionic 18.04.3 / Disco 19.04)
Thanks!

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.