Ubuntu

[lucid] rt2860 frequently fails to connect to mixed mode WPA/WPA2 secured wireless networks

Reported by Matt Drake on 2009-12-13
This bug affects 219 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
Undecided
Unassigned
Release Notes for Ubuntu
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned
Lucid
High
Unassigned
linux-backports-modules-2.6.32 (Ubuntu)
Undecided
Unassigned
Lucid
High
Unassigned

Bug Description

SRU Justification for Lucid for linux-backports-modules-2.6.32:

The change adds a new version of the rt2860sta and rt2870sta drivers to the linux-backports-modules-wireless package. The drivers did not exist before, so there is no regression potential due to them. If the drivers fail to work properly, the user can just remove the package and use the stock drivers.

Note: To get the backported driver:
# aptitude install linux-backports-modules-wireless-lucid-generic

=====

The rt2860sta module, included with Ubuntu Lucid Lynx (10.04) cannot connect to mixed WPA/WPA2 networks.
This driver is used in most EeePCs.
This issue is fixed in the 2.6.33 kernel, unfortunately this kernel is not yet available in Lucid.

Symptoms are: connection works once but disconnects rapidly and then gets stuck in a connect/ask password cycle, or cannot connect at all.

There are two known fixes at the moment:
[1]: Ricardo Salveti maintains a 2.6.32 kernel with the fix backported (See comment #80)
[2]: Installing the official drivers from RaLink also solves the issue for some. (See comment #107).

To check if your wireless chipset is indeed the RaLink chipset that is affected by this driver, execute the "lspci -vnn | grep RaLink" command.
It should display something close to the following:

$ lspci -vnn | grep RaLink
01:00.0 Network controller [0280]: RaLink RT2860 [1814:0781]
 Subsystem: RaLink Device [1814:2790]

Matt Drake (mattduckman) wrote :

I can confirm that. I have booted a fresh daily lucid 64 bit via grub2 loopback every few days for the last week or so and have never been able to connect to the WEP ad hoc network that I use every day with karmic (I have to use WEP because I can not get WPA to work with that ad hoc network under karmic).

module rt2860sta

Changed in linux (Ubuntu):
status: New → Confirmed

Just checked again with lucid 20091218. Bug is still present.

I can confirm the same problem with the rt 2561s. WEP or WPA does not work, unencrypted networks do. All worked fine in Karmic.

It seems to be due to this bug: http://bugzilla.kernel.org/show_bug.cgi?id=14731
I linked it to this bug report.

As a temporary fix:

sudo iwconfig wlan0 power off

Made it work again for me.

There is a patch in development at: http://patchwork.kernel.org/patch/65154

Changed in linux:
status: Unknown → Confirmed

Thank you Wouter for all the info.

For my rt2860sta your workaround unfortunately does not work. I get ..."Operation not supported"

CSkau (clementskau-gmail) wrote :

I too can confirm this bug on my EEE PC with ra2860sta using a fully updated xubuntu lucid.
' sudo iwconfig wlan0 power off ' doesn't seem to work for the RT2860 as Kufner reports.

I remember having the same symptoms in the early days of Jaunty (or was it Intrepid?), but the problems were resolved and my system has been working flawless since.
Could a possible solution be found in the earlier releases ?

Changed in linux:
status: Confirmed → Invalid
Changed in linux:
status: Invalid → Unknown
Matt Drake (mattduckman) wrote :

wouter, you are using a different driver and experiencing a different bug. i've changed the bug watch to link to the correct bug upstream

the last commenter on that bug provided:
"This seems only to happen with Wireless Encrypten of Mixed WPA/WPA2

WPA or WPA-2 only or other encryptions and unencrypted seems to work fine"

It might be a different problem, but the patch provided in http://bugzilla.kernel.org/show_bug.cgi?id=14896 is for both the rt61 nd the rt2800 driver and suggests both suffer from the same problem.

Matt Drake (mattduckman) wrote :

but according to modinfo, rt2860sta doesn't depend on any other modules. so changes in rt2800lib and rt61pci shouldn't affect people using rt2860sta

Changed in linux:
status: Unknown → Confirmed
tags: added: cherry-pick

Sorry for the confusion, I opened bug 503563 for my problem. Please ignore my previous comments here.

Fixed with linux 2.6.31-18.55. I have booted todays daily lucid 64 bit iso 20100109 via grub2 loopback. The wireless connection with rt2860sta WEP worked immediately and reliably (I was online for 60 minutes). For further testing I disconnected and reconnected 5 times. Worked every time.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
CSkau (clementskau-gmail) wrote :

Doesn't the repository still point to the 2.6.32-9.9 kernel?
The problem seems to be with the 2.6.32 branch not the 2.6.31 which I've been using for ages on my Karmic system without any indications of the above problem.

Ooops. You are right, of course.
Todays lucid iso has:
ubuntu@ubuntu:~$ uname -a
Linux ubuntu 2.6.32-9-generic #13-Ubuntu SMP Thu Dec 17 17:01:59 UTC 2009 x86_64 GNU/Linux
So the fixed with statement from my previous post is wrong.
Which raises the quesetion, why does it work now?

CSkau (clementskau-gmail) wrote :

Perhaps, as the original post describes, it was just a fluke?
I noticed some days ago that I was able to connect to my WPA2 network, but after a short while of surfing I lost the connection again, and it wouldn't re-connect no matter how many times I tried.
I would say the bug doesn't completely break rt2860sta - it just makes it highly unstable with the rare occurrence of a functional run.

Kufner, perhaps you could report whether functionality persists even after reboots?

I've just updated my lucid (through chroot from karmic) so I'll give it a try and report back if anything has changed for the better.

I have given the daily lucid 64 bit iso 20100109 some more testing via grub2 loopback. The wireless connection with rt2860sta WEP worked immediately and reliably. Specifically I did:
disconnect and reconnect 9 times
shutdown and reboot 2 times
sleep and resume 2 times
there was 1 involuntary disconnect with immediate automatic reconnect
total time connected now something like 5 hours

I have now used the WLAN (WEP rt2860sta) on lucid 20100110 iso for the whole day without problems. It seems safe to say that this combination works now.
However WPA & WPA2 remains to be tested. It might still not work.

Changed in linux (Ubuntu):
status: Fix Released → Incomplete

Just had the opportunity to try connecting to a WLAN hub (infrastructure mode) with lucid 20100113 64bit desktop iso (loopback from hd via grub2). Connected immediately and always (tried 4 disconnect/reconnect cycles and one extra shutdown/reboot cycle) and stayed connected. Connection information from network manager says: "Security: WPA/WPA2" "Speed: 54 Mb/s" and the mode is called "WPA & WPA2 Personal" in "Edit Connections...".
2 other notebooks where also connected to the same hub with the same mode.

Matt Drake (mattduckman) wrote :

to experience this bug you have to setup your router for both WPA and WPA2 security.

when I have my router on WPA2 only, i can always connect
when I have my router on WPA/WPA2, i can rarely connect

Indeed. Confirmed with lucid alpha-2 iso loopback booted from hd. Could not connect to the wireless router set to:
WPA-PSK Encryption: TKIP+AES
WPA-PSK Version: WPA+WPA2
three times out of three.

During my tests documented in comment #20 this router was set to WPA-PSK Version: WPA.

The network manager's connection information tab says "Security: WPA/WPA2" in both modes, so one really has to look at the router to see what it is set to in detail.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
summary: - [lucid] rt2860 frequently fails to connect to secured wireless networks
+ [lucid] rt2860 frequently fails to connect to mixed mode WPA/WPA2
+ secured wireless networks
killerbee (eth) wrote :

did an upgrade yesterday "update-manager -d"

and have the same issue:

I have to AP, one with WPA2 only the other one with WPA2 AND WPA enabled.

I am running eeePC witgh Rt2860 and am stuck as the main AP with WPA and WPA2 enabled is rather old and dont laugh i forgot how to admin it :O( the WPA2 only AP is in the basement and hardly reachable.....

The dkms workaround also doesnt work as the compilation fails with kernel 2.6.32 ....

Please provide fix or workaround....

CSkau (clementskau-gmail) wrote :

This bug is still present in the 2010-01-24 daily live of Xubuntu.
I installed and got the same result as earlier.
This time however I tried to compile the rt2860 driver directly from Ralink. The original source release does not compile because of an error, but with a source patch back from Ubuntu 9.10 (I can probably find the link again if needed) I managed to compile anyway.
The self-compiled driver did however not help at all - in fact it seemed to make everything worse since the driver wouldn't load and function with network manager.
The way I ended up fixing it in the end was by simply installing the old 2.6.31-18 kernel from the archive - now everything works perfectly.
This is clearly (imho) a bug in the kernel, so I'm thinking it should be fairly simple to revert whatever kernel patch is causing this..

killerbee (eth) wrote :

Hi,

just downloaded the v2.3 version of the driver BRANDNEW :O)

It still has the same issue.

To resolve you need to modify ./os/linux/config.mk. Set:

    HAS_WPA_SUPPLICANT=y
    ...
    HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y

and change the line in ./common/cmm_wpa.c from MIX_CYPHER_NOTUSE to:

    WPA_MIX_PAIR_CYPHER FlexibleCipher = WPA_TKIPAES_WPA2_TKIPAES

sudo make
sudo make install
sudo ifconfig ra0 down
sudo rmmod rt2860sta
(maybe for safety also rename the ko file from /lib/modules/2.6.*/kernel/drivers/staging/rt2860 into .ko.dist to be sure its not used anymore)
sudo depmod -a (?? not sure if really needed but better to be sure :O)
sudo modeprobe rt2860sta
sudo ifconfig ra0 up

See it connect :O)

This is really a Choke, IF THERE IS SOMEONE FROM RALINK LISTENING, PLEASE GET THESE TWO LINES INTO THE NEXT HOTPACTH / MIONOR RELEASE !

Changed in linux (Ubuntu):
assignee: nobody → Chase Douglas (chasedouglas)
Chase Douglas (chasedouglas) wrote :

@killerbee,

The FlexibleCipher change is already in the ubuntu kernel, and the WPA_SUPPLICANT config defines do not have any effect in the build of the driver. My guess is that the fix is due to the updated version of the driver from ralink.

Chase Douglas (chasedouglas) wrote :

I've looked at the upstream sources (including -next), and I haven't seen anything that appears to fix the issue. At this point, we're likely just waiting for the fix to be merged from the ralink sources into upstream.

Changed in linux (Ubuntu):
status: Confirmed → Triaged
assignee: Chase Douglas (chasedouglas) → nobody
Surbhi Palande (csurbhi) on 2010-02-05
Changed in linux (Ubuntu):
importance: Undecided → Medium
Bernhard (b.a.koenig) wrote :

If you want to set importance for this bug, it should definitely be "high" or "critical". I need around 20 tries to connect after startup, then stable for as long as I like. Also seems to me that this bug was imported in the 2.6.32 kernel. And contrary to other users I have this problem even though my router is clearly set to "WPA2 only".

meijer.o (meijer-o) wrote :

I own a eeepc 1000h. and can report the same problem when using a 2.6.32 kernel or the lucid kernel. When the networkmanager indicates wpa/wpa2, I cannot connect to the network. module: rt2860sta. I hope this can be solved

James Dupin (james.dupin) wrote :

Looks like a regression from Karmic.

This was solved since bug #339891 (at least for most people).

The only changes to do in the driver config.mk are (using the driver version from ralink because I don't know where to get the source in ubuntu repository - 2010-01-29-RT2860-Linux-STA-v2.3.0.0.tar.bz2)
HAS_WPA_SUPPLICANT=y
HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y

To be noticed that under Karmic the wifi interfice was called ra0 then in Lucid it is called wlan0 until you use the above driver from ralink then the interface is renamed ra0 (not important but well...)

Bernhard (b.a.koenig) wrote :

The problem is not that it doesn't connect, the problem is that the interrupts an established connection for no good reason.

CSkau (clementskau-gmail) wrote :

Bernhard, I believe it is both.
For me I'm usually able to connect for at short some to begin with, then after only a very short while it's interrupted.
Following that I'm not able to connect at all.

Paspartout (pv-ndsmail) wrote :

Same here on my eee pc 901 with rt2860 and 10.04 beta1.
Hope you're able to fix it till the release

Bernhard (b.a.koenig) wrote :

I just tested with a Lubuntu 10.04 beta 1 live CD: that one has linux 2.6.32-16 and the latest gnome network-manager and it works without any problems. If the bug is not with the kernel nor with network-manager, what could it be? Could somebody look into this?

Walter_Wittel (wittelw) wrote :

My experience upgrading from Alpha to Beta 1 the other day was that initially on WPA2 worked but after sleep / other activities it stopped working. Seems still intermittent at least for the upgrade scenario.

I'd like to upgrade my primary partition to put more mileage on the beta but both Wi-Fi's I connect to are WPA2 :-(.

So I tested other live CDs and it turns out that all live CDs (Ubuntu,
Lubuntu) work fine for me. But once I install Ubuntu on my HD, wpa2
connections are unstable as hell. What could be the problem for this
when the live CD works fine?

Unc0nn3ct3d (netflow) wrote :

I can confirm as of today with 2.6.31-20-generic the bug is still present. I've tried with Gnome network manager and wicd and there is no problem seeing the AP but the problem is with validating the authentication. For both managers it comes back with an invalid password error when of course the password entered is correct and triple checked

[ 17.541185] rt2860sta: module is from the staging directory, the quality is unknown, you have been warned.
[ 17.544757] rt2860 0000:08:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
[ 17.545009] rt2860 0000:08:00.0: setting latency timer to 64

Bernhard (b.a.koenig) wrote :

Is anybody having this problem with 32 bits? From all the reports I googled and the ones I see here, it seems this is mostly a problem for 64 bit people. Maybe that would be another hint.

Tom Jaster (futur3-tom) wrote :

<- 32 bit and got this problem on my eeepc 1000h

Walter_Wittel (wittelw) wrote :

Likewise 32-bit eeepc 901. I think it is the chip set / driver.

Paspartout (pv-ndsmail) on 2010-04-20
description: updated
tags: added: patch
Andy Whitcroft (apw) on 2010-04-23
Changed in linux (Ubuntu):
milestone: none → lucid-updates
Changed in linux (Ubuntu):
assignee: nobody → Parham D. (parhamdibajnia)
assignee: Parham D. (parhamdibajnia) → nobody
assignee: nobody → Mark Shuttleworth (sabdfl)
Changed in linux (Ubuntu Lucid):
status: Triaged → Confirmed
Changed in linux (Ubuntu):
status: Triaged → Confirmed
Steve Langasek (vorlon) on 2010-05-02
Changed in linux (Ubuntu):
assignee: Mark Shuttleworth (sabdfl) → nobody
Steve Langasek (vorlon) on 2010-05-02
Changed in linux (Ubuntu Lucid):
status: Confirmed → Triaged
Changed in linux (Ubuntu):
status: Confirmed → Triaged
Dries Harnie (dharnie) on 2010-05-04
description: updated
Gary M (garym) on 2010-05-10
tags: added: encryption-wpa encryption-wpa2
h1repp (heinz-repp) on 2010-05-10
Changed in linux:
importance: Unknown → Undecided
status: Confirmed → New
status: New → Invalid
Gary M (garym) on 2010-05-26
tags: added: regression-release
removed: regression-potential
Gary M (garym) on 2010-05-26
tags: added: i386
Changed in linux (Ubuntu Lucid):
importance: Medium → High
Changed in linux (Ubuntu):
status: Triaged → Fix Released
Changed in linux (Ubuntu Lucid):
assignee: nobody → Chase Douglas (chasedouglas)
Changed in linux (Ubuntu):
status: Fix Released → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Changed in linux (Ubuntu Lucid):
status: Triaged → Won't Fix
Changed in linux-backports-modules-2.6.32 (Ubuntu):
status: New → Invalid
Changed in linux-backports-modules-2.6.32 (Ubuntu Lucid):
status: New → In Progress
assignee: nobody → Chase Douglas (chasedouglas)
importance: Undecided → High
Changed in linux (Ubuntu Lucid):
assignee: Chase Douglas (chasedouglas) → nobody
description: updated
Colin Watson (cjwatson) on 2010-06-14
Changed in linux-backports-modules-2.6.32 (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in linux-backports-modules-2.6.32 (Ubuntu):
status: Invalid → Fix Released
status: Fix Released → Invalid
Changed in linux-backports-modules-2.6.32 (Ubuntu Lucid):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) on 2010-06-14
Changed in linux-backports-modules-2.6.32 (Ubuntu Lucid):
status: Fix Released → Fix Committed
Martin Pitt (pitti) on 2010-06-15
tags: added: verification-done
removed: verification-needed
192 comments hidden view all 272 comments
nucleuskore (doctorjohn2) wrote :

eeepc 1000h. I installed both these kernels
2.6.33.3-lucid: http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.33.3-lucid/
2.6.34-rc7-lucid: http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.34-rc7-lucid/

Neither of them work for me :(

Using an eeePC 901.

It' OK on a fresh lucid install after adding /lucid-proposed backport wireless module.

nucleuskore (doctorjohn2) wrote :

As I understand, I install the kernel and reboot the system, selecting the correct kernel from grub to boot with.

I have tried

2.6.33.3-lucid: http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.33.3-lucid/
2.6.34-rc7-lucid: http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.34-rc7-lucid/
and the rsalveti kernel

none of these make my wireless work on my WPA2 AES encrypted network. I am sure of my wireless card. It works with ndiswrapper and I have reported this on http://ndiswrapper.sourceforge.net and ubuntuforums.org

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-backports-modules-2.6.32 - 2.6.32-23.16

---------------
linux-backports-modules-2.6.32 (2.6.32-23.16) lucid-proposed; urgency=low

  [ Chase Douglas ]

  * Add in staging rt28x0 drivers from 2.6.34
    - LP: #496093
  * Added iwlwifi 6050 series firmware
    - LP: #532451
  * Don't munge iwlwifi firmware filenames anymore
    - LP: #591822
 -- Stefan Bader <email address hidden> Mon, 14 Jun 2010 10:31:02 +0200

Changed in linux-backports-modules-2.6.32 (Ubuntu Lucid):
status: Fix Committed → Fix Released
h1repp (heinz-repp) wrote :

I can confirm that after today's updates to kernel 2.6.32-23 and linux-backports-modules-wireless 2.6.32-23 for the first time my ASUS EeePC 1000H with RaLink RT2860 works with the .32 kernel and mixed mode WPA/WPA2 - still 54 mbit and no 'n' connection, though, but that was not possible with all other workarounds too. So, from my point of view this bug can be closed. Verifying ...

Thank you, Chase.

nucleuskore (doctorjohn2) wrote :

The kernel I have 2.6.32-23.37
and linux-backports-modules-wireless-2.6.32-23.16

I have a wireless network at home with SSID hidden, WPA2-PSK, AES, key interval 3600 and cannot connect.

However, I can connect to my neighbour'ss wireless network which I help set up -> SSID visible, WPA2-PSK, AES, key interval 3600 and can connect and is stable !

nucleuskore (doctorjohn2) wrote :

I have Ubuntu 9.10 on the same eeepc 1000H running on 2.6.31-22.60 and linux-backports-modules-wireless-karmic-generic 2.6.31.22.35 working without any issues on both the above wireless networks

Robb Romans (robb-txstate) wrote :

I have the exact same situation and issue as described in comment #227. Asus eeePC 1000. Not working for me.

Elton Woo (elton-woo) wrote :

@ Robb Romans:
I have an Asus eee 1000 PC, *no hardware modifications*, so it should be the same as your machine. I manually installed Lucid Lynx as posted in the ubuntu forums:
http://ubuntuforums.org/showthread.p...22#post9203922 [#136] ... perhaps this might help you?
I never installed the RaLink drivers, and after the system was running for a week or so, I replaced the salvetri kernel with the newer one.
I am now running the current and most recent kernel from the channel. NO connection problems.

Johannes F. (waaaaargh) on 2010-07-04
Changed in ubuntu-release-notes:
status: New → Fix Released
robod (robert-dobozy) wrote :

Hi there,

This is just to confirm that this issue still doesn't seem to be resolved (unless I've missed something).

$lspci -vnn | grep RaLink
02:00.0 Network controller [0280]: RaLink RT2860 [1814:0781]
 Subsystem: RaLink Device [1814:2790]

$ dpkg -l |grep backport
ii linux-backports-modules-wireless-2.6.32-23-generic 2.6.32-23.16 compat-wireless Linux modules for version 2.
ii linux-backports-modules-wireless-lucid-generic 2.6.32.23.24 Backported wireless drivers for generic kern

$ lsmod |grep rt2860
rt2860sta 498817 1
crc_ccitt 1339 2 rt2800pci,rt2860sta

$ modinfo rt2860sta
filename: /lib/modules/2.6.32-23-generic/updates/staging/rt2860sta.ko
version: 2.1.0.0
[snip]

$tail -f /var/log/messages
Jul 5 00:07:50 robonb1 kernel: [ 1290.154100] ===>rt_ioctl_giwscan. 2(2) BSS returned, data->length = 270
Jul 5 00:08:50 robonb1 kernel: [ 1350.154230] ===>rt_ioctl_giwscan. 2(2) BSS returned, data->length = 270

I believe that the symptoms above are in-line with what was already mentioned. It seems that the RT driver 2.1.0.0 included in the backport modules still doesn't work properly.

I'm using WPA/WPA2 with hidden SSID.

Hope this helps ...

Steve Langasek (vorlon) on 2010-07-05
Changed in ubuntu-release-notes:
status: Fix Released → New
nucleuskore (doctorjohn2) wrote :

I did a fresh install and would like to verify that the new backport wireless package has fixed my problem.

Security WPA2-PSK
SSID hidden
Encryption AES
Key Interval 3600 seconds

Kyle Fazzari (kyle.f) wrote :

Can anyone verify that a fresh (yet updated) install now works with the backported wireless package for an eee 901? This has been the only issue holding me back from installing it.

description: updated
Kyle Fazzari (kyle.f) wrote :

Alright-- I decided to grow up, be a man, and try this for myself. I can verify that the backported driver, installed as given in the description, fixes this problem for the eee 901 (fresh install, fully updated). I still don't have N... but I didn't have N in previous releases, either.

sokai (sokai) wrote :

Hi there,

I also have the problems like Mass-Yas wrote in #227 - can't connect after "wlan0: direct probe to 00:1a:2a:41:13:fc (try 1)", "wlan0: direct probe to 00:1a:2a:41:13:fc (try 2)", "wlan0: direct probe to 00:1a:2a:41:13:fc (try 3)" and "wlan0: direct probe to 00:1a:2a:41:13:fc timed out".

Hardware: ASUS eeePC 1000

$ lspci -vnn | grep RaLink
01:00.0 Network controller [0280]: RaLink RT2860 [1814:0781]
        Subsystem: RaLink Device [1814:2790]

$ uname -a
Linux axolotl 2.6.32-24-generic #38-Ubuntu SMP Mon Jul 5 09:22:14 UTC 2010 i686 GNU/Linux

$ dpkg -l |grep backport
ii linux-backports-modules-wireless-2.6.32-24-generic 2.6.32-24.17 compat-wireless Linux modules for version 2.
ii linux-backports-modules-wireless-lucid-generic 2.6.32.24.25 Backported wireless drivers for generic kern

$ modinfo rt2860sta
filename: /lib/modules/2.6.32-24-generic/updates/staging/rt2860sta.ko
version: 2.1.0.0
alias: rt3090sta
license: GPL
description: RT2860/RT3090 Wireless Lan Linux Driver
author: Jett Chen <email address hidden>
firmware: rt3090.bin
firmware: rt2860.bin
srcversion: F46A8C05E7D08B926C958B2
[snip]
vermagic: 2.6.32-24-generic SMP mod_unload modversions 586
parm: mac:rt28xx: wireless mac addr (charp)

$ lsmod |grep rt2
rt2860sta 498817 0
rt2800pci 8495 0
rt2800lib 23668 1 rt2800pci
rt2x00usb 9694 1 rt2800lib
rt2x00pci 5921 1 rt2800pci
rt2x00lib 26858 4 rt2800pci,rt2800lib,rt2x00usb,rt2x00pci
crc_ccitt 1339 2 rt2860sta,rt2800pci
led_class 2864 1 rt2x00lib
mac80211 225171 3 rt2x00usb,rt2x00pci,rt2x00lib
cfg80211 144682 2 rt2x00lib,mac80211
compat_firmware_class 6554 1 rt2x00lib
eeprom_93cx6 1333 1 rt2800pci

$ iwlist wlan0 scan
wlan0 Scan completed :
          Cell 01 - Address: 00:1A:2A:41:13:FC
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=70/70 Signal level=27 dBm
                    Encryption key:on
                    ESSID:"xyz.abc"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
[snip]
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
[snip]

Please give me/us a solution for this _annoying_ bug!

Hint(?):
At first I booted up normaly and installed the backport modules. After that and _without_ rebooting I _could_ connect to the net listed above (WPA+TKIP). After teh reboot I got the messages like Mass-Yas...

After installing backported modules my wireless connection works like a charm on my Asus Eee PC1000. Thanks!

sokai (sokai) wrote :

@Roman Vorobets (#247):
Hi Roman!
What does your comment mean? - Which Kernel do you have installed? Which Ubuntu version are you using? Have you a fresh or upgraded installation? Which network encryption type "works like a char" now?

ATM I'm looking for a real _solution_ cause I tried a lot of things (only "tips") out there (forums, launchpad bugs, launchpad answers,...) and nothing worked. :(

Best regards and thanks!

Walter_Wittel (wittelw) wrote :

FWIW I've been running Alphas of Maverick on an SD card (Eeepc 901) for the last month or so with great success connecting to two different WPA routers that I never got running on Lucid. Note that I have a Karmic partition that still works great as a backup, but you might want to just consider jumping ahead to Maverick to fix the problem. You could always try a LiveCD on a flash drive first to see if it would work for you.

sokai (sokai) wrote :

@Walter_Wittel (#249):
Thanks Walter for that hint! I tried a Maverick LiveCD and could connect to the network...

But now:
How can I make my Lucid to connect, too!?

Best regards!

Walter_Wittel (wittelw) wrote :

Sokai, sorry I have been busier at work and home than very early in this thread and have not had time to even try. That's why I had stuck with Karmic until Maverick came along. But from my past experience it is fairly difficult to make this work and it will break every time there is a Kernel update to Lucid until what ever fix went into Karmic or Maverick (likely different fixes) goes into the upstream Kernel.

If you really want to make it work on Lucid I guess you will have to just walk backwards on this thread and start trying anything where someone reported success. It is a bit of a moving target so the suggestions early on in the bug likely don't apply any more. Good luck.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

On Tue, 03 Aug 2010 11:06:44 -0000, sokai wrote:

>@Walter_Wittel (#249):
>Thanks Walter for that hint! I tried a Maverick LiveCD and could connect to the network...
>
>But now:
>How can I make my Lucid to connect, too!?
>
>Best regards!
>
>--
>[lucid] rt2860 frequently fails to connect to mixed mode WPA/WPA2 secured wireless networks
>https://bugs.launchpad.net/bugs/496093
>You received this bug notification because you are a direct subscriber
>of the bug.
>

Running the Maverick kernel from ppa:kernel-ppa/ppa in Lucid works a
treat. This installs rt2800pci (vice rt2860) and works (for me, eeepc
901) with both mixed mode and hidden ESSIDs.

- -jh

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iQIcBAEBCAAGBQJMXGpCAAoJENfuMNsHzpexyewP/R/+ePAnusvQSzUsH2XRM+G9
/fnxl7XVZwPN8h6U5WK31fyWBnkd05UWipTOALpEpgq6rZ5ZxmVHXPZf7Q767vpK
kxsvr9kR9CLMsy5T3viLEQMUFdTZnvob6+h+NsQOmAeDr97H76CKm4KmuAkprKZi
5Rpj2GpsQoRXsJc3jcDGpABdstYTI5Qt1lPsnffentQY27L8KcK1QUyc4MhI5/FQ
oXuk1RVoJTIzg347EBe2XWEKdH6b/lRlX86ln2sEQ0TKj7j98jcECVIFKfVMpExI
99q+qOAdb9MKUHb9XYDu0IDIivdhyWH2VLnSXSr8l8UqGPYJ8HJ+n8XvN6Qa0G1m
hKT8Y7y5IgnB13BbPuKIhu6D1goLJpkWUqqRIVqvpsc+ax6cYf80zy5C4ULA28gM
zkfXBQnPYKwHhG1zmW2Z89uzOfq+7V5wgpZKBABIfniY+CeJTstK2j5iSd6BjVUw
+jkw2A5X2dD+ypyzDPFXqx96KO14OrsPciZthz//r23OE9avOs6lJ1/SanChDqRE
WREuIOO6weEUL4hiisixU26cJFdhQ0yTepzf2UL4G32Fa+KK0Qp+u0IfSrc0ezzT
BJq4W29LFWmB1eXK3z0qMgeBHGsPsvsHZDfMpN+qWm7jjU3v1BwiZ+D0ovo3gqUY
J3bYubSCxS0aeaZL7YdU
=f/G/
-----END PGP SIGNATURE-----

Matej Kovacic (matej-kovacic) wrote :

Hmm, I have Lucid installed, with kernel 2.6.32-24-generic, but it doesn't working.

Any idea?

Matej Kovacic (matej-kovacic) wrote :

Sorry, after reboot it is working, but very slow, and connection is breaking.

Kyle Uhlmeyer (kyle-uhlmeyer) wrote :

I can confirm that installing Linux Kernel 2.6.32-24 breaks wireless again in Lucid. I had to reload the driver manually and it works again.

This is starting to get really annoying.

OS/2-User (fzf7a2c02) wrote :

I was under the impression, that the rt2870sta mess, preventing an USB WiFi adapter to connect to a WPA2 protected access point, which was introduced in Lucid, has been sorted out by now and should have been fixed in 10.04.1 Desktop Live-CD.
But for me, it is still not working, keeping Lucid useless.
Btw, both drivers, rt2870sta and rt2800usb are still being loaded simultaneously, as initially reported i.e. for Karmic in Bug #460323. Unloading rt2800usb however does not help in case of 10.04.1 to connect.

It was a week or two ago now but I upgraded my eeePC 901 to Maverick (via update-manager -d) and the wireless works well now (it did break GRUB, but I recovered using an Ubuntu server CD which I happened to have lying around). Previously I had problems were my other laptop (Dell 1557) would loose wireless connection if I switched on the 901 but that all seems fine now. Can't seem to get Ubuntu One working in Maverick, that could just be me perhaps. I'm not actually recommending Maverick as such, just relaying my experience from the perspective of this problem.

OS/2-User (fzf7a2c02) wrote :

@Mark: Thanks for sharing your experience. During the last 2 week or so I gave some daily Mavericks, installed on an USB stick via usb-crator-gtk, a try, but here I still pretty much had a no go, when it comes to WiFi and my RT2870 based 802.11n USB adapter.
Usually I'm just stuck in the evil and vicious "Authentication required by wireless network" cycle, from which I just can't break free.

But it looks like, that the latest over-sized build with kernel 2.6.35-19-generic from 2 or 3 days, now finally seems to be working again with my WiFi adapter, once I 'modprobe -r rt2800usb' one of the two competing USB-adapter drivers rt2870sta and rt2800usb, using the methods, that started to become so crucial with Karmic. I'm now connected since some 30 minutes straight, a new record since Karmic.

This nuisance, where both wireless USB drivers are getting loaded, was first introduced with Karmic and still hasn't been fixed. I wonder if that ever will still happen. 365 days, 2 Lucid releases and an almost Maverick one should have been plenty of time for that, one would think.

Right now I am d/l'ing the latest, now again correctly sized 10.10 Daily Build ISO file - the Beta release date seems to be getting close - to then update my USB stick, which btw. has to be done with Maverick's usb-creator-gtk version. The one being part of Karmic fails to boot from the stick's logical partitions.
Then I just hope, that the rt2870 nightmare after some 8 months now, eventually has really come to an end - at least until they break something new, that is ;-)

h1repp (heinz-repp) wrote :

Unfortunately, the kernel update to 2.6.32-25 again broke wireless connectivity of my EeePC 1000H with our WPA/WPA2 mixed mode 802.11n network.

Up to linux-image-2.6.32-24-generic 2.6.32-24.43
and linux-backports-modules-wireless-2.6.32-24-generic 2.6.32-24.17
it worked,

but with linux-image-2.6.32-25-generic 2.6.32-25.44
and linux-backports-modules-wireless-lucid-generic 2.6.32.25.27
I experience the endless authentication failure loop again.

h1repp (heinz-repp) wrote :

additional hint: 'lsmod | grep rt28' output differs, the differences are:
2.6.32-24:
rt2860sta 498817 1
crc_ccitt 1339 2 rt2800pci,rt2860sta
2.6.32-25
rt2860sta 498817 0
crc_ccitt 1339 2 rt2860sta,rt2800pci

meaning the rt2860sta driver on the 2.6.32-25 kernel is loaded but not used?

h1repp, this sounds like the bug 589342. Try blacklisting rt2800pci.

Jonathan Davies (jpds) wrote :

Marking as invalid as this appears to be fixed in Lucid updates.

Changed in ubuntu-release-notes:
status: New → Invalid
eric wang (eric-wang-china) wrote :

The problem is still there on my laptop Thinkpad T400 with ubuntu 10.04(Lucid)

towerlexa (towerlexa) wrote :

I have also still the same problem with the endless authentication loop. I also tried the linux-backports-modules-wireless-lucid-generic Package, but it don't work for me on my eeepc 1000HE with rt2760sta.
I'am using the kernel from the latest updates Linux 2.6.32-27-generic 32 Bit.
Maybe it helps

weeix (weeaix) wrote :

I'm using Lucid in EeePC 1000H

- I recompiled the driver using method in http://ubuntuforums.org/showthread.php?t=1476007
- Today, I updated the kernel to 2.6.32-29
- Wireless fails again
- I have to recompile again
- This is bad
- Really, this is very bad :(

Changed in linux-backports-modules-2.6.32 (Ubuntu Lucid):
assignee: Chase Douglas (chasedouglas) → nobody
sokai (sokai) wrote :

Hi there!
Maybe it's a solution for you - like me - to install the backported wireless modules ("linux-backports-modules-wireless-lucid-generic") and blacklist the "rt2860sta" module (sudo echo "blacklist rt2860sta" >> /etc/modprobe.d/blacklist.conf). After that my wifi is very stable by using the modules rt2800lib, rt2800pci, rt2800lib and rt2x00pci.
I have a ASUS Eee PC 1000 with a "RaLink RT2860" wifi chip and use Ubuntu Maverick with kernel 2.6.35-28-generic.

Cheers!

jbatista (jmnbatista) wrote :

Dear all,

I've long tried to get my RT2860 to successfully connect to encrypted wireless networks with a EeePC 1000H on Lucid Lynx (i386), without success. I'm posting here a solution based on http://ubuntuforums.org/showpost.php?p=9255730&postcount=1 After compiling and installing the rt2860sta.ko kernel module I was still unable to establish a connection with the Network Manager or doing it manually on a terminal.

I've posted my experience here: http://ubuntuforums.org/showpost.php?p=10775056&postcount=140 I hope it helps others. Basically, I configure "ra0" with a few "iwpriv", instead of using "wlan0".
I'll keep looking to find out whether it's possible to coherce Network Manager to connect, but so far I've come out empty-handed. The solution on the last link at least got me to connect with the wireless AP.

Happy Cinco de Mayo! :-)

MrHaroldA (mrharolda) wrote :

> EeePC 1000H on Lucid Lynx (i386)

Nothing a release-upgrade can't fix. I haven't got any real wireless problems since I upgraded to 10.10 apart from the fact that the network sometimes doesn't connect after a standby. Dis- and enabeling the wifi fixes this too.

$ sudo do-release-upgrade

Walter_Wittel (wittelw) wrote :

I am occasionally having to disable/ enable after sleep on 11.04 also (a
bit more noticeable than on

On May 6, 2011 12:51 AM, "MrHaroldA" <email address hidden> wrote:

> EeePC 1000H on Lucid Lynx (i386)
Nothing a release-upgrade can't fix. I haven't got any real wireless
problems since I upgraded to 10.10 apart from the fact that the network
sometimes doesn't connect after a standby. Dis- and enabeling the wifi
fixes this too.

$ sudo do-release-upgrade

--
You received this bug notification because you are a direct subscriber
of the bug.
https://bugs...

Walter_Wittel (wittelw) wrote :

... (sorry, bus bounced send) ... on 10.10, but both have been usable.

On May 6, 2011 6:34 AM, "Walter Wittel" <email address hidden> wrote:

I am occasionally having to disable/ enable after sleep on 11.04 also (a
bit more noticeable than on

>
> On May 6, 2011 12:51 AM, "MrHaroldA" <email address hidden> wrote:
>
> > EeePC 1000H on Lu...

>
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
https://bugs...

Gary Helbig (ghelbig) wrote :

Near as I can tell it is still broken in ubuntu 10 LTS with all current updates

Igor S. Pelykh (kesha) wrote :

Yes, I can tell it too.
I have asus eee 1000h with this wireless-card, just install 10 LTS+updates and can not connect to router with WPA2.

Displaying first 40 and last 40 comments. View all 272 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.