Ubuntu

external monitor output is switched off when closing the laptop-lid when gnome-power-manager is set to blank screen on closing

Reported by Bernhard Gehl on 2009-06-22
160
This bug affects 28 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
gnome-power
Fix Released
Medium
gnome-power-manager (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned

Bug Description

Binary package hint: gnome-power-manager

On a laptop system (LG S1 with ATI Radeon 9600 mobility) the VGA output is getting "blanked" when the option to blank the screen on laptop lid close is selected. At first sight this might not seem to be a bug, but it is a real problem in docking-station setups. Would it be possible to select which outputs (LVDS, VGA, HDMI, ...) are getting blanked on lid close?

Scott Ritchie (scottritchie) wrote :

Confirming, this one annoys me personally.

In order to use my docking station I have to plug in my computer and then hit the "switch displays" button, requiring me to open my laptop. Once it's no longer outputting to the laptop screen I then close the laptop, but my monitor output goes dark until I move the mouse a bit.

Gnome-power-manager shouldn't turn off the output, even when this setting is enabled, when using an external monitor. I'm not quite sure how to handle the twinview case - perhaps then only blanking the laptop screen (disabling twinview) would be the best solution.

Changed in gnome-power-manager (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in gnome-power:
status: Unknown → New
Vish (vish) wrote :

Thank you for bringing this bug to our attention. Unfortunately a paper cut should be a small usability issue that affects many people and is quick and easy to fix. I'm afraid this bug can't be addressed as part of this project.

This is not the setup of an average user and hence not a papercut.

A paper cut is a minor usability annoyance that an average user would encounter on his/her first day of using a new installation of Ubuntu 9.10.

For further info about papercuts criteria , pls read > https://wiki.ubuntu.com/PaperCut

Don't worry though, This bug has been marked as "invalid" ONLY in the papercuts project.

Changed in hundredpapercuts:
status: New → Invalid
Scott Ritchie (scottritchie) wrote :

mac_v, I'm pretty sure the "darken screen on lid close" is a default feature. You're right that this only affects laptop users with external monitors though.

Vish (vish) wrote :

@Scott Ritchie:
Actually, if i'm not mistaken , the default is "standby" on lid close.
I always had to change that after every install.

Scott Ritchie (scottritchie) wrote :

We might want to examine that default too. By chance does it standby even when there's an external monitor too?

nick (swcodfather) wrote :

This has not been a problem with my Dell XPS 1330 laptop with Janty or Karmic , until the latest round of fixes this monrning. It is 100% reproducible.

If you shut the lid on the laptop , it now blanks the external monitor screen. As I wish to use my laptop in the office this is a massive problem as I'm having to prop the lid open to stop it powering off the external monitor. This is definitely a regression, as I have been using this features for many months. It may also be connected to another bug that has been reported about the lack of ability to set the external monitor and laptop monitor to have seperate screen resolutions. I have attached a screenshot of the current gnome-power-preferences settings.

Ubunty: 9.10 beta x86_64
Kernel: 2.6.31-13
Machine: Dell XPS 1330
Memory:2.5 Gig
Graphics Card:
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
 Subsystem: Dell Device 0209
 Flags: bus master, fast devsel, latency 0, IRQ 29
 Memory at fea00000 (64-bit, non-prefetchable) [size=1M]
 Memory at e0000000 (64-bit, prefetchable) [size=256M]
 I/O ports at eff8 [size=8]
 Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable+

Mathias Dietrich (theghost) wrote :

I also have the problem, that when I close my laptop's lid that my external lcd is blanked.

But I found a way to prevent this. You have to start: gconf-editor (via terminal)
There you can find the options you need at:

/apps/gnome-power-manager/buttons

You can change the parameter: "lid_ac" to the value "nothing" (without "") to prevent your external lcd from being blanked. That is the option for ac connection. If you run on battery you should also change lid_ac.

From now on it should also be accessible via system->preferences->powersettings (sorry I am not sure whether it is the right name at the english translation).

In my opinion it is very deplorable that you can't access this option via the gui that is build for that (even on karmic). :(
Hopefully it will integrated into 10.04, it is just a drop down item. :(

santq (santq) wrote :

I agree with previous writer.

Here's also quick terminal solution from forum:

gconftool-2 --type string --set /apps/gnome-power-manager/buttons/lid_ac "nothing"
gconftool-2 --type string --set /apps/gnome-power-manager/buttons/lid_battery "nothing"

http://ubuntuforums.org/showthread.php?t=1430420

Changed in gnome-power-manager (Ubuntu Lucid):
assignee: nobody → Chris Coulson (chrisccoulson)
Nicolò Chieffo (yelo3) wrote :

Yes but in this way the laptop monitor won't blank (it is enabled but you don't see it because the lid is closed)

Shih-Yuan Lee (fourdollars) wrote :

I see the following in gnome-power-manager-2.30.0/src/gpm-prefs-core.c line 382

} else if (policy == GPM_ACTION_POLICY_NOTHING) {
    /* we only add do nothing in the GUI if the user has explicitly specified this in GConf */
    if (value == GPM_ACTION_POLICY_NOTHING) {
        gtk_combo_box_append_text (GTK_COMBO_BOX (widget), _("Do nothing"));
        g_ptr_array_add (array, GINT_TO_POINTER (policy));
    }
} else {
    egg_warning ("Unknown action read from conf: %i", policy);
}

Mark W (jedimark64) wrote :

The gconf thing, whilst very hacky, did the trick for me. seems I'm having to use it a lot lately :(
I now have a Do Nothing in the menu. Yay! Why wasn't it the default?

@Nicolo, the closed screen should still blank, the hardware switch is (usually? :) wired to disable at least the backlight (which is the screen's main power drain). In some notebooks you can engage your lid-close switch without actually closing the screen and see what happens. But I suppose a per monitor software solution would be the best solution.. Klunky to implement. Perhaps a "ignore non-software power saving events for this monitor" under Monitors?

Making gnome easier to use for newbies shouldn't come at the expense of flexibility for power users.. A little Borg mentality is slipping though. :(

We could possibly compile a list of all these little gconf gems for power users and fixes for the other little "regressions" that have popped up for the sake of newbie proofing, and maybe put them in a big script with a check-box during installation that says "If I wanted to be told what I'm allowed to do with my computer, I'd be using Microsoft/Apple/Sony/Nintendo/Oracle software!"

[Insert 'gconf + Ubuntu/Gnome's "users==idiots" Policy should be buried in the same grave as Micro$oft' rant here]

Changed in gnome-power:
status: New → Fix Released
Mark Edgington (edgimar) wrote :

I don't know to what extent it relates to this issue, but there is a difference in behavior on my Lucid installation between pressing the suspend-button, and closing the lid (with the system configured to suspend on lid-close).

If I have a second monitor connected and active (configured with something like xrandr --right-of ...) at the same time as the laptop LCD display, then in the first case (button-press), resuming from suspend correctly restores the display on both the LCD and external display. However, in the second case (closing the lid), upon resume, the LCD's resolution is changed to match the (lower-res) external monitor resolution, and the screens become identical clones of each other.

Martin Wildam (mwildam) wrote :

I also noticed that the option to clone outputs is always getting re-enabled - it seems just to ignore it when disabled by the user.

Martin Wildam (mwildam) wrote :

Maybe this workaround can help you also in the suspend case: http://it-tactics.blogspot.com/2010/08/ubuntu-1004-with-docking-station.html
I noticed that after these changes my Desktop is much more stable in the meaning of flickering and resolution changes (which also happened e.g. when starting TeamViewer (and other applications) for the first time.
The bug #613650 and bug #617421 could be related to this one I guess.

Changed in gnome-power:
importance: Unknown → Medium
Martin Pitt (pitti) wrote :

Was fixed upstream a while ago, assuming fixed in natty.

Changed in gnome-power-manager (Ubuntu):
assignee: Chris Coulson (chrisccoulson) → nobody
status: Triaged → Fix Released
Changed in gnome-power-manager (Ubuntu Lucid):
assignee: Chris Coulson (chrisccoulson) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.