Ubuntu

The default MP3 profile is broken

Reported by Pascal de Bruijn on 2010-05-25
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME media utilities
Fix Released
High
gnome-media (Ubuntu)
Low
Unassigned
Lucid
Low
Unassigned

Bug Description

Binary package hint: gnome-media

By default the "CD Quality, MP3" profile is broken.

It seems to encode to 128kbit CBR, while it intends to encode to VBR Quality 6.
Changing the VBR Quality has no effect at all.

I was told the 'lame' encoding plugin has been deprecated, and it's being
replaced by 'lamemp3enc'.

I attached a patch which changes the default, including the adding of a xing
header. This will make sure Totem and others will properly display the file's
bitrate and length.

I hope this can be resolved in a future update for Lucid.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-media 2.30.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
Architecture: amd64
Date: Tue May 25 19:42:09 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-media

Pascal de Bruijn (pmjdebruijn) wrote :
Changed in gnome-media:
status: Unknown → New
Changed in gnome-media (Ubuntu):
importance: Undecided → Low
status: New → Triaged
tags: added: patch
Changed in gnome-media:
status: New → Confirmed
Changed in gnome-media:
status: Confirmed → Fix Released
Changed in gnome-media (Ubuntu Lucid):
importance: Undecided → Low
status: New → Fix Committed
assignee: nobody → Sebastien Bacher (seb128)
Changed in gnome-media (Ubuntu):
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

I've tried the change on lucid but it seems the quality stays around 125k, not sure if that works as it should, let's get testing on the new upload to maverick before considering that for lucid updates

Changed in gnome-media (Ubuntu Lucid):
status: Fix Committed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-media - 2.30.0-0ubuntu2

---------------
gnome-media (2.30.0-0ubuntu2) maverick; urgency=low

  * debian/patches/91_better_mp3_profile_definition.patch:
    - git change to update the mp3 profile from 128 cbr to vbr quality 6
      (lp: #585496)
 -- Sebastien Bacher <email address hidden> Thu, 03 Jun 2010 17:09:45 +0200

Changed in gnome-media (Ubuntu):
status: Fix Committed → Fix Released
Pascal de Bruijn (pmjdebruijn) wrote :

That sounds about right...

http://wiki.hydrogenaudio.org/index.php?title=LAME

Quality average range
-V 6 115 100...130

The point is that the resulting file should not have a constant bitrate of exactly 128...

Pascal de Bruijn (pmjdebruijn) wrote :

Btw small note...

GNOME had always intended this to be VBR quality 6, however because of how the code fails it became CBR 128...

Sebastien Bacher (seb128) wrote :

the vbr encoding is quite slower, what is the win for users there if the quality is similar?

Pascal de Bruijn (pmjdebruijn) wrote :

Well first, this is still a bugfix, since the original intention has always been to use VBR... The slowing down is just a side-effect.

Then, I highly doubt the quality is similar...

And this brings up another point altogether, since the presets are called CD Quality, it's way to low quality anyways, for MP3 it should probably be Q4.

And Q5 for Vorbis. But this is a whole different discussion.

Sebastien Bacher (seb128) wrote :

could you explain how the quality is better if the biterate is the same?

Pascal de Bruijn (pmjdebruijn) wrote :

Huh? The _average_ bitrate is about the same...

But that's the whole point of variable bitrate encoding...

VBR conserves bits when they are not needed (silent pieces, etc), and uses them whenever the encoding gets hardest...

Constant bitrate does not produce constant quality
Variable bitrate can approach constant quality

http://en.wikipedia.org/wiki/Variable_bitrate#Average_bitrate

Changed in gnome-media:
importance: Unknown → High
Changed in gnome-media (Ubuntu Lucid):
assignee: Sebastien Bacher (seb128) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.