Ubuntu

thunderbird loses langpacks after upgrade

Reported by urusha on 2012-05-05
100
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
adblock-plus (Ubuntu)
Undecided
Unassigned
Lucid
Medium
Unassigned
enigmail (Ubuntu)
Undecided
Unassigned
Lucid
Medium
Micah Gersten
mozilla-devscripts (Ubuntu)
Undecided
Unassigned
Lucid
High
Micah Gersten
mozvoikko (Ubuntu)
Undecided
Unassigned
Lucid
Medium
Unassigned
thunderbird (Ubuntu)
Undecided
Unassigned
Lucid
High
Micah Gersten

Bug Description

Hi.
After upgrading thunderbird to version 12.0.1+build1-0ubuntu0.10.04.1 on 10.04 I cannot see any system-wide langpack in the addons menu. The reason of it is that somehow (I think it's the order of package installation/configuring ) '/usr/lib/thunderbird/extensions' becomes a directory while upgrade (it should be symlink to '/usr/lib/thunderbird-addons/etenstions' normally). So, all langpacks stays in '/usr/lib/thunderbird-addons/extensions', but thunderbird doesn't detect them. I don't see this problem on 12.04, I think it's because it already had /usr/lib/thunderbird folder before upgrade, but ubuntu 10.04 used /usr/lib/thunderbird-a.b directories for storing thunderbird package data earlier, so it has this problem.

A quick solution is:
mv /usr/lib/thunderbird/extensions/* /usr/lib/thunderbird-addons/extensions
rmdir /usr/lib/thunderbird/extensions
ln -s /usr/lib/thunderbird-addons/extensions /usr/lib/thunderbird

This bug has already affected many machines in our office.

Thanks.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed
urusha (urusha) wrote :

Seems it's not a bug in thunderbird, but a bug in enigmail package (and possibly all extensions packages that uses thunderbird directory instead of thunderbird-addons) - it has '/usr/lib/thunderbird/extensions' directory, but should have '/usr/lib/thunderbird-addons/extensions'. So, when installation of new version of enigmail happens earlier than installation of thunderbird itself - this bug appears.

Looking wide I have to say that /usr/lib/thunderbird-addons directory becomes meaningless now, when we have one /usr/lib/thunderbird directory (without version suffix). May be it's time to make it just a symlink to /usr/lib/thunderbird (for compatibility reasons)?

Micah Gersten (micahg) wrote :

Apparently, mozills-devscripts was still creating symlinks in /usr/lib/thunderbird/extensions, I've got an update to fix this.

summary: - thunderbird looses langpacks after upgrade
+ thunderbird loses langpacks after upgrade
Changed in thunderbird (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in thunderbird (Ubuntu Lucid):
importance: Undecided → High
status: New → Triaged
Changed in thunderbird (Ubuntu):
importance: High → Undecided
status: Triaged → Invalid
Changed in enigmail (Ubuntu):
status: New → Invalid
Changed in mozilla-devscripts (Ubuntu):
status: New → Invalid
Changed in thunderbird (Ubuntu Lucid):
status: Triaged → Invalid
Changed in mozilla-devscripts (Ubuntu Lucid):
importance: Undecided → High
Changed in thunderbird (Ubuntu Lucid):
status: Invalid → Triaged
Changed in mozilla-devscripts (Ubuntu Lucid):
status: New → Triaged
Changed in enigmail (Ubuntu Lucid):
importance: Undecided → Medium
status: New → Triaged
assignee: nobody → Micah Gersten (micahg)
Changed in mozilla-devscripts (Ubuntu Lucid):
assignee: nobody → Micah Gersten (micahg)
Changed in thunderbird (Ubuntu Lucid):
assignee: nobody → Micah Gersten (micahg)
Micah Gersten (micahg) on 2012-05-08
Changed in mozvoikko (Ubuntu):
status: New → Invalid
Micah Gersten (micahg) on 2012-05-08
Changed in adblock-plus (Ubuntu):
status: New → Invalid
Changed in adblock-plus (Ubuntu Lucid):
importance: Undecided → Medium
status: New → Triaged
Changed in mozvoikko (Ubuntu Lucid):
importance: Undecided → Medium
status: New → Triaged
tags: added: lucid regression-update
Olivier Mengué (dolmen) wrote :

Confirming on locale fr_FR.UTF-8. I just did the migration 10.04->10.10->11.04->11.10->12.04.

The problem is that the thunderbird-locale-xx is not automatically installed during system upgrade.
Even using the gnome-language-selector does not fixes the problem.

Workaround: manually install the missing package.

Changed in thunderbird (Ubuntu):
status: Invalid → Confirmed
Olivier Mengué (dolmen) wrote :

The problem is worse than what I described above: the thunderbird-locale-fr is correctly installed, but Thunderbird does not seem to see it.

The real workaround:
cd /usr/lib/thunderbird
sudo rmdir extensions
sudo ln -s ../thunderbird-addons/extensions .

So the real problem is that the thunderbird installation did not replace the directory /usr/bin/thunderbird/extensions by the symlink.

Olivier Mengué (dolmen) on 2012-05-08
tags: added: oneiric2precise precise
Olivier Mengué (dolmen) wrote :

How can we register this bug not only for Ubuntu Lucid (if that is still relevant) but also for Ubuntu Precise?

Micah Gersten (micahg) wrote :

I don't believe the issue is in precise, but rather in the lucid packages, once they are fixed, the issue should go away. Although, people that upgraded in between might need manual fixing.

Micah Gersten (micahg) wrote :

Filed bug 995054 to get upgrades from old versions of lightning-extension

urusha (urusha) wrote :

Why not to add postinst script into packages that would check if /usr/lib/thunderbird/extensions is a directory (and make changes if it is)? Then manual fixing this problem would be needless.

Micah Gersten (micahg) wrote :

I'll be adding a postinst to clean up the symlink if the update removes the last file from that directory (i.e. it's empty).

urusha (urusha) wrote :

Did you mean 'clean up' = create? Then that's a cool solution. Thanks.

Yes, I meant remove the directory and create the symlink if it's the
last package with files in there.

Stefan Hammer (j-4) wrote :

Hello!

I can confirm, that my thunderbird ist just english after an update on ubuntu 10.04.
Further are all language packs installed as described above.

BUT: Even after making the symlink from /usr/lib/thunderbird-addons/extensions to /usr/lib/thunderbird/extensions the thunderbird still is only displayed in english (not german).

Futher i realized that the "Language"-Tab is missing in the about:addons overview page. This tab is present in Ubuntu 12.04, but not in 10.04.
But also in Ubuntu 12.04 disabling a Language there does not have any effect on the UI Language.

Thanks!

Stefan Hammer (j-4) wrote :

Sorry for spamming you.
The language-tab in abbout:addons appears after making the symlink and the installed language packs are shown in thunderbird.

But all the Menus and buttons (complete ui) is still in english. Maybe i get it wrong, and the language pack is not for UI translations, but only for dictionaries?
If they are only for dictionaries: Do i have to report a new bug concerning the missing translation of the user interface?
Thanks again!

urusha (urusha) wrote :

2 Stefan Hammer:
Langpacks are for interface. Can you see langpack xpi files in 'extensions' directory? Are langpacks enabled in about:addons? Did you restart thunderbird? Maybe your environment variable (LANG) is not set correctly (for example you selected english in gdm screen). Try to run thunderbird with proper LANG variable from terminal, e.g:
# LANG=ru_RU.UTF-8 thunderbird

Olivier Mengué (dolmen) wrote :

Steffan Hammer: you did not follow my instructions. You made the symlink in the reverse order.
thunderbirb/extensions must link to thunderbird-addons/extensions, not the reverse. You probably destroyed the content of the thunderbird-addons/extensions directory in the process.

Eric Seigne (eric-seigne) wrote :

Solution is:

cd /usr/lib/thunderbird/extensions
sudo ln -s /<email address hidden>

The workaround in post #17 solved the problem for me (but replacing langpack-sv for langpack-fr). Using Thunderbird version 12.0.1+build1-0ubuntu0.10.04.1

(The workaround in post #5 didn't work as is, since /usr/lib/thunderbird/extensions/ isn't empty.)

Micah Gersten (micahg) wrote :

I'm sorry for the delay, this will all be sorted when I push out Thunderbird 13 on Tuesday.

Mantas Kriaučiūnas (mantas) wrote :

This bug isn't fixed in Thunderbird 13 stable release from ppa:ubuntu-mozilla-security/ppa - language packs (thunderbird-locale-xx) still doesn't work and doesn't appear in the addons menu :(
Micah Gersten are you planing to fix this important regression ?

Micah Gersten (micahg) wrote on 2012-06-03:
> this will all be sorted when I push out Thunderbird 13 on Tuesday.

Micah Gersten (micahg) wrote :

No, the fix isn't in thunderbird itself, but in the other extensions. I just uploaded lightning-extension which was one of the main addons with issues left.

Micah Gersten (micahg) wrote :

Nothing to fix in thunderbird itself

Changed in thunderbird (Ubuntu):
status: Confirmed → Invalid
Mantas Kriaučiūnas (mantas) wrote :

After upgrading all packages from thunderbird-stabe PPA (xul-ext-lightning_1.5~b2+build1-0ubuntu0.11.04.1~ubuntu10.04.1~ppa1 xul-ext-calendar-timezones_1.5~b2+build1-0ubuntu0.11.04.1~ubuntu10.04.1~ppa1 and xul-ext-gdata-provider_1.5~b2+build1-0ubuntu0.11.04.1~ubuntu10.04.1~ppa1) I got empty folder /usr/lib/thunderbird/extensions/, but not symlink to ../thunderbird-addons/extensions :(

~$ ls -la /usr/lib/thunderbird/extensions
viso 8
drwxr-xr-x 2 root root 4096 2012-06-12 04:29 .
drwxr-xr-x 8 root root 4096 2012-06-08 10:37 ..
:~$

Micah Gersten (micahg) wrote :

Reinstalling thunderbird (sudo apt-get install --reinstall thunderbird) should fix that up if you have an empty /usr/lib/thunderbird/extensions

On Tue, Jun 12, 2012 at 02:17:12AM -0000, Micah Gersten wrote:
> Reinstalling thunderbird (sudo apt-get install --reinstall thunderbird)
> should fix that up if you have an empty /usr/lib/thunderbird/extensions

No, this doesn't help, an empty /usr/lib/thunderbird/extensions folder stays after reinstallation, please make a real fix for this bug.

I'm pasting contents of my terminal window with apt-get --reinstall install thunderbird command:

mantas@mantas-linux:~$ sudo apt-get --reinstall install thunderbird
Skaitomi paketų sąrašai... Baigta
Konstruojamas priklausomybių medis
Skaitoma būsenos informacija... Baigt
0 atnaujinti, 0 naujai įdiegti, 1 įdiegti iš naujo, 0 bus pašalinta ir 6 neatnaujinta.
Reikia parsiųsti 19,7MB archyvų.
Po šios operacijos bus naudojama 0B papildomos disko vietos.
Ar norite tęsti [T/n]?
Gauti:1 http://ppa.launchpad.net/mozillateam/thunderbird-stable/ubuntu/ lucid/main thunderbird 13.0+build1-0ubuntu0.10.04.1 [19,7MB]
Parsiųsta 19,7MB iš 39s (495kB/s)
(Skaitoma duomenų bazė ... šiuo metu įdiegta 176727 failų ir aplankų.)
Ruošiamasi pakeisti thunderbird 13.0+build1-0ubuntu0.10.04.1 (naudojant .../thunderbird_13.0+build1-0ubuntu0.10.04.1_i386.deb) ...
Išpakuojamas thunderbird pakaitalas...
Apdorojami desktop-file-utils trigeriai...
Apdorojami python-gmenu trigeriai...
Rebuilding /usr/share/applications/desktop.lt_LT.utf8.cache...
Apdorojami man-db trigeriai...
Apdorojami python-support trigeriai...
Tvarkomas paketas thunderbird (13.0+build1-0ubuntu0.10.04.1) ...

mantas@mantas-linux:~$ ls -la /usr/lib/thunderbird/extensions
viso 8
drwxr-xr-x 2 root root 4096 2012-06-12 04:29 .
drwxr-xr-x 8 root root 4096 2012-06-13 20:52 ..
mantas@mantas-linux:~$

It's very easy to fix this bug in debian/postinst or preinst scripts - well known 'rmdir' command removes empty folder:

root@mantas-linux:/usr/lib/thunderbird# rmdir extensions
root@mantas-linux:/usr/lib/thunderbird# ln -s ../thunderbird-addons/extensions extensions

I think these commands should go to lightning-extension (and other previously buggy thunderbird extensions) postinst

> https://bugs.launchpad.net/bugs/995054
> Title:
> thunderbird loses langpacks after upgrade

--
Labanaktis/Good luck,
Mantas Kriaučiūnas Jabber ID: <email address hidden> GPG ID: 43535BD5
Public organization "Open Source for Lithuania" - www.akl.lt
Geriausios biuro programos verslui ir namams - http://openoffice.lt
Prekyba naujais ir atnaujintais kompiuteriais su Linux OS - http://tinklas.eu
Naudok Baltix GNU/Linux sistemą savo kompiuteryje - http://baltix.lt

Micah Gersten (micahg) wrote :

I'm sorry, I forgot that there was no need for a postinst in thunderbird. I'll add a proper postinst to the new version of lightning-extension and enigmail that'll be going out with Thunderbird 13.

VinsS (vincent-vandevyvre) wrote :

The workaround in post #5 solved the problem for me with Thunderbird 15.0 on Ubuntu 10.04

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mozilla-devscripts - 0.22ubuntu0.10.04.3

---------------
mozilla-devscripts (0.22ubuntu0.10.04.3) lucid-security; urgency=low

  * Don't mark thunderbird as an incompatible app that can't read
    /usr/share/mozilla; This makes install-xpi create a symlink in
    /usr/lib/thunderbird/extensions which is now a symlink itself (LP: #995054)
    - update src/install-xpi
 -- Micah Gersten <email address hidden> Mon, 07 May 2012 17:56:43 -0700

Changed in mozilla-devscripts (Ubuntu Lucid):
status: Triaged → Fix Released
Jamie Strandboge (jdstrand) wrote :

What is the status of this for mozcoikko and adblock-plus? There are (rather old) packages in https://launchpad.net/~ubuntu-mozilla-security/+archive/ppa/+packages that claim to fix this bug. Are they actually needed? If so, should those go through SRU?

Changed in adblock-plus (Ubuntu Lucid):
status: Triaged → Incomplete
Changed in mozvoikko (Ubuntu Lucid):
status: Triaged → Incomplete
Jamie Strandboge (jdstrand) wrote :

Marking thunderbird task as Invalid per Micah's comment.

Changed in thunderbird (Ubuntu Lucid):
status: Triaged → Invalid
Jamie Strandboge (jdstrand) wrote :

What is the status of enigmail wrt this bug? There were some changes surrounding localizations but it isn't clear to me if they fix this bug.

Changed in enigmail (Ubuntu Lucid):
status: Triaged → Incomplete
Jamie Strandboge (jdstrand) wrote :

Closing the mozvoikko and adblock tasks and deleting the packages from the PPA since there was no feedback. If this is in error, let me know and I can bring them back.

Changed in adblock-plus (Ubuntu Lucid):
status: Incomplete → Won't Fix
Changed in mozvoikko (Ubuntu Lucid):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers