enigmail is uninstallable in lucid, needs update to 1.0 - blocked by missing thunderbird-config

Bug #527138 reported by Matthew Paul Thomas on 2010-02-24
216
This bug affects 33 people
Affects Status Importance Assigned to Milestone
enigmail (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned
thunderbird (Ubuntu)
High
Chris Coulson
Lucid
High
Chris Coulson

Bug Description

Problem occurs with: Ubuntu Lucid
Does not occur with: Ubuntu 9.10

enigmail's package description says that it is "GPG support for Thunderbird". But installing enigmail uninstalls Thunderbird.

------------
15:37:58@~> apt-cache show enigmail | grep Description
Description: Enigmail - GPG support for Thunderbird
15:38:22@~> sudo apt-get install enigmail
[sudo] password for mpt:
Reading package lists... Done
Building dependency tree
Reading state information... Done
...
The following extra packages will be installed:
  iceape-mailnews seamonkey-browser seamonkey-mailnews
Suggested packages:
  seamonkey-dom-inspector
Recommended packages:
  seamonkey-gnome-support
The following packages will be REMOVED
  language-support-translations-en language-support-translations-pt thunderbird thunderbird-locale-en-gb thunderbird-locale-fr thunderbird-locale-pl thunderbird-locale-pt-br
  thunderbird-locale-pt-pt
...
Do you want to continue [Y/n]? n
------------

Workaround: Install Enigmail from Thunderbird's Add-ons window ("Tools" > "Add-ons").

description: updated
Mikael Gerdin (mgerdin) wrote :

This is because thunderbird was recently updated to 3.0 in ubuntu but the enigmail package conflicts with thunderbirds of version greater than 2.0. Enigmail v 1.0 is needed to support thunderbird 3.0 according to the enigmail website.

Max Bowsher (maxb) on 2010-02-24
summary: - enigmail claims to be for Thunderbird, but conflicts with it
+ enigmail is uninstallable in lucid, needs update to 1.0

1.0 is not even in Debian experimental. Once we have a proposed package to upload, we will need to get an exception to feature freeze.

Changed in enigmail (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-10.04-beta-2
status: New → Confirmed
Micah Gersten (micahg) wrote :

This is dependent on getting the thunderbird-dev package populated which I am working on.

I tried to use the Add-ons manager in Thunderbird on my 64-bit system:

I was offered the enigmail-1.0.1-tb-linux.xpi, but this only gave me this error:

"Enigmail" could not be installed because it is not compatible with your Thunderbird build type (Linux_x86_64-gcc3). Please contact the author of this item about the problem.

Amber Graner (akgraner) wrote :

When I tried to install it enigmail it overwrote thunderbird and installed seamonkey

Enigmail in Archive will not work with Thunderbird 3. I'm going to try
to work on it this weekend.

On 03/13/2010 02:41 PM, Amber Graner wrote:
> When I tried to install it enigmail it overwrote thunderbird and
> installed seamonkey
>
>

+1 for thunderbird without enigmail to be considered not fully functional:

[...]
The protection of electronic mail from unauthorized access and inspection is known as electronic privacy. In countries with a constitutional guarantee of the secrecy of correspondence, e-mail is equated with letters and thus legally protected from all forms of eavesdropping.
[...]

Without e-mail encryption, lots of citizens of countries without constitutional guarantee of privacy will have to face great threats without such techniques to protect their rights.

Alexander Sack (asac) wrote :

blocked by thunderbird not shipping a complete sdk.

Changed in thunderbird (Ubuntu Lucid):
importance: Undecided → High
status: New → Triaged
summary: - enigmail is uninstallable in lucid, needs update to 1.0
+ enigmail is uninstallable in lucid, needs update to 1.0 - blocked by
+ missing tbird sdk

This bug was fixed in the package thunderbird - 3.0.3+nobinonly-0ubuntu2

---------------
thunderbird (3.0.3+nobinonly-0ubuntu2) lucid; urgency=low

  * fix LP: #526290 - Thunderbird 3 hyperlinks broken; installing
    the thunderbird-gnome-support package does not trigger component
    re-registration. This caused users that install thunderbird-gnome-support
    after first run without gnome integration until they upgrade/reinstall
    thunderbird main package. We fix this by adding a postinst.in/prerm.in
    for the -gnome-support package that touches $PKGLIBDIR/.autoreg to trigger
    component reregistration on next start.
    - add debian/thunderbird-gnome-support.postinst.in
    - add debian/thunderbird-gnome-support.prerm.in
    - update debian/rules
  * fix LP: #527138 - enigmail is uninstallable in lucid, needs update to 1.0 - blocked
    by missing tbird sdk; add missing SDK and headers to thunderbird-dev package;
    this allows extensions with native components like enigmail and traybiff to build.
    To fix this we add INSTALL_SDK=1 to DEB_MAKE_EXTRA_ARGS in rules and add the
    appropriate paths to a fresh thunderbird-dev.install package.
    - update debian/rules
    - add debian/thunderbird-dev.install
  * fix SDK packaging for system-nspr/nss; we install links for nspr-config and
    /usr/include/nspr (and nss-config and /usr/include/nss) to the tbird sdk if
    system nspr/nss is used
    - update debian/rules
  * fix build failures on hardy-jaunty; DEB_MAKE_EXTRA_ARGS doesnt exist in the
    cdbs versions available there; using DEB_MAKE_ENVVARS is supposed to work
    everywhere; hence we use that to set INSTALL_SDK
    - update debian/rules
  * the sdk binaries (xpt_* and xpidl) seems to get not installed for applications
    != xulrunner; we work around by patching toolkits packager.mk to install them
    into "installdir"
    - add debian/patches/fix_install_sdk_bin.patch
    - update debian/patches/series
  * mailnews does not install enough mime headers for enigmail when using
    INSTALL_SDK=1; we add nsStreamConverter.h, mimecryp.h and mimemoz2.h to
    EXPORT.
    - add debian/patches/fix_sdk_install_mimecrypt.patch
    - update debian/patches/series
  * install xpidl and xpt_link/xpt_dump to pkglibdir of thunderbird-dev package
    - update debian/thunderbird-dev.install
 -- Alexander Sack <email address hidden> Mon, 22 Mar 2010 23:51:02 +0100

Changed in thunderbird (Ubuntu Lucid):
status: Triaged → Fix Released
Rolf Leggewie (r0lf) wrote :

Does enigmail need to be rebuilt now?

The situation as it is in the archive still does not allow installation of Thunderbird alongside enigmail.

My guess is that enigmail needs to be rebuilt after the INSTALL_SDK=1 magic has been added.

Martin Pitt (pitti) on 2010-03-26
Changed in enigmail (Ubuntu Lucid):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) wrote :

Assigning to c-d-t to keep it on the radar. However, help with this would be greatly appreciated!

This is a universe app, so not a release blocker. Changing importance to medium. Still targeted to Lucid, so a fix before final freeze would be greatly appreciated.

Changed in enigmail (Ubuntu Lucid):
importance: High → Medium
Martin Pitt (pitti) on 2010-04-01
Changed in enigmail (Ubuntu Lucid):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
Benjamin Drung (bdrung) wrote :

enigmail still FTBFS due to missing thunderbird-config in thunderbird-dev.

Steve Langasek (vorlon) on 2010-04-09
Changed in enigmail (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-2 → ubuntu-10.04
summary: enigmail is uninstallable in lucid, needs update to 1.0 - blocked by
- missing tbird sdk
+ missing thunderbird-config
Martin Pitt (pitti) wrote :

Chris, can you please have a look at this? Is thunderbird-config just missing from the *.install file? Or was it perhaps dropped upstream?

Benjamin, you said "enigmail still FTBFS..."; so it seems you already have an enigmail 1.0 package somewhere?

Changed in thunderbird (Ubuntu Lucid):
assignee: nobody → Chris Coulson (chrisccoulson)
status: Fix Released → Triaged
milestone: none → ubuntu-10.04
Max Bowsher (maxb) wrote :

I assume this isn't actually "blocked by missing thunderbird-config" any more, as asac has a working enigmail for i386 in his PPA. (The amd64 build failed because dh_xul-ext apparently fails to support the common debhelper options for selecting packages to process, i.e. -a in this case).

Martin Pitt (pitti) wrote :

Ah, thanks for confirming.

Changed in thunderbird (Ubuntu Lucid):
status: Triaged → Fix Released
Max Bowsher (maxb) wrote :

Oh, and actually it looks like asac has fixed that FTBFS since I last checked.... woot! I have working enigmail on lucid for the first time in ages :-)

So asac just needs to get his fix uploaded.

Benjamin Drung (bdrung) wrote :

The bug in mozilla-devscripts, which provides dh_xul-ext, is fixed in version 0.21.

Martin Pitt (pitti) on 2010-04-13
Changed in enigmail (Ubuntu Lucid):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package enigmail - 2:1.0.1-0ubuntu1

---------------
enigmail (2:1.0.1-0ubuntu1) lucid; urgency=low

  * First releaase of enigmail 1.0.1 for tbird/icedove 3
    (LP: #527138)
  * redo packaging from scratch
    + add debian/make-orig target that uses xulrunner provided
      buildsystem + enigmail tarball to produce a proper orig.tar.gz
    + use debhelper 7 with mozilla-devscripts
    + use debian source format 3.0 (quilt)
    + patch enigmail to use frozen API only
      - add debian/patches/frozen_api.diff
    + patch build system to not link against -lxul - which isnt
      available for sdks produced by all-static apps like tbird
      - add debian/patches/build_system_dont_link_libxul.diff
    + add minimal build-depends to control
 -- Alexander Sack <email address hidden> Sat, 10 Apr 2010 01:42:24 +0200

Changed in enigmail (Ubuntu Lucid):
status: Fix Committed → Fix Released

When will it hit repositories?

It already has for i386 and amd64. You can check the status yourself
in launchpad:
https://launchpad.net/ubuntu/+source/enigmail

On 04/15/2010 06:43 PM, Michał Gołębiowski wrote:
> When will it hit repositories?
>

I use 64-bit Lucid with official repositories (no mirrors) and it's
still not there. I guess the end of the build process doesn't
automatically mean that it hit repositories...

But OK, since it's been build less than an hour ago, I guess it will
soon be on its place.

Rolf Leggewie (r0lf) wrote :

I'm happy to report that the package installed and works fine here. Thanks, guys.

hannuko (hannu-kotipalo) wrote :

Well, it installs, but does not work on my AMD64. Settings says it cannot find GnuPG from /usr/bin/gpg. But it IS there...

@hannuko

Please file a new bug against the enigmail package.

On 04/23/2010 10:39 AM, hannuko wrote:
> Well, it installs, but does not work on my AMD64. Settings says it
> cannot find GnuPG from /usr/bin/gpg. But it IS there...
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers