Ubuntu

Cannot change mouse cursor theme when compiz is enabled

Reported by Nipas on 2009-10-24
678
This bug affects 138 people
Affects Status Importance Assigned to Milestone
Compiz
Unknown
Unknown
compiz (Ubuntu)
Low
Unassigned
Lucid
Medium
Scott Kitterman
Maverick
Low
Unassigned

Bug Description

Binary package hint: gnome-control-center

Gnome cursor theme does not change when compiz is enabled.

System: Ubuntu 9.10 karmic amd64
updates installed

ProblemType: Bug
Architecture: amd64
Date: Sat Oct 24 12:11:56 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: gnome-control-center 1:2.28.1-0ubuntu1
ProcEnviron:
 LANGUAGE=el_GR.UTF-8
 LANG=el_GR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: gnome-control-center
Uname: Linux 2.6.31-14-generic x86_64

TEST CASE: (Warning: I'm translating the UI elements from German, from memory, so interpret them loosely.) Open the "Appearance" control panel, customize the current theme, then switch to the "Mouse pointer" tab. On a system with this bug, changing the mouse pointer size does not show an immediate effect. On a system where this bug is fixed, it goes into effect in real time.

Nipas (nik8pol) wrote :
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
Ben (ben2talk) wrote :

Confirmed here - and the option to enter the cursor theme in the compiz settings is now removed.

I can set the Obsidian cursor theme and it works perfectly under Metacity.

With compiz, the effects are rather fragmented - initially, the cursor doesn't appear. Switching to metacity gives perfect results, going back to compiz may show the obsidian cursor as the cursor passes over firefox window, and back to the default cursor when the cursor passes over the desktop.

I think this bug is perhaps more with compiz.

Ben (ben2talk) wrote :

Update - strangely, though I see a white cursor, when I take a screenshot it records the Obsidian (black) cursor!!!

Ben (ben2talk) on 2009-12-02
tags: added: compiz cursor display
removed: amd64
bdoe (bdoe-att) wrote :

Any word on this issue? Any workarounds? Anything?

This may be of "low" importance, but it is very annoying nonetheless - the sort of thing that makes Windows users point and laugh.

Ben (ben2talk) wrote :

It cleared to some extent after a reboot. I remember previously (last year) installing a silver cursor as the default cursor and I didn't have this problem - so maybe it's just a matter of communication. Very amateur - really, it should be a matter of changing the basic default system cursor in a single location - how is it possible for compiz to confuse the issue? The setting for cursor in Compiz has now been removed from view (though clearly it still exists).

Perhaps the onslaught of a new generation of gnome will see the exit of compiz, and hopefully the inclusion of the main features (magic lamp, scale, wobblys etc).

It's annoying, because wobbly windows feels natural and I really feel uncomfortable on other systems without it now!

mullens101 (sean-planetbean) wrote :

OK, I was having this same issue. What I've found is that I can change the cursor theme by running the gconf configuration editor and navigating to Desktop->gnome->peripherals->mouse and manually changing the value of the "cursor_theme" key. I changed it from "default" to "whiteglass" and the cursor_size key from 18 to 27. I then logged out and back in and now have the whiteglass cursor theme working well. It seems that the Appearance Preferences dialog is not setting this key when the cursor theme is customized through the preferences menu.

mullens101 (sean-planetbean) wrote :

One further note ... you have to use the folder name from /usr/share/icons, not the theme name identified in the appearances dialog. For example, if I used "DMZ (White)" (as shown in the appearances dialog), I got the default theme. If I changed it to "DMZ-White" (the folder in /usr/share/icons), I get the DMZ White theme.

mullens101 (sean-planetbean) wrote :

And yet another ... if you want to change the default theme (this will also affect the GDM login screen), edit the file /usr/share/icons/default/index.theme. under [Icon Theme], change the Name setting to the name that appears in the Appearance menu. Not sure if it's necessary, but I also changed the Inherits value to the folder of the theme in the /usr/share/icons directory. Here's my index.theme Icon section.

[Icon Theme]
Name = DMZ (White)
Comment = Nice White Theme
Inherits = DMZ-White

This combined with the above changes to the desktop->gnome->peripherals->mouse->cursor_theme key now gives me a consistent DMZ (White) theme through login and my session.

babygenius55 (babygenius55a) wrote :

Is there any more input on this? I tried Mullens101 suggestions, and they worked to change the default, but it will not update the desktop mouse presentation unless you log out/back in. I'm rebooting and will tell more.

babygenius55 (babygenius55a) wrote :

Well, changing the .theme file with gedit gets results when you log out, and on the logon screen. That's probably what it's supposed to do. Using the appearance preferences does indeed update the cursor, but the changes don't carry over to the desktop. Weird. Upon changing the overall theme to dust...a pre-packaged one, I now have red glass on some portions of some windows, Comix on others, and the dmz-white on others. That's 3! different mouse themes in one session!

Note: with compiz visusal effects set to none the theme/icon switching works fine. When I add any eye candy, it goes back to it's normal foul acting self. I'm thinking openGL layers, or alpha blending handling issues. Is there anyone else with me? I think it's definitely compiz.

babygenius55 (babygenius55a) wrote :

I changed my theme after switching back to compiz today, it didn't update correctly, but it was the reverse. Gnome desktop was showing the comix pointer theme, and firefox was showing the DMZ white. Just because I switched back to compiz I decided to change to the default theme so that I didn't get a jumpy mouse graphic. So, on a whim, I decided to switch back to comix and it's working, so I won't be switching back anytime soon. A reboot will tell what I'm lacking I suppose...

I'm not sure is this bug is from Gnome or Compiz. Can somebody check if this also happens with Compiz in KDE?

Jean Roberto Souza (sjeanr) wrote :

I can't change the Pointer Theme on Ubuntu 10.04 Lucid.

mabawsa (mabawsa) wrote :

I have the same problem but only on one of my machines (both fully updated) in Lucid. However two of my machines work as expected. I even created a new user on the buggy machine and get the same symptoms. Strange problem.

mabawsa (mabawsa) wrote :

OK a work around for this is to create a file in:
~/.icons/default/index.theme

Add the following lines

[Icon Theme]
Name = <anything you want>
Comment = <anything you want>
Example = <anything you want>
Inherits = <YOUR THEME NAME>

Where your theme name can be obtained from running gconf-editor under the key

/desktop/gnome/peripherals/mouse/cursor_theme

Restart compiz (Alt + F2 then compiz --replace)

Every time you change the mouse theme you have to remember to change the file you have created.

Lee Hyde (anubeon) wrote :

I'm experiencing a similar issue. I have the default cursor themes as well as the oxygen and comix cursor themes installed and have selected oxy-white as my cursor and yet the oxy-white theme only appears when I'm hovering over an application (e.g. Firefox, Docky, etc...). At all other times (i.e. when hovering over the desktop or any applications title bar) the cursor theme defaults to the first (alphabetically) cursor theme which was initially comix-black-large-slim but since then I've uninstalled the comix cursor theme and it now defaults to DMZ (black).

Interestingly, before yesterday this issue seemed to effect all cursors except to default cursor arrow (i.e. the oxy-white cursor arrow would persist, but all other cursors (zoom, resize, etc...) would display as comix-black-large-slim. Originally I though that is was just a rather eclectic cursor theme but it's clear now that its a bug.

@mabawsa: I can't speak for anybody else but I'm afraid that your work around didn't work for me.

mabawsa (mabawsa) wrote :

Sorry to hear the work around didn't do anything. Maybe the fields other than Inherits actually matter I basically thought that the ~/.icons/default/index.theme would override the /usr/share/icons/default/index.theme. It does for me but I am using the simple DMZ (White) theme.

[Icon Theme]
Name = DMZ (White)
Comment = Nice White Theme
Inherits = DMZ-White

WangLu (coolwanglu) wrote :

I used update-alternatives to change /usr/share/icons/default/index.theme into what I want, Now everything's fine.

But still I think this is a bug...

I've had this problem in Lucid for about a week now. It started sometime during the updates to Gnome 2.30. It's exactly what other people are experiencing too: selected pointer theme is not honored when Compiz is active and the cursor is over any GTK window. Definitely a bug.

Mabawsa's workaround (setting Inherits to name of desired theme in ~/.icons/default/index.theme) works for me, although I had to adapt my icon theme (Griffin Embers Cursors) not to use any spaces in its name and directory.

are any developers looking at this? It seems like it should be a simple fix, such as giving us back the option to set the cursor theme in compiz.

Sebastien Bacher (seb128) wrote :

the issue is mostly cosmetic and higher priority bugs are on the desktop team list for lucid so no, nobody is working on this one, you are welcome to try to fix it though we would welcome extra hands fixing issues

Alexander Usyskin (sanniu) wrote :

There was similar bug from 2007, patched once. May be with new compiz update this patch was accidentally left behind?
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/86184

Jeremy Nickurak (nickurak) wrote :

I get this with openbox running under gnome as well, so I don't think it's a compiz bug.

Hello Jeremy

Am 13.04.2010 01:58, schrieb Jeremy Nickurak:
> I get this with openbox running under gnome as well, so I don't think
> it's a compiz bug.
>

on my IBM T41 i turn off compiz = i have my nice coursor (theme)
if i turn on compiz (e.g. normal settings) i have the (buggy) blue
coursor theme.

Mit freundlichen Grüßen / Yours sincerely

M. Kappes
--
| www.linuxnetz.info
| Linux - Social - Open - BLOG

Geoff B (ransom-onetel) wrote :

I get this too. I noticed that the selected theme appears in Firefox, Open Office and Terminal (but not Terminal menu bar).

Bevan (bevan-bi-co) wrote :

I can confirm Geoff's observation. Also the text cursor seems to be always correct (e.g. in gedit or in evolution text fields).

Majestyx (majestyx) wrote :

just a little observation: at the time i cant re-install firefox. temp. is my default browser opera. if opera starts, the cursor theme change to the "bug" (blue cursor) whit epiphany-browser is the right (white) cursor theme....

Majestyx (majestyx) wrote :

another app that shows the blue cursor (comix?!) SKYPE - if i start skype i have blue, opera also .....

Pedro Casagrande (pccampos) wrote :

Can anyone confirm if this bug is on a clean 10.04 install?

sstuzzi (sstuzzi) wrote :

Yes, the bug still remains.

Plato Puthur (platodreams) wrote :

for me tooo!!! :(

Diego (diego-spd) wrote :

i'm having the same problem on a clean 10.04 install

Phil Borman (phil-borman) wrote :

A workaround that works for me is cd ~/.icons ; ln -s /usr/share/themes/theme_name default

I have the same problem on Lucid, the only workaround is metacity --replace, in the run dialog, but it conflicts with emerald...so not a permanent fix...will keep looking...

ptruax (philiptruax) wrote :

Mullins solution worked for me.
Found the solution for this issue in another bug as well.
Located:https://bugs.launchpad.net/ubuntu/+source/gcursor/+bug/138491/comments/22

Peekie wrote on 2009-01-25: #22

Installing a mouse cursor theme has kept me busy for a couple of hours. I agree with others that you should be able to change it in the Mouse settings.
Despite all solutions in the above I found a way to change the cursors:
- Download the tar-ball from e.g. gnome-look.org
- Extract it as root to /usr/share/icons
- Then edit as root the index.theme file located in usr/share/icons/default
Change the line Inherits= to the name of your new icon theme.
Logout and login again and your new cursor is in use.

Followed the instructions and it worked like a charm with my Shiny new clean Lucid Install.

ptruax (philiptruax) wrote :

Just realized that some people who find this may not know how to open as root. For those new souls press alt -f2 and type "gksudo nautilus" to open the file explorer and when you get to the index.theme file do the same thing except type "gksudo gedit" and then drag the file into gedit which will let you save with the proper rights.

Majestyx (majestyx) wrote :

on my fresh lucid install. i have the same problem. wrong cursor theme. the workaround in #35 do not work for my. my file: /usr/share/icons/default/index.theme is only a link to /etc/alternatives/x-cursor-theme. if i edit x-cursor-theme, i see the right :

[Icon Theme]
Name=Chameleon-Pearl Large 0.5
Comment=Cursor Theme by Giuseppe Benigno <email address hidden>
Inherits=Chameleon-Pearl-Large
Example=left_ptr

marc1uk (marc1uk-) wrote :

Can anyone tell me the key to add to icon.theme to change the cursor size? I've used this workaround to change from DMZ to whiteglass, but even after changing the size to 12 in gconf-editor, both in compiz and gnome peripherals, my cursor's still appearing huge on the desktop (but not in some windows like firefox). I've tried adding Size=12 to the icon.theme file; maybe this is the wrong key to add?

Thiago Teixeira (tvst) wrote :

In response to this:
--------------
Sebastien Bacher wrote on 2010-04-07:
the issue is mostly cosmetic and higher priority bugs are on the desktop team list for lucid so no, nobody is working on this one, you are welcome to try to fix it though we would welcome extra hands fixing issues
--------------

The issue *is not* a cosmetic one. This is an accessibility issue. Some people have trouble seeing and need a large cursor, or a high-contrast one.

So the priority on this should be quite high, especially since this is a regression.

Comment #35 worked for me too. Thanks avengingwatcher!

affects: gnome-control-center (Ubuntu) → compiz (Ubuntu)
d.a. (glukensoft) on 2010-05-23
Changed in compiz (Ubuntu):
assignee: nobody → d.a. (glukensoft)
assignee: d.a. (glukensoft) → nobody
status: New → Fix Committed
d.a. (glukensoft) on 2010-05-23
Changed in compiz (Ubuntu):
assignee: nobody → Ubuntu Development Team (ubuntu-dev)
Changed in compiz (Ubuntu):
assignee: Ubuntu Development Team (ubuntu-dev) → nobody
Vish (vish) on 2010-05-24
Changed in compiz (Ubuntu):
status: Fix Committed → New
status: New → Confirmed
Julian Mehnle (jmehnle) on 2010-06-04
description: updated
Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Changed in compiz (Ubuntu Lucid):
importance: Undecided → Medium
status: New → In Progress
milestone: none → ubuntu-10.04.1
tags: added: regression-release
Martin Pitt (pitti) on 2010-06-09
Changed in compiz (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) on 2010-06-15
tags: added: verification-failedd
removed: verification-needed
Changed in compiz (Ubuntu Lucid):
assignee: nobody → Scott Kitterman (kitterman)
status: Fix Committed → In Progress
Changed in compiz (Ubuntu Maverick):
status: Fix Released → Triaged
Martin Pitt (pitti) on 2010-07-20
Changed in compiz (Ubuntu Lucid):
milestone: ubuntu-10.04.1 → ubuntu-10.04.2
63 comments hidden view all 143 comments
Martin Pitt (pitti) wrote :

I removed the lucid-proposed package again. This wasn't fixed in maverick yet, and there is a reported regression.

Changed in compiz (Ubuntu Lucid):
status: In Progress → Triaged
tags: removed: verification-failedd
conorsulli (conorsulli) wrote :

Added Bug as also effecting the one hundred papercuts ubuntu project hopefully be fixed in time for maverick.

Claudio (claudio-melioli) wrote :

I answer to Majestyx, comment #37: I was in your exact situation and I workarounded the problem simply removing the file /etc/alternatives/x-cursor-theme; after that I also noticed that some other problems disappeared (i.e. the cursor theme wasn't always the same in every application, but somewhere was the default one specified in /etc/alternatives/x-cursor-theme, and somewhere was the theme I had choosen).
It seems to me that somewhere the /etc/alternatives/x-cursor-theme is predominant; but if this is the case, how can a user change it without administrative rights? I mean, when you change your PC appearance (your theme) you do it without administrative rights, so how can you possibly hope to change the /etc/alternatives/x-cursor-theme content?

DjznBR (djzn-br) wrote :

I want to confirm that workaround #45 worked BEAUTIFULLY for me. I know it's kinda of a hard work solution, etc, but this bug was DRIVING ME INSANE. And look, it's just caused by a typo.

If you are going to do this workaround, don't forget to LOCK PACKAGE after installing your modified one. You can do that in Synaptic -> Package -> Lock Version.

DjznBR (djzn-br) wrote :

I find this bug of a certain critical level, please fix this for Maverick.

Vish (vish) wrote :

Thank you for bringing this bug to our attention. However, a paper cut should be a small usability issue, in the default Ubuntu install, that affects many people and is quick and easy to fix. So this bug can't be addressed as part of this project.

- This is a bug and will be addressed on its own, not a design issue or a papercut.
For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.
Don't worry though, this bug has been marked as "Invalid" only in the papercuts project.

Changed in hundredpapercuts:
status: New → Invalid
Andy (andy-xillean) wrote :

Here is my workaround.

1)
create a file in the folder of the Icon theme you want to use and name it
cursor.theme and put the following it it.
[Icon Theme]
Inherits=NameOfTheme

2)
type the following at the command line.
$ sudo update-alternatives --install /usr/share/icons/default/index.theme x-cursor-theme path/to/cursor.theme

3)
type the following
sudo update-alternatives --config x-cursor-theme
then chose the theme you want to use.

Larry Kyrala (larry-kyrala) wrote :

#110 works great! thx Andy!

Unsubscribing the Papercutters team.

affects: hundredpapercuts → null
Vaibhav (vnagarnaik) wrote :

#110 works for me too. I have the latest released lucid packages and am not on patched compiz. I don't see the problems regarding partial cursor theme display.
Also, I tried to remove the x-cursor-theme config item but compiz used a fallback theme and still did not honor the selected cursor theme. It is weird to have to use superuser permissions to change the user cursor theme.

Changed in compiz (Ubuntu Maverick):
status: Triaged → Fix Released
Mackenzie Morgan (maco.m) wrote :

Here's a debdiff for Lucid to make the same change as was made to fix it in Maverick.

Impact: inconsistent mouse theme for Compiz users
What the patch does: change a patch in debian/patches so it modifies the correct file
Regression potential: none

This is the same fix that already failed verification once. I still think it's
the right fix, but it would be useful to revisit the last time we tried this
and see what else is going on.

Mackenzie Morgan (maco.m) wrote :

Could there be two bugs? Two guys came up to me at Ohio LinuxFest today
saying it worked perfectly for them and asking me to find a way to get a patch
merged, and there are comments on here saying it works correctly in Maverick
with this fix.

Could it be that this is Compiz on one and metacity on the other side? Changing the theme works now within the windows/apps but isn't overtaken on the Borders and Title.

Just a thought...

Corrction: ONLY the borders....

Sam Spilsbury (smspillaz) wrote :

Just to double check, can you check to see if for example, the cursor theme does not change when the mouse is in QT windows?

Setting the cursor image away from the X11 default is something that is done by the client windows, and probably automatically by GTK. In this case, it should be possible for the GTK window decorator to try and integrate with the cursor theme.

- Sam (upstream)

Scott Kitterman (kitterman) wrote :

I suspect your fix solves the problem at hand, but exposes some other issue in
some cases.

Sam, I've tested that with QCad and no, the theme does not change within QT-Windows.

Sam Spilsbury (smspillaz) wrote :

Try it with a KDE application which will force QT not to draw using GTK widgets, like KDE4's systemsettings or amarok.

The result should be that the mouse cursor will change.

In this case what we need is a system or upstream patch to gtk-w-d to read the cursor settings from gnome.

Mackenzie Morgan (maco.m) wrote :

KDE apps will masquerade as GTK just fine...

Sebastien Bacher (seb128) wrote :

Unsubscribing the sponsors for now since that still seems in discussion

ColdEgo (coldego) wrote :

This bug affects me too... I`ve been installed in my Ubuntu 10.04 wondering theme pack "Elegant"...but cursor theme changes only in Firefox.
 After some googling I`ve find temporary solution, that don`t touch system files like /etc/alternatives, only creates some files in user home folder. I`ve find it here - http://ubuntuforums.org/showpost.php?p=9548085&postcount=2.
Quote:
Using Compiz?

It's a fairly common problem if you are. Creating a new document at ~/.icons/default, calling it "index.theme" opening it with gedit (or equivalent) and putting the following content in it:
Code:

[Icon Theme]
Name =
Comment =
Example =
Inherits = <NAME OF CURSOR THEME YOU WANT>

fixes it. You can put whatever you want after Name, Comment and Example, but make sure you put the exact name of the cursor theme after Inherits. Log out and back in, and it should display the cursor you want.

Big thanks to guy, whose username there is "WorMzy"!

Changed in compiz (Ubuntu Maverick):
assignee: nobody → Gerald Clark (gerald-wendy-gmail)
Steve Langasek (vorlon) on 2010-11-26
Changed in compiz (Ubuntu Maverick):
assignee: Gerald Clark (gerald-wendy-gmail) → nobody

I'm still getting this error on a fresh install of Maverick. Previously (with Lucid) I could use the mentioned work-arounds (with ~/.icon/default/index.theme, etc) to get proper cursors but that wasn't even working in 10.10.

Now it will change it for some windows (firefox) or for certain cursors (resize) but the main pointer was the default white cursor. No combination of logging out or rebooting gave different results.

What's odd is that if I used the compiz system tray icon (package 'fusion-icon') to change the window decorator to 'GTK Window Decorator' instead of 'Emerald,' then everything works as expected. In fact, I removed my ~/.icons/default/index.theme and I can successfully switch cursor themes with compiz running as long as I have the window decorator set to GTK. I can then switch back to Emerald without problems after.

It would seem this is a problem with Emerald and not Compiz, at least in my case.

Mackenzie Morgan (maco.m) wrote :

Is anyone else using Emerald? If it's an Emerald bug, it's unlikely to be
fixed. Emerald's been dead upstream for...2 or 3 years.

Alexander Usyskin (sanniu) wrote :

I have this bug with GTK decorator, not Emerald

Yep, I'm getting the exact same thing as Taylor mentioned. Switching
cursor theme while Emerald is enabled doesn't work. Switching cursor
theme while GTK Window Decorator is enabled works fine, though not
perfect. The main pointer changes as expected, but the resize pointer
doesn't. I have to switch to Emerald and then back to GTK to get all
cursors right.

max (max-illis) wrote :

Not sure whether this will help anyone, but I've been trying [again] to figure this out and appear to have solved it just by deleting - in a fit of frustration - the 'cursors' directory under ~/.icons/default and restarting X

the directory has not been recreated

I'd be interested to hear if that helps anyone else

Joseph Lansdowne (j49137) wrote :

Hmm, I don't even have an ~/.icons/default (Linux Mint 9).

Changed in compiz (Ubuntu Lucid):
milestone: ubuntu-10.04.2 → ubuntu-10.04.3

On Fri, 2011-02-18 at 07:16 +0000, Kate Stewart wrote:
> ** Changed in: compiz (Ubuntu Lucid)
> Milestone: ubuntu-10.04.2 => ubuntu-10.04.3
>

I'm getting the same error after todays compiz-updates under Natty.

1 comments hidden view all 143 comments

Andre, those Options aren't available on Natty. I didn't find them there.

Please, can someone file this against Ubuntu 11.04? The Bug is back there, too.

David F. (malteworld) wrote :

There seems to be a regression lately. I first noticed the problem yesterday and remember an update to some Gnome packages during the last days.

- Gnome packages ranging from 1:2.28+1ubuntu4 to 1:2.32.0-0ubuntu2
- Compiz 1:0.8.6-0ubuntu9.1
- Emerald 0.7.2-0ubuntu6 (don't know, if this is related)

Colin (tekash) wrote :

I can confirm this bug in 11.04 as well using Unity and Compiz.

Here is my workaround: (I think Step 6 was last and not before #4...)
1) Manually unpack your cursor tar.gz files in usr/share/icon.
2) Log out and back in to have Natty see all the ones you just unpacked in the Pointer selection menu.
3) Go to System Settings -> Appearance -> Customize -> Pointer tab -> Select the theme you unpacked in step 1 -> Save your custom theme -> Close the Appearance window.
4) Navigate to etc/alternatives and edit x-cursor-theme. It should say:
[Icon Theme]
Inherits=NAME_OF_A_UNPACKED_FOLDER_IN_STEP_1
5) Log out and back in.
Alas, it still only half worked for me and was using an old icon set I had chosen on some pages.
6) Go to Appearances again and notice that your Theme may now NOT be selected and be Custom instead. I could not delete Custom, so selected the same icons, border window, cursors etc and saved it with the same name in Step 3 overwriting the original.
7) Enjoy.

DjznBR (djzn-br) wrote :

Bug present in Natty. Workaround mentioned on post #45 no longer works in this version.
Always coming up like crap keeping strong against toilet flush.

mikeloco14 (mikeloco14) wrote :

not fixed yet.

Dean Sadites (dsadites-gmail) wrote :

ATTENTION DEVELOPERS: You may be treating this as a low-priority item simply because you believe it to be cosmetic in nature. However, you need to be treating this as an accessibility issue and giving it a little more attention than it has gotten over the past several years that this defect has stagnated and continually resurfaced. Users with impaired vision absolutely depend on the ability to increase the mouse pointer size (especially on today's high resolution displays). While some of the workarounds above allow a different cursor theme to be installed, none of them solve the related problem in which the mouse pointer cannot be resized when Compiz is enabled (even with the default DMZ White theme).

Please focus on fixing the basics (and ensuring they remain stable from release to release) before wasting time on things like Unity and other relatively pointless endeavors like overlay scroll-bars.

Peter Belew (peterbe) wrote :

Note - the above comment should probably be moved to bug #86184.

Also, I totally concur with the comments in #140. There has been too much emphasis in Ubuntu on adding flashy new features that end users really don't need, and much too little in actually fixing bugs like this one. In particular, I completely agree with regard to Unity.

I must point out however, that some changes, such as the transition to Gnome 3, are pretty much beyond the control of Canonical. Unity is another story.

Ovidiu Zeicu (ovidiu-zeicu) wrote :

The workaround offered by Colin in #137 worked for me, but it was not necesary to take all the steps.
I have the Oxygen cursor theme installed via Synaptic (oxygen-cursor-theme & oxygen-cursor-theme-extra packages). The only thing I had to do was step 4 and reboot (I prefer to reboot rather than log out/in). Look in /usr/share/icon for the theme's name.
Works for me in all tested windows. So far...
Thanks Colin.

drillerccg (ddsinaurora) wrote :

I never had any use for eye-candy hence no need to change themes or cursor icons. That is until my 78 year-old mother-in-law complained that the cursor was too small. I tried to change the size on default cursor and it did in some windows but not on desktop or system windows. The search began and I came across this you tube video that solved my problem, the link at the end. Here is a step by step of what I did courtesy of AbhiramH on you tube:

1-Go to http://gnome-look.org/ , click on X11 Mouse Themes in the left margin, and download a pointer theme you like. I needed a large cursor so I downloaded Large Mouse Cursor 1.0
 http://gnome-look.org/content/show.php/Large+Mouse+Cursors?content=140787

2-go to download folder and extract to desktop, you now have a folder on desktop named as the downloaded theme

****MY extracted folder was named Large Mouse Cursor and I had to rename it Large-Mouse-Cursor (with dashes) to get this to work, it seems like spaces don't really work in this process. Themes without spaces worked without renaming.

3-Fire up the terminal, type sudo nautilus, enter password
4- once browsing as root in the file browser, copy the folder on the desktop and paste to usr/share/icons folder
5-close nautilus and terminal
6- Fire terminal again and type sudo gedit /usr/share/icons/default/index.theme
7-enter password
8- when the file opens, you will see Inherits=name of your current pointer theme, change that to Inherits=name of new pointer theme which is the name of the extracted folder you copied in step 4. Mine was Inherits=Large-Mouse-Cursors (again note the lack of space and addition of dashes)
9-save and exit.
10- now go to system/preferences/appearance, click customize, click pointer tab, and choose your new pointer theme, and exit
11- shut down and restart. Log in and out did not work for me. That's it, it should work.

Other than a few exceptions above, I take no credit for this. All the credit goes to this dude AbhiramH on you tube

http://www.youtube.com/watch?v=CvS9kh_bMyM

Displaying first 40 and last 40 comments. View all 143 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.