Brasero Fails to open using the -p argument

Bug #543892 reported by bbordwell on 2010-03-22
106
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Brasero
Fix Released
Medium
brasero (Ubuntu)
Medium
Canonical Desktop Team
Lucid
Low
Sebastien Bacher

Bug Description

Binary package hint: rhythmbox

To reproduce create a play-list in rhythmbox and then right click on it and press create audio CD. It should open Brasero and make a CD but nothing happens.

Another way to reproduce this bug is to start an audio CD project in brasero, save it, then exit brasero and in nautilus double click on the project file (open with brasero), brasero fails to open.

Another way to reproduce this bug is to save a project file, then open a terminal and enter "brasero --project=<projectname>"

Workaround (for the first way to repoduce this bug): Rhythmbox succesfuly creates a project file and puts it in /tmp, So you can open brasero and open the project manually. The burn will most likely fail just before it starts to write to the disk due to bug 571021, see the bug report for a workaround on that.

ProblemType: Bug
Architecture: amd64
Date: Sun Mar 21 22:22:06 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/rhythmbox
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100313.1)
Package: rhythmbox 0.12.7-0ubuntu7
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: rhythmbox
Uname: Linux 2.6.32-16-generic x86_64
XsessionErrors: (polkit-gnome-authentication-agent-1:1381): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

bbordwell (benbordwell) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, do you have rhythmbox-plugin-cdrecorder installed?

Changed in rhythmbox (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
bbordwell (benbordwell) wrote :

synaptic reports rhythmbox-plug-in-cdrecorder is installed, the version is 12.7-0ubuntu7

bbordwell (benbordwell) wrote :

okay this may be helpful, this is the terminal output from me opening rythmbox and attempting to press create audio cd 3 times.

ben@ben-desktop:~$ rhythmbox

(-r:4964): GLib-GObject-CRITICAL **: g_object_ref: assertion `object->ref_count > 0' failed

(-r:4964): GLib-GObject-CRITICAL **: g_object_unref: assertion `object->ref_count > 0' failed

(-r:4964): GLib-GObject-CRITICAL **: g_object_ref: assertion `object->ref_count > 0' failed

(-r:4964): GLib-GObject-CRITICAL **: g_object_unref: assertion `object->ref_count > 0' failed

(-r:4994): GLib-GObject-CRITICAL **: g_object_ref: assertion `object->ref_count > 0' failed

(-r:4994): GLib-GObject-CRITICAL **: g_object_unref: assertion `object->ref_count > 0' failed

(-r:4994): GLib-GObject-CRITICAL **: g_object_ref: assertion `object->ref_count > 0' failed

(-r:4994): GLib-GObject-CRITICAL **: g_object_unref: assertion `object->ref_count > 0' failed

(-r:5013): GLib-GObject-CRITICAL **: g_object_ref: assertion `object->ref_count > 0' failed

(-r:5013): GLib-GObject-CRITICAL **: g_object_unref: assertion `object->ref_count > 0' failed

(-r:5013): GLib-GObject-CRITICAL **: g_object_ref: assertion `object->ref_count > 0' failed

(-r:5013): GLib-GObject-CRITICAL **: g_object_unref: assertion `object->ref_count > 0' failed

bbordwell (benbordwell) wrote :

Marking as confirmed since I have provided the information that Sebastian asked for and he has not gotten back to me yet+ someone else marked it as affecting them.

Changed in rhythmbox (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for sending the bug to GNOME

Changed in rhythmbox (Ubuntu):
status: Confirmed → Triaged
Changed in rhythmbox (Ubuntu Lucid):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Canonical Desktop Team (canonical-desktop-team)
Pedro Villavicencio (pedro) wrote :

the relevant part of the debug:

(10:03:42) [0x8d51028] [source_burn] rb-disc-recorder-plugin.c:470: Burning playlist test
(10:03:42) [0x8d51028] [source_burn] rb-disc-recorder-plugin.c:474: Creating audio project
(10:03:42) [0x8d51028] [source_burn] rb-disc-recorder-plugin.c:486: Starting brasero
(10:03:42) [0x8d51028] [window_focus_cb] rb-mmkeys-plugin.c:142: window got focus, re-grabbing media keys

(-r:10800): GLib-GObject-CRITICAL **: g_object_ref: assertion `object->ref_count > 0' failed

(-r:10800): GLib-GObject-CRITICAL **: g_object_unref: assertion `object->ref_count > 0' failed
(10:03:45) [0x8d51028] [rb_shell_quit] rb-shell.c:2572: Quitting
(10:03:45) [0x8d51028] [rb_shell_player_stop] rb-shell-player.c:3168: stopping

bbordwell (benbordwell) wrote :

Pedro, in case you are not subscribed to the upstream bug they are asking for a stacktrace, if you could do so i would appreciate it. I am having trouble doing so (never done it before).

Pedro Villavicencio (pedro) wrote :

Upstream said this is a brasero bug thus reassigning.

affects: rhythmbox (Ubuntu Lucid) → brasero (Ubuntu Lucid)
bbordwell (benbordwell) on 2010-04-01
description: updated
Changed in rhythmbox:
status: Unknown → Confirmed
bbordwell (benbordwell) on 2010-04-29
summary: - Clicking "Create Audio CD" does nothing
+ Brasero Fails to open using the -p argument
description: updated
bbordwell (benbordwell) on 2010-05-01
description: updated
bbordwell (benbordwell) on 2010-05-01
description: updated
description: updated
Emmet Hikory (persia) on 2010-05-05
Changed in brasero (Ubuntu):
importance: Low → Medium
bbordwell (benbordwell) on 2010-05-05
affects: rhythmbox → brasero
John McK. (jovaldan) wrote :

Brasero stopped working literally overnight. Given that it is linked to Rhythmbox - and therefore Rythmbox Playlists can no longer be burnt to CD has any thought been given to making it a "high" priority fix!?

Achim (ach1m) on 2010-05-20
tags: added: regression-potential
bbordwell (benbordwell) wrote :

Achim, regression potential means it is a regression in the development version of Ubuntu, this is a regression in lucid which is released so changing your tag as such.

tags: added: regression-release
removed: regression-potential

okay, I will do so in the future :-)

Thanks for that information.

Changed in brasero:
status: Confirmed → Fix Released
bbordwell (benbordwell) wrote :

For anyone interested I have a brasero package with this bug fix (and as of right now that is the only change) included. https://launchpad.net/~benbordwell/+archive/ppa

Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now

Changed in brasero (Ubuntu):
status: Triaged → Fix Committed
Changed in brasero (Ubuntu Lucid):
assignee: Canonical Desktop Team (canonical-desktop-team) → Sebastien Bacher (seb128)
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

the debdiff for the change is on bug #572942

Accepted into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Martin Pitt (pitti) wrote :

I accepted 2.30.1-0ubuntu2 into lucid-proposed with a followup fix. Please test.

Pedro Villavicencio (pedro) wrote :

I've managed to reproduce the bug with the package version on Lucid. After installed the proposed package, i created a playlist with rhythmbox and choose burn cd, a brasero window was shown with the selected tracks and options to burn those to CD, it also works fine if you open the tmp project (located on /tmp/brasero-tmp-project-XXXX) with brasero -p ; the issue is fixed with the proposed package, marking this as verification done, thanks all.

tags: added: verification-done
removed: verification-needed

The proposed package works as supposed.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.30.1-1ubuntu1

---------------
brasero (2.30.1-1ubuntu1) maverick; urgency=low

  * Rebase on Debian unstable, remaining Ubuntu changes:
  * debian/control.in:
    - Set build-depend version on libgconf2-dev
    - Build-depend on libappindicator-dev
    - Build-depend on liblaunchpad-integration-dev
    - Bump Standards-Version
    - Set Vcs-Bzr info
    - libbrasero-media0 suggests instead of recommends gstreamer0.10-plugins-ugly
      and cdrdao
    - libbrasero-media0 suggests gstreamer0.10-fluendo-mp3
    - Bump libbrasero-media-dev depends for libglib2.0-dev and libgtk2.0-dev
    - libbrasero-media0 replaces brasero (plugins moved from this package)
  * debian/rules:
    - Run autoconf on build
  * debian/patches/010_lpi.patch:
    - Add launchpad-integration
  * debian/patches/011_nautilus_menu_move.patch
    - Moved the CD/DVD Creator menu item to Accessories
  * debian/patches/012_appindicator.patch:
    - Support application indicator
  * debian/patches/90_git_audio_project_creation.patch,
    debian/patches/91_git_audio_project_creation.patch:
    - git change to fix recording an audio project, which is what rhythmbox is
      using to record playlist for example (lp: #543892)
  * debian/patches/92_git_audio_cd_recording.patch:
    - git change to fix recording of audio cds, there is another git change
      which might be required to fix similar issues but it's not trivial so
      let's get that change in a first update for now (lp: #572942)
  * debian/patches/93_git_new_caps_function_definition.patch:
    - don't forget the git commit which define the function which is used
      in the previously uploaded revision
  * debian/watch:
    - Watch for unstable versions
 -- Robert Ancell <email address hidden> Mon, 31 May 2010 17:41:56 +1000

Changed in brasero (Ubuntu):
status: Fix Committed → Fix Released
papukaija (papukaija) on 2010-06-08
tags: added: lucid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.30.1-0ubuntu2

---------------
brasero (2.30.1-0ubuntu2) lucid-proposed; urgency=low

  * debian/patches/93_git_new_caps_function_definition.patch:
    - don't forget the git commit which define the function which is used
      in the previously uploaded revision

brasero (2.30.1-0ubuntu1) lucid-proposed; urgency=low

  * debian/patches/90_git_audio_project_creation.patch,
    debian/patches/91_git_audio_project_creation.patch:
    - git change to fix recording an audio project, which is what rhythmbox is
      using to record playlist for example (lp: #543892)
  * debian/patches/92_git_audio_cd_recording.patch:
    - git change to fix recording of audio cds, there is another git change
      which might be required to fix similar issues but it's not trivial so
      let's get that change in a first update for now (lp: #572942)

  [ Robert Ancell ]
  * New upstream release:
    - Add support for Tracker 0.8.x
    - brasero-rename.c: Fix signedness issues by assigning proper types
    - Harden code by checking for callback value being a BRASERO_PROJECT
    - Fix for Bug 578068 - Brasero does not check for free space before copying disc
    - Many updated translations
 -- Sebastien Bacher <email address hidden> Thu, 27 May 2010 19:20:52 +0200

Changed in brasero (Ubuntu Lucid):
status: Fix Committed → Fix Released

about:
debian/patches/90_git_audio_project_creation.patch,
    debian/patches/91_git_audio_project_creation.patch:
    - git change to fix recording an audio project, which is what rhythmbox is

It seems the bug is still present in brasero 2.30.2

I use rhythmbox 0.13.0 backported from Maverick and brasero 2.30.2 from lucid/proposed (maverick uses the same version) and I am unable to burn cd from rhythmbox, the button does anything and I receive this error from the terminal:

(brasero:20343): GLib-GObject-CRITICAL **: g_object_ref: assertion `object->ref_count > 0' failed

I don't know if the bug is in maverick too, but I suspect it is because the programs versions are the same.

bbordwell (benbordwell) wrote :

Guiodic: thank for you for finding this bug, but it is a different one that this so I filed a new on as bug 622535. you can follow the bugs status and provide any missing information there.

Changed in brasero:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.