sawfish is missing depencency on rep

Bug #616115 reported by Fergal Daly on 2010-08-10
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
sawfish (Ubuntu)
Medium
Daniel T Chen
Karmic
Undecided
Unassigned
Lucid
Medium
Daniel T Chen
Maverick
Medium
Daniel T Chen

Bug Description

-- StableReleaseUpdate information follows --

Impact statement: Attempting to invoke the sawfish-ui command in a pristine Lucid or lucid-proposed install fails (also stated below in the original defect report).

Bug fix: Uploaded and available in Maverick as of 1:1.3.5.2-1ubuntu3

Minimal patch: https://bugs.edge.launchpad.net/ubuntu/lucid/+source/sawfish/+bug/616115/+attachment/1492196/+files/sawfish_1.3.5.2-1ubuntu1.2.debdiff

TEST CASE: Install sawfish from lucid or lucid-proposed and attempt to use sawfish-ui. Note that the error message as reported below occurs.

Regression potential: Low to none -- none identified

-- Original defect report follows --

Binary package hint: sawfish

rep is not list as a depdendency, so executing sawfish-ui gives me "exec: 8: rep: not found".

installing rep fixes this error and sawfish-ui runs correctly.

Daniel T Chen (crimsun) on 2010-08-12
Changed in sawfish (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
importance: Undecided → Medium
status: New → Triaged
Daniel T Chen (crimsun) wrote :

Hmm, there is an existing dependency on rep-gtk already. Can you confirm that having rep-gtk installed *but not rep* reproduces this behavior?

confirmed

fergal@fergal-glaptop:~$ dpkg -l rep
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
un rep <none> (no description available)

fergal@fergal-glaptop:~$ dpkg -l rep-gtk
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii rep-gtk 1:0.90.0-2 GTK+ binding for librep

fergal@fergal-glaptop:~$ sawfish-ui
exec: 8: rep: not found

Daniel T Chen (crimsun) wrote :
Changed in sawfish (Ubuntu Lucid):
assignee: nobody → Daniel T Chen (crimsun)
importance: Undecided → Medium
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sawfish - 1:1.3.5.2-1ubuntu3

---------------
sawfish (1:1.3.5.2-1ubuntu3) maverick; urgency=low

  * Add rep as an explicit dependency of sawfish, otherwise sawfish-ui
    fails. (LP: #616115)
 -- Daniel T Chen <email address hidden> Sun, 15 Aug 2010 15:22:38 -0400

Changed in sawfish (Ubuntu Maverick):
status: Triaged → Fix Released
tags: added: patch
Daniel T Chen (crimsun) on 2010-08-16
description: updated
Changed in sawfish (Ubuntu Lucid):
milestone: none → lucid-updates

Accepted sawfish into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in sawfish (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Lucid:
I have reproduced the problem with sawfish 1:1.3.5.2-1ubuntu1 in lucid and have verified that the version of sawfish 1:1.3.5.2-1ubuntu1.2 in -proposed fixes the issue and rep is installed as a dependency.

But bug 573197 (sawfish < 1.5.2 incompatible with rep >= 0.90) needs a fix too.

I'm marking as verification-done because the issue reported here is fixed but the package still need a fix.

Daniel, do you plan to fix the version in Karmic or is it a won't fix ?

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sawfish - 1:1.3.5.2-1ubuntu1.2

---------------
sawfish (1:1.3.5.2-1ubuntu1.2) lucid-proposed; urgency=low

  * Add rep as an explicit dependency of sawfish, otherwise sawfish-ui
    fails. (LP: #616115)

sawfish (1:1.3.5.2-1ubuntu1.1) lucid-proposed; urgency=low

  * debian/patches/remote_sawfish_error.patch:
    Cherry-pick relevant code hunk from upstream git changeset
    ff1212a2006f195fa35335e1a6432cfb3ab51e7b to resolve fatal
    error at runtime. (LP: #433358)
 -- Daniel T Chen <email address hidden> Sun, 15 Aug 2010 15:22:38 -0400

Changed in sawfish (Ubuntu Lucid):
status: Fix Committed → Fix Released
tags: added: testcase
Rolf Leggewie (r0lf) wrote :

Karmic has long since stopped to receive any updates. Marking the Karmic task for this ticket as "Won't Fix".

Changed in sawfish (Ubuntu Karmic):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers