Ubuntu

Overuse of system beep without volume control

Reported by Chris Murphy on 2006-12-23
274
This bug affects 45 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
High
Unassigned
Nominated for Lucid by fusebox
libgnome (Ubuntu)
Medium
Martin Pitt
Declined for Intrepid by Scott Ritchie
Nominated for Lucid by Mat Tomaszewski
Karmic
Medium
Martin Pitt
linux (Ubuntu)
Medium
Unassigned
Declined for Intrepid by Scott Ritchie
Nominated for Lucid by Mat Tomaszewski
Karmic
Medium
Unassigned
module-init-tools (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Scott Ritchie
Nominated for Lucid by Mat Tomaszewski
Karmic
Undecided
Unassigned
pulseaudio (Ubuntu)
Medium
Luke Yelavich
Declined for Intrepid by Scott Ritchie
Nominated for Lucid by Mat Tomaszewski
Karmic
Medium
Luke Yelavich

Bug Description

  System 'beeps' have become omnipresent in gnome. When I unplug my power cord, the notification system emits a system beep. When I try to do quick find in Firefox and I type a word that doesn't exist in the document, it beeps. When I tab-autocomplete in a gnome-terminal, it beeps if there are no completions. There are numerous other software packages that behave similarly.

This is a problem for multiple reasons.

First of all, there are some cases where the beep is used inappropriately -- I really *don't care* that my power cord is unplugged - in fact I unplugged it! I appreciate the technology advances that gnome-power-management has made in recent history, but I feel like I just want it to `go away' most of the time - I don't care about most of the things it informs me (besides low battery). Firefox has color feedback in the "Find" bar, why do I need auditory feedback too?

Second of all, I can't control the volume of the beep, or disable it in all cases. In the case of the gnome-terminal I can disable the console "bell", but that only solves a single instance of the problem. In most other cases, there is nothing I can do to prevent the beeps. This can be very obtrusive in quite environments, and simply annoying in other cases. On my laptop (recent Dell Latitude D620) the beep is incredibly loud - it is very noticeable. It would be great to have a toggle button in the system "sound" preferences, or better yet, a volume slider for the system bell.

  This is a large problem, affecting multiple packages and systems - I don't know the best way to fix it, but I do know that it is definitely an overall gnome UI issue. I've read that some programs literally just have the ASCII "BEL" coded into the source, so in some cases the problem may be unavoidable - I don't know enough of the technical details to recognize an appropriate solution.

Any help dividing this into specific fixes for multiple projects or identifying the best place for an overall fix would be appreciated.

Mike Benjamin (miccotech) wrote :

Thanks for your comment. The changes you are requesting require more
discussion and should rather be done on an appropriate mailing list or
forum.

http://www.ubuntu.com/community/forums/ might be a good start.

Chris Murphy (chrismurf) wrote :

Thanks for your response Mike. I disagree with your assessment that the changes all require more discussion - I think some of them are pretty straightforward, it's just a question of correct categorization. Do developers actually pay attention to the forums? I was under the impression that it was more for user->user support + communication.

Kyromaster (kyromaster) wrote :

I also agree with chris. The system beep (from the pc speaker) is obsolete and should IMHO never be used. The GNOME system beep should be used instead.

1 comments hidden view all 135 comments

I also agree disabling system beeps also in virtual consoles. If you have your loudspeakers pluged in and want to listen to music and a system beep appears it's a big pain for the ears! Especially when your loudspeakers stand in the near, for example on your desk!

The problem on my Thinkpad Z61m is - even if I listen to music in low volume the beep is so much louder than normal music that it trashes the ears.

I also cannot disable or lower the volume of my PC speakers in Gnome mixer:

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
        Subsystem: Lenovo ThinkPad T60/R60 series
        Flags: bus master, fast devsel, latency 0, IRQ 21
        Memory at ee240000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>

M (asobi) wrote :

Completely agree with felix - on my Thinkpad system beeps through the headphones are physically painful.

Fred (eldmannen+launchpad) wrote :

I agree!

When I use 'gedit' Text Editor, and I press backspace when there is no text, it beeps.

Callum Macdonald (chmac) wrote :

For anyone who finds this bug and wants to disable or change the system beep, here are a few options:

1) System > Preferences > Sound > System Beep > Enable System Beep (check / uncheck)

2) To change the volume / pitch, use `xset b 30 500`. The first number is the volume, in percentage, and the second is the frequency in hertz. See `man xset` for more info.

Adding to Ayatana to signal the DX/DUX teams to take a look at this.

I very frequently hear complaints from new users that Ubuntu makes their computer beep really loudly and nastily whenever the press backspace too many times in a text entry field, or otherwise trigger an alert noise. Ubuntu has a much more pleasant alert sound that should be played instead (which you can hear in System > Preferences > Sound > Sounds > Alert Sound). I would go so far as to say that we NEVER want to play the system beep during the course of a normal graphical session; sometimes it is so loud, users look as if they had received an electric shock.

Rick Spencer said pitti would save us.

Changed in hundredpapercuts:
assignee: nobody → Martin Pitt (pitti)
Kyromaster (kyromaster) wrote :

"I would go so far as to say that we NEVER want to play the system beep during the course of a normal graphical session; sometimes it is so loud, users look as if they had received an electric shock"

That was exactly my point, too ;) Which I wrote here 2 and a half years ago. And which EVERY GOOD BETA TESTER notices immediately but nobody cares.

Stefan Hammer (j-4) wrote :

There is another bug, #290204, only for beeping on shutdown.
but the solution posted by "w1zard" disables every beep! Fantastic! Legendary!

He woote:
"An upgrade to Intrepid has re-enabled the 'bell' or 'beep' when clicking 'Shutdown' or at the login screen. There is no way in the GUI or standard Gnome settings to reset this (none that work, anyway). The only way to disable it again is:

run gconf-editor from terminal and set
/desktop/gnome/peripherals/keyboard/bell_mode
to 'off' rather than 'on'

Not exactly easy to find for your experienced users, impossible for the average user. At the very least this should setting should be migrated during an upgrade, but should really be editable from the Sound properties tab."
(https://bugs.launchpad.net/hundredpapercuts/+bug/290204/comments/12)

This setting should be made in Audio-configurations! I am sure this can be fixed in 100 paper cuts!

Stefan Hammer (j-4) wrote :

There is another bug, #290204, only for beeping on shutdown.
but the solution posted by "w1zard" disables every beep! Fantastic! Legendary!

He wrote:
"An upgrade to Intrepid has re-enabled the 'bell' or 'beep' when clicking 'Shutdown' or at the login screen. There is no way in the GUI or standard Gnome settings to reset this (none that work, anyway). The only way to disable it again is:

run gconf-editor from terminal and set
/desktop/gnome/peripherals/keyboard/bell_mode
to 'off' rather than 'on'

Not exactly easy to find for your experienced users, impossible for the average user. At the very least this should setting should be migrated during an upgrade, but should really be editable from the Sound properties tab."
(https://bugs.launchpad.net/hundredpapercuts/+bug/290204/comments/12)

This setting should be made in Audio-configurations! I am sure this can be fixed in 100 paper cuts!

Changed in hundredpapercuts:
status: New → Confirmed
Changed in hundredpapercuts:
milestone: none → round-3
Roger Sperberg (rsperberg) wrote :

I have to say that one of the ridiculously small 12 reasons that led me to abandon Ubuntu (& return to Windows XP, not happily) was the jarring beep described here. It was especially antagonizing when I was playing Solitaire as my last act before heading to bed, using the rote click-click-click to stupefy my attention and relax; except that clicking an already clicked card caused this loud shrieking bleep, which rather defeated the purpose of the game for me.

I only tried 10 or 20 times to figure out how I could fix or change this. Apparently, using GUIs since 1985 was insufficient preparation for smooth Ubuntu use and after twelve months I admitted my Linux devotion was inadequate to the demand for mastering Linux obscurities.

SY (optical267) wrote :

I agree with Roger that this is currently one of the most irritating minor issues with Ubuntu and Gnome. It bothered me some much hearing the system beep when using Firefox's find feature that I spent a fair amount of time looking for solutions to this. In the end, the only solution I was able to make work was disabling the system beep entirely, and using Compiz's visual system bell feature.

Like many people have written, really the correct solution is to play the Gnome alert sound instead of triggering the system beep. This would bring Ubuntu more in line with what Mac OS X does in similar situations, allowing the user to choose the alert sound to play through the speakers in the Sound preference pane. In this day and age, there is really no excuse to trigger the system beep during a normal graphical Gnome session.

Peter Rhone (prhone-gmail) wrote :

pretty much the first thing I do after every Ubuntu install is add the line
blacklist pcspkr
to /etc/modprobe.d/blacklist.conf
I'm not sure if this will fix all your beepy problems, but I don't get most/any of the beeps you complain about...

Doug Holton (edtechdev) wrote :

I agree with Michael and others - please disable the pcspkr module by default in Ubuntu.

I've been embarrassed too many times by that super loud beep after using a new install of Ubuntu - then I realize, oh yeah I forgot to blacklist that stupid module.

SY (optical267) wrote :

Peter, your solution merely causes the computer to ignore alerts by silencing the internal speaker. This is hardly the correct behavior. The correct behavior is for the Gnome Alert sound (which is user customizable) to be played through the active sound device at the times when currently Gnome activates the system beep.

In any case, a user should not have to customize their /etc/modprobe.d/blacklist.conf file just to get a decent experience with Ubuntu.

Doug Holton (edtechdev) wrote :

That solution silences only the internal motherboard pc speaker, not the regular speaker.

Gnome can still visually flash if a program still uses the obsolete pc speaker.

I blacklist pcspkr everytime I install Ubuntu.

Eventually perhaps calls to the pc speaker could be redirected to use the gnome alert sound, but this is an easier shortterm solution that works just fine with no coding.

SY (optical267) wrote :

While blacklisting the pcspkr device is certainly an improvement over the current behavior, I wouldn't go as far as to call it a "solution that works just fine," unless a replacement is provided for the system beep. If we do blacklist the pcspkr by default, we need to ensure that Gnome/Compiz is configured by default to visually flash when a program tries to activate a system beep. Simply losing the alerts is not acceptable. However, it seems to me like it would take only a few lines of code at most to trigger the Gnome Alert sound whenever a program tries to activate the system beep. That being said, I am not very familiar with Linux/Gnome programming, so it could be substantially more complicated.

This is an issue that should have been fixed long ago, but it seems to have been overlooked.

tgpraveen (tgpraveen89) wrote :

while i agree that if a speaker or headphone is attached then the use of system beep should be minimised and used only in high priority cases.

BUT if there are no speakers or headphones attached then the current settings should be place.

jollywollup (jollywollup) wrote :

I feel the same as Doug: It's annoying to have to blacklist the stupid speaker every time I install Ubuntu - it's happened more than a couple of times where I've wanted to just quietly shut down the computer before going to bed, but end up waking my girlfriend up due to the ridiculously loud beep.

What is interesting is that the beep depends on the master volume, so if it's set low than it's not a big deal. But when it's set near/at 100%, it can rattle the room.

I don't have any technical input on this bug, and I'm not even sure if this affects the majority of Ubuntu users, but as a casual user this is very annoying.

Scott Ritchie (scottritchie) wrote :

The annoying beeping is fixed in karmic somewhat - it now plays the much softer Gnome alert bell through the sound system (rather than the internal speaker) instead.

Still, we need to address that we may be using that too much (like hitting backspace)

Scott, if you have information about the state of this problem, can you please add it to these bugs?

http://tinyurl.com/lq7nfd

John Vivirito (gnomefreak) wrote :

Callum: I dont see this option in System > pref > Sound

"For anyone who finds this bug and wants to disable or change the system beep, here are a few options:

1) System > Preferences > Sound > System Beep > Enable System Beep (check / uncheck)"

Right now my system beep only works on shit down i want system beep to work instead of the speakers
with irssi and terminal and such.

Brett Alton (brett-alton) wrote :

When I shut down my computer, or the last three laptops I installed using Ubuntu 9.04, the system beeps repeatedly about 5-8 times as its shutting down, then stops.

I've turned off system beeps in "System > Preferences > Sound > System Beep > Enable System Beep" yet this problem remains.

Doug Holton (edtechdev) wrote :

Yeah that's why I just disable the pcspkr module, instead of merely turning off beeps in gnome, because it still can beep other times, like when shutting down.

Changed in ubuntu:
status: Invalid → Confirmed
Dread Knight (dread.knight) wrote :

OMG! My prayers have been heard! *tears in his eyes*
Disable the damn thing already! We're not in the 70's anymore! Kill it with fire!

Martin Pitt (pitti) wrote :

We discussed that here at the platform sprint, and nobody objected to blacklisting the PC speaker by default.

affects: ubuntu → module-init-tools (Ubuntu)
Changed in module-init-tools (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Confirmed → In Progress
Martin Pitt (pitti) on 2009-08-07
Changed in hundredpapercuts:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package module-init-tools - 3.10-2

---------------
module-init-tools (3.10-2) karmic; urgency=low

  * blacklist.conf: Blacklist pcspkr. It produces an ugly and loud noise,
    getting on everyone's nerves. If still needed at all, this should be done
    by a nice pulseaudio bing. (LP: #77010)

 -- Martin Pitt <email address hidden> Fri, 07 Aug 2009 17:02:28 +0100

Changed in module-init-tools (Ubuntu):
status: In Progress → Fix Released
Martijn Bastiaan (hmb1) wrote :

Great :-). To be honest: I just unplugged the speaker from my motherboard!

On 08/08/2009 07:53 AM, Martijn Bastiaan wrote:
> Great :-). To be honest: I just unplugged the speaker from my
> motherboard!
>
Please forgive me but i dont recall the backlist file location.
I will use locate however i havent had a system beep at all since the
first couple of weeks before A1 IIRC, but it does beep on shutdown.

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

"How can i get lost, if i have no where to go"
    -- Metallica from Unforgiven III

Rich Jones (richwjones) wrote :

Hooray!

Dread Knight (dread.knight) wrote :

Redemption! :D

Changed in ayatana:
status: New → Invalid

Please see comment 26 on bug 301174, "Use proper sound event instead of system beep".

I don't think the issue here is the fact that users can't or don't readily know how to address the loud system beep that plays, I think the issue is that audio works for the user in other applications, but that the default alert sound selected in gnome-control-panel isn't played, with no reason given to the user, or any indication given to them that something is awry. Blacklisting the pc speaker module or adjusting the volume of the speaker sounds in your mixer are just work arounds, not fixes, and as far as
blacklist.conf: Blacklist pcspkr. It produces an ugly and loud noise,
    getting on everyone's nerves. If still needed at all, this should be done
    by a nice pulseaudio bing. (LP: #77010)
goes, if we can play a nice pulse audio bing, why can't we play the default alert sound selected by the user? To me this sounds like an issue with something underlying in the wm or audio subsystem, considering it appears in both compiz and metacity, in multiple applications (like firefox, gnome-terminal, and even the gtk+ demo application).
I'd love to hear from a developer (you know, then they get to it, not to sound antsy or anything :) ) about what causes the system beep to play instead of the selected alert sound, why the user isn't notified that the system couldn't play the selected alert sound, or even just that this is a fallback behavior from any number of issues that couldn't possibly all be resolved in one bug report. That way the individuals having this issue could give feedback and logs to the developers, and we could squash the or all of the bugs that are causing this to happen in the first place. I guess I just don't see 'make the pc speaker stop making noise' as a resolution for 'when I choose an alert sound in gnome-control-panel, a beep plays instead,' because it sounds like a workaround to me. I'm not complaining! work arounds are good, but in all the bug reports mentioning the system beep playiing instead of the alert sound, not one I've seen has addressed /why/ this is happening or how to get alert sounds to play. I'm also just another human like you, so if I've missed such an explanation or resolution, feel free to point it out to me and ill try to say thank you around the foot in my mouth :)

Mat Tomaszewski (mat.t.) wrote :

Still getting a system beep on battery low. Dell Mini 9, Karmic Beta

Mat Tomaszewski (mat.t.) on 2009-10-01
Changed in module-init-tools (Ubuntu):
status: Fix Released → New
Changed in hundredpapercuts:
status: Fix Released → New
2 comments hidden view all 135 comments
Martin Pitt (pitti) wrote :

It doesn't seem to happen any more for anyone else. Can you please check "lsmod | grep pc" whether you have pcspkr or snd_pcsp loaded?

Changed in module-init-tools (Ubuntu):
status: New → Incomplete
Martin Albisetti (beuno) wrote :

Test comment, sorry.

Mat Tomaszewski (mat.t.) on 2009-10-06
Changed in hundredpapercuts:
importance: Undecided → High
status: New → Triaged
Martin Pitt (pitti) on 2009-10-11
Changed in module-init-tools (Ubuntu):
assignee: Martin Pitt (pitti) → nobody
status: Incomplete → Fix Released
Changed in hundredpapercuts:
assignee: Martin Pitt (pitti) → nobody
status: Triaged → Incomplete
status: Incomplete → Confirmed
Martin Pitt (pitti) on 2009-10-20
Changed in libgnome (Ubuntu Karmic):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Medium
milestone: none → ubuntu-9.10
status: New → In Progress
Changed in alsa-lib (Ubuntu Karmic):
assignee: nobody → Luke Yelavich (themuso)
importance: Undecided → High
milestone: none → ubuntu-9.10
status: New → Confirmed
Changed in alsa-lib (Ubuntu Karmic):
importance: High → Medium
Martin Pitt (pitti) on 2009-10-23
Changed in linux (Ubuntu Karmic):
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
importance: Undecided → Medium
status: New → Triaged
Changed in alsa-lib (Ubuntu Karmic):
milestone: ubuntu-9.10 → none
status: Confirmed → Won't Fix
Martin Pitt (pitti) on 2009-10-23
tags: added: regression-potential
Martin Pitt (pitti) on 2009-10-23
Changed in libgnome (Ubuntu Karmic):
status: In Progress → Fix Committed
Changed in libgnome (Ubuntu Karmic):
status: Fix Committed → Fix Released
Andy Whitcroft (apw) on 2009-10-23
Changed in linux (Ubuntu Karmic):
assignee: Canonical Kernel Team (canonical-kernel-team) → Andy Whitcroft (apw)
55 comments hidden view all 135 comments
beandog (beandog) wrote :

I just uninstalled Ubuntu because of this problem. I installed it this morning, and had been using it in my university classes. I hit backspace too many times and got some scary loud beeps, despite volume being muted. I Googled for advice, and was advised to destroy my PC speaker physically. Some more digging revealed a possible manual change to some configuration file to turn off the beeps. I did the change, and hit Reboot. When shutting down, I got about 10 rapid high-pitched outrageously-loud beeps. Lecture stopped as everyone looked at me for a few seconds in disgust.

I will not boot into that installation of Ubuntu ever, ever again. I'll be back in a few versions, but you can bet I'll be installing it and testing it in a place where loud noises are OK.

Turn off all system beeps, completely, period, every time, all the time, or I'll never be back.

1 comments hidden view all 135 comments
beandog (beandog) wrote :

I just uninstalled Ubuntu because of this problem. I installed it this morning, and had been using it in my university classes. I hit backspace too many times and got some scary loud beeps, despite volume being muted. I Googled for advice, and was advised to destroy my PC speaker physically. Some more digging revealed a possible manual change to some configuration file to turn off the beeps. I did the change, and hit Reboot. When shutting down, I got about 10 rapid high-pitched outrageously-loud beeps. Lecture stopped as everyone looked at me for a few seconds in disgust.

I will not boot into that installation of Ubuntu ever, ever again. I'll be back in a few versions, but you can bet I'll be installing it and testing it in a place where loud noises are OK.

Turn off all system beeps, completely, period, every time, all the time, or I'll never be back.

(Also, this form submission didn't work in Google Chrome)

Noel J. Bergman (noeljb) wrote :

If we are talking about the completion-beep, etc., as described by the original post, SOME OF US WANT IT. I opened a bug report a week or so ago (now fixed) when Karmic started muting the beep on reboot all the time; I had to go in via ALSAMIXER to re-enable the beep after each reboot, and adjust its volume down to about 20% or so (yes, full volume is far too loud).

1 comments hidden view all 135 comments
Noel J. Bergman (noeljb) wrote :

beandog, the alsa mixer allows beep to be muted and/or the volume controlled.

Daniel T Chen (crimsun) wrote :

Gals/Guys, please do not use this bug report as a means to spew
vitriolic bits. This bug report has a clear description, has clearly
identified Karmic tasks, and has clear progress indicators for those
tasks. In other words, it is narrow in scope, we know what's broken,
and we're fixing them.

Please use the ubuntu-devel-discuss mailing list to vent, and/or file
a separate bug report. Thanks!

Mat Tomaszewski (mat.t.) wrote :

On 23/10/2009 17:51, Noel J. Bergman wrote:
> If we are talking about the completion-beep, etc., as described by the
> original post, SOME OF US WANT IT. I opened a bug report a week or so
> ago (now fixed) when Karmic started muting the beep on reboot all the
> time; I had to go in via ALSAMIXER to re-enable the beep after each
> reboot, and adjust its volume down to about 20% or so (yes, full volume
> is far too loud).
>
>
The beep could be re-enabled by the user if he specifically requires it,
but I've no doubt that by default all beeps should be muted.

Mat

Noel J. Bergman (noeljb) wrote :

Mat,

> The beep could be re-enabled by the user if he specifically requires it,
> but I've no doubt that by default all beeps should be muted.

In case it wasn't clear, I have no problem with that at all. I only object(ed) when the system changes my settings after I've made them, forcing me to re-do them on each reboot (side effect, I believe, of addressing comment #78). Daniel very quickly fixed that problem, and I've no issue with how karmic is today, nor with the default being set to off.

1 comments hidden view all 135 comments
Luke Yelavich (themuso) wrote :

Also bare in mind that if one re-enables the bell event, that Martin disabled in the fix of libgnome, the beep/bell event is played as a sound event, and once the kernel issue is fixed, it will not be a horrible system screech like many of you have experienced.

Were scary beeping noises reduced for Karmic? I did some testing and the beeping seems to have abated. May I mark the paper cut as fixed?

Changed in hundredpapercuts:
status: Confirmed → Fix Released
1 comments hidden view all 135 comments
Jussi (jussi-lahtinen-gmail) wrote :

Seems that this problem is "fixed" by breaking possibility to use pc speaker?
Or is this; https://bugs.launchpad.net/ubuntu/+source/linux/+bug/398161
unrelated issue?

3 comments hidden view all 135 comments
Jussi (jussi-lahtinen-gmail) wrote :

Seems that this problem is "fixed" by breaking possibility to use pc speaker?
Or is this: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/398161
unrelated issue?

Mat Tomaszewski (mat.t.) wrote :

I'm still getting the beep on battery low...

Robert Schroll (rschroll) wrote :

> The beep could be re-enabled by the user if he specifically requires it,

How does the user re-enable the PC speaker beep? This user can't figure it out.

tags: added: regression-release
removed: regression-potential
tags: added: karmic
Mat Tomaszewski (mat.t.) wrote :

The beep is still present - Lucid alpha 1... :(

Is anyone else having this problem or am I the single most unlucky person in the world?

Changed in hundredpapercuts:
status: Fix Released → New
Mat Tomaszewski (mat.t.) wrote :

Again, to reproduce on Dell Mini 9:

- let your battery run critically low (> 10%)

- listen carefully :)

This bug is extremely frustrating to me. Every time I get the beep I have to stop working, even though there's still plenty of battery life left. I don't have to mention the potential embarassement that it can cause...

Martin Pitt (pitti) wrote :

Mat,

right, the linux task is still open. That's where it needs to be fixed for good (need to disable CONFIG_SND_HDA_INPUT_BEEP)

1 comments hidden view all 135 comments
Martin Pitt (pitti) wrote :

Mat,

right, the linux task is still open. That's where it needs to be fixed for good (need to disable CONFIG_SND_HDA_INPUT_BEEP)

On Mon, 2009-12-14 at 22:24 +0000, Mat Tomaszewski wrote:

> Again, to reproduce on Dell Mini 9:
>
> - let your battery run critically low (> 10%)
>
> - listen carefully :)
>
> This bug is extremely frustrating to me. Every time I get the beep I
> have to stop working, even though there's still plenty of battery life
> left. I don't have to mention the potential embarassement that it can
> cause...
>
This one almost certainly comes from the Dell BIOS not Ubuntu.

Scott
--
Scott James Remnant
<email address hidden>

Mat Tomaszewski (mat.t.) wrote :

@pitti

Thanks, who do I need to poke to get the ball rolling? :)

@keybuk

Hm, are you sure? It wasn't the case on Hardy and Jaunty, and I have never upgraded the BIOS.

Robert Schroll (rschroll) wrote :

> > The beep could be re-enabled by the user if he specifically requires it,
>
> How does the user re-enable the PC speaker beep? This user can't figure it out.

Several of us have been spending a fair amount of time over in bug #486154 trying to figure this out, and we still haven't accomplished it. In fact, we're not entirely sure in what sub-system the PC speaker beep was disabled. Can those responsible for the change *please* stop by and let us know what was changed, so we know what we have to undo?

Pretty please?

We have cookies.

Guy Van Sanden (gvs) wrote :

I wiped my system and reinstalled karmic, and this behaviour is gone.
It seems that you have it when you where running karmic during the alpha/beta phases

1 comments hidden view all 135 comments
Götz Christ (g-christ) wrote :

What happens if some part of the computer overheats? Shouldn't it first beep, and if nothing happens, then shut down?

bhuvi (bhuvanesh) wrote :

this bug affects in my ubuntu jaunty installation

1 comments hidden view all 135 comments
Mat Tomaszewski (mat.t.) wrote :

This is now fixed in Lucid.

Changed in hundredpapercuts:
status: New → Invalid
status: Invalid → Fix Released
Daniel T Chen (crimsun) on 2010-01-25
affects: alsa-lib (Ubuntu) → pulseaudio (Ubuntu)
Andy Whitcroft (apw) on 2010-06-18
Changed in linux (Ubuntu):
assignee: Andy Whitcroft (apw) → nobody
Changed in linux (Ubuntu Karmic):
assignee: Andy Whitcroft (apw) → nobody
Peter Rhone (prhone-gmail) wrote :

Just to add my two cents: although this has been already mentioned in comment 83 I'd like to add that to mute the "PC Beep", just select it with the arrow keys and press 'm'. Simply setting the volume bars to 0 is *not* enough! This completely solved the issue for me in Lucid on a Dell XPS M1530. (along with blacklisting pcspkr, but that is default now anyway)

1 comments hidden view all 135 comments
Charles Baum (baumcharles) wrote :

Need software for sound please help us....

Brad Figg (brad-figg) wrote :

This bug was opened for a version of the kernel that is no longer supported. If there is a kernel issue w.r.t. this problem on a supported kernel version, please open a new bug.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

This bug was nominated against a series that is no longer supported, ie karmic. The bug task representing the karmic nomination is being closed as Won't Fix.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu Karmic):
status: Triaged → Won't Fix
Displaying first 40 and last 40 comments. View all 135 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers