[Karmic] Update to 2.6.31.5 Stable Kernel

Bug #461556 reported by Leann Ogasawara
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Invalid
Medium
Leann Ogasawara
Karmic
Fix Released
Medium
Leann Ogasawara

Bug Description

SRU Justification/Impact: The upstream process for stable tree updates is quite similar in scope to the Ubuntu SRU process, e.g., each patch has to demonstrably fix a bug, and each patch is vetted by upstream by originating either directly from Linus' tree or in a minimally backported form of that patch. The 2.6.31.5 upstream stable patch set is now available. It should be included in the Ubuntu kernel as well.

TEST CASE: TBD

http://kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.31.5

http://kernel.org/pub/linux/kernel/v2.6/patch-2.6.31.5.bz2

==========

The 2.6.31.5 Upstream Stable Kernel brings in the following 47 patches:

* SCSI: Retry ADD_TO_MLQUEUE return value for EH commands
* SCSI: Fix protection scsi_data_buffer leak
* SCSI: sg: Free data buffers after calling blk_rq_unmap_user
* ARM: pxa: workaround errata #37 by not using half turbo switching
* tracing/filters: Fix memory leak when setting a filter
* x86/paravirt: Use normal calling sequences for irq enable/disable
* USB: ftdi_sio: remove tty->low_latency
* USB: ftdi_sio: remove unused rx_byte counter
* USB: ftdi_sio: clean up read completion handler
* USB: ftdi_sio: re-implement read processing
* USB: pl2303: fix error characters not being reported to ldisc
* USB: digi_acceleport: Fix broken unthrottle.
* USB: serial: don't call release without attach
* USB: option: Toshiba G450 device id
* USB: ipaq: fix oops when device is plugged in
* USB: cp210x: Add support for the DW700 UART
* USB: Fix throttling in generic usbserial driver
* USB: storage: When a device returns no sense data, call it a Hardware Error
* arm, cris, mips, sparc, powerpc, um, xtensa: fix build with bash 4.0
* intel-iommu: Cope with broken HP DC7900 BIOS
* futex: Detect mismatched requeue targets
* futex: Fix wakeup race by setting TASK_INTERRUPTIBLE before queue_me()
* tpm-fixup-pcrs-sysfs-file-update
* TPM: fix pcrread
* Bluetooth: Disconnect HIDRAW devices on disconnect
* Bluetooth: Add extra device reference counting for connections
* Bluetooth: Let HIDP grab the device reference for connections
* connector: Keep the skb in cn_callback_data
* connector: Provide the sender's credentials to the callback
* connector: Removed the destruct_data callback since it is always kfree_skb()
* dm/connector: Only process connector packages from privileged processes
* dst/connector: Disallow unpliviged users to configure dst
* pohmelfs/connector: Disallow unpliviged users to configure pohmelfs
* uvesafb/connector: Disallow unpliviged users to send netlink packets
* e1000e: swap max hw supported frame size between 82574 and 82583
* MAINTAINERS: Fix Riku Voipio's address
* macintosh: Don't assume i2c device probing always succeeds
* i2c: Hide probe errors caused by ACPI resource conflicts
* ALSA: Don't assume i2c device probing always succeeds
* bsdacct: switch credentials for writing to the accounting file
* sysfs: Allow sysfs_notify_dirent to be called from interrupt context.
* Staging: rt2860sta: prevent a panic when disabling when associated
* usb-storage: Workaround devices with bogus sense size
* iwlwifi: incorrect method used for finding valid OTP blocks
* mac80211: fix vlan and optimise RX
* tty: Make flush_to_ldisc() locking more robust
* Linux 2.6.31.5

description: updated
Changed in linux (Ubuntu):
assignee: nobody → Leann Ogasawara (leannogasawara)
importance: Undecided → Medium
status: New → In Progress
description: updated
description: updated
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

"Staging: rt2860sta: prevent a panic when disabling when associated" - fixes bug 404626

description: updated
Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

"usb-storage: Workaround devices with bogus sense size" - fixes bug 446146

Revision history for this message
Leann Ogasawara (leannogasawara) wrote :

"e1000e: swap max hw supported frame size between 82574 and 82583" - fixes bug 445572

Stefan Bader (smb)
Changed in linux (Ubuntu):
status: In Progress → Invalid
tags: added: 2.6.31.5
Stefan Bader (smb)
Changed in linux (Ubuntu Karmic):
status: In Progress → Fix Committed
RobertW (rh-winder)
Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted linux into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (11.9 KiB)

This bug was fixed in the package linux - 2.6.31-17.54

---------------
linux (2.6.31-17.54) karmic-proposed; urgency=low

  [ John Johansen ]

  * SAUCE: AppArmor: Fix oops after profile removal
    - LP: #475619
  * SAUCE: AppArmor: Fix Oops when in apparmor_bprm_set_creds
    - LP: #437258
  * SAUCE: AppArmor: Fix cap audit_caching preemption disabling
    - LP: #479102
  * SAUCE: AppArmor: Fix refcounting bug causing leak of creds
    - LP: #479115
  * SAUCE: AppArmor: Fix oops there is no tracer and doing unsafe
    transition.
    - LP: #480112

  [ Leann Ogasawara ]

  * Revert "[Upstream] (drop after 2.6.31) usb-storage: Workaround devices
    with bogus sense size"
    - LP: #461556
  * Revert "[Upstream] (drop after 2.6.31) Input: synaptics - add another
    Protege M300 to rate blacklist"
    - LP: #480144

  [ Tim Gardner ]

  * [Config] udeb: Add squashfs to fs-core-modules
    - LP: #352615

  [ Upstream Kernel Changes ]

  * Revert "e1000e: swap max hw supported frame size between 82574 and
    82583"
    - LP: #461556
  * Revert "drm/i915: Fix FDI M/N setting according with correct color
    depth"
    - LP: #480144
  * Revert "agp/intel: Add B43 chipset support"
    - LP: #480144
  * Revert "drm/i915: add B43 chipset support"
    - LP: #480144
  * Revert "ACPI: Attach the ACPI device to the ACPI handle as early as
    possible"
    - LP: #327499, #480144
  * SCSI: Retry ADD_TO_MLQUEUE return value for EH commands
    - LP: #461556
  * SCSI: Fix protection scsi_data_buffer leak
    - LP: #461556
  * SCSI: sg: Free data buffers after calling blk_rq_unmap_user
    - LP: #461556
  * ARM: pxa: workaround errata #37 by not using half turbo switching
    - LP: #461556
  * tracing/filters: Fix memory leak when setting a filter
    - LP: #461556
  * x86/paravirt: Use normal calling sequences for irq enable/disable
    - LP: #461556
  * USB: ftdi_sio: remove tty->low_latency
    - LP: #461556
  * USB: ftdi_sio: remove unused rx_byte counter
    - LP: #461556
  * USB: ftdi_sio: clean up read completion handler
    - LP: #461556
  * USB: ftdi_sio: re-implement read processing
    - LP: #461556
  * USB: pl2303: fix error characters not being reported to ldisc
    - LP: #461556
  * USB: digi_acceleport: Fix broken unthrottle.
    - LP: #461556
  * USB: serial: don't call release without attach
    - LP: #461556
  * USB: option: Toshiba G450 device id
    - LP: #461556
  * USB: ipaq: fix oops when device is plugged in
    - LP: #461556
  * USB: cp210x: Add support for the DW700 UART
    - LP: #461556
  * USB: Fix throttling in generic usbserial driver
    - LP: #461556
  * USB: storage: When a device returns no sense data, call it a Hardware
    Error
    - LP: #400652, #461556
  * arm, cris, mips, sparc, powerpc, um, xtensa: fix build with bash 4.0
    - LP: #461556
  * intel-iommu: Cope with broken HP DC7900 BIOS
    - LP: #461556
  * futex: Detect mismatched requeue targets
    - LP: #461556
  * futex: Fix wakeup race by setting TASK_INTERRUPTIBLE before queue_me()
    - LP: #461556
  * tpm-fixup-pcrs-sysfs-file-update
    - LP: #461556
  * TPM: fix pcrread
    - LP: #461556
  * Bluetooth: Disconnect HIDRAW devices on disconnect
    - LP...

Changed in linux (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers