python-qwt5-qt4 will not install on Jaunty

Bug #342782 reported by Darren Dale on 2009-03-14
52
This bug affects 8 people
Affects Status Importance Assigned to Milestone
pyqwt (Ubuntu)
Undecided
Unassigned
Jaunty
Undecided
Unassigned
pyqwt5 (Ubuntu)
Undecided
Unassigned
Jaunty
Undecided
Unassigned

Bug Description

Binary package hint: python-qwt5-qt4

I am unable to install python-qwt5-qt4 on jaunty alpha 6:

$ sudo apt-get install python-qwt5-qt4
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  python-qwt5-qt4: Depends: python (< 2.6) but 2.6.1-0ubuntu3 is to be installed
E: Broken packages

Antonio Valentino (a.valentino) wrote :

Jaunty beta is also affected.

Darren Dale (dsdale24) wrote :

Between this broken package and the difficulty I have experienced installing my own copies of sip/PyQt4/qscintilla/PyQwt5 (probably due to the changes in the default package installation directories, where /usr/local/lib is preferred to /usr/lib, but /usr/lib has precedence on sys.path!), I have had an unpleasant and unsuccessful experience trying to reestablish the development environment I had on Intrepid. This is not intended to be overly critical of the good work being done on Jaunty, I'm just trying to provide useful feedback.

This still seems to be an issue for Jaunty.

---%<---
$ sudo apt-get install python-qwt5-qt4

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  python-qwt5-qt4: Depends: python (< 2.6) but 2.6.2-0ubuntu1 is to be installed
E: Broken packages
---%<---

Nikos

Gene Hilton (genehilton) wrote :

I have the same problem with Jaunty - python-qwt5-qt4 need python2.5, Jaunty has python2.6. Upstream sources seem to work with python2.6.

zzarko (zzarko-gmail) wrote :

I have the same problem after upgrade to Jaunty... Any solutions? I'll try to recompile it myself...

Gene Hilton (genehilton) wrote :

OK, I am a no good liar. The stable version of pyqwt5 does NOT support 2.6. I was led to believe it did by this page ( http://pyqwt.sourceforge.net/doc5/installation.html ). However there is only a snapshot that supports it. The link on the above page is wrong - the snapshot is actually at http://pyqwt.sourceforge.net/snapshot/PyQwt-5.1.1.tar.gz

Having said this is build just fine using the jaunty qwt library. The install is another matter. Edit the Makefile in configure/qwt5qt4 changing all references for /usr/lib/python2.5/site-packages/ to /usr/lib/python2.6/dist-packages/

It seems to work fine for me on Jaunty 32 bit. Sorry for the erroneous bug report.

I followed your steps but I have no luck to get some QGIS-plugins [1][2] (which require qwt5) to work.

Kind regards, Nikos
---

[1] http://qgis.org
[2] For example the "Value Tool" and "Profile" plugins depend on qwt5

Rasmus Nyström (rtough) wrote :

It seem ther are at least a few packages python-qwt packages that are affected by this. In my case it's python-qwt4

Assuming it is impossible for me to change the system standard python to 2.6 I'm guessing the following things need to be done.

- Make it depend on python2.5 instead of python.
- Use /usr/lib/python2.5 as a base instead of /usr/lib/python that I assume it's using.

The above solution is not optimal but it will make it usable for at least those of us that can use python2.5.

I tried to add the python-qwt4 package to this bug but for the life of me I do not understand how that is done. Is that possible at all.

Rasmus Nyström (rtough) wrote :

I did a test on this. And so far it seems to work..

I changed the XS-Python-Version variable in debian/control from all to 2.5.

That worked atleast regarding where to put the binary.

After that I did however get a build error.

"%MappedType template for this type has already been defined"

It seems like that had something to do with the version sip. By searching google wildly I found that by commenting the entire content of the faulty file would atleast get it to build.

So now I have a python-qwt4 file that depends on python >= 2.5. Not a very nice situation =) But at least it installs.

If I am correct and this is the same problem as the original bug report it should work for that package as well.

Rasmus Nyström (rtough) wrote :

After some further investigation I can conclude that this is the same bug for both pyqwt.

The reason for the bug is that upstream (debian) at least was using python 2.5 as a standard. So this is not a bug upstream. I do not know what their running as default in unstable at the moment.

In the case of pyqwt the problem is that python 2.6 is not supported. So the package need to change name to python2.5-qwt4 or something like that. I do have a patch this package that I can post later.

Regarding pyqwt5 it should support python 2.6. At least according på upstream (pyqwt). So in that case It seems to be enough to create a separate package for python2.5 and one python. At least that seems to work when I tried this.

Both those fixes included doing very bad stuff with the sip code on order to get sip to preprocess it. pyqwt themselves says that sip 4.7.x should work with both releases so I'm not sure I'm looking in correct place.

What I find really strange is that both those packages could have been caught by automatic builds and installs tests on the ubuntu side. Both packages should have been excluded from the distribution or fixed for that matter.

A note about the following patch. The patch renames python-qwt4 to python2.5-qwt4 and instead provides python-qwt4. That since the only need I seem to have for package is to resolve dependencies. I also uncommented a huge chunck of code reagarding QwkMemArray. I still don't know what effect of that is. But at least it compiles =)

Darren Dale (dsdale24) wrote :

I don't understand why people think pyqwt5 does not work with python-2.6. Has anyone bothered to contact the developer? He says he reinstalled the official release on python-2.6 and ran his tests and they all passed.

Maybe there are problems installing on jaunty, perhaps related to jaunty's python installing packages to /usr/local/lib/python2.6/dist-packages instead of /usr/lib/python2.6/site-packages, but that is just a wild guess.

Darren Dale (dsdale24) wrote :

I just downloaded the PyQwt-5.1.0 release, not a snapshot, and installed it for python-2.6 using:

$ python configure.py -Q ../qwt-5.1 -4 -L /usr/lib -I /usr/include/ --module-install-path=/usr/lib/python2.6/dist-packages/PyQt4/Qwt5

$ make
$ sudo make install

I ran some of the qt4 examples distributed with the release and observed no problems. I think this should be sufficient to counter assertions in this bug report that pyqwt-5.1.0 is incompatible with python-2.6. There is a problem with ubuntu's packaging of python-qwt5-qt4, not with pyqwt-5.1.0 itself.

SamTux (samuelmesa-gmail) wrote :

thank you very much for your help Darren, this has worked.

Wouter van Heyst (larstiq) wrote :

Reading commit messages it seems like the debian packaging has fixed this more correctly, but, if you only care about python2.6 and qt4, the attached patch hammers python-qwt5-qt4 into action.

Changed in pyqwt5 (Ubuntu Jaunty):
status: New → Confirmed
summary: - python-qwt5-qt4 will not install on Jaunty alpha 6
+ python-qwt5-qt4 will not install on Jaunty
Darren Dale (dsdale24) wrote :

Does anyone know what is holding up applying the fix to the package manager?

I confirm that finally qwt5 works on my Jaunty 64-bit after following instructions found at <http://pyqwt.sourceforge.net/doc5/installation.html>.

Greetings, Nikos

Darren Dale (dsdale24) wrote :

Does anyone know what is holding up applying the fix to the package manager?

Wouter van Heyst (larstiq) wrote :

Still need to iron out the Qt3 packages (honestly, is anyone still using qt3?), attaching intermediate patch that works for qt4 with python2.5 and python2.6

Wouter van Heyst (larstiq) wrote :

Oh, just a note. This is all a hack to get the current package to work, the shell code in the makefile is yucky, and ideally it would use setup.py install --install-layout=deb, but ah well.

Wouter van Heyst (larstiq) wrote :

And this should be it.

Scott Kitterman (kitterman) wrote :

There's a new cvs snapshot in Debian that should work. I've asked to have it sync'ed into Karmic. See Bug 393515 for details.

Scott Kitterman (kitterman) wrote :

Sync fixes it in Karmic.

Changed in pyqwt (Ubuntu):
status: New → Invalid
Changed in pyqwt (Ubuntu Jaunty):
status: New → Invalid
Changed in pyqwt5 (Ubuntu):
status: New → Fix Released
Darren Dale (dsdale24) on 2009-09-29
Changed in pyqwt5 (Ubuntu):
status: Fix Released → New
Darren Dale (dsdale24) wrote :

This package was never fixed in Jaunty, and it is broken again in Karmic. I was able to install pyqwt-5.2.0 from source by running the following in PyQwt-5.2.0/configure:

$ python configure.py -Q ../qwt-5.2 -4 -L /usr -I /usr --module-install-path=/usr/lib/pymodules/python2.6/PyQt4/
Qwt5

$ make
$ sudo make install

Please bump pyqwt to version 5.2.0, which is the latest stable release, and consider the above configuration to fix the broken package in Jaunty and Karmic.

tranchais (pmathe) wrote :

An other quick way and dirty way to have PyQwt5 installed and working under Karmic is as follow:

1. install the karmic python-qwt5-qt4 broken package

2. download and unpack PyQwt-5.2.0.tar.gz

3. do (require g++ and sip4 to be installed) :
cd PyQwt-5.2.0
cd configure
python configure.py -Q ../qwt-5.2
make

4. don't do 'make install', instead copy :
    /PyQwt-5.2.0/configure/iqt5qt4/_iqt.so to /usr/lib/pyshared/python2.6/PyQt4/Qwt5
    /PyQwt-5.2.0/configure/qwt5qt4/Qwt.so to /usr/lib/pyshared/python2.6/PyQt4/Qwt5

That's it.

fccoelho (fccoelho) wrote :

I second the request od Darren above, please upgrade pyqwt to 5.2!

Goyo (goyodiaz) wrote :

Thos won't be fixed since Jaunty went out of support on 23 October 2010 but I can't set status to wontfix.

Steve Langasek (vorlon) on 2011-10-15
Changed in pyqwt5 (Ubuntu Jaunty):
status: Confirmed → Won't Fix
Micah Gersten (micahg) on 2011-12-30
Changed in pyqwt5 (Ubuntu):
status: New → Invalid
zzarko (zzarko-gmail) wrote :

Yeah, Jaunty is out of support, but problems with qwt libraries (specifically qwt3d) still exist in 11.10:
https://bugs.launchpad.net/ubuntu/+source/pyqwt3d/+bug/888326

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers