Ubuntu

[i965] MASTER: Compiz is disabled on GM965 as of Apr 19, 2009 due to bug 359392

Reported by Telorn on 2009-04-19
284
This bug affects 22 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Wishlist
Unassigned
Nominated for Intrepid by CodeDude
Nominated for Karmic by CodeDude
Nominated for Lucid by CodeDude
Jaunty
Wishlist
Unassigned
xserver-xorg-video-intel (Ubuntu)
Critical
Unassigned
Nominated for Intrepid by CodeDude
Nominated for Karmic by CodeDude
Nominated for Lucid by CodeDude
Jaunty
Critical
Martin Pitt

Bug Description

Compiz has been intentionally disabled on i965 due to bug 359392, "[i965] X freezes starting on April 3rd"

If you do not have freezes while using compiz, you can force it to load via:

  SKIP_CHECKS=yes compiz

or you can add the following to the config file ~/.config/compiz/compiz-manager:

  SKIP_CHECKS=yes

[Original Report]
On Jaunty, after today updates compiz fails to start.

using system -> preferences -> appearance, can't change appearance settings to extra.

It is trying to find suitable drivers, and then it says sorry.

System: Acer 6292, Intel GMA X3100 (GM965)

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
MachineType: Acer, inc. TravelMate 6292
Package: compiz 1:0.8.2-0ubuntu8
PackageArchitecture: all
ProcCmdLine: root=UUID=d291a857-dbf6-4fba-99d6-9365c5245f75 ro quiet splash
ProcEnviron:
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.28-11.42-generic
SourcePackage: compiz

Telorn (telorn) wrote :
Telorn (telorn) wrote :

Some investigations tells, that GM 965 was blacklisted in /usr/bin/compiz.

Please, turn it back on, compzi actually work fine on my X3100 card.

And "XV does not play with XAA under compiz, only with EXA " looks very strange, i can watch movies using compiz, including full screen and scalling, even if using UXA.

I think, that X3100 is so popular device, and disabling compiz for it is ambigous.

Now i have manually changed
T="$T 8086:2a02 " # Intel GM965
to
#T="$T 8086:2a02 " # Intel GM965
in /usr/bin/compiz.

still waiting for changes in Jaunty release.

Elias K Gardner (zorkerz) wrote :

Agreed compiz has appeared to work fine for me with EXA and UXA until it was disabled.

Telorn (telorn) on 2009-04-19
Changed in compiz (Ubuntu):
status: New → Confirmed
Dan Ballard (haplo) wrote :

I've been using compiz and this video card for over a year and was a bit choked when I logged in tonight to suddenly have it fail on me telling me it's been blacklisted because it doesn't work. To have compiz drop for my video card after it was in the last last two or three releases and only a week before jaunty comes out seems weird and crazy and poorly timed.

Shang Wu (shangwu) wrote :

Me second, the avant-window-navigator is disabled because of this. If I run it form the command line

$ avant-window-navigator

it shows:

(awn-applets-migration:15829): GLib-GObject-WARNING **: invalid uninstantiatable type `(null)' in cast to `AwnConfigClient'
Warning: Screen isn't composited. Please run compiz (-fusion) or another compositing manager.

And if I run the command:

compiz -fusion

It shows:

Checking for Xgl: not present.
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
Blacklisted PCIID '8086:2a02' found
aborting and using fallback: /usr/bin/metacity

The card seems blacklisted till this bug get resolved:
https://bugs.edge.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/359392/

Bryce Harrington (bryce) on 2009-04-21
summary: - Jaunty: Compiz fails on GM965 after today updates, fails to find
- suitable driver.
+ MASTER: Compiz is disabled on GM965 as of Apr 19, 2009
Changed in compiz (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Triaged
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Critical
milestone: none → jaunty-updates
status: New → Triaged
assignee: nobody → Bryce Harrington (bryceharrington)
Bryce Harrington (bryce) on 2009-04-21
description: updated
summary: - MASTER: Compiz is disabled on GM965 as of Apr 19, 2009
+ MASTER: Compiz is disabled on GM965 as of Apr 19, 2009 due to bug 359392

Hello, here is a Thinkpad T61 Tablet running Jaunty since February. Compiz was always running fine (also with UXA) until it was disabled based on this bug report.
Thanks for noting. Rgds, Dani

Shang Wu (shangwu) wrote :

For anyone's video card does not freeze but still want to have their compiz enabled, can try to create a script under the home directory called: compiz_enable.sh with the content:

#!/bin/bash

SKIP_CHECKS=yes compiz

Then, Give the file executed permission:

chmod +x compiz_enable.sh

Last, go to System> Preferences> Startup Applications and add the entry there.

Log out and log back in. Everything should start working again.

* I tried to write it under ~/.config/compiz/compizconfig/config & ~/.config/compiz/compizconfig/Default.ini, but it does not work for me.

Don Owen (donald.e.owen) wrote :

Also confirmed on an HP dv6565us laptop (mine).

On Wed, Apr 22, 2009 at 07:17:08PM -0000, Donald Owen wrote:
> Also confirmed on an HP dv6565us laptop (mine).

There is absolutely NO NEED to give confirmations of this bug.

@Shang wu

it worked for me using ~/.config/compiz/compiz-manager, but i had to create the file first.
Try
       echo "SKIP_CHECKS=yes" >> ~/.config/compiz/compiz-manager
this should reenable it.

(in case it helps - dell vostro 1400 with a GMA695 - I've had no problems with crashes (using "accelmethod" "uxa") - about to try to reproduce it using bug #359392 - most annoying thing for me is that all my settings are now lost)...

Andrew

Bryce Harrington (bryce) on 2009-04-24
summary: - MASTER: Compiz is disabled on GM965 as of Apr 19, 2009 due to bug 359392
+ [i965] MASTER: Compiz is disabled on GM965 as of Apr 19, 2009 due to bug
+ 359392
Everthon Valadão (everthonvs) wrote :

I think it is a "conflict situation", because I just run
`gconftool-2 --set --type=bool /apps/metacity/general/compositing_manager false`
and `compiz --replace` worked!

Sean Stoops (brutimus) wrote :

I did what Everthon suggested and that seemed to clear up my issue of compiz failing to start.

And just to clarify my issues... I just installed Jaunty on a Macbook Pro 2,2. Compiz was working out of the box for a couple days, then it quit working and I couldn't for the life of my get it to start. I reinstalled radeon drivers, updated to kernel 2.6.29-1 - nothing. But disabling metacity fixed my issue.

jeepmonster01 (jeepmonster01) wrote :

same here, Everthon's suggestion seamed to work for me too; this is getting ridiculous, it seams that ubuntu is against Sony laptops at every turn; i had web-cam and blue-tooth finally working and the upgrade ruined that too

> same here, Everthon's suggestion seamed to work for me too; this is
> getting ridiculous, it seams that ubuntu is against Sony laptops at
> every turn; i had web-cam and blue-tooth finally working and the upgrade
> ruined that too

Stop making stupid accusions and take a look at
https://bugs.launchpad.net/bugs/359392 please...

On Tue, Apr 28, 2009 at 5:38 PM, jeepmonster01 <email address hidden> wrote:
> same here, Everthon's suggestion seamed to work for me too; this is
> getting ridiculous, it seams that ubuntu is against Sony laptops at
> every turn; i had web-cam and blue-tooth finally working and the upgrade
> ruined that too
>
> --
> [i965] MASTER: Compiz is disabled on GM965 as of Apr 19, 2009 due to bug 359392
> https://bugs.launchpad.net/bugs/363821
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Alwin Garside
Email: <email address hidden>
Blog: http://www.yogarine.net
Twitter: http://twitter.com/yogarine
MSN: <email address hidden>
Skype: yogarine
Phone: +31 (0)23 8442699
Mobile: +31 (0)6 49 748 424

joshual (joshua-lowell) wrote :

What is the state of the bug fix? Are you seriously going to have a bunch of Dell users not be able to use desktop effects? That is simply ridiculous. I have a preinstalled Dell laptop Inspiron 1525, and I feel pretty let down by the current fix for this incredibly harmful bug.

@joshual

you can track the status of the bug fix in the bug that is mentioned in the title:
https://bugs.launchpad.net/bugs/359392

Since the status of the bug changes, it would better for you to read that bug than to wait for updates on it here.

Thanks for using Ubuntu, I'm sorry that you are finding this mitigation frustrating. Note that it is possible to turn on desktop effects if you prefer that and don't mind the running the risk of the occasional freeze. Instructions are located in the linked bug, and it has been documented various places on the web.

In the meantime, please keep in mind that Ubuntu is an open source community project, so if you have some expertise or time to donate to helping resolve the problem you are having, you are quite free to do so, though it's also fine to simply wait until it is fixed.

Bryce Harrington (bryce) wrote :

[Pitti is in process of re-enabling compiz.]

Changed in xserver-xorg-video-intel (Ubuntu):
assignee: Bryce Harrington (bryceharrington) → nobody
Bryce Harrington (bryce) on 2009-05-01
Changed in xserver-xorg-video-intel (Ubuntu Jaunty):
assignee: Bryce Harrington (bryceharrington) → Martin Pitt (pitti)
Steve Langasek (vorlon) wrote :

it's not clear to me why this was a separate bug from 359392, but in any event a proper fix for bug #359392 is now waiting in jaunty-proposed, so I believe this bug can be closed out.

Changed in xserver-xorg-video-intel (Ubuntu Jaunty):
status: Triaged → Invalid
Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Invalid
Changed in compiz (Ubuntu Jaunty):
status: Triaged → Fix Committed

I also had problems with compiz. They started with 8.10 (Intrepid). I'm using the intel xorg driver.
I was able to get compiz to work again by 'dpkg-reconfigure xserver-xorg' and enable the use of
the framebuffer. This adds the following lines to xorg.conf

Section "Device"
 Identifier "Configured Video Device"
 Option "UseFBDev" "true"
EndSection

Changed in compiz (Ubuntu):
status: Triaged → Fix Released
CodeDude (theo-ew) on 2009-11-05
Changed in compiz (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → In Progress
Chris Coulson (chrisccoulson) wrote :

CoreDude - please don't just change the bug state for no reason, and without any explanation

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
CodeDude (theo-ew) wrote :

sorry about that...I didn't realize what I was doing.

CodeDude

On Thu, Nov 5, 2009 at 10:10 AM, Chris Coulson <<email address hidden>
> wrote:

> CoreDude - please don't just change the bug state for no reason, and
> without any explanation
>
> ** Changed in: compiz (Ubuntu)
> Status: In Progress => Fix Released
>
> --
> [i965] MASTER: Compiz is disabled on GM965 as of Apr 19, 2009 due to bug
> 359392
> https://bugs.launchpad.net/bugs/363821
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “compiz” package in Ubuntu: Fix Released
> Status in “xserver-xorg-video-intel” package in Ubuntu: Invalid
> Status in “compiz” source package in Jaunty: Fix Committed
> Status in “xserver-xorg-video-intel” source package in Jaunty: Invalid
>
> Bug description:
> Compiz has been intentionally disabled on i965 due to bug 359392, "[i965] X
> freezes starting on April 3rd"
>
> If you do not have freezes while using compiz, you can force it to load
> via:
>
> SKIP_CHECKS=yes compiz
>
> or you can add the following to the config file
> ~/.config/compiz/compiz-manager:
>
> SKIP_CHECKS=yes
>
> [Original Report]
> On Jaunty, after today updates compiz fails to start.
>
> using system -> preferences -> appearance, can't change appearance settings
> to extra.
>
> It is trying to find suitable drivers, and then it says sorry.
>
> System: Acer 6292, Intel GMA X3100 (GM965)
>
> ProblemType: Bug
> Architecture: amd64
> DistroRelease: Ubuntu 9.04
> MachineType: Acer, inc. TravelMate 6292
> Package: compiz 1:0.8.2-0ubuntu8
> PackageArchitecture: all
> ProcCmdLine: root=UUID=d291a857-dbf6-4fba-99d6-9365c5245f75 ro quiet splash
> ProcEnviron:
> LANG=ru_RU.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.28-11.42-generic
> SourcePackage: compiz
>

Travis Watkins (amaranth) wrote :

This package was uploaded to jaunty on April 30th.

Changed in compiz (Ubuntu Jaunty):
status: Fix Committed → Fix Released
To post a comment you must log in.