Ubuntu

ulimit -t doesn't work in Ubuntu 09.04 (beta) 2.6.28-11-generic

Reported by nguyenthanhvuh on 2009-04-15
10
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
linux (Ubuntu)
Medium
Manoj Iyer
Jaunty
Medium
Manoj Iyer

Bug Description

ulimit -t doesn't work as expected in kernel 2.6.28.

I think it might be some bug imcompatability w/ kernel 2.6.28 --- I want to file a bug to kernel dev group but just want to check here first. Whenever I use kernel 2.6.28 (e.g., compile my own vanilla linux source), the problem occurs. To make sure that it isn't due to my own kernel compilation and settings, I tried on the latest Ubuntu version (Jaunty, beta) w/ kernel 2.6.28 default, problem occurs again (I didn't touch the kernel of Jaunty at all, it's the stock default one).

Everything seems fine w/ kernel 2.6.27 (e.g., Intrepid or Hardy) or lower. Also note that dash / bash doesn't seem to be the problem (i.e., ulimit should work w/ both dash and bash).

Below is an example to reproduce the bug.

file: ulimit_test.sh

#!/bin/bash
ulimit -t 1
perl -e 'while(true){}'
exit 0

sh ulimit_test.sh : expected: process is killed after 1 sec,
but w/ 2.6.28: it doesn't get killed at all -- loop forever.

Update: okay it is a kernel related bug -> http://patchwork.kernel.org/patch/13605/ and a patch is being worked on.

nguyenthanhvuh (thanhvu) on 2009-04-15
description: updated
tags: added: 2.6.28 kernel ulimit
nguyenthanhvuh (thanhvu) on 2009-04-15
description: updated
affects: ubuntu → linux (Ubuntu)

Hi,

Thanks for the reference to the patch upstream. I'm pasting the upstream git commit id below for the kernel team to reference. Unfortunately the kernel is currently frozen for the upcoming Jaunty release, but I'll nominate this for a Stable Release Update. Thanks.

ogasawara@yoji:~/linux-2.6$ git log -p 37bebc70d7ad4144c571d74500db3bb26ec0c0eb
commit 37bebc70d7ad4144c571d74500db3bb26ec0c0eb
Author: Oleg Nesterov <email address hidden>
Date: Mon Mar 23 20:34:11 2009 +0100

    posix timers: fix RLIMIT_CPU && fork()

    See http://bugzilla.kernel.org/show_bug.cgi?id=12911

Changed in linux (Ubuntu Jaunty):
importance: Undecided → Medium
status: New → Triaged
Changed in linux:
status: Unknown → Fix Released
Manoj Iyer (manjo) on 2009-04-22
Changed in linux (Ubuntu Jaunty):
assignee: nobody → manjo
Manoj Iyer (manjo) wrote :

Can you please test the kernel in http://people.ubuntu.com/~manjo/lp361508-jaunty/ and report back here ?

Changed in linux (Ubuntu Jaunty):
status: Triaged → Incomplete
nguyenthanhvuh (thanhvu) wrote :

Yes the kernel in http://people.ubuntu.com/~manjo/lp361508-jaunty/ seems to work --- thanks for the quick work.

Manoj Iyer (manjo) wrote :

Thanks for testing my kernel. In jaunty sru submit queue.

Manoj Iyer (manjo) wrote :

SRU JUSTIFICATION:

IMPACT: ulimit -t doesn't work in Ubuntu 09.04
FIX: This is a workaround patch for 2.6.28.
TEST: Originator of the bug tested the kernel in
http://people.ubuntu.com/~manjo/lp361508-jaunty/ and reported to work.

Changed in linux (Ubuntu Jaunty):
status: Incomplete → Fix Committed
Steve Langasek (vorlon) on 2009-05-01
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Steve Langasek (vorlon) wrote :

Accepted linux into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
vos_ck (christian-klein1) wrote :

Hi everybody,
I am having exactly the same problem with my x86 kernel.
Linux christian-laptop 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux
I am running Jaunty with 2.6.28-11.42

I ran the test code from above and it behaves exactly the same. I added the proposed repos to my sources but the error remains the same - probably because I am not running the amd kernel ;o)

I am also getting an error when calling ulimit -n 2048 :
bash: ulimit: open files: cannot modify limit: Operation not permitted

Are those issues related somehow?
Could you please insert the working path to the other kernels as well?

If you need more information just let me know.
Thanks,
Christian

vos_ck (christian-klein1) wrote :

Hi again,

okay, ulimit -n has nothing to do with this bug. I am so sorry. I just had a typo in my config file. uname -n is now working for me...

But the rest remains the same. ulimit -t 1 does not work on my kernel as well.

Sorry for my mistake.

Chris

nguyenthanhvuh (thanhvu) wrote :

Can you tell me how to try the kernel image in proposed ? I followed what suggested https://wiki.ubuntu.com/Testing/EnableProposed and created /etc/apt/preferences w/ all of those packages pinned so I don't update all of them automatically. Now how to just install the kernel-image in jaunty proposed ? Thanks

Manoj Iyer (manjo) on 2009-06-05
Changed in linux (Ubuntu):
status: Triaged → Fix Committed
Steve Beattie (sbeattie) wrote :

I have reproduced the issue that ulimit -t not being applied with the 2.6.28-11.42 version of the kernel in jaunty, and have confirmed that the version of the kernel in jaunty-proposed, 2.6.28-13.44, does indeed fix the issue. Marking verification-done.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.28-13.44

---------------
linux (2.6.28-13.44) jaunty-proposed; urgency=low

  [ Stefan Bader ]

  * Revert "SAUCE: [jaunty] ALSA: Add retry for Intel8x0 clock measurement"
  * Revert "SAUCE: [jaunty] ALSA: Fix clock and buffer calculations for
    Intel8x0"
  * Revert "SAUCE: [jaunty] ALSA: Fix buffer positions and checks"

linux (2.6.28-12.43) jaunty-proposed; urgency=low

  [ Amit Kucheria ]

  * Enable SYN_COOKIES for iop32x and versatile flavours
    - LP: #361687
  * SAUCE: Quirk for BT USB device on MacbookPro to be reset before use
    - LP: #332443

  [ Brad Figg ]

  * [jaunty] Add missing mvsas (Marvel SAS 6440) module configuration.
    - LP: #352336

  [ Chuck Short ]

  * SAUCE: [USB] Unusual Device support for Gold MP3 Player Energy
    - LP: #125250

  [ Daniel T Chen ]

  * SAUCE: [jaunty] ALSA: Fix buffer positions and checks
    - LP: #345627
  * SAUCE: [jaunty] ALSA: Fix clock and buffer calculations for Intel8x0
    - LP: #345627
  * SAUCE: [jaunty] ALSA: Add retry for Intel8x0 clock measurement
    - LP: #345627

  [ Luke Yelavich ]

  * disable CONFIG_SND_HDA_INPUT_BEEP on amd64 and i386
    - LP: #331589

  [ Makito SHIOKAWA ]

  * [ARM] 5404/1: Fix condition in arm_elf_read_implies_exec() to set
    READ_IMPLIES_EXEC
    - LP: #364358

  [ Manoj Iyer ]

  * SAUCE: Added quirk to fix key release for Samsung NC20
    - LP: #360247

  [ Oleg Nesterov ]

  * posix timers: fix RLIMIT_CPU && fork()
    - LP: #361508

  [ Scott James Remnant ]

  * [Config] Disable libusual and the ub driver
    - LP: #364538

  [ Stefan Bader ]

  * Disable unwanted staging builds
    - LP: #366144
  * Remove prism2_usb driver from ubuntu and use the one from staging
    - LP: #325366
  * SAUCE: Make rtl8187se depend on WIRELESS_EXT
    - LP: #366144
  * Disable CONFIG_RTL8187SE for armel.versatile
    - LP: #366144

  [ Tejun Heo ]

  * libata: handle SEMB signature better
    - LP: #257790

  [ Tim Gardner ]

  * Set USB_SERIAL=m for i386/amd64
    - LP: #345002
  * SAUCE: Jaunty - aic79xx - set reset delay to 5 seconds, down from 15.
    - LP: #79542
  * SAUCE: (drop after 2.6.28) Wifi suspend/resume scan timeout fixes
    - LP: #336055
  * Sony laptop: Sony Vaio laptops do not enable wwan power by default.
    - LP: #364678

  [ Tyler Hicks ]

  * SAUCE: (drop after 2.6.28) eCryptfs: Larger buffer for encrypted
    symlink targets
    - LP: #357345

  [ Upstream Kernel Changes ]

  * V4L/DVB (9999): gspca - zc3xx: Webcam 046d:089d added.
    - LP: #326674
  * V4L/DVB (10044): gspca - pac7311: Webcam 093a:2620 added.
    - LP: #363195
  * hwmon: (it87) Add support for the ITE IT8720F
    - LP: #357766
  * vgacon: Return the upper half of 512 character fonts
    - LP: #355057
  * drm/i915: add support for G41 chipset
    - LP: #365958

 -- Stefan Bader <email address hidden> Mon, 25 May 2009 17:30:40 +0200

Changed in linux (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Jeremy Foshee (jeremyfoshee) wrote :

Marking Fix Released as this was simply overlooked earlier.

-JFo

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in linux:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.