2.6.27-2.3 fails to boot on Compaq Presario S6010V:

Bug #267295 reported by Jonathan Thomas on 2008-09-07
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Stefan Bader
Intrepid
High
Stefan Bader

Bug Description

SRU Justification:

Impact (from patch): "We found a situation on Linus' machine that the Nvidia timer quirk hit on a Intel chipset system. the problem is that the system has a fancy Nvidia card with an own PCI bridge, and the early-quirks code looking for any NVidia bridge triggered on it incorrectly. This didn't lead a boot failure by luck, but the timer routing code selecting the wrong timer first and some ugly messages. It might lead to real problems on other systems."

Fix: "I checked all the devices which are currently checked for by early_quirks and it turns out they are all located in the root bus zero. So change the early-quirks loop to only scan bus 0. This incidently also saves quite some unnecessary scanning work, because early_quirks doesn't go through all the non root busses. The graphics card is not on bus 0, so it is not matched anymore."

Testcase: See below.

Kubuntu Intrepid Ibex (8.10) alpha5 will not boot on my computer with the 2.6.27-2.3 kernel. The 2.6.26 kernel works fine. I have tested with the livecd and have received similar results. My computer is a Compaq Presario S6010V. Specs are something like:
-Pentium Celeron 2.5 GHZ
-640 MB RAM (DDR)
-Nvidia GeForce4 MX 440

Here are screenshots:
This is basically at the start of the boot. The errors look suspicious.
http://i31.photobucket.com/albums/c355/Woremar/img_8982.jpg

Then after that sometimes it goes on after "Loading Hardware drivers" and throws a bunch of errors about not being able to launch some executables from /sbin. Other times stuff just crashes. Sort of hard to get good info since it all goes by so fast.

On the LiveCD it proceeds to "Loading Hardware Drivers" then throws 3 lines of SQAUSHFS errors after which it hangs indefinitely.

After some investigation, I found out that switching the videocard in use from PCI (my Geforce4) to onboard in the BIOS avoids this crash, so it could be something fiddly triggered by my videocard or the BIOS or some combination of the two.

Related branches

Hi Jonathan,

Looking at the picture you attached, I'm curious if you'd take a look at bug 246269 as this may be a duplicate of that based on the error messages. Thanks.

Changed in linux:
status: New → Incomplete
Jonathan Thomas (echidnaman) wrote :

Installing v86d silences the first two lines of error messages, but it change behavior beyond that. I'm not experiencing any of the symptoms of bug 246269 anyway.

I found out that it's modprobe that crashes/halts the boot process. A nice backtrace floods the screen and below that an error message says "/sbin/modprobe exited abnormally" or something to that effect.

Jonathan Thomas (echidnaman) wrote :

"but it change behavior beyond that"
should be:
"but it *doesn't* change behavior beyond that"

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → High
status: Incomplete → Triaged
Colin Ian King (colin-king) wrote :

Hi Jonathan,

Can you change your kernel boot line by removing the "quiet" boot parameter and booting off this and attaching a screen shot of when it stops?

Thanks, Colin

Changed in linux:
assignee: ubuntu-kernel-team → colin-king
milestone: none → ubuntu-8.10
Jonathan Thomas (echidnaman) wrote :

Ugh, you won't believe this but my sister dropped the camera and broke it.
I've copied all of the backtrace that would fit in my screen on a sheet of paper, but I need to wait a bit (a few hours max) so I can scan it.

Jonathan Thomas (echidnaman) wrote :
Colin Ian King (colin-king) wrote :

Many thanks - sorry to hear about your camera - and you are to be congratulated for the amount of time and effort required to provide the backtrack.

Jonathan Thomas (echidnaman) wrote :

Changing the videocard from "PCI" to "Onboard" in the BIOS works around the issue.
I had similar issues back in Gutsy and Fiesty or thereabouts that eventually got fixed in Hardy and Intrepid up until 2.6.27

Pete Graner (pgraner) wrote :

@Jonathan

Can you please re-test with the lastest Intrepid beta to see if the problem persists.

Thanks

Jonathan Thomas (echidnaman) wrote :

Yes, this problem still affects linux-image-generic version 2.6.27.7.10 in Intrepid.
The Intrepid beta CD also will not boot.

description: updated
Ben Collins (ben-collins) wrote :

Make sure to test the latest kernel version. Specifically check the version of the package linux-image-2.6.27-7-generic (the package you mentioned above is a meta package and isn't the absolute kernel version).

You can also check by doing "cat /proc/version_signature"

Thanks

Changed in linux:
assignee: colin-king → ben-collins
status: Triaged → In Progress
Colin Watson (cjwatson) wrote :

This bug does not appear to have really been diagnosed, yet it is milestoned for ubuntu-8.10, which is in a week's time. Should this be deferred?

Ben Collins (ben-collins) wrote :

Yep. I can't do much until I get more feedback.

Changed in linux:
milestone: ubuntu-8.10 → none
Pete Graner (pgraner) wrote :

Moving to intrepid-updates per BenC & cjwatson's discussion below.

Changed in linux:
milestone: none → intrepid-updates
Jonathan Thomas (echidnaman) wrote :

I am testing with the latest kernel version. linux-image-2.6.27-7-generic is at 2.6.27-7.13.
The bug still occurs.

Mike Homer (homerhomer) wrote :

FTW - This also happens with Compaq v2000 :(

I had this issue when doing an upgrade from Hardy.

Mike Homer (homerhomer) wrote :

I couldn't wait anymore, I decided to do a fresh install. I'm now able to boot the latest Kenel

Thanks

The waiting is the hardest part -Tom Petty

Guillermo Belli (glock24) wrote :

I tried the Intrepid beta and the final release on a Gigabyte AMD690G (GA-MA69GM-S2H) with an AthlonX2 4800+, and it drops to a busybox shell after "Loading Hardware Drivers" and some lines of SQAUSHFS errors.

It also ahppens on a Gigabyte G33 motherboard, so it is not AMD related.

Happens with x86 and AMD64 version.

The same happened with Mandriva One 2009, so it may be a kernel bug.

Steve Beattie (sbeattie) wrote :

This bug was found in the Intrepid development cycle; removing regression-potential and marking as regression-release.

Stefan Bader (smb) on 2009-02-24
Changed in linux:
assignee: ben-collins → stefan-bader-canonical
assignee: ben-collins → stefan-bader-canonical
Stefan Bader (smb) wrote :

Sorry for the really long time without any response. We are trying to catch up. First of all, does this still happen with the latest Intrepid kernel from updates (-11.27)? If yes, could someone try to boot without the quiet option and add picture of the hang? Thanks.

Changed in linux:
status: In Progress → Incomplete
Jonathan Thomas (echidnaman) wrote :

Dunno about Intrepid, but with the latest kernel in Jaunty I get the same result as I did when I reported the bug. (The 2.6.26 kernel still serves me well.. :P)

jonathan@jonathan-desktop:~$ apt-cache policy linux-image-2.6.28-8-generic
linux-image-2.6.28-8-generic:
  Installed: 2.6.28-8.26
  Candidate: 2.6.28-8.26
  Version table:
 *** 2.6.28-8.26 0
        500 http://archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

Also, should there really be a confirmed Intrepid task if an SRU-able fix isn't available? Maybe it should be at least bumped down to New.

Jonathan Thomas (echidnaman) wrote :

Well, maybe it should have been bumped down to New if it wasn't already at incomplete, heh.

Stefan Bader (smb) wrote :

With the Intrepid task we try to indicate that this was a regression start started with Intrepid. It might not be perfect but hopefully this helps to have it more in view. And sorry about asking te same questions again. But sometimes bugs are fixed by patches not necessarily recognizable as a fix for a certain problem.

As for the crash. Unfortunately with these, there is a good chance that there have been several and we are looking at the last of a series. And page up conveniently does not work anymore. There would be ways to get a better view on this, but incidentally I just was made aware of a fix that would match your situation just too well. This has to do with certain adjustments for NVidia chipsets which unfortunately get triggered for Intel chipsets if there is a NVidia graphics card. This and your comment that everything works if you activate the internal graphics card sound really promising for that.

If I build a test kernel, which version would be the most convenient for you? Something based on the latest Intrepid or Jaunty? Thanks, Stefan

Stefan Bader (smb) on 2009-03-04
Changed in linux:
status: Incomplete → In Progress
Jonathan Thomas (echidnaman) wrote :

A Jaunty-based kernel would be most convenient for me. Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.28-8.27

---------------
linux (2.6.28-8.27) jaunty; urgency=low

  [ Amit Kucheria ]

  * Updating configs (arm:ixp4xx)

  [ Andy Whitcroft ]

  * SAUCE: enable Intel HDMI output

  [ Manoj Iyer ]

  * SAUCE: Added quirk for Linksys WUSB600N USB wifi-n networking adapter
    - LP: #323473

  [ Steve Beattie ]

  * fix apparmor memory leak on unlinked file ops
    - LP: #329489

  [ Tim Gardner ]

  * SAUCE: Dell XPS710 reboot quirk
    - LP: #323592
  * SAUCE: (drop after 2.6.28) ieee80211: Add infrastructure to obsolete
    scan results
    - LP: #336055
  * Add modules.order to the linux-image package.

  [ Upstream Kernel Changes ]

  * iwlwifi: fix time interval misuse in iwl_poll_{direct_}bit
  * x86: only scan the root bus in early PCI quirks
    - LP: #267295
  * ALSA: hda - Intel HDMI audio support
  * ALSA: hda - Fix unused function in patch_intelhdmi.c
  * ALSA: handle SiI1392 HDMI codec in patch_intelhdmi.c
  * ALSA: hda-intel: reorder HDMI audio enabling sequence
  * ALSA: introduce snd_print_pcm_rates()
  * ALSA: create hda_eld.c for ELD routines and proc interface
  * ALSA: ELD proc interface for HDMI sinks
  * ALSA: hda: make standalone hdmi_fill_audio_infoframe()
  * ALSA: hda: make global snd_print_channel_allocation()
  * ALSA: hda: HDMI channel allocations for audio infoframe
  * ALSA: hda: HDMI channel mapping cleanups
  * ALSA: hda: minor code cleanups
  * ALSA: hda: rename sink_eld to hdmi_eld
  * ALSA: hda - Release ELD proc file
  * ALSA: hda - minor HDMI code cleanups
  * ALSA: hda - report selected CA index for Audio InfoFrame
  * ALSA: hda - Add Intel vendor id string

 -- Tim Gardner <email address hidden> Wed, 25 Feb 2009 14:23:46 -0700

Changed in linux:
status: In Progress → Fix Released
Jonathan Thomas (echidnaman) wrote :

Wow, thanks a ton!

Stefan Bader (smb) wrote :

The Jaunty upload was rather coincidental, but hey. Please let me know whether this fixed your problem, so I can finish off the SRU for Intrepid. Thanks

Stefan Bader (smb) on 2009-03-05
description: updated
Jonathan Thomas (echidnaman) wrote :

Unfortunately, it still crashes identically to how it has been crashing. :(

jonathan@jonathan-desktop:~/ubuntu$ apt-cache policy linux-image-2.6.28-8-generic
linux-image-2.6.28-8-generic:
  Installed: 2.6.28-8.27
  Candidate: 2.6.28-8.27
  Version table:
 *** 2.6.28-8.27 0
        500 http://archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

Stefan Bader (smb) wrote :

Doh, it sounded just like too well matching. So, we have to go through more pain, sorry. When you boot the 2.6.28 kernel, break for grub and on the selection screen edit the arguments. Remove "quiet" and "splash" and add "vga=ask pause_on_panic=60". When you boot you'll get a screen that lets you select a VGA mode. Get the one with the most lines and go on. Hopefully by that, you can catch the place and backtrace of te first oops that happens with a bit more of the messages around it.

Stefan Bader (smb) on 2009-03-10
Changed in linux:
status: In Progress → Incomplete
Stefan Bader (smb) wrote :

This bug report is being closed because we received no response to the previous inquiry for information. Please reopen if this is still an issue in the current Ubuntu release, Jaunty Jackalope 9.04 - http://www.ubuntu.com/getubuntu/download. If the issue remains in Jaunty, please test the latest upstream kernel build - https://wiki.ubuntu.com/KernelMainlineBuilds . To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

Changed in linux (Ubuntu Intrepid):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers