autopkgtests fail due to precise being removed from the archive

Bug #1929865 reported by Brian Murray
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Undecided
Brian Murray
Bionic
Undecided
Unassigned
Focal
Undecided
Brian Murray
Groovy
Undecided
Brian Murray
Hirsute
Undecided
Brian Murray

Bug Description

The autopkgtests for update-manager are failing on stable releases. The test is checking for an upgrade from Lucid to Precise but Precise has been removed from the archive. This change updates the test so it uses Bionic and Focal both of which will be supported longer than Hirsute.

[Test Case]
verify the autopkgtest passes

ERROR: test_html_uri_real (test_meta_release_core.TestMetaReleaseCore)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/tmp/autopkgtest.uS0Qrh/build.YA2/src/tests/test_meta_release_core.py", line 186, in test_html_uri_real
    f = urlopen(uri)
  File "/usr/lib/python3.9/urllib/request.py", line 214, in urlopen
    return opener.open(url, data, timeout)
  File "/usr/lib/python3.9/urllib/request.py", line 523, in open
    response = meth(req, response)
  File "/usr/lib/python3.9/urllib/request.py", line 632, in http_response
    response = self.parent.error(
  File "/usr/lib/python3.9/urllib/request.py", line 561, in error
    return self._call_chain(*args)
  File "/usr/lib/python3.9/urllib/request.py", line 494, in _call_chain
    result = func(*args)
  File "/usr/lib/python3.9/urllib/request.py", line 641, in http_error_default
    raise HTTPError(req.full_url, code, msg, hdrs, fp)
urllib.error.HTTPError: HTTP Error 404: Not Found
-------------------- >> begin captured logging << --------------------root: WARNING: using fake release name 'lucid' (because of META_RELEASE_FAKE_CODENAME environment)

Revision history for this message
Brian Murray (brian-murray) wrote :

This has been fixed in impish by switching to use python3-distro-info but for any stable releases let's just change the release name in the test.

update-manager (1:21.10.2) impish; urgency=medium

  * debian/changelog: Fix the date in an old changelog entry. (LP: #1927850)
  * tests/test_meta_release_core.py: use distro_info to determine a supported
    release to test instead of Lucid which was hardcoded.

Changed in update-manager (Ubuntu Hirsute):
assignee: nobody → Brian Murray (brian-murray)
Changed in update-manager (Ubuntu):
status: New → Fix Released
assignee: nobody → Brian Murray (brian-murray)
description: updated
tags: added: block-proposed-hirsute
tags: added: block-proposed-focal block-proposed-groovy
Changed in update-manager (Ubuntu Groovy):
assignee: nobody → Brian Murray (brian-murray)
Changed in update-manager (Ubuntu Focal):
assignee: nobody → Brian Murray (brian-murray)
Revision history for this message
Timo Aaltonen (tjaalton) wrote : Please test proposed package

Hello Brian, or anyone else affected,

Accepted update-manager into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:18.04.11.14 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in update-manager (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Changed in update-manager (Ubuntu Focal):
status: New → Fix Committed
tags: added: verification-needed-focal
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Hello Brian, or anyone else affected,

Accepted update-manager into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:20.04.10.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in update-manager (Ubuntu Groovy):
status: New → Fix Committed
tags: added: verification-needed-groovy
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Hello Brian, or anyone else affected,

Accepted update-manager into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:20.10.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in update-manager (Ubuntu Hirsute):
status: New → Fix Committed
tags: added: verification-needed-hirsute
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Hello Brian, or anyone else affected,

Accepted update-manager into hirsute-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:21.04.11 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-hirsute to verification-done-hirsute. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-hirsute. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (update-manager/1:20.10.7)

All autopkgtests for the newly accepted update-manager (1:20.10.7) for groovy have finished running.
The following regressions have been reported in tests triggered by the package:

ubuntu-release-upgrader/1:20.10.16 (armhf, arm64, amd64, s390x, ppc64el)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/groovy/update_excuses.html#update-manager

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (update-manager/1:20.04.10.8)

All autopkgtests for the newly accepted update-manager (1:20.04.10.8) for focal have finished running.
The following regressions have been reported in tests triggered by the package:

ubuntu-release-upgrader/1:20.04.33 (arm64, amd64, armhf, s390x, ppc64el)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/focal/update_excuses.html#update-manager

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

tags: added: block-proposed-bionic
Revision history for this message
Brian Murray (brian-murray) wrote :

The autopkgtests are passing for all releases with the new version of update-manager.

tags: added: verification-done-bionic
removed: verification-needed-bionic
tags: added: verification-done-focal
removed: verification-needed-focal
tags: added: verification-done-groovy
removed: verification-needed-groovy
tags: added: verification-done-hirsute
removed: verification-needed-hirsute
Revision history for this message
Steve Langasek (vorlon) wrote : Proposed package removed from archive

The version of update-manager in the proposed pocket of Groovy that was purported to fix this bug report has been removed because the bugs that were to be fixed by the upload were not verified in a timely (105 days) fashion.

Changed in update-manager (Ubuntu Groovy):
status: Fix Committed → Won't Fix
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:20.04.10.9

---------------
update-manager (1:20.04.10.9) focal; urgency=medium

  * ubuntu-security-status: use ubuntu-advantage-tools to determine whether or
    not livepatch or esm are enabled and if the system is attached. Thanks to
    Chad Smith for the patch. (LP: #1938043)

 -- Brian Murray <email address hidden> Fri, 03 Sep 2021 15:17:22 -0700

Changed in update-manager (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers