hirsute beta desktop AMD64 ISO kernel panic on boot when booting using UEFI

Bug #1922403 reported by Ben Wibking on 2021-04-03
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Critical
Unassigned
Focal
Undecided
Unassigned
Hirsute
Critical
Unassigned
linux-oem-5.10 (Ubuntu)
Undecided
Unassigned
Focal
Critical
Unassigned
Hirsute
Undecided
Unassigned

Bug Description

I've tried to boot the Ubuntu 21.04 desktop beta Live CD (AMD64; http://releases.ubuntu.com/21.04/ubuntu-21.04-beta-desktop-amd64.iso) inside a Hyper-V Gen 2 Virtual Machine with UEFI enabled.

The GRUB boot menu loads, and I continue with the default option. I immediately get a kernel panic (screenshot attached).

Ben Wibking (bwibking) wrote :
Ben Wibking (bwibking) wrote :

changed to 'linux' to reflect that this is a kernel bug

affects: ubuntu → linux (Ubuntu)
Ben Wibking (bwibking) on 2021-04-03
summary: - hirsute live cd kernel panic
+ hirsute live cd kernel panic on boot

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1922403

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: hirsute

(Obviously, I can't run apport-collect since it panics on boot.)

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Ben Wibking (bwibking) wrote :

The 04-04-2021 daily ISO also has the same bug (screenshot attached).

Chris Guiver (guiverc) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

I realize you cannot run the `apport-collect`, but this bug currently is missing details as to

- what ISO you're talking about? server? desktop? etc
- which daily image? (usually in format yyyymmdd but may also have a .y appended if image is re-spun that day)
- if you validated the ISO checksum? (did you verify your ISO? as per https://tutorials.ubuntu.com/tutorial/tutorial-how-to-verify-ubuntu#0 for example)

You do mention the 2021-04-04 ISO had that same issue, thanks for that detail, but is that the ISO you filed against? and what ISO was it?

Thank you for your report.

Ben Wibking (bwibking) on 2021-04-08
description: updated
Ben Wibking (bwibking) wrote :

I am using the desktop ISO (both images).

I've added to the bug description that the original ISO that I used was the beta ISO downloaded from this URL: http://releases.ubuntu.com/21.04/ubuntu-21.04-beta-desktop-amd64.iso

I validated the ISO checksum against the given checksum and verified the checksum file against the signing key.

I downloaded the daily image on 04-05-2021 when the file had a last modified date of 04-05-2021 from this URL: https://cdimage.ubuntu.com/daily-live/current/hirsute-desktop-amd64.iso and it had the same issue.

summary: - hirsute live cd kernel panic on boot
+ hirsute beta desktop ISO kernel panic on boot
summary: - hirsute beta desktop ISO kernel panic on boot
+ hirsute beta desktop AMD64 ISO kernel panic on boot

I've tested the beta ISO without Secure Boot -- it still fails. I've also tested the beta ISO with a Gen1 (non-UEFI) Hyper-V VM, and it works fine!

description: updated
summary: - hirsute beta desktop AMD64 ISO kernel panic on boot
+ hirsute beta desktop AMD64 ISO kernel panic on boot when booting using
+ UEFI
Kai-Heng Feng (kaihengfeng) wrote :

I can reproduce the issue. Let me work on this...

Changed in linux (Ubuntu):
assignee: nobody → Kai-Heng Feng (kaihengfeng)
status: Confirmed → In Progress
Kai-Heng Feng (kaihengfeng) wrote :

Ugh, I can't boot into older kernels from GRUB. Do you know how to boot to an older kernel?

Changed in linux (Ubuntu Hirsute):
status: In Progress → Confirmed
importance: Undecided → Critical
assignee: Kai-Heng Feng (kaihengfeng) → nobody
Changed in linux (Ubuntu Focal):
status: New → Invalid
Changed in linux-oem-5.10 (Ubuntu Hirsute):
status: New → Invalid
Changed in linux-oem-5.10 (Ubuntu Focal):
status: New → Confirmed
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 5.11.0-16.17

---------------
linux (5.11.0-16.17) hirsute; urgency=medium

  * hirsute beta desktop AMD64 ISO kernel panic on boot when booting using UEFI
    (LP: #1922403)
    - SAUCE: efifb: Check efifb_pci_dev before using it

 -- Seth Forshee <email address hidden> Wed, 14 Apr 2021 14:31:58 -0500

Changed in linux (Ubuntu Hirsute):
status: Confirmed → Fix Released
Kai-Heng Feng (kaihengfeng) wrote :

The daily iso no longer has this issue.

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
tags: added: verification-done-focal
removed: verification-needed-focal
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-oem-5.10 - 5.10.0-1025.26

---------------
linux-oem-5.10 (5.10.0-1025.26) focal; urgency=medium

  * focal/linux-oem-5.10: 5.10.0-1025.26 -proposed tracker (LP: #1926155)

  * Packaging resync (LP: #1786013)
    - update dkms package versions

  * CirrusLogic: Cracking noises appears in built-in speaker when output volume
    is set >80% (LP: #1924997)
    - SAUCE: ALSA: hda/cirrus: Use CS8409 Equalizer to fix abnormal sounds on
      Bullseye

 -- Timo Aaltonen <email address hidden> Mon, 26 Apr 2021 16:18:11 +0300

Changed in linux-oem-5.10 (Ubuntu Focal):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers