Ubuntu

winbind should be downgraded to "Recommends"

Reported by Loye Young on 2008-07-11
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
wine (Ubuntu)
Low
Scott Ritchie
Hardy
Wishlist
Unassigned

Bug Description

Binary package hint: wine

Wine now depends on winbind, but the dependency should be downgraded to "Recommends".

In many (maybe most?) instances, having winbind installed alongside Wine is good, right, just, and builds a better tomorrow. However, the system administrator may not want to have Linux machines connecting to his legacy Windows machines. Because winbind is not essential to running other applications on Wine, there is no reason to require winbind in each and every case. A Recommends dependency gives the best of both worlds: winbind is installed by default, but the admin may remove it without breaking Wine itself.

Happy Trails

Loye Young
Isaac & Young Computer Company
Laredo, Texas
http://www.iycc.net

Scott Ritchie (scottritchie) wrote :

Oops, i thought I fixed that already. Preparing new upload. Thank you for reporting.

Changed in wine:
assignee: nobody → scottritchie
importance: Undecided → Low
status: New → Confirmed
Scott Ritchie (scottritchie) wrote :

Fixed in Intrepid

Changed in wine:
status: Confirmed → Fix Released

Scott,
Is this going to be backported to Hardy? Hardy is a long term support
release, and this is an easy fix, so it makes sense to do.

Loye

Daniel T Chen (crimsun) on 2008-08-26
Changed in wine:
importance: Undecided → Wishlist
status: New → Triaged
fermulator (fermulator) wrote :

Agreed. This is a nuisance in hardy still.

A. Denton (aquina) wrote :

I'm affected by the same thing.

Since some guys in our organization run wine I also want to have the dependency downgraded to "Recommends". This would slightly increase overall security on our network. I also agree with Mr. Young that Wine indeed can run without winbind.

Further the winbind package must be fixed so it won't search for "/etc/samba/smb.conf" anyomore (try "sudo winbindd -SF -d 10" and see yourself).

Considering the wine Recommends on winbind is actually causing breakage in some circumstance (see bug #605326), I think it really ought to be a Suggests. I will pursue that in bug #302148, since this one is Fix Released.

A. Denton (aquina) wrote :

I agree with commenter #6, Etienne. I think this bug is not specific to any given distribution release number and therefore not obsolete yet. Can the appropriate owner/person in charge (S. R.) alter the package and set the dependency to recommends, please?

Scott Ritchie (scottritchie) wrote :

Not going to fix Hardy Wine bugs at this point.

Wine recommends (rather than suggests) winbind because most users will want it by default, however it is not absolutely essential. In the case of the likewise-open issue above, that is properly solved with the likewise-open package conflicting with winbind, which will still allow wine to be installed because it is merely a recommends and not a depends. This is exactly what recommends is for -- we can't downgrade everything to suggests just because other packages don't properly declare their conflicts.

Changed in wine (Ubuntu Hardy):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers