Comment 36 for bug 303199

gmck (gmck) wrote :

I had a related problem - I could not see *any* new versions of "virtualbox-ose-modules-2.6.24-xx" after "virtualbox-ose-modules-2.6.24-16", even though I could see all of the kernel images from "linux-image-2.6.24-16-generic" to "linux-image-2.6.24-24-generic".

Traced my issue to the default apt "sources.list" file from Hardy, which had the following lines:
deb http://de.archive.ubuntu.com/ubuntu hardy-updates main restricted
deb-src http://de.archive.ubuntu.com/ubuntu hardy-updates main restricted

However, the virtualbox-ose-modules packages are in the "universe" repository, so the new packages in "hardy-updates" were not being downloaded by 'apt-get update'. Adding the following lines to sources.list fixed the problem.

deb http://de.archive.ubuntu.com/ubuntu hardy-updates universe multiverse
deb-src http://de.archive.ubuntu.com/ubuntu hardy-updates universe multiverse

The meta-package "virtualbox-ose-modules-generic" now functions as expected, and Virtualbox works with the "virtualbox-ose-modules-2.6.24-24" package installed.