MASTER: "New partition size" UI is confusing

Bug #42532 reported by Robin Munn on 2006-05-02
74
Affects Status Importance Assigned to Milestone
ubiquity (Baltix)
Undecided
Unassigned
ubiquity (Ubuntu)
Medium
Ubuntu Installer Team
Hardy
Medium
Ubuntu Installer Team

Bug Description

Installing Dapper Beta 2 on a VMware virtual machine that already contains a previous Ubuntu install, the partitioner gave me three options:

1) Resize SCSI1 (0,0,0), partition #1 (sda) and use freed space
2) Erase entire disk: SCSI1 (0,0,0) (sda) - 85.9 GB VMWare, VMWare Virtual S
3) Manually edit partition table

Choosing option #1 activated the "New partition size" slider -- but there's no feedback as to what its numbers mean. It's numbered from 0 to 100, so I assume it's a percentage slider. But does setting it to 30 mean "Resize sda1 to 30% of its previous size" or "Allocate 30% of the disk to the new partition, leaving sda1 at 70% of its previous size"?

I think the slider should have units attached: % if it's percentage, or GB (GiB?) if it's in gigabytes. In addition, I think it would be nice to have two text labels below the slider, updated continually as the slider is moved:

"Existing partition will be resized to ___ GB"
"___ GB of freed space will be created. Ubuntu will be installed into this space."

The wording is just what I came up with in a few minutes, and someone may well be able to improve on it.

Here's a mockup of the suggested change.

Confirming, this was definitely confusing when selecting automatic resizing of a win partition on a friend's machine. I would consider this a major bug, as there is absolutely no help text describing what should be selected with the slider etc.

Changed in ubiquity:
status: Unconfirmed → Confirmed
Colin Watson (cjwatson) wrote :

This upload improves matters:

ubiquity (0.99.83) dapper; urgency=low

  [ Jonathan Riddell ]
  * KDE Frontend:
    - Update timezone information when clicking on map
    - i18n various strings, closes Malone #43818
    - Allow line wrap on Reboot dialogue, closes Malone #43680
    - Fix cancel button on debconf progress dialogue from jumping position

  [ Colin Watson ]
  * Avoid starting cardmgr while running hw-detect.
  * Remove old partman state each time the installer is started.
  * Rearrange partman component control flow to set the default resize
    slider position straight away rather than waiting until the resize
    option is selected (closes: Malone #39062).
  * Round default resize slider position up rather than down.
  * GTK frontend:
    - Show % indicator on resize slider.
  * Display the actual new partition size as well as the percentage of the
    existing size on the resize slider.
  * Add/update .desktop file translations from Rosetta: Breton, French,
    Indonesian, Slovenian.
  * Add/update translations from Rosetta: Greek, Spanish, Galician,
    Hungarian, Occitan, Portuguese, Turkish, Vietnamese.
  * Automatic update of included source packages: user-setup 1.1ubuntu3.

 -- Colin Watson <email address hidden> Tue, 16 May 2006 21:13:24 +0100

I agree that additional explanatory text would be good, but I'm really running badly out of time to do this for Dapper. We have a design for a completely restructured automatic partitioner which shouldn't suffer from this confusion; I hope to be able to implement that for Edgy.

Tristan Rhodes (tristanrhodes) wrote :

Colin,

Thanks for your great work on Ubiquity. There is one improvement that I would like to see.

This past week I installed Ubuntu on a second hard drive in a PC. It is a 250 GB drive, and I wanted to give 30 GB to Ubuntu. I got to the "Resize Partion" and dragged the slider so that it said "New partition size: 30 GB". When the system came up, I realized that the "New Partition" was not the Ubuntu partition, but the original partition! (I fixed this using the gparted livecd).

We need to make it more obvious which side of the slider is the new Ubuntu partition, and which side is the existing partition. This can be done graphically:

_____________________________________________
| Ubuntu | Original |
|___30 GB___|________________220 GB___________|

Or change your text to be more obvious:

New size of original partition: 220 GB
New size of Ubuntu partition: 30 GB

Thanks for your time!

pirast (pirast) wrote :

Yeah, this would be definitly nice and would remove confusion.

Maybe Apple's Boot Camp can be taken as an "inspiration":

http://screenshots.softonic.com/s2de/50000/50912/3_boot_camp_01.jpg

I think that the resizing screen should look similar in Ubiquity.

Andreas Gustafsson (gson) wrote :

The ambiguous wording "New partition size" bit me yesterday as I installed Ubuntu 6.10 on a PC by shrinking the existing Windows partition and adding a new Ubuntu partition. I thought "New partition size" meant "size of the new partition" (logical, no?), but it didn't...

Richard Bailey (rmjb) wrote :

I'm installing Feisty on my work laptop and this confused me. Also, answers on ubuntuforums.org were not convincing and went both ways as to if this referred to the size of the new partition --"New Partition" Size-- or the new size of the existing partition --New "Partition Size"--.

Too bad it's still not adjusted since Dapper but I think changing to wording to "Shrink existing partition to" would be good enough.

Bradly Wilson (mocoloco) wrote :

I don't think any new dialog sections are necessary, just rewording. As pointed out, the phrase in English "New partition size" can mean:
Size of (the) new partition
or
New size of (the) partition
Just reword it to the latter, maybe adding "in GB" or "in MB". This isn't an issue in most languages so vast amounts of change are unnecessary and would then be redundant in most localisations.

Steven Wagner (stevenwagner) wrote :

Gutsy. Another ubuntu release,.. another release with this bug.

Juerd (ubuntu-juerd) wrote :

The Dutch translation is confusing in the same way. Apparently it is the size of the new partition, not the new size of the existing partition, but I wasted an hour because I interpreted it the other way.

Suggestion: change "Nieuwe partitiegrootte" to "Grootte van nieuwe partitie:"

Juerd (ubuntu-juerd) wrote :

I even remembered it the wrong way around; go figure. I'm suggesting "Nieuwe grootte bestaande partitie" now. :)

Mark Stosberg (markstos) wrote :

I consider myself an experienced user, and I have misread this UI before, and found myself again confused by it when installing Gutsy. It should be easy to fix, especially with the suggestions given below. I'm assigning it to the "ubuntu-installer" team to be fixed for Hardy.

Changed in ubiquity:
assignee: nobody → ubuntu-installer
Steven Wagner (stevenwagner) wrote :

Can we get the importance level on this raised too? When an addition NOTE: string could fix this, it is silly to force people to have a confusing install. Definitely shouldn't be in the next LTS release.

On Mon, Nov 26, 2007 at 11:18:01PM -0000, Steven Wagner wrote:
> Can we get the importance level on this raised too? When an addition
> NOTE: string could fix this, it is silly to force people to have a
> confusing install. Definitely shouldn't be in the next LTS release.

I don't have the ability to change the "Importance" myself, although I
seem to be able to change the Status, nominate it and assign it.

   Mark

Changed in ubiquity:
status: New → Invalid
Henrik Nilsen Omma (henrik) wrote :

The fact that 'New partition size' refers to the new size of the old partition is clearly problematic. We should probably avoid the word 'New' altogether. Perhaps:

Original partition size: X
Ubuntu partition size: Y

Targeting for Hardy.

perhaps the text "new partition size" should simply be changed to "new size of partition". Then the idea of resize and use free space makes sense.

But i think a graphic showing the sizes of both partitions with a bar in the middle that you can slide would be best, to make it really obvious.

Colin Watson (cjwatson) wrote :

This was fixed for the GTK frontend in ubiquity 1.7.7:

  [ Evan Dandrea ]
  * Replace the resize slider with a custom widget in gtk_ui.

However, the same work needs to be done for the KDE frontend, I think.

Colin Watson (cjwatson) wrote :

The KDE frontend work seems to have been done now, so I think this bug is fixed at last.

ubiquity (1.8.4) hardy; urgency=low

  [ Jonathan Riddell ]
  * kde_ui:
[...]
   - Replace the resize slider with the custom widget
[...]

 -- Colin Watson <email address hidden> Sat, 12 Apr 2008 13:23:13 +0100

Changed in ubiquity:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints