Ubuntu

package texlive-formats-extra None failed to install/upgrade: trying to overwrite `/usr/share/texmf-texlive/tex/latex/latexconfig/mllatex.ini', which is also in package texlive-latex-base

Reported by Reiner Jung on 2008-02-04
10
Affects Status Importance Assigned to Milestone
texlive-extra (Ubuntu)
Medium
Unassigned
Hardy
Undecided
Unassigned

Bug Description

upgrade from fgutsy to hardy.

ProblemType: Package
Architecture: i386
Date: Mon Feb 4 00:02:31 2008
Dependencies:

DistroRelease: Ubuntu 8.04
ErrorMessage: trying to overwrite `/usr/share/texmf-texlive/tex/latex/latexconfig/mllatex.ini', which is also in package texlive-latex-base
Package: texlive-formats-extra None
PackageArchitecture: all
SourcePackage: texlive-extra
Title: package texlive-formats-extra None failed to install/upgrade: trying to overwrite `/usr/share/texmf-texlive/tex/latex/latexconfig/mllatex.ini', which is also in package texlive-latex-base
Uname: Linux helsinki 2.6.24-5-rt #1 SMP PREEMPT RT Thu Jan 24 21:57:04 UTC 2008 i686 GNU/Linux

Reiner Jung (prefec2) wrote :

On Mo, 04 Feb 2008, Reiner Jung wrote:
> ErrorMessage: trying to overwrite `/usr/share/texmf-texlive/tex/latex/latexconfig/mllatex.ini', which is also in package texlive-latex-base
> Package: texlive-formats-extra None

Fixed in Debian packages version whatever, there is/was a missing
Replace: ..., please pull from Debian.

Best wishes

Norbert

-------------------------------------------------------------------------------
Dr. Norbert Preining <email address hidden> Vienna University of Technology
Debian Developer <email address hidden> Debian TeX Group
gpg DSA: 0x09C5B094 fp: 14DF 2E6C 0307 BE6D AD76 A9C0 D2BF 4AA3 09C5 B094
-------------------------------------------------------------------------------
(aikamuotojen käyttö aikamatkustuksessa)
You can arrive (mayan arivan on-when) for any sitting you
like without prior (late fore-when) reservation because you
can book retrospectively, as it were when you return to
your own time. (you can have on-book haventa forewhen
presooning returningwenta retrohome.)
                 --- Douglas Adams, The Hitchhikers Guide to the Galaxy

Ming Hua (minghua) wrote :

Hi Norbert,

Which package should we pull? This bug happened when upgrading texlive-formats-extra (src:texlive-extra) from 2007-3 to 2007.dfsg.1-1, and Debian unstable also has texlive-extra 2007.dfsg.1-1.

Ming Hua (minghua) wrote :

Okay, I think I can identify the problem now.

In gutsy, /usr/share/texmf-texlive/tex/latex/latexconfig/mllatex.ini is shipped in texlive-latex-base (src:texlive-base) 2007-10; In hardy, this file is moved to texlive-formats-extra. No Replaces seems to exist in the Debian unstable, and it apparently isn't a big deal for Debian now (testing already has texlive-base 2007-13).

Norbert, is it possible to add proper Replaces for Debian's texlive-formats-extra package? Or is Ubuntu on its own here?

Hi,

On Mi, 06 Feb 2008, Ming Hua wrote:
> shipped in texlive-latex-base (src:texlive-base) 2007-10; In hardy,
> this file is moved to texlive-formats-extra. No Replaces seems to exist
> in the Debian unstable, and it apparently isn't a big deal for Debian
> now (testing already has texlive-base 2007-13).

Yes, I didn't introduce them because I uploaded the respective versions
of -base and -extra at the same time, and ignored the problem that it
takes different time to enter testing.

> Norbert, is it possible to add proper Replaces for Debian's texlive-
> formats-extra package? Or is Ubuntu on its own here?

If you prefer I can add a Replaces, but is it really useful now? It is
only for the development version, right?

Anyway, tell me and I will add it to the Debian pacakges next upload.

Best wishes

Norbert

-------------------------------------------------------------------------------
Dr. Norbert Preining <email address hidden> Vienna University of Technology
Debian Developer <email address hidden> Debian TeX Group
gpg DSA: 0x09C5B094 fp: 14DF 2E6C 0307 BE6D AD76 A9C0 D2BF 4AA3 09C5 B094
-------------------------------------------------------------------------------
TWEEDSMUIR (collective n.)
The name given to the extensive collection of hats kept in the
downstairs lavatory which don't fit anyone in the family.
   --- Douglas Adams, The Meaning of Liff

Ming Hua (minghua) wrote :

On Thu, Feb 07, 2008 at 06:42:02PM -0000, Norbert Preining wrote:
>
> On Mi, 06 Feb 2008, Ming Hua wrote:
>
> > shipped in texlive-latex-base (src:texlive-base) 2007-10; In hardy,
> > this file is moved to texlive-formats-extra. No Replaces seems to exist
> > in the Debian unstable, and it apparently isn't a big deal for Debian
> > now (testing already has texlive-base 2007-13).
>
> Yes, I didn't introduce them because I uploaded the respective versions
> of -base and -extra at the same time, and ignored the problem that it
> takes different time to enter testing.

This is tangent to the bug at hand, but I think it doesn't really matter
when those packages enters testing. My understanding is that when you
uploaded those two packages at the the same time, the upgrade path in
unstable is immediately broken. Although broken upgrade in unstable
only is usually not a big problem.

> > Norbert, is it possible to add proper Replaces for Debian's texlive-
> > formats-extra package? Or is Ubuntu on its own here?
>
> If you prefer I can add a Replaces, but is it really useful now? It is
> only for the development version, right?

No, Ubuntu 7.10 (gutsy) was released with texlive-base 2007-10.

> Anyway, tell me and I will add it to the Debian pacakges next upload.

We need this Replaces relation for a smooth gutsy->hardy upgrade. So if
you can add it to the Debian texlive-formats-extra package (though I
don't what exact version of texlive-latex-base it should replace), it
would be very helpful.

Ming
2008.02.09

Norbert Preining (preining) wrote :

On Sa, 09 Feb 2008, Ming Hua wrote:
> when those packages enters testing. My understanding is that when you
> uploaded those two packages at the the same time, the upgrade path in
> unstable is immediately broken. Although broken upgrade in unstable

No it wasn't, because normally the packages were installed at the same
time. Anyway.

> We need this Replaces relation for a smooth gutsy->hardy upgrade. So if

Good argument. I have added
 texlive-formats-extra replaces texlive-latex-base (<= 2007-10)
that should do it for gutsy, right?

Best wishes

Norbert

-------------------------------------------------------------------------------
Dr. Norbert Preining <email address hidden> Vienna University of Technology
Debian Developer <email address hidden> Debian TeX Group
gpg DSA: 0x09C5B094 fp: 14DF 2E6C 0307 BE6D AD76 A9C0 D2BF 4AA3 09C5 B094
-------------------------------------------------------------------------------
ALLTAMI (n.)
The ancient art of being able to balance the hot and cold shower taps.
   --- Douglas Adams, The Meaning of Liff

Ming Hua (minghua) wrote :

On Sat, Feb 09, 2008 at 10:01:04AM -0000, Norbert Preining wrote:
> On Sa, 09 Feb 2008, Ming Hua wrote:
>
> > when those packages enters testing. My understanding is that when you
> > uploaded those two packages at the the same time, the upgrade path in
> > unstable is immediately broken. Although broken upgrade in unstable
>
> No it wasn't, because normally the packages were installed at the same
> time. Anyway.

Hmm, I see that texlive-formats-extra depends on texlive-latex-base (>=
2007-11), so yeah, they need to be upgraded at the same time. I think
the problem here is that during upgrade, texlive-formats-extra is
unpacked before texlive-latex-base is unpacked (this is possible because
dependency is only required to be satified when configure happens,
which is after unpacking). Therefore, a Replaces is still desired
because it make sure the upgrade succeeds.

> > We need this Replaces relation for a smooth gutsy->hardy upgrade. So
>
> Good argument. I have added
> texlive-formats-extra replaces texlive-latex-base (<= 2007-10)
> that should do it for gutsy, right?

Yes, looks correct to me. Thanks!

Ming
2008.02.09

 texlive-extra (2007.dfsg.1-2) unstable; urgency=low

   * let -formats-extra replace -latex-base (<= 2007-10) to make
     smooth upgrades in Ubuntu (gutsy->hardy) possible (Closes Ubuntu
     bug 188910) [np]

 -- Norbert Preining <email address hidden> Fri, 25 Apr 2008 23:39:03 +0200

Changed in texlive-extra:
importance: Undecided → Medium
status: New → Triaged

I believe this qualifies for a Stable Release Update for hardy, subscribing the ubuntu-sru team.

Martin Pitt (pitti) wrote :

Newer version is in intrepid, so it should be fixed there. Thanks, Norbert!

Changed in texlive-extra:
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

Indeed this is a nice SRU (although it comes with a basically no-op upgrade for users who already have it installed, at the expense of a huge download.) Pascal, do you want to own this SRU? (preparing patch, do the testing) I can help out with sponsoring.

Changed in texlive-extra:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers