Ubuntu

SiSU fails to install due to Ruby version dependency

Reported by Brian Dunnette on 2008-09-09
4
Affects Status Importance Assigned to Milestone
sisu (Ubuntu)
Medium
Unassigned
Hardy
Medium
Unassigned

Bug Description

Binary package hint: sisu

When installing sisu, the package installation fails with the following message:

The following packages have unmet dependencies:
  sisu: Depends: ruby (< 1.9) but 4.1 is to be installed

Isn't Ubuntu's Ruby "4.1" actually v1.8.x -- thus, isn't the dependency met (as I have the "ruby" package installed on Hardy)?

Alessio Treglia (quadrispro) wrote :

This bug is valid only for hardy.

Changed in sisu:
status: New → Confirmed
Alessio Treglia (quadrispro) wrote :

I'm sorry, it's valid for intrepid too.

Devid Antonio Filoni (d.filoni) wrote :

There is no reason to upload the fix for intrepid as it is already fixed, your fix is useless because 4.2 (the ruby version in this moment) >= 1.8.2, so there is no reason to upload it. Also your SRU fix should have hardy-proposed as distribution and ubuntu0.1 as revision number. I'm unsubscribing u-u-s.

Changed in sisu:
status: Confirmed → Invalid
Alessio Treglia (quadrispro) wrote :
Luca Falavigna (dktrkranz) wrote :

From sisu 0.62.0 release notes:
    ruby 1.9, for present time retain restriction on running and testing sisu
    with ruby 1.9, there are still issues with 1.9 (at the C stack level, and
    probably some in sisu compatibility/updating as well)

Even if this change should be sane enough, could you please test if there are issues?

Changed in sisu:
status: Invalid → Fix Released
importance: Undecided → Medium
importance: Undecided → Medium
Steve Beattie (sbeattie) wrote :

Confirming that this is both broken on hardy and fixed in Intrepid.

Changed in sisu:
status: New → Confirmed
Changed in sisu:
status: Confirmed → Incomplete
dino99 (9d9) wrote :
Changed in sisu (Ubuntu Hardy):
status: Incomplete → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers